[Gelöst] Medion X10 KEY_UP und KEY_DOWN funktionieren nicht.

  • Hallo leute habe ein kleinens Problemm und zwar gehen die Tasten UP und Down nicht weder in vdr noch in xbmc.


    Da meine Tevii s646 nicht ging musste ich folgendes installieren


    : sudo apt-get install linux-media-dkms linux-firmware-yavdr



    danach ging die Medion x10 nicht mehr also habe ich in webif. ATI/NVidia/X10 RF Remote (userspace) eingestellt.
    und anschliessend. folgende /etc/lirc/lircd.conf eingefügt:



    lircd.conf


    nun gehehen alle tatsten bis auf KEY_DOWN and KEY_UP


    meine /var/lib/vdr/remote.conf sieht so aus:

    remote.conf


    mit "sudo irw /var/run/lirc/lircd.891 " wenn ich die tasten nach oben drücke kommt nichts, es werden keine codes angezeigt :( bei allen anderen tasten wird alles angezeigt.


    Kann mir jemand helfen wie bekomme ich die richtigen codes für die beiden tasten ???

  • Erstmal das simpelste...
    Stimmt das?


    Code
    1. KEY_UP 0x14CDF80000 <<<<<<<<< Hier stimmt was nicht ??????
    2. KEY_DOWN 0x14C5F00000 <<<<<<<<< Hier stimmt was nicht ??????


    mode2 zeigt die Codes an wenn du die Tasten drückst.


    cu

  • bingt nichts


    sudo mode2 -d /dev/lirc0


    zeigt nichts an


    sudo ir-keytable

    Code
    1. Found /sys/class/rc/rc0/ (/dev/input/event2) with:
    2. Driver cx88xx, table rc-tevii-nec
    3. Supported protocols: NEC RC-5 RC-6 JVC SONY LIRC other
    4. Enabled protocols: NEC RC-5 RC-6 JVC SONY LIRC other
    5. Repeat delay = 500 ms, repeat period = 125 ms




    meine DEVICE :


  • bingt nichts


    sudo mode2 -d /dev/lirc0


    zeigt nichts an


    Wenn du nen lirc userspace Treiber verwendest musst du ihn auch verwenden.


    ----
    -H --driver=driver
    use given driver
    ----


    Und das ir-keytable /proc/bus/input/devices Geraffel ist irrelevant wenn du lirc nutzt.


    cu

  • ok habe es hinbekommen nun geht die fernbedienung komplett habe die richtigen Transcodes herausgefunden (AUS dem Netz). Leider habe ich ein neues Problem, wenn ich eine Taste drücke kommen dann 4x signale.


    drücke eich einmal runter geht der viermal runter


    HTPC:~$ irw
    8d 0 KEY_SETUP devinput
    8d 1 KEY_SETUP devinput
    8d 2 KEY_SETUP devinput
    8d 3 KEY_SETUP devinput



    Ein tasten Druck = 4x Befehle :(


  • Hm, ich musste auch das linux-media-dkms installieren damit meine DD cine ging.
    Die X10 spielte (ohne jedes lirc gehühnere) einfach so "out of the box" (yaVDR 0.5).
    Fast. Ich musste nur den Code für die "Back"-taste ändern.
    Such mal nach "X10 scroll". Da ging es um das Problem, das das sroll rad nicht ging.
    Auch zum Problem der mehrfach tastendrücke gab's ne lösung hier.
    Das musste was im rc-core treiber gemacht werden IIRC.


  • Nein, das ist die Tastenwiederholung. Das geht so schon I.O.


    Geht dir die zu shcnell must du halt mit der Repeat Einstellung rumspielen (jenachdem wie du sie einbindest gibts da verschiedene Methoden).


    cu

  • etc/init/eventlircd.conf
    dann dort den --repeat-filter auskommentieren.


    Wobei der Weg mit dem Userspacetreiber schon irgendwie seltsam ist, AFAIK geht das unter yaVDR besser. Die X10 sollte eigentlich OOTB laufen. Lese doch mal die Anleitung http://www.yavdr.org/documentation/de/index.html


    cu

  • das wars danke euch :=


    habe in der "eventlircd.conf" den eintrag " --repeat-filter " enfernt. Nun geht alles, so wie es soll.


    sudo nano /etc/init/eventlircd.conf




    Hier noch die fertige lircd.conf für Pollin x10 P/N 2002 972S Alle Tasten gehen. wer es braucht.
    [Blocked Image: http://forum.team-mediaportal.com/attachments/remote-png.52736/