Xineliboutput 1.0.90 instabil?

  • Schönen guten Tag,


    mein Debian-basierter VDR mit Xineliboutput 1.0.90 (vgl. Signatur) läuft leider nicht wirklich stabil:

    • wenn ich versuche, DivX-Filme mit Xineliboutput abzuspielen, stürzt VDR in unregelmäßigen Abständen ab bzw. startet sich neu; eine Fehlermeldung in /var/log/messages oder /var/log/syslog finde ich nicht;
    • wenn ich die Wiedergabe eines laufenden DivX-Films mit der Stoptaste der Fernbedienung beende, startet VDR sich neu oder hängt sich auf, so dass ich per SSH neu starten muss; aus der /var/log/messages erfahre ich nur "[vdr-fe] unwiring audio post plugins";
    • das Live-TV-Bild fängt grundsätzlich nach circa 15-25 Minuten an zu ruckeln und zu stottern; manchmal fängt es sich wieder, wenn ich den Kanal wechsle oder den VDR neu starte, manchmal muss ich erst den Rechner neu starten, bevor es wieder glatt läuft; hier finde ich keine Fehlermeldungen in /var/log/messages oder /var/log/syslog.

    Hat jemand ähnliche Schwierigkeiten und kann mir einen Tip geben, an welchen (der zahllosen) Schrauben ich drehen muss? Füge die /var/lib/vdr/plugin/xineliboutput/config_xineliboutput und die /var/lib/vdr/setup.conf der Vollständigkeit halber bei.


    Bin für jede Hilfe dankbar!!!
    Muzzlehatch

    Files

    Software:
    Debian Squeeze 6.0.6, Kernel 2.6.32-5-686, VDR-Pakete aus dem e-Tobi-Repository
    VDR 1.7.28 mit VDPAU
    Xineliboutput 1.0.90-cvs
    Nvidia-VDPAU-Driver 310.19 (manuell installiert)
    Hardware:
    Viotech 3100+,
    VIA C7-D 1.6+ GHz onboard (passiv gekühlt), FSB 800MHz + 2 GB DDR2-RAM
    Nvidia GeForce 8400 GS (passiv gekühlt) mit TV-Out (S-Video -> Röhrenfernseher)
    PCI Hauppauge WinTV Nova T 500 (dual) (diversity edition (vgl. http://linuxtv.org/wiki/index.php/Hauppauge_WinTV-NOVA-T-500))

  • Quote

    wenn ich versuche, DivX-Filme mit Xineliboutput abzuspielen, stürzt VDR in unregelmäßigen Abständen ab bzw. startet sich neu; eine Fehlermeldung in /var/log/messages oder /var/log/syslog finde ich nicht


    Seit wann ist div-X ein vdr-Problem?


    ... und xineliboutput ist doch nur ein Player - also für mich nicht die erste Adresse, um einen Schuldigen für einen Absturz zu suchen.


    Quote

    das Live-TV-Bild fängt grundsätzlich nach circa 15-25 Minuten an zu ruckeln und zu stottern; manchmal fängt es sich wieder


    Hm, das habe ich gelegentlich bei der DVB-C FF auch.
    Scheinbar verschluckt sich der DVB-Treiber gelegentlich. Ein paar Mal Kanalwechsel hilft bei mir meistens.
    Mit der Angabe Deiner Sig komme ich nicht ganz klar - auf Hauppauge.de wird ein USB-Stick "WinTV-NOVA-TD" erwähnt und es gibt eine Steckkarte "WinTV-NOVA T 500" ...
    ... watt denn nu?
    Oder fehlt Dein Modell auf der Hauppauge-Seite?


    wenn Du den USB-Stick hast, könnten noch IO-Probleme dazu kommen.
    Wie ich sehe, hast Du eine via-CPU - die sind bekannt für IO-Probleme.


    ... wie auch immer - Du scheinst jedenfalls DVB-T zu verwenden.
    Schau doch mal im Log, ob Du Ausgaben findest, dass der Puffer zuläuft.
    Dann könntest Du noch femon anschauen, wie denn die Signal-Qualität ist, bzw. die Fehlerrate.
    Erst dann kann man weiter orakeln ;)


    Gruß Gero

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

  • Seit wann ist div-X ein vdr-Problem?

    Ich bin einfach davon ausgegangen, dass meine Probleme zumindest teilweise mit Xineliboutput zusammenhängen, da sie auch auftrteten, wenn ich DivX-Filme abspiele, und das übernimmt in meinem Fall doch, wenn ich es richtig verstanden habe, Xineliboutput. Habe ich da etwas falsch verstanden?

    ... und xineliboutput ist doch nur ein Player - also für mich nicht die erste Adresse, um einen Schuldigen für einen Absturz zu suchen.

    OK.

    Zitat
    das Live-TV-Bild fängt grundsätzlich nach circa 15-25 Minuten an zu ruckeln und zu stottern; manchmal fängt es sich wieder

    Hm, das habe ich gelegentlich bei der DVB-C FF auch.
    Scheinbar verschluckt sich der DVB-Treiber gelegentlich. Ein paar Mal Kanalwechsel hilft bei mir meistens.
    Mit der Angabe Deiner Sig komme ich nicht ganz klar - auf Hauppauge.de wird ein USB-Stick "WinTV-NOVA-TD" erwähnt und es gibt eine Steckkarte "WinTV-NOVA T 500" ...
    ... watt denn nu?
    Oder fehlt Dein Modell auf der Hauppauge-Seite?

    Mein Fehler: Es ist die PCI-Karte Hauppauge WinTV-Nova-T 500, allerdings eine mit zwei Antennenbuchsen, und die wird auf der entsprechenden Seite von LinuxTV als "diversity edition" (TD) bezeichnet, daher habe ich die Bezeichnung übernommen.

    wenn Du den USB-Stick hast, könnten noch IO-Probleme dazu kommen.
    Wie ich sehe, hast Du eine via-CPU - die sind bekannt für IO-Probleme.

    S.o.

    ... wie auch immer - Du scheinst jedenfalls DVB-T zu verwenden.
    Schau doch mal im Log, ob Du Ausgaben findest, dass der Puffer zuläuft.
    Dann könntest Du noch femon anschauen, wie denn die Signal-Qualität ist, bzw. die Fehlerrate.
    Erst dann kann man weiter orakeln ;)

    Richtig, DVB-T. (Scusi, ich dachte, das ginge schon aus der "Nova-T" hervor.)


    Laut femon liegt die Signalstärke fast immer zwischen 60% und 90%, die Signalqualität allerdings immer irgendwo zwischen 10 und 15%, obwohl Bild und Ton in den ersten 15-25 Minuten, also bevor das Ruckeln und Stottern anfängt, sehr gut sind. Fehlerrate, genauer BER und UNC liegen aber nach femon auch fast immer bei 0 (bzw. 00000000). Jetzt, wo ich darüber nachdenke, scheint mir das seltsam.

    Gruß Gero

    Besten Dank erst einmal.

    Software:
    Debian Squeeze 6.0.6, Kernel 2.6.32-5-686, VDR-Pakete aus dem e-Tobi-Repository
    VDR 1.7.28 mit VDPAU
    Xineliboutput 1.0.90-cvs
    Nvidia-VDPAU-Driver 310.19 (manuell installiert)
    Hardware:
    Viotech 3100+,
    VIA C7-D 1.6+ GHz onboard (passiv gekühlt), FSB 800MHz + 2 GB DDR2-RAM
    Nvidia GeForce 8400 GS (passiv gekühlt) mit TV-Out (S-Video -> Röhrenfernseher)
    PCI Hauppauge WinTV Nova T 500 (dual) (diversity edition (vgl. http://linuxtv.org/wiki/index.php/Hauppauge_WinTV-NOVA-T-500))

    The post was edited 1 time, last by muzzlehatch ().

  • Seit ich
    - in der config_xineliboutput den Parameter video.output.vdpau_sd_deinterlace_methode auf bob gesetzt
    - und den aktuellen NVIDIA-Treiber installiert habe,
    tritt das Problem des ruckelnden und stotternden Live-TV-Bildes/-Tons nicht mehr auf.


    Das Problem, dass der VDR beim Beenden der Wiedergabe von DivX-Filmen mit xineliboutput einfriert und sich anschließend ohne eine für mich erkennbare Fehlermeldung neustartet, besteht weiterhin. Hat jemand ähnliche Erfahrungen gemacht? Bin für jeden Tip dankbar. (Springen (z.B. mit der gelben Taste) kann ich bei der WIedergabe von DivX-Filmen auch nicht, da friert der VDR wie beim Beenden ein und startet sich dann neu.)

    Software:
    Debian Squeeze 6.0.6, Kernel 2.6.32-5-686, VDR-Pakete aus dem e-Tobi-Repository
    VDR 1.7.28 mit VDPAU
    Xineliboutput 1.0.90-cvs
    Nvidia-VDPAU-Driver 310.19 (manuell installiert)
    Hardware:
    Viotech 3100+,
    VIA C7-D 1.6+ GHz onboard (passiv gekühlt), FSB 800MHz + 2 GB DDR2-RAM
    Nvidia GeForce 8400 GS (passiv gekühlt) mit TV-Out (S-Video -> Röhrenfernseher)
    PCI Hauppauge WinTV Nova T 500 (dual) (diversity edition (vgl. http://linuxtv.org/wiki/index.php/Hauppauge_WinTV-NOVA-T-500))

  • Hat niemand eine Idee? Ansonsten läuft der VDR rund, alles wunderbar. Mein einziges Problem ist das Einfrieren/Abstürzen des VDR beim Beenden der Wiedergabe von DivX-Filmen, und ich finde in den Log-Dateien noch nicht einmal eine Fehlermeldung. Hilfe!

    Software:
    Debian Squeeze 6.0.6, Kernel 2.6.32-5-686, VDR-Pakete aus dem e-Tobi-Repository
    VDR 1.7.28 mit VDPAU
    Xineliboutput 1.0.90-cvs
    Nvidia-VDPAU-Driver 310.19 (manuell installiert)
    Hardware:
    Viotech 3100+,
    VIA C7-D 1.6+ GHz onboard (passiv gekühlt), FSB 800MHz + 2 GB DDR2-RAM
    Nvidia GeForce 8400 GS (passiv gekühlt) mit TV-Out (S-Video -> Röhrenfernseher)
    PCI Hauppauge WinTV Nova T 500 (dual) (diversity edition (vgl. http://linuxtv.org/wiki/index.php/Hauppauge_WinTV-NOVA-T-500))