SOLVED [0.5 alpha] Nach Umstellung auf Headless-Betrieb startet der VDR nicht

  • Habe heut meinen VDR auf den Headless-Betrieb umgestellt. Leider startet der VDR nicht mehr automatisch. Mit einem start vdr in der Konsole läufts dann.
    Das Upstart-Frontend-Log meckert das er X-display nicht öffnen kann. Das brauch er doch gar nicht für Headless??? Ist ja auch kein Screen mehr angeschlossen.


    cat /var/log/upstart/vdr-frontend.log
    wait-for-job-state stop/waiting
    wait-for-job-state stop/waiting
    wait-for-job-state stop/waiting
    Traceback (most recent call last):
    File "<stdin>", line 356, in <module>
    File "<stdin>", line 91, in status
    IndexError: list index out of range
    feh ERROR: Can't open X display. It *is* running, yeah?
    wait-for-job-state stop/waiting
    wait-for-job-state stop/waiting
    wait-for-job-state stop/waiting
    wait-for-job-state stop/waiting
    wait-for-job-state stop/waiting
    wait-for-job-state stop/waiting
    edit
    Das hier ist dazu gekommen. Weiß nicht auf was die Kiste wartet..
    /proc/self/fd/9: line 9: 999 Terminated start wait-for-job-state WAIT_FOR=vdr TARGET_GOAL=start WAIT_STATE=running WAITER=vdr-frontend WAIT_FOREVER=1

  • Wie sieht denn deine /etc/init/vdr-frontend.conf momentan aus? Eigentlich sollte da nichts existieren, das den Start des VDR verhindert oder verzögert.
    Ansonsten kannst du mal einfach den Upstart-Job ausknipsen:

    Code
    1. echo "manual" | sudo tee /etc/init/vdr-frontend.override

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • # yavdr-frontend - Starts vdr frontend
    #


    description "yavdr-frontend"
    author "Steffen Barszus <steffenbpunkt@gmail.com>"


    env HOME=/var/lib/vdr
    export HOME


    respawn




    start on started vdr or stopped openbox-tools or started sound-device \
    or vdr-frontend-restart
    stop on stopping vdr or stopping openbox



    pre-start script
    # dont start if some other application is running
    if [ -e /tmp/.standalone ]; then
    vdr-dbus-send /Remote remote.Disable ||:
    exit 1
    fi


    # wait for vdr, Xorg (after wm is running) and the sound devices to be loaded
    start wait-for-job-state WAIT_FOR=vdr TARGET_GOAL=start WAIT_STATE=running WAITER=vdr-frontend WAIT_FOREVER=1 ||:

  • Zeig doch mal ein Syslog das mehr beinhaltet - bei dem oben sieht man ja praktisch nichts vom Start des VDR...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Vermutlich die Soundkarte.


    Nehme an du bist hoffentlich nicht mehr auf der 0.5 alpha sondern hast auf das stable-ppa umgestellt und hast ein dist-update gemacht.


    Ich musste dann in der Soundcard
    sound-device.conf die "0" anfügen damit auf die richtige Soundkarte gewartet wird.
    Siehe hier:
    [solved] [yavdr0.5-beta] SoftHDDevice kommt nicht hoch

  • Ahh, Fehler gefunden!
    In der /etc/init/vdr.conf hatte ich noch ein OSCAM Eintrag drin der das starten verhindert hat.


    start on ( (started dbus and started udev and stopped networking and started oscam) or \


    Trotzdem danke

  • Eigentlich sollte das aber nur den vdr-frontend Upstart Job betreffen, der VDR selbst wartet da nicht: https://github.com/yavdr/yavdr…-0.5/etc/init/vdr.conf#L6
    omek :
    Klar, ein manueller Start des VDR sollte zeigen wenn da irgendwo ein prinzipielles Problem besteht.
    Ansonsten wäre die Ausgabe nach dem Booten ganz interessant:

    Code
    1. initctl list


    Edit: :whatever

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)