NFS Freigabe vom Windows Server zum VDR

  • Hallo VDR Profis,
    ich habe ja schon mal in folgenden Thema um Hilfe gebeten
    XBMC und NFS-Freigabe zum Windows Home Server
    Leider hab ich es nicht hinbekommen, bevor ich aber mein bisschen Weihnachtsgeld in einen leistungstärkeren Server stecke dieses würde wohl mein Problem lösen - möchte ich hier nochmal versuchen, mein Problem zu beseitigen.
    Würde mich sehr freuen, wenn mir jemand hilft. Das Problem ist aber, das ich sehr wenig Durchblick in Sachen Linux habe. Bräuchte also schon eine genaue Anleitung, also sowas wie einfach mal libnfs1 per apt-get installieren hilft mir nicht wirklich weiter. Sorry ?(
    So nun nochmal zu meinem Problem !
    Ich möchte gerne per NFS Freigabe von meinen Windows Home Server 2011 meine mkv Filme per Xbmc auf dem VDR wiedergeben.
    NFS habe ich auf mein WHS eingerichtet und scheint auch zu funktionieren, da ich mit einem anderen Windows Rechner und XBMC auf die Freigabe zugreifen kann und die Filme auch abspielen kann.
    Wenn ich über Putty showmount -e 192.168.xxx.xx eingebe werden mir die Verzeichnisse auch angezeigt.


    Export list for 192.168.xxx.xx:
    /Filme Test (everyone)
    /New (everyone)
    /Testordner (everyone)


    Gebe ich über WFE bei NFS Freigabe 192.168.xxx.xx:/New ein, wird mir das Verzeichnis angezeigt /srv/share/vdr/192.168.180.21.000, aber leider sind keine Filme zu sehen und über XBMC bekomme ich sie auch nicht eingelesen.
    Würde mich sehr freuen, wenn mir jemand hilft.
    Vielen Dank.
    Gruss becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Wenn Du das nur fürs XBMC brauchst, warum nutzt Du nicht direkt die Freigaben des WHS? Das ist CIFS und sollte direkt in xbmc unter smb genutzt werden können. Funktioniert bei mir tadellos.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Hi Torsten73,
    Habe über SMB Probleme das bei MKV Datein gelegentlich der Film angehalten wird und der Speicher nachgeladen wird. Ich besitze ein Acer H341 und gehe davon aus das die CPU zu schwach ist. Ich habe schon ziemlich viel ausprobiert, u. a. den WHS neu installiert von WHSV1 auf WHS2011, andere Netzwerkkarte eingebaut und einige Einstellungen - leideralles ohne Erfolg.
    Beim googeln habe ich von einigen gelesen, dass sie auch das Problem haben , aber leider keine direkte Lösung, bis auf dass einige ihr System auf NFS umgestellt haben. Leider aber nicht in Verbindung mit einem VDR sondern mit Dreambox und anderen Geräten. Meine HOffnung war nun, dass ich damit das Problem auch in den Griff kriege.
    Gruß beck

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Gut da muss man natürlich bei Wissen wobei der schwächelt. Soll heißen, bricht der Datendurchsatz im Netzwerk zusammen, oder schafft es die CPU nicht die mkv's zu dekodieren. Insbesondere da hier ein Atom D410 @1,66Ghz SingelCore drin ist. Bei HD Files benötigt man dafür schon einiges mehr an Rechenleistung (mind. Core i aufwärts). Dieses Problem betrifft aber nur die Nutzung den Zugriff übers Web oder DLNA/Upnp/Mediaplayer wenn die Videofiles und Bilder recodiert werden müssen. Dann kann natürlich auch der Netzwerkdurchsatz darunter leiden, da die CPU auf Vollast hängt.


    Die reine Netzfreigabe kann ich mir nicht vorstellen, dass es Probleme bereitet. Das schafft auch ein Atom System in den meisten NAS Speichern, und eine Übertragungsgeschwindigkeit im Netz sollte locker über 50Mbit liegen. Da eh nur ein Softraid 0+1 unterstützt wird sollte es da auch keine Performanceeinbrüche wie bei Soft Raid 5 geben. Und da ist es vollkommen egal ob NFS oder Samba, die Systemlast ist bei beiden niedrig.


    Hast Du mal darüber nachgedacht da ein FreeNAS oder direkt einen vdr drauf zu installieren? Das sollte als reiner Streamingserver für VDR Zwecke gehen.


    Auf meinem Xeon Quad Core Server läuft auf 2 Kernen mit KVM so gerade mit HD1080i Files flüssig unter WHS2011...

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Hi Torsten73,
    auf FreeNAS oder VDR als Server wollte ich eigentlich nicht umsteigen
    , da ich auch Windows Programme zu laufen habe und von außen auch zugreife. Deswegen ist mir die alte Windoof Oberfläche schon angenehmer. Natürlich laufen keine Programme oder Zugriffe, wenn ich Filme abspiele.
    Die Filme werden nur im eigenen Netzwerk abgespielt WHS - VDR - XBMC.
    Das es am Netzwerk liegt, kann ich mir auch nicht vorstellen. Ich habe ein 1000 Mbit Netzwerk, da ich aber gelesen habe, das es mit 1000 Mbit Probleme geben kann, habe ich auch 100 Mbit ausprobiert und auch eine neue Netzwerkkarte eingebaut. Viele schreiben, das die Netzwerkkarte vom H341 viele Probleme verursacht und nur Schrott ist.
    Auch habe ich meine Fritzbox 7390 durch einen anderen Router getauscht. Habe jetzt nur WHS Router VDR angeschlossen, aber immer das gleiche Problem.
    Habe auch mal die Netzwerklast beim Film beobachtet
    , sie liegt immer zwischen 1 und 10 %, CPU Last bei 40 bis 70 %
    auch im Fehlerfall weder WHS noch XBMC zeigen mir eine totale Auslastung an.
    Habe mal meine Filme von einem Windows 7 Rechner abgespielt hat allerdings auch ein
    Intel Core i5-2310 4x2.9GHz alles ohne Probleme.
    Meine Filme 1080p haben eine Datengröße zwischen 4 und 25 Gb.Umso grösser, umso häufiger auch die Fehler.
    Es kann aber auch vorkommen, das ich eine 18 Gb Datei ohne Aussetzer sehen kann und eine 7 Gb Datei fängt nach 20 min für ca. 5 min mit Aussetzer an und lädt den Speicher nach. Die Aussetzer treten aber nie an der gleichen Stelle auf.
    Ich habe auch noch eine WD TV Live Media Play, auch hier gibt es keine Aussetzer und hier ist ja auch keine Power CPU verbaut.


    Vielen Dank
    Gruß Becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Hallo Becky,
    ich kann dir unter Windows das Programm Hanewin NFS Server empfehlen. Es ist wirklich gut und schafft einen sehr hohen Durchsatz an Daten. Ich hatte es früher auch mal mit den Windowsfreigaben versucht aber da ist der Durchsatz einfach zu gering, so das die Filme (große mkvs) ruckelten.

    Meine Hardware:
    Client 1 : yaVDR 0.5 + Zotac IONITX-P-E + 4GB Ram + Samsung LE46C750
    Client 2 : Raspberry Pi 2 + MLD 5.0.0 + VDR + Streamdev-Client
    Server : VMware ESXi 6.0 + 54 GB ECC Ram + yaVDR 0.5 als Streaming Server + Cine S2 + headless
    NAS : FreeNAS 9.3 + 7,5 TB Raid 5 für Filme + 3 TB Raid 5 für Backup und Daten

  • Hi GeforceGamer,
    erst mal vielen Dank für Deinen Tip. Habe diesen auch schon von einem anderen User aus dem Forum empfohlen bekommen.
    Leider habe ich es aber nicht zum Laufen gebracht, hab mich wohl mal wieder zu doof angestellt :D. Und der andere User konnte mir leider auch nicht weiter helfen, aber vielleicht kannst du mir ein paar Tips geben. Werde es nochmal installieren und mich dann melden.
    Ich glaube, es liegt wohl am mounten und dem richtigen Eintrag in der fstab.
    Schönes Wochenende
    Gruss Becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Hi GeforceGamer,
    habe jetzt nochmal Hanewin und habe überhaupt keinen Durchblick. Habe gegoogelt aber leider nur eine englische Anleitung für die Installation unter WHS V1 gefunden. Nun ist mein Englisch auch nicht so gut und irgendwie sieht unter WHS 2011 alles anders aus.


    Sehe ich es richtig, dass ich auf meinen WHS 2011 Windows Services for UNIX Version 3.5 installieren muß ???


    Gruss Becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Hi GeforceGamer,
    so, habe fast den ganzen Sonntag damit verbracht meine NFS Freigabe zum Laufen zu bringen, leider nicht mit dem gewünschten Erfolg.
    Vielleicht könntest Du mir nochmal helfen oder jemand aus dem Forum kann mir weiter helfen.
    Also den Hanewin NFS Server habe ich installiert und scheint auch zu funktionieren, denn wenn ich von einem zweiten Windows Rechner mit XBMC auf das freigegebene Verzeichnis gehe, wird es mir angezeigt. Nur leider über den VDR und XBMC bekomme ich das freigegebene Verzeichnis nicht zu sehen. Ich glaube, das ich dem VDR nur nicht den richtigen Pfad zuweise. Wenn ich im WFE unter Netzwerk NFS 192.168.xxx.xx:/new eintrage, funktioniert dieses nicht. Vielleicht stell ich mich ja zu doof an,auch wenn unten steht, was man eingeben soll.
    Habe mal unter putty folgende Abfrage getätigt. Hier wird mir auch das freigegebene Verzeichnis angezeigt.


    root@YAVDRWZ04:~# showmount -e 192.168.xxx.xx
    Export list for 192.168.xxx.xx:
    /d/new 192.168.xxx.xx,192.168.xxx.xx,-range


    Wäre schön, wenn mir jemand weiterhiflt, damit mir der VDR auch endlich anzeigt, das was ich sehen will.
    Gruß becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram


  • Hallo,


    kenne mich zwar mit dem Hanewin-Zeugs nicht aus, aber du schreibst oben, dass du im WFE 192.168.x.x:/new angibst. Vielleicht funktioniert es mit "192.168.x.x:/d/new?
    Falls das nicht funktioniert, versuch mal auf der Kommandozeile das Verzeichnis manuell zu mounten und sag uns, was du für eine Fehlermeldung bekommst.


    mfG,
    f.

    VDR1: HW: Asrock Q1900M, Celeron J1900, Zotac GT 630 Zone Edition, DigitalDevices Cine C2/T2, Sundtek MediaTV Pro USB-Stick, Sundtek MediaTV Digital Home, IR-Empfänger: Atric USB Eco, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr 0.6x
    VDR2: yavdr 0.6, Intel Pentium E5300, MS-Tech MC-1200, ASUS P5G41C-M LX, G41,MSI VN210-MD512H (NVIDIA GeForce 210), Atric, Sundtek MediaTV Digital Home, FB: Harmony 300, USB-Sound: Terratec Aureon Dual USB
    VDR3: Raspberry Pi2 als Streaming Client, MLD 5.1

  • Guten morgen fatzgenfatz,
    hatte ich auch schon ausprobiert, habe es aber nochmal gemacht aber ohne Erfolg.

    Quote

    "192.168.x.x:/d/new"

    Das Problem mit der Kommandozeile ist, das ich nicht weiss, was ich hier wirklich eingeben muss ? Ich habe es damit probiert !


    Quote


    sudo mount -t cifs //192.168.180.31/d/mew
    mount -t nfs -o udp 192.168.180.31:/d/new
    mount -t nfs -o 192.168.180.31:/new
    mount -t nfs 192.168.180.31:/new

    dann kommt als Antwort !


    oder

    Quote

    root@YAVDRWZ04:~# sudo mount -t cifs //192.168.xxx.xx/video /mew
    Couldn't chdir to /mew: No such file or directory
    root@YAVDRWZ04:~#

    Mein Problem ist auch, das ich nicht weiß, wie mein Pfad genau angegeben werden muss
    Ich habe ein Windows Server mit der IP 192.168.xxx.xx es befindet sich eine Festplatte in diesem Server mit 3 Partitionen eine lautet D: Video hier habe ich ein Ordner der heist New.
    Ich gebe immer irgendwas ein und weiß eigentlich garnicht ob es stimmt bin hier echt am verzweifeln.


    Vielen Dank Gruß Becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Das Problem mit der Kommandozeile ist, das ich nicht weiss, was ich hier wirklich eingeben muss ? Ich habe es damit probiert !


    Man kann so etwas durchaus nachlesen: http://wiki.ubuntuusers.de/Sam…ifs#Temporaeres-Einbinden


    root@YAVDRWZ04:~# sudo mount -t cifs //192.168.xxx.xx/mew


    Das hier schlägt fehl, weil du nicht angibst, wohin die Freigabe gemountet werden soll.

    root@YAVDRWZ04:~# sudo mount -t cifs //192.168.xxx.xx/video /mew


    Und das hier, weil es kein Verzeichnis /mew auf dem Rechner gibt.

    Ich habe ein Windows Server mit der IP 192.168.xxx.xx es befindet sich eine Festplatte in diesem Server mit 3 Partitionen eine lautet D: Video hier habe ich ein Ordner der heist New.


    Dann verstehe ich nicht, warum du versuchst ein Verzeichnis mit dem Namen des 151. Pokemonzu mounten.


    Zeig doch mal bitte die Ausgabe davon:

    Code
    1. sudo smbclient -L <IP des Servers>


    Edit: cifs ist nur für Samba-Freigaben, um die NFS-Freigaben des Server zu sehen musst du dir die Ausgabe von showmount ansehen:

    Code
    1. sudo showmount -e <IP des Servers>

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Hallo,


    zur Klarstellung: Wenn du eine Freigabe vom nfs-Server mounten willst, brauchst du "-t cifs" nicht, das ist für Samba.
    Bei mir funktioniert das Mounten von NFS auch ohne explizite Angabe von "-t nfs".


    Du brauchst auf dem vdr-Rechner ein (temporäres) Verzeichnis, in das du die Freigabe reinmountest. Ich würde vorschlagen, dass du dir zum Testen ein Verzeichnis unterhalb von /tmp/ erstellst:

    Code
    1. mkdir /tmp/new


    Dann sollte dein Befehl so lauten:

    Code
    1. sudo mount 192.168.x.x:/d/new /tmp/new


    Und wenn das nicht funktioniert, poste bitte die Fehlermeldung.


    mfG,
    f.

    VDR1: HW: Asrock Q1900M, Celeron J1900, Zotac GT 630 Zone Edition, DigitalDevices Cine C2/T2, Sundtek MediaTV Pro USB-Stick, Sundtek MediaTV Digital Home, IR-Empfänger: Atric USB Eco, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr 0.6x
    VDR2: yavdr 0.6, Intel Pentium E5300, MS-Tech MC-1200, ASUS P5G41C-M LX, G41,MSI VN210-MD512H (NVIDIA GeForce 210), Atric, Sundtek MediaTV Digital Home, FB: Harmony 300, USB-Sound: Terratec Aureon Dual USB
    VDR3: Raspberry Pi2 als Streaming Client, MLD 5.1

  • Hallo seahawk1986


    vielen dank für Deine Hilfe, klar kann man alles nachlesen, wenn man weiß, wo und was ?( . Ich lese schon seit Wochen und meine liebe Frau fragt mich, ob ich mit der Kiste verheiratet bin oder mit Ihr :D , ich solle mir doch was vernünftiges kaufen. :(


    Habe mir gerade die Seite angesehen. Da fängt es schon an, das ich nicht verstehe, was ich mit Samba soll. Ich will doch NFS mounten und gleich am Anfang steht was von Paketen installieren, also ich glaube, das ich das nicht muss,
    da ich denke, das diese ja in yavdr breits installiert sind.
    Ich weiß es aber ehrlich gesagt nicht wirklich. Vielleicht denkst Du jetzt, oh man ist der doof, wenn er nicht mal das weiß, sollte er lieber den VDR an den Nagel hängen.


    Da ich YaVDR aber echt super finde, möchte ich aber mein Problem lösen ohne gleich ein ganzes Studium in Sachen Linux zu belegen.
    YaVDR ist so gut geworden das es eigentlich auch für den Leihen einfach ist, ohne große Kenntnisse ein VDR aufzusetzen. Aber wehe es gibt Probleme, dann legt man sich schnell die Karten. Und ich versuch mir wirklich möglichst selbst zu helfen, bevor ich hier im Forum um Hilfe schreie. Aber selbst ein kleinster Fehler wie z.b.

    Quote

    Und das hier, weil es kein Verzeichnis /mew auf dem Rechner gibt.

    O.k. es sollte New heißen, 5.40 Uhr ein Auge zu und statt N auf M gehauen, :sleep aber manchmal reicht auch ein Doppelpunkt oder eine Leerstelle, die einen zum Verzweifeln bringt.
    So
    , da ich nicht vor meiner Kiste sitze werde ich deine Tips heute Nachmittag umsetzen und berichten.


    Also nochmal vielen Dank für Deine Hilfe
    Gruss Becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

    The post was edited 2 times, last by Becky ().


  • Habe mir gerade die Seite angesehen. Da fängt es schon an, das ich nicht verstehe, was ich mit Samba soll. Ich will doch NFS mounten und gleich am Anfang steht was von Paketen installieren, also ich glaube, das ich das nicht muss,
    da ich denke, das diese ja in yavdr breits installiert sind.


    Hallo,


    ich denke, seahawk dachte, dass du per Samba mounten willst, da du "-t cifs" angegeben hast. Cifs steht nun mal für Samba.


    mfG,
    f.

    VDR1: HW: Asrock Q1900M, Celeron J1900, Zotac GT 630 Zone Edition, DigitalDevices Cine C2/T2, Sundtek MediaTV Pro USB-Stick, Sundtek MediaTV Digital Home, IR-Empfänger: Atric USB Eco, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr 0.6x
    VDR2: yavdr 0.6, Intel Pentium E5300, MS-Tech MC-1200, ASUS P5G41C-M LX, G41,MSI VN210-MD512H (NVIDIA GeForce 210), Atric, Sundtek MediaTV Digital Home, FB: Harmony 300, USB-Sound: Terratec Aureon Dual USB
    VDR3: Raspberry Pi2 als Streaming Client, MLD 5.1

  • Habe mir gerade die Seite angesehen. Da fängt es schon an, das ich nicht verstehe, was ich mit Samba soll.


    Du hast doch mit cifs angefangen und das ist nun mal nur für Samba-Freigaben...

    Ich will doch NFS mounten und gleich am Anfang steht was von Paketen installieren, also ich glaube, das ich das nicht muss,
    da ich denke, das diese ja in yavdr breits installiert sind.
    Ich weiß es aber ehrlich gesagt nicht wirklich. Vielleicht denkst Du jetzt, oh man ist der doof, wenn er nicht mal das weiß, sollte er lieber den VDR an den Nagel hängen.


    Nein, ich denke du musst dir einfach grundsätzlich angewöhnen da systematisch heranzugehen, das spart Zeit und Nerven (ok, ist langweiliger als sich haareraufend über lustige Fehlermeldungen zu Ärgern...)
    Also du willst eine NFS-Freigabe (zunächst vorübergehend) einbinden. Wenn du dir nicht sicher bist, wie der exakte Pfad zur Freigabe lautet (Linux unterscheidet im Gegensatz zu Windows sehr genau zwischen Groß- und Kleinschreibung), lässt du dir erst mal die NFS-Freigaben des Servers auflisten:

    Code
    1. sudo showmount -e <IP des Servers>


    Dein Server listet dann alle per NFS freigegebenen Verzeichnisse auf, das sieht z.B. so aus:

    Code
    1. ~$ sudo showmount -e 192.168.1.108
    2. Export list for 192.168.1.108:
    3. /media/redone *


    Jetzt willst du die NFS-Freigabe mit dem Tool mount einbinden. Die Manpage ("man mount") sagt dir (neben vielem Anderen, daher ist es nicht schlecht sich für den Einstieg an die Artikel im UbuntuUsers-Wiki zu halten, weil die sich aufs die wichtigsten Dinge beschränken):

    Quote
    Code
    1. The standard form of the mount command, is
    2. mount -t type device dir


    Der Dateisystemtyp "type" ist hier "nfs" (mount kann eine Autoerkennung nutzen, daher kann man die Option für den Typ bei der Nutzung von NFS normalerweise weglassen, wie z.B. hier geschehen: http://wiki.ubuntuusers.de/NFS#Auf-Freigaben-zugreifen). Das "device", das eingebunden werden soll liegt im oben geposteten Beispiel auf dem Server mit der IP 192.168.1.108 im Pfad /media/redone. Das Zielverzeichnis, in welches die Freigabe eingehängt werden soll muss existieren. Falls es noch nicht vorhanden ist, kannst du es mit mkdir erstellen.


    Also angenommen, wir wollten jetzt die Freigabe am yaVDR im noch nicht existierenden Verzeichnis /media/video/new einhängen, machen wir folgendes:

    Code
    1. sudo mkdir -p /media/video/new # die Option -p sorgt dafür, dass automatisch alle nötigen Ordner bis zum Zielverzeichnis erstellt werden
    2. sudo mount -t nfs 192.168.1.108:/media/redone /media/video/new

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • seahawk1986 ,
    boah, das haut mich jetzt aber um, da freue ich mich ja schon auf Feierabend - so ein ausführlicher Lehrgang.
    Vielen vielen Dank, habe zwar gerade erfahren, das ich noch heute das Fahrrad meiner Tochter reparieren muss, was hoffentlich schneller und leichter geht, werde dann aber alles umsetzen und berichten.

    Quote

    Du hast doch mit cifs angefangen und das ist nun mal nur für Samba-Freigaben..

    :] Ja richtig denn er weiß ja nicht was er tut aber alles probiert. :D


    Gruss Becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • seahawk1986 ,
    ach ist das ein schöner Feierabend - es funktioniert
    :) aber noch nicht so wie es soll und ich habe natürlich noch Fragen.
    Wie lautet nun die Zeile, die ich in der fstab eintrage, damit das Verzeichnis selbstständig gemountet wird ?
    Mein Server ist nicht immer an und was passiert, wenn ich den VDR einschalte und erst später den Server. Wird dann beim Starten von XBMC das Verzeichnis automatisch gemountet ?


    Im Menü von XBMC Videos hinzufügen.../Suchen : Nach einer neuen Quelle suchen gibt es die Option Netzwerk Dateisystem (NFS) hier passiert aber nichts. Gehe ich auf Root Dateisystem finde ich aber mein gemountetes Verzeichnis und kann so meine Filme wiedergeben.Warum ist das so ? Habe mich natürlich erstmal wieder daran aufgehangen.
    Wenn ich über Windows mit XBMC gehe, werden mir die NFS freigegebenen Ordner angezeigt.


    Danke Gruss Becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Wie lautet nun die Zeile, die ich in der fstab eintrage, damit das Verzeichnis selbstständig gemountet wird ?
    Mein Server ist nicht immer an und was passiert, wenn ich den VDR einschalte und erst später den Server. Wird dann beim Starten von XBMC das Verzeichnis automatisch gemountet ?


    Das schließt sich mit der klassischen Methode über die fstab ohne zusätzliche Hilfsprogramme wie autofs (http://wiki.ubuntuusers.de/Autofs - wenn du es damit schaffst, weißt du dass du schon einiges über Linux gelernt hast :P - aber du musst wissen was du tust (am besten in einer VM damit spielen... ) eigentlich aus, zur prinzipiellen Syntax beim Einbinden von NFS-Freigaben über die fstab siehe das UbuntuUsers-Wiki ;) http://wiki.ubuntuusers.de/NFS#Freigaben


    Im Menü von XBMC Videos hinzufügen.../Suchen : Nach einer neuen Quelle suchen gibt es die Option Netzwerk Dateisystem (NFS) hier passiert aber nichts.


    XBMC kann selbstständig NFS-Freigaben einbinden - man muss den Pfad halt unter Umständen von Hand eingeben, wenn die Freigabe nicht angezeigt wird, hier am Test-Rechner klappt die Anzeige der Freigaben im Netz.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo seahawk1986,


    du schreibst:


    Quote

    XBMC kann selbstständig NFS-Freigaben einbinden - man muss den Pfad halt unter Umständen von Hand eingeben, wenn die Freigabe nicht angezeigt wird, hier am Test-Rechner klappt die Anzeige der Freigaben im Netz

    Wo gibt man den Pfad von Hand ein ? Direkt in XBMC unter Netzwerkfreigabe hinzufügen (hier geht es bei mir nicht] oder gibt es eine Datei wo man den Pfad eintragen muss ?


    Gruß Becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram