Xineliboutput vdr-sxfe Audioausetzer - Probleme mit libGL.so.1 Abhängigkeitsinformationen beim kompilieren

  • Hallo Leute,


    ich versuche gerade Xineliboutput(1.0.7+cvs20120623.0945) für meinen Debian squeeze mit dem e-Tobi vdr_1.7.28 zu kompilieren. Laut Wiki habe ich eine Chance die Audioaussetzer zu reduzieren, wenn ich den Puffer von 250 auf 5000 erhöhe(http://www.vdr-wiki.de/wiki/in…#Sporadische_Tonaussetzer). Leider bricht dpkg-buildpackage mit

    Code
    1. dpkg-shlibdeps: Fehler: Keine Abhängigkeitsinformationen für /usr/lib/libGL.so.1 (verwendet von debian/libxineliboutput-sxfe/usr/lib/vdr/plugins/libxineliboutput-sxfe.so.1.0.90-cvs) gefunden.
    2. dh_shlibdeps: dpkg-shlibdeps -Tdebian/libxineliboutput-sxfe.substvars debian/libxineliboutput-sxfe/usr/lib/vdr/plugins/libxineliboutput-sxfe.so.1.0.90-cvs returned exit code 2
    3. make: *** [binary] Fehler 9
    4. dpkg-buildpackage: Fehler: Fehler-Exitstatus von debian/rules binary war 2


    ab. Ich habe die Nvidia GraKa-Treiber installiert, und möchte eigentlich auch dabei bleiben.. :)


    Irgendwo hab ich gelesen, dass ein

    Code
    1. dh_shlibdeps -- --ignore-missing-info

    helfen könnte..


    Code
    1. /usr/src/vdr-plugin-xineliboutput-1.0.7+cvs20120623.0945# dh_shlibdeps -- --ignore-missing-info
    2. dpkg-shlibdeps: Warnung: Abhängigkeit von libdbus-1.so.3 könnte vermieden werden, falls »debian/libxineliboutput-sxfe/usr/lib/vdr/plugins/libxineliboutput-sxfe.so.1.0.90-cvs« nicht unnötigerweise dagegen gelinkt wäre (es verwendet keines ihrer Symbole).
    3. dpkg-shlibdeps: Warnung: Abhängigkeit von libGLU.so.1 könnte vermieden werden, falls »debian/libxineliboutput-sxfe/usr/lib/vdr/plugins/libxineliboutput-sxfe.so.1.0.90-cvs« nicht unnötigerweise dagegen gelinkt wäre (es verwendet keines ihrer Symbole).
    4. dpkg-shlibdeps: Warnung: Abhängigkeit von librt.so.1 könnte vermieden werden, falls »debian/libxineliboutput-sxfe/usr/lib/vdr/plugins/libxineliboutput-sxfe.so.1.0.90-cvs« nicht unnötigerweise dagegen gelinkt wäre (es verwendet keines ihrer Symbole).
    5. dpkg-shlibdeps: Warnung: Abhängigkeit von libgthread-2.0.so.0 könnte vermieden werden, falls »debian/libxineliboutput-sxfe/usr/lib/vdr/plugins/libxineliboutput-sxfe.so.1.0.90-cvs« nicht unnötigerweise dagegen gelinkt wäre (es verwendet keines ihrer Symbole).
    6. dpkg-shlibdeps: Warnung: Abhängigkeit von libdbus-1.so.3 könnte vermieden werden, falls »debian/xineliboutput-sxfe/usr/bin/vdr-sxfe« nicht unnötigerweise dagegen gelinkt wäre (es verwendet keines ihrer Symbole).
    7. dpkg-shlibdeps: Warnung: Abhängigkeit von libGLU.so.1 könnte vermieden werden, falls »debian/xineliboutput-sxfe/usr/bin/vdr-sxfe« nicht unnötigerweise dagegen gelinkt wäre (es verwendet keines ihrer Symbole).
    8. dpkg-shlibdeps: Warnung: Abhängigkeit von librt.so.1 könnte vermieden werden, falls »debian/xineliboutput-sxfe/usr/bin/vdr-sxfe« nicht unnötigerweise dagegen gelinkt wäre (es verwendet keines ihrer Symbole).
    9. dpkg-shlibdeps: Warnung: Abhängigkeit von libgthread-2.0.so.0 könnte vermieden werden, falls »debian/xineliboutput-sxfe/usr/bin/vdr-sxfe« nicht unnötigerweise dagegen gelinkt wäre (es verwendet keines ihrer Symbole).


    ..hat aber so noch nichts gebracht.


    Kann mir jemand weiterhelfen?


    Vielen Dank und Grüße,
    Martin


    PS.:
    Hab noch vergessen - make vermisst den VDR source tree. VDR-dev ist aber installiert - es scheint aber bisher auch nichts auszumachen...

    Code
    1. Makefile:112: ********************************************************
    2. Makefile:113: VDR source tree not detected !
    3. Makefile:114: VDR plugins will not be installed.
    4. Makefile:115: ********************************************************

    Möge dein Leben eines Tages so schön sein, wie du es auf Facebook darstellst!

    The post was edited 1 time, last by BDB ().

  • *uff* Andere Frage:
    Es scheint ja daran zu liegen, dass die libGL.so.1 von Nvidia keine *.symbols oder *.shlibs Datei in /var/lib/dpkg/info/ hat, in der die Abhängigkeiten beschrieben werden?!


    Kann ich dpkg-shlibdeps nicht irgendwie zu frieden stellen? mit einer leeren libGL.symbols in dem Verzeichnis funktioniert es jedenfalls nicht.. :s
    hmm...

  • Ich hatte die gleiche Fehlermeldung beim Übersetzen der VirtualBox.
    Bei mir half die Installation des Paketes libgl1-fglrx-glx.
    (Mainboard: ASRock FM2A75 Pro4, OnBoard Grafik, Debian Wheezy).