TechnoTrend Premium S2-6400 dual HD Technik / Treiber / Firmware

  • Hallo,


    da der alte gleichnamige Thread zwischenzeitlich geschlossen wurde, mache ich mal einen neuen auf.


    Ich habe gerade gesehen, das Powarman eine neue Version des dvbhddevice veröffentlicht hat (Rev 101)


    "...Sat, 13 Oct 2012 20:02:35 +0200
    Do not enable AFD support in cDvbHdFfDevice:: SetVideoFormat.


    This should fix an issue on e.g. zdf_neo where 4by3 programmes where not
    pillarboxed after startup. It already worked when the setting was changed
    afterwards.


    From: Torsten Lang


    Signed-off-by: Andreas Regel <andreas.regel@gmx.de> ..."



    zu finden hier




    BITTE HIER NUR KONSTRUKTIVE BEITRÄGE POSTEN


    umso weniger Arbeit haben die Mods

  • es gibt wieder Neuigkeiten:


    -----------------------------------------------------------------------------------------------------------------


    Sun, 04 Nov 2012 19:29:49 +0100No A/V sync during audio-only playback. default tip
    Andreas Regel <andreas.regel@gmx.de> [Sun, 04 Nov 2012 19:29:49 +0100] rev 105
    No A/V sync during audio-only playback.


    This fixes audio trickmode and jump bugs.


    Signed-off-by: Andreas Regel <andreas.regel@gmx.de>


    ---------------------------------------------------------------------------------------------------


    Sun, 04 Nov 2012 19:19:03 +0100Support audio playback during trickmodes of audio-only recordings.


    Andreas Regel <andreas.regel@gmx.de> [Sun, 04 Nov 2012 19:19:03 +0100] rev 104
    Support audio playback during trickmodes of audio-only recordings.


    There should be no issue with video/audio recordings as VDR only sends video
    data during trickmodes.


    Signed-off-by: Andreas Regel <andreas.regel@gmx.de>


    ----------------------------------------------------------------------------------------------------------------


    Sun, 04 Nov 2012 18:59:13 +0100Fix not working play time in audio-only playback.


    Andreas Regel <andreas.regel@gmx.de> [Sun, 04 Nov 2012 18:59:13 +0100] rev 103
    Fix not working play time in audio-only playback.


    Now the audio PTS instead of the video PTS is returned when there is only audio
    data played back.


    Signed-off-by: Andreas Regel <andreas.regel@gmx.de>


    --------------------------------------------------------------------------------------------------


    Tue, 01 Nov 2011 20:31:57 +0100Support play mode pmExtern_THIS_SHOULD_BE_AVOIDED.


    Andreas Regel <andreas.regel@gmx.de> [Tue, 01 Nov 2011 20:31:57 +0100] rev 102
    Support play mode pmExtern_THIS_SHOULD_BE_AVOIDED.


    This is needed for extern player support, like mplayer.


    Signed-off-by: Andreas Regel <andreas.regel@gmx.de>


    -----------------------------------------------------------------------------------------------------

  • Hi,



    Was hat das zu bedeuten???


    das bedeutet, dass die Chancen größer werden, doch noch mal per mplayer Filme in Formaten abspielen zu können, die der VDR selber nicht beherrscht.


    drucks


    Ciao.
    Michael.

  • Das "THIS_SHOULD_BE_AVOIDED" bedeutet, dass es eigentlich eher so gedacht wäre, dass die Daten über die VDR-Schnittstellen zur Karte wandern und nicht der VDR angewiesen wird, die Karte freizugeben, damit ein externer Player direkt auf die Karte wiedergibt.


    Das eine Wiedergabe mit mplayer möglich wird setzt voraus, dass jemand Interesse daran hat, eine entsprechende Ausgabe in den mplayer zu programmieren.

  • Das eine Wiedergabe mit mplayer möglich wird setzt voraus, dass jemand Interesse daran hat, eine entsprechende Ausgabe in den mplayer zu programmieren.


    Oder jemand ist einfach mal so mutig und probiert das vorhandene ins Devicefile zu schreiben (halt genauso wie bei der SD FF) ;) Weil beim letzten Log was ich hier sahr scheiterte es daran das das Devicefile nicht freigegeben war (war halt noch vom hddevice Plugin exclusiv geöffnet). Wäre mal interesannt zu sehen wies weitergeht.


    cu

  • Neues vom Wochenende:


    ----------------------------------------------------------------------------------------------
    Andreas Regel <andreas.regel@gmx.de> [Sun, 11 Nov 2012 20:41:18 +0100] rev 107
    Disable direct output of UTF-8 strings for newer firmware.
    It does not work on systems that do not use UTF-8 in their locale.
    Signed-off-by: Andreas Regel <andreas.regel@gmx.de>


    ------------------------------------------------------------------------------------------------


    Andreas Regel <andreas.regel@gmx.de> [Sun, 11 Nov 2012 18:48:51 +0100] rev 106
    merge: Support play mode pmExtern_THIS_SHOULD_BE_AVOIDED.
    Signed-off-by: Andreas Regel <andreas.regel@gmx.de>


    ------------------------------------------------------------------------------------------------

  • Momentan ist dvbhddevice Rev 113 aktuell:


    "...Andreas Regel <andreas.regel@gmx.de> [Fri, 28 Dec 2012 20:54:02 +0100] rev 113
     
    Implement GrabImage().
     
    Scaling the image is not supported yet, it always returns the full Image.
     
    Needs the latest driver to work.
     
    Signed-off-by: Andreas Regel <andreas.regel@gmx.de> ..."


    zu finden an gewohnter Stelle

  • Würde das bedeuten, das z.B. das Live-Plugin nun ein Bild bei der Funktion "Fernbedienung" anzeigen kann?

    Gruss,
    Michael


    VDR1: openSuSe Linux 10.2 Kernel 2.6.22.9, P4 650, VDR 1.6.0-2, Terratec S-2300 modded+Full_TS-&4MB-Mod, DVB-S, GraphLCD,AvBoard. Plugins: femon,remote,live,dvd,radio,wirbelscan,burn,epgsearch,extrecmenu,fritzbox,streamdev;
    VDR2: openSuSe LEAP Kernel 4.4.120-45-default,TT-S2 6400 DVB-S, VDR 2.2.0, TouchTFT. Plugins: remote,dvbhddevice,live,graphtft,epgsearch,extrecmenu,fritzbox

  • Würde das bedeuten, das z.B. das Live-Plugin nun ein Bild bei der Funktion "Fernbedienung" anzeigen kann?


    Wenn es das Bild über cDevice::GrabImage() holt, dann sollte das wohl gehen.


    Ich habe GRAB mit der TT S2-6400 heute ausprobiert und es geht schon recht gut.
    powarman : Vielen Dank!


    Klaus


  • Wenn es das Bild über cDevice::GrabImage() holt, dann sollte das wohl gehen.


    Ich habe GRAB mit der TT S2-6400 heute ausprobiert und es geht schon recht gut.
    powarman : Vielen Dank!


    Hi,
    auch von mir, Vielen Dank an powarman! :)
    Wie kann ich die neue Funktion testen? Bisher ist das gescheitert.... dvbhddevice plugin und dvb-treiber ist aktualisiert!
    Muss ich dem Modul eine Option mitgeben?



  • Hi,
    auch von mir, Vielen Dank an powarman! :)
    Wie kann ich die neue Funktion testen? Bisher ist das gescheitert.... dvbhddevice plugin und dvb-treiber ist aktualisiert!
    Muss ich dem Modul eine Option mitgeben?


    Ja, du mußt video_capture=1 angeben.
    Warum das defaultmäßig aus ist, weiß ich auch nicht, aber ich nehme mal an powarman wird seine Gründe dafür haben.


    Klaus

  • @Klaus Super, vielen Dank für die Info! Teste ich nach der Aufnahme (3sat-HD) ... :)

  • Hallo,


    Ja, du mußt video_capture=1 angeben.
    Warum das defaultmäßig aus ist, weiß ich auch nicht, aber ich nehme mal an powarman wird seine Gründe dafür haben.


    wo genau muss das angegeben werden?
    Beim Laden des Moduls als Parameter oder als Parameter in der setup.conf oder beim Compile im Makefile?
    Irgendwie sehe ich keinen Unterschied - egal wo ich das hinschreibe 8-(


    Klaus


    Thx und ciao!
    Michael.

  • Hallo,



    wo genau muss das angegeben werden?
    Beim Laden des Moduls als Parameter oder als Parameter in der setup.conf oder beim Compile im Makefile?
    Irgendwie sehe ich keinen Unterschied - egal wo ich das hinschreibe 8-(


    Das ist ein Parameter des Treiber-Moduls.
    Ich habe mir das hier gleich in die Treiber-Source reingepatcht:


    Klaus

  • Hallo,


    danke für die Antwort, aber ...


    Das ist ein Parameter des Treiber-Moduls.


    ... obwohl ich eigentlich den neuesten media_build_experimental verwende, kennt mein saa716x_ff den Parameter nicht:


    modprobe saa716x_ff
    FATAL: Error inserting saa716x_ff (/lib/modules/3.6.2-3-desktop/kernel/drivers/media/pci/saa716x/saa716x_ff.ko): Unknown symbol in module, or unknown parameter (see dmesg)


    Was mache ich da denn falsch?


    Klaus


    Ciao.
    Michael.


  • ... obwohl ich eigentlich den neuesten media_build_experimental verwende, kennt mein saa716x_ff den Parameter nicht:


    modprobe saa716x_ff
    FATAL: Error inserting saa716x_ff (/lib/modules/3.6.2-3-desktop/kernel/drivers/media/pci/saa716x/saa716x_ff.ko): Unknown symbol in module, or unknown parameter (see dmesg)


    Was mache ich da denn falsch?


    Kann man mit "dmesg" anzeigen lassen.


    Der aktuelle Treiber kennt "video_capture":


    Code
    1. modinfo v4l/saa716x_ff.ko
    2. ...
    3. parm: verbose:verbose startup messages, default is 1 (yes) (int)
    4. parm: int_type:force Interrupt Handler type: 0=INT-A, 1=MSI, 2=MSI-X. default INT-A mode (int)
    5. parm: int_count_enable:enable counting of interrupts (int)
    6. parm: video_capture:capture digital video coming from STi7109: 0=off, 1=one-shot. default off (int)


    CU
    Oliver