kein Ton über HDMI nach S3

  • Hallo,


    erst mal vielen dank an das Yavdr-Team für die Distri.


    Habe seit etwa ein bis zwei Wochen keinen Ton nach S3 bei meiner gt430.
    Diese speist über HDMI einen Denon-Receiver und dieser den TV.
    Zuvor lief yavdr-0.5-beta sehr stabil und mit Ton, auch nach S2ram.
    Auch ein Umstellen der Einträge in der /etc/apt/sources.list.d/yavdr.list von testing auf stable und
    ein anschließendes "sudo apt-get update && sudo apt-get dist-upgrade" brachte keine Besserung.


    Grüße
    Funzt

  • Hi,


    bin ich der einzige mit diesem Problem?
    Liegt es ev. am neuen nvidia Treiber?
    Habe bisher immer brav regelmäßig apt-get update && apt-get dist-upgrade von yavdr-0.5-beta gemacht und
    wie gesagt seit ein paar Wochen dieses Problem, wobei es nicht immer sondern nur gefühlt zu etwa 90% auftritt.


    Grüße
    Funzt

  • Löst da ein "sudo restart vdr-frontend" das Problem?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,

    Quote

    Löst da ein "sudo restart vdr-frontend" das Problem?

    nein, leider nicht.
    Habe aber fest gestellt, dass der Ton nach S3 nicht verschwindet, wenn ich nur den VDR-Rechner schlafen lege und den Verstärker samt TV an lasse.
    Vermute, dass es was mit dem HDMI-Handshake zu tun hat!?


    Grüße
    Funzt

  • ist ein bug im nvidia treiber. Hab auch einen Denon Receiver. Liegt irgendwie an der Startreihenfolge der Geräte. Ich hab alles mögliche probiert, bin dann wieder auf den 295 zurück

    Mein VDR: Software: vdr 1.7.30 vdr-xine, xine-lib-1.2, Ubuntu 10.04, 2.6.35 Hardware: GT 220, TT-PCI S2-1600 + Mystique SaTiX-S2 V2

  • Bei mir gabs das Problem, das ich den HTPC immer 2x aufwecken musste, beim ersten mal gabs keinen Ton mehr, beim zweiten mal dann eigentlich recht zuverlässig. Bei mir hat geholfen das nvidia Kernelmodul neuladen zu lassen nach dem aufwachen, seit dem scheint das Ganze ok zu sein, keine Fehler mehr seit geraumer Weile.


    Grüz!
    Hibbelharry

    - HTPC mit zerbasteltem Yavdr 0.6 , Origen ae X15e, MCE Remote, Asus P5N7A-VM, 1x Digibit R1, Kodi und vdr an Pana 46PZ85E
    - Diverse HTPCs im Umfeld bei Familie und Freundenm die sich vor mir fürchten, mit allen möglichen gruseligen Konfigurationen.
    Auch gern Debian, aber wehe jemand kommt mir mit Suse.

  • Hi,


    habe zu Test nach dieser Anleitung: http://www.vdr-wiki.de/wiki/index.php/YaVDR/FAQ
    Die Datei "/etc/yavdr/force-reload-modules.list" anlegen und dort das Modul "nvidia" eintragen.
    Hilft aber auch nicht.
    Wird diese Datei zum Neuladen der Module aktuell noch von yavdr verwendet?
    Im syslog steht bez. nvidia nur was von resume:

    Code
    1. Oct 20 09:40:10 gt430 kernel: [ 327.157607] PM: resume of drv:nvidia dev:0000:01:00.0 complete after 251.074 msecs
    2. Oct 20 09:44:57 gt430 kernel: [ 457.664791] nvidia 0000:01:00.0: restoring config space at offset 0xc (was 0xf7000000, writing 0x0)
    3. Oct 20 09:44:57 gt430 kernel: [ 457.664801] nvidia 0000:01:00.0: restoring config space at offset 0x3 (was 0x800010, writing 0x800000)
    4. Oct 20 09:44:57 gt430 kernel: [ 457.915956] PM: resume of drv:nvidia dev:0000:01:00.0 complete after 250.959 msecs


    Grüße
    Funzt

  • Ich kenne das Phänomen hier auch. Entweder ist es eine der letzten softhddevice Änderungen oder der neue Treiber.


    Temporäre Lösung hier ist:


    stop vdr-frontend && xrandr -d :1 -r 50 && sleep 1 && start vdr-frontend

  • Hi Steffen_b,
    habe leider genau dasselbe Problem. Da meine Kenntnisse von Linux total unten angesiedelt sind, kann ich leider mit Deiner Zeile ganz unten nichts anfangen.


    " stop vdr-frontend && xrandr -d :1 -r 50 && sleep 1 && start vdr-frontend "


    Kannst Du vielleicht mal so nett sein und für son dummen Schüler wie mich nochmal erklären, was ich mit dieser Zeile machen soll.


    Schönen Sonntag und schonmal schönen Dank.


    Viele Grüße becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Hallo,
    gibt es vielleicht jemand der mir weiter helfen kann, was es mit dieser Zeile auf sich hat ???


    " stop vdr-frontend && xrandr -d :1 -r 50 && sleep 1 && start vdr-frontend "


    Ist nämlich ganz schön doof so ohne Ton.
    Jetzt ist mein VDR aus dem Standby aufgewacht um Nachrichten aufzunehmen und ich habe kein Ton. Musste nun den ganzen VDR runterfahren somit die Aufnahme unterbrechen und neu starten um auf einem anderen Programm eine Sendung mit Ton zu sehen.


    Vielleicht ist ja meine Frage zu doof ich habe aber absolut keine Ahnung, was ich mit der o. g. Zeile anfangen soll und wie ich das Problem in den Griff bekomme.
    Vielen Dank.


    Gruß becky

    VDR1
    SW: yavdr 0.5
    HW: Silverstone LC18, M3N78 Pro, AMD 64 3400+,, 2x 2GB Ram, 2 x TT 3200 S2


    VDR2
    SW: yavdr 0.4
    HW: M4A78 Pro, Gainward GeForce GT430 (1024 MB), AMD 64 3400+. 2x 512 MB Ram

  • Hallo,


    habe auch das gleiche Problem.
    " stop vdr-frontend && xrandr -d :1 -r 50 && sleep 1 && start vdr-frontend " hilft tatsächlich.
    Nur möchte ich das ja nicht nach jedem wakeup manuell ausführen müssen.
    Gibt es also irgend ein Script, das nach dem wakeup ausgeführt wird, wo man das einfügen kann???
    Oder kann man das "xrandr -d :1 -r 50" in das starten des vdd-frontend mit einbauen?


    Vielen Dank im Voraus.

  • Ich kenne das Phänomen hier auch. Entweder ist es eine der letzten softhddevice Änderungen oder der neue Treiber.


    Temporäre Lösung hier ist:


    stop vdr-frontend && xrandr -d :1 -r 50 && sleep 1 && start vdr-frontend


    Vielen Dank für den Tipp mit xrandr - ich habe es über eine PM-Hook bzw. SustemD-Hook gelöst.
    Dazu habe ich einen langen Artikel auf meinem Blog geschrieben - ich hoffe es hilft. ;)



    Ich habe es mit einer PM-Hook bzw. SustemD-Hook gelöst - diese wird automatisch beim Ausführen aus dem S3 / Suspend to RAM ausgeführt. Dazu habe ich einen Artikel auf meinem Blog geschrieben - den Link findest du über deinem Zitat. :D

  • Du kannst einen Aufruf von nvidia-settings hinterherschieben (mit deinen Einstellungen):

    Code
    1. nvidia-settings --assign CurrentMetaMode="DFP-0: 1280x720_50 { ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}"

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo,
    die Lösung hier hat mir auch geholfen obwohl ich meine beiden yavdr 0.5 PC's mit HDMI direkt am TV habe - also ohne Dolby Surround Anlage. Auch hier hatte ich nach dem S3 keinen Ton egal ob das TV beim VDR-Start an war oder nicht.
    Vielen Dank u. Grüße
    JP

    SW: 3 mal yaVDR 0.5 (SAT), 1 mal yaVDR 0.6 (Kabel) , 1 mal Kodi 15.2 Client
    HW: 2 mal SST LC10B mit ASUS M4N78 Pro , SST-GD01B-MXR u. Antec Micro Fusion 350 mit M3N78 EM
    Cine S2 V6 + Duoflex S2, Cine CT (V6) , Skystar HD2
    Logitech diNovo Edge, Logitech Harmony 900 , Logitech Harmony One , Imon Pad
    Panasonic TH-D42PN73E , Pionieer VSX-D511, Samsung LE32R52B

  • Müssen wir nur noch mal so einbauen :)


    Macht es nicht mehr Sinn das xrandr --off beim suspend zu machen und das --auto bei resume ?
    Was das --auto mit nicht-default Auflösungen macht wäre auch noch zu eruieren.


    Mal schauen ...

  • Du kannst einen Aufruf von nvidia-settings hinterherschieben (mit deinen Einstellungen):

    Code
    1. nvidia-settings --assign CurrentMetaMode="DFP-0: 1280x720_50 { ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}"


    Das ist bei mir leider auch so :(


    Nachdem Aufwachen ruckeln es heftigst bei HD Sendern !!!!!!


    Wie genau muss man das denn Hinterherschieben? Ich denke das wäre auch für mich eine Lösung :)

    Gigabyte GA-A55M (FM1) ++++ AMD A4-3400 ++++ 4 GB DDR3 ++++ Geforce GT 620 ++++ Tevii 464 mit YAVDR 0.5 - XBMC Frodo 12

  • Ich verstehe das Problem nicht ganz - _nico hat doch wunderschön beschrieben, wie man das angehen kann: http://www.loggn.de/linux-nvid…smodus-s3-suspend-to-ram/ - da lässt sich die Zeile für den Overscan doch auch unterbringen...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Also einfach nur ans Ende des scriptest die Zeile einfügen?

    Gigabyte GA-A55M (FM1) ++++ AMD A4-3400 ++++ 4 GB DDR3 ++++ Geforce GT 620 ++++ Tevii 464 mit YAVDR 0.5 - XBMC Frodo 12

  • Nein, du musst schon die Syntax des Shell-Skripts beachten - ich habs mal markiert, wo sich das anbietet:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)