[yavdr-0.5] Doppelte EPG-Einträge (gelöst durch xmltv2vdr )

  • Moin


    Ich verwende das epgdata2vdr-addon und habe Probleme mit doppelten EPG-Einträgen. Ich finde in den Einstellung die Punkte :
    Zeitspanne für dop. EPG-Suche (min): 15
    Doppelten externen EPG-Eintrag: anwenden>
    Internes und externes EPG mischen: nein>


    nicht mehr. Gibt es die Funktion in der neuen Version nicht mehr? Oder bin ich nur zu Blöd diese zu finden?
    Oder gibt es inzwischen eine andere Möglichkeit doppelte EPG-Einträge zu verhindern ohne auf die Aktualisierung vom Provider zu verzichten.
    Inzwischen habe ich 3-4 Einträge für eine Sendung auf einigen Sendern.


    Hat jemand einen Tipp für mich.


    Gruß Olli





    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

    The post was edited 1 time, last by azuver ().

  • Das war nen Patch. Scheint so als ob der (nicht mehr?) drin ist.


    Entweder per noEPG das Sender EPG abschalten oder xmltv2vdr verwenden, das kann mischen.


    cu

  • Ich danke dir für deine Antwort.


    Ich versuche jetzt xmltv2vdr zu konfigurieren und habe dabei ein Problem. Im Log bekomme ich diese Fehlermeldung:


    Code
    1. Jul 14 16:32:00 yavdr vdr: [3148] xmltv2vdr importer thread started (pid=2663, tid=3148)
    2. Jul 14 16:32:00 yavdr vdr: [3148] xmltv2vdr: 'epgdata' epgdata 10 'X' 1 13th-street.de ....
    3. Jul 14 16:32:00 yavdr vdr: [3148] xmltv2vdr: 'epgdata' executing epgsource
    4. Jul 14 16:32:00 yavdr vdr: [3148] xmltv2vdr: 'epgdata' ERROR (script) sh: epgdata: Kommando nicht gefunden.
    5. Jul 14 16:32:00 yavdr vdr: [3148] xmltv2vdr: 'epgdata' ERROR epgsource returned 127
    6. Jul 14 16:32:00 yavdr vdr: [3148] xmltv2vdr importer thread ended (pid=2663, tid=3148)


    In einem andern Post wird beschrieben das ich die epgdata2xmltv übersetzten soll damit es funktioniert. Ich habe jetzt aber das Paket vdr-plugin-xmltv2vdr-grabber-epgdata2xmltv
    installiert, also sollte es doch schon vorhanden sein. Oder habe ich etwas falsch verstanden?


    Oder muß ich noch etwas anderes anpassen?


    Gruß Olli

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

  • Mach mal ein

    Code
    1. apt-cache policy vdr-plugin-xmltv2vdr-grabber-epgdata2xmltv

    dann schaue ich mir den Grabber mal an.
    Normalerweise sollte das einfach so funktionieren.


    cu

  • Also meine Kiste zeigt mir das diese Version installiert ist:


    Code
    1. vdr-plugin-xmltv2vdr-grabber-epgdata2xmltv:
    2. Installiert: 0.2.0pre.git20120612-0yavdr0~precise
    3. Kandidat: 0.2.0pre.git20120612-0yavdr0~precise
    4. Versionstabelle:
    5. *** 0.2.0pre.git20120612-0yavdr0~precise 0
    6. 500 http://ppa.launchpad.net/yavdr/testing-vdr/ubuntu/ precise/main amd64 Packages
    7. 100 /var/lib/dpkg/status


    Gruß Olli

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

  • Entweder wie gehabt konfigurieren (quasi Oldschool), dann müsstest du aber das noepg Plugin installieren (Die EPG Schnittstelle des VDR hat sich geändert, das braucht jetzt keinen Patch mehr) oder du versuchst dich am xmltv2vdr Plugin, das merged und vermeidet so die doppelten EPG Einträge. Letzteres habe ich noch nicht getestet (nie die Zeit gefunden dafür)

  • Das Paket [vdr-plugin-xmltv2vdr-grabber-epgdata2xmltv_0.2.0pre.git20120612-0yavdr0~precise_amd64.deb] scheint fehlerhaft zu sein.


    Mach mal ein

    Code
    1. mv /var/lib/epgsources/epgdata2xmltv/epgdata2xmltv.dist /var/lib/epgsources/epgdata2xmltv/epgdata2xmltv

    und probiere es nochmal (kann aber auch sein das da noch Rechte angepasst werden müssen).


    cu

  • Vielleicht kommt auch daher mein Problem. Ich konnte über OSD das Plugin nicht komplett konfigurieren die Punkte: EPG Quellen und EPG Quellkanäle konnte ich nicht auswählen.
    Erst nachdem ich ein


    cp /var/lib/epgsources/epgdata2xmltv/epgdata2xmltv.dist /var/lib/epgsources/epgdata
    abgeschickt habe konnte ich die Punkte anwählen.
    Rechte habe ich auf 777 gesetzt.


    Gruß Olli

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

  • Gehts jetzt richtig? Auch mit EPG Bildern? Weil das Verzeichnis für die EPG Bilder wird vom Paket auch nicht behandelt.


    Wenn ja dann mach mal nen Bugreport (mit Verweis auf diesen Thread) im yaVDR Bugtracker, das sollte dort ja dann irgendwann gefixt werden (sonst hat jeder Nutzer das Problem).


    cu

  • Ne es funktioniert leider noch nicht.


    Gruß Olli

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

  • Was sagt denn das Log?


    Und probiere mal

    Code
    1. epgdata 10 <deine PIN> 1 13th-street.de

    von der Shell aus aufzurufen.


    Und in deinen vorherigen Log sehe ich auch keine PIN, hast du deine epgdata PIN im Plugin eingetragen und sie hier nur fürs Log posten ausgeXst (was ja durchaus korrekt ist)?


    cu

  • Ich bekomme diese Meldung:


    "-bash: epgdata: Kommando nicht gefunden."


    Ja den PIN habe ich eingetragen.


    Gruß Olli

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

  • Ups, das muss nicht epgdata sondern epgdata2xmltv heissen, ich weiss gar nicht wo auf einmal das epgdata aus dem Log herkommt.


    Also

    Code
    1. epgdata2xmltv 10 <deine PIN> 1 13th-street.de


    Und mach mal nen

    Code
    1. ls -l /var/lib/epgsources


    cu

  • Das wars ich habe den Fehler gefunden.


    Im Ordner "/var/lib/epgsources" ist keine Konfig-Datei sondern ein Ordner indem die epgdata2xmltv liegt.


    Ich habe jetzt den Ordner gelöscht und die epgdata2xmltv stattdessen angelegt und jetzt scheint es zu funktionieren.


    Eine Frage habe ich aber noch in den Plugin-Einstellung bei EPG Quellen erscheint jetzt epgdata2xmltv, ich kann aber nirgens einstellen das er auch die Daten vom Provider(Das EPG vom Sender) benutzen soll, macht er es automatisch oder muss ich dafür noch etwas einstellen?


    Ich danke dir für deine Mühen!


    Gruß Olli

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

  • Im Ordner "/var/lib/epgsources" ist keine Konfig-Datei sondern ein Ordner indem die epgdata2xmltv liegt.


    Das ist auch korrekt so.


    Ich habe jetzt den Ordner gelöscht und die epgdata2xmltv stattdessen angelegt und jetzt scheint es zu funktionieren.


    Das verstehe ich nicht, so sollte das eigentlich nicht funktionieren.


    Mach mal den Testaufruf an der Shell.


    cu

  • Ich mache es gleich im Moment läuft nur ne Aufnahme und ich muß noch bis 20.15 warten sonst bekomm ich Ärger. :)


    Gruß Olli

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

  • Also es funktioniert so, keine Ahnung warum. Ich habe den Download über den Plugintimer angeworfen.
    Er hat die Dateien von epgdata.com heruntergeladen und verarbeitet sie jetzt.


    Im Log kommt:


    Gut die nickcomedy.de Zuweisung habe ich jetzt durchgeführt,aber ich verstehe nicht wieso er nur bei ganz wenigen Sendungen die ShowID von epgdata.com anzeigt. Ist er im Hintergrund noch am arbeiten?
    Kann ich irgendwie feststellen ob er noch etwas macht?


    Gruß Olli

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

  • Lass ihm einfach etwas Zeit. Es wird nicht das komplette EPG auf einmal gemischt, das passiert so mit der Zeit im Hintergrund.


    Was die ShowID weiss ich jetzt nicht. aber beim mischen werden nicht alle EPG Einträge erfasst, weichen Sender EPG zu stark voneinander ab (oder haben zu unterschiedliche Titel) wird das externe für die Sendung ignoriert.


    cu

  • Ne Volltextsuche nach "show" im epgdata Grabber liefert keine Ergebnisse. Also ich würde die ShowID nicht erwarten ;)


    Was macht die überhaupt?


    cu