yavdr0.5-alpha1 / traco

  • Hallo!


    Ich versuche traco unter yavdr-0.5-alpha1 zum laufen zu bringen.


    Installation:



    Gruß


    Murry

    Files

    The post was edited 1 time, last by Murry ().

  • Erste Tests:


    HTPC:~$ HandBrakeCLI
    Missing input device. Run HandBrakeCLI --help for syntax.


    HTPC:~$ tracosrv.pl -d -vvv -f

  • Nach einem reboot beibt das Bild schwarz, keine Anzeige im Status-LCD (pearl).


    syslog:




    Nach 3 min. kam ein Bild:


  • Neue Aufnahme (nach 3mi n abgebrochen):


    tracosrv.pl -d -vvv -f


  • Nach einem weiteren reboot kommt das Bild sofort. Aber traco meint ich nehme noch auf:


    HTPC:~$ tracosrv.pl -d -vvv -f



    Bei dem Befehl "prepare transcode file" kommt folgende Meldung:


    tracoadm exit with xmlfile_not_found


    Weiß jemand weiter?


    Gruß


    Murry

  • hi


    also


    Proc::Daemon muss ab ubuntu version 12 nicht mehr via cpan installiert werden


    ein apt-get install libproc-daemon-perl sollte reichen


    hat sich das format von info datei geaendert ?


    traco wertet die startzeit sowie die lauftzeit aus der info aus um anhand dessen fest zustellen ob ein recording noch aktiv ist.


    solange traco mein das da noch aufgezeichnet wird , wird keine xml datei erstellt.
    ohne diese xml datei sind keine weiteren schritte moeglich fuer die laufende aufnahme .


    bei aufnahmen die fertig sind und die .xml entalten sollte alles funktionieren


    h
    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit

  • Proc::Daemon muss ab ubuntu version 12 nicht mehr via cpan installiert werden


    ein apt-get install libproc-daemon-perl sollte reichen


    Ich habe die Anleitung angepasst



    info:



    Jetzt geht das "prepare transcode file": transcodeadm exit with done


    "start transcode": transcodeadm exit with done --> aber keine Datei unter /srv/vdr/video.00/iso


    vdrtranscode.xml



    Gruß


    Murry

  • laeuft der daemon ?


    wenn als status YourPictureIsReadyToView ist was fertig umgerechnet worden .
    also mal im zielverzeichniss checken oder im aufnahme verzeichnis falls das umkopieren nicht geklappt hat.


    du kannst auch per hand den status aendern .


    prepare_traco_ts -> aufnahme dateien ggf schneiden und zusammen fuegen.
    ready oder online -> traco sollte dann los rennen und anfangen umzurechnen


    der unterschied liegt hier wie der daemon gestartet wurde ...... sollte aber im detail egal sein.


    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit

  • Anscheinend läuft der Server nicht. Auch nachdem ich die Rechte für diese Datei auf root geändert habe:


    /etc/init.d/tracosrv.sh


    Muss noch irgendwo ein Eintrag gemacht werden?


    Wenn ich den Server von Hand laufen lasse, erhalte ich folgende Fehlermeldung:


    sudo tracosrv.pl -d -vvv -f


    Code
    1. [DEBUG]/srv/vdr/video.00/Die_Simpsons/2012-07-11.17.56.7-0.rec have status ready
    2. in /srv/vdr/video.00/Die_Simpsons/2012-07-11.17.56.7-0.rec ,no vdrtranscode.ts exist , stop _preproccess for transcodevideo , set status to offline
    3. Can't use an undefined value as a SCALAR reference at /usr/bin/tracosrv.pl line 396


    Gruß


    Murry

  • Anscheinend läuft der Server nicht. Auch nachdem ich die Rechte für diese Datei auf root geändert habe:


    /etc/init.d/tracosrv.sh


    Muss noch irgendwo ein Eintrag gemacht werden?


    Ich habe jetzt folgende Datei erstellt:


    /etc/init/traco.conf


    Code
    1. start on (runlevel [2345] and vdr-started)
    2. exec /usr/bin/tracosrv.pl -c /etc/vdr/vdrtranscode.conf
    3. stop on (runlevel [016] and vdr-stopped)


    Der Server startet immer noch nicht :-(

  • hi


    kannst du mal bitte den tracosrv.pl editieren


    aenderung 1
    am anfang so zeile 23 sollte eine zeile

    Code
    1. #user Data::Dumper ;


    stehen


    bitte diese aendern in

    Code
    1. use Data::Dumper;


    aenderung 2


    in zeile 396
    sollte das stehen

    Code
    1. if (${$trrc} =~ /[_]done$/smx ) {


    bitte davor einfuegen

    Code
    1. print Dumper ${$trrc} ;


    bitte vorher mal die xml datei in der simson aufnahme anschauen , im speziellen die status zeile


    dann den aufruf nochmal machen.


    wenn du per hand

    Code
    1. /usr/bin/tracosrv.pl -c /etc/vdr/vdrtranscode.conf

    ein gibst gibt es dann einen fehler ?


    was sagt das logfile /var/log/syslog ?


    nochmal zu klar stellung , tracosrv.pl muss laufen .
    dieser wird dann ueber die xml datei mit tracoadm.pl gesteuert.


    des wegen kann man auch tracoadm.pl benutzen ohne das was passiert weil tracoadm.pl nur die xml datei manipuliert was der server proccess dann verarbeitet.


    holger


    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit

  • /usr/bin/tracosrv.pl -c /etc/vdr/vdrtranscode.conf


    Muss es nicht "/usr/bin/tracosrv.pl -c /etc/vdr/traco.conf" heißen?


    /usr/bin/tracosrv.pl -c /etc/vdr/traco.conf


    Nun läuft der Server (es dauert recht lange, bis er von selbst startet):


    HTPC:~$ sudo ps -A|grep tracosrv.pl
    2389 ? 00:00:01 tracosrv.pl


    syslog
    Jul 13 19:53:57 HTPC /usr/bin/tracosrv.pl[2310]: fork to the background pid 2310 with EUID = 666


    Jetzt erhalte ich bei "prepare transcoder file"
    missing vdr_user in config or passwd


    Gruß


    Murry

    The post was edited 2 times, last by Murry ().

  • moin


    -c path/zur/config.conf
    da ist es egal wiese sie heist


    wihtig ist auch das sie angepasst ist also nicht im zweifel blind uebernehmen


    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit

  • Hallo holger,


    so der server läuft:


    HTPC:~$ sudo /etc/init.d/tracosrv.sh status
    * tracosrv.pl is running


    Jetzt habe ich mal eine andere Aufnahme ausprobiert. Leider gibt es jetzt eine andere Fehlermeldung.


    Code
    1. [DEBUG]/srv/vdr/video.00/Drag_Me_to_Hell/2012-06-30.22.13.5-0.rec have status renameaftertranscode
    2. Use of uninitialized value $y in substitution (s///) at /usr/lib/perl5/Traco/Tracorenamefile.pm line 88.
    3. [DEBUG]_rename_and_store | /srv/vdr/video.00/Drag_Me_to_Hell/2012-06-30.22.13.5-0.rec | build filename Drag_Me_to_Hell-(14.7.2012,720x,25).mp4
    4. [DEBUG]_rename_and_store | work with
    5. [DEBUG]_rename_and_store | copy to /srv/vdr/video.00/iso/Drag_Me_to_Hell-(14.7.2012,720x,25).mp4


    Ist das etwas einfaches?


    Anderenfalls warte ich bis du auf yavdr0.5 umgestiegen bist.


    Vielen Dank,


    Murry

  • hi
    @murrry das ein kleiner fehler ... der aber fuer das umbenennen / kopieren keine rolle spielen.
    kannst du mal bitte in die xml datei von dieser aufnahme schauen ?
    das scheint es die ypixel angabe nicht zu geben , bzw
    kannst du die xml mal posten ?


    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit

  • das scheint es die ypixel angabe nicht zu geben , bzw
    kannst du die xml mal posten ?



  • hi


    mans sieht sehr schen das ypixel fehlt in der xml datei,



    vergleich mal ob alle xml files beid dir so sind.




    ggf hast du schon mal mit einer aelteren version getestet oder die version die du jetzt hast ist nicht die richtige.



    ggf mal

    Code
    1. git clone https://github.com/kakadoo/traco.git


    git vorher installieren falls noch nicht getan.
    ( apt-get install git )


    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit


  • mans sieht sehr schen das ypixel fehlt in der xml datei,
    vergleich mal ob alle xml files beid dir so sind.
    ggf hast du schon mal mit einer aelteren version getestet oder die version die du jetzt hast ist nicht die richtige.


    Beim PAL-Profile ist es da, beim SD-Profile nicht. Alle Dateien sind aktuell.




    Leider läuft es mit PAL auch nicht durch:



    Die Dateien aus dem GIT nur ersetzen?


    Gruß


    Murry

  • hi
    ja einfach ersetzen


    kann es sein das du nicht abwartest bis sich der status nach waehlen von prepare_traco_ts selber aendert ?


    zu mindestens sieht das so aus im log.


    deswegen kann er dann auch nicht umrechnen weil die traco.ts bte vdrtranscode.ts fehlt .


    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit

  • hi


    ich habe gerade 2 commits im git gemacht , bitte nochmal clonen .


    im tracosrv.pl habe ich das handling der lck dateien gaendert bzw erweitert so das man , hoffentlich ;) , nicht mehr vorschnell
    eine status aendern kann.


    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit