Aktuelle Treiber für Octopus(ddbridge), CineS2(ngene/ddbridge), DuoFlex-S2, DuoFlex-CT, CineCT sowie TT S2-6400 (Teil 2)

  • Es sieht so aus, daß die Fehler eher zufällig aufgetreten sind. Nach viermal war wieder Ruhe.


    Hm - Wackelkontakt/ungünstige Verlegung des Datenkabels käme auch noch in Frage.


    Quote


    In dem Bereich gibt es keine Unterschiede. Irgendwo gab es aber eine Änderung, die mit I²C und Locking zu tun hatte. Daher hatte ich das Treiber-Update in Verdacht.


    Die o.g. Dateien sind imho alles, was aus media_build_experimental/media_build kommt und für die Karte benötigt wird.
    Ansonsten käme noch der Kernel in Frage, diesen hast Du aber ja wohl nicht geändert...


    CU
    Oliver

  • Hallo,


    ich möchte unter ubuntu 12.04 x64 eine Digital Devices Cine CT V6 für DVB-C in Betrieb nehmen. Den Treiber habe ich wie zu Threadbeginn beschrieben gebaut. Dann bekomme ich aber diesen Fehler.


    Die Karte selbst wird erkannt.

    Code
    1. lspci|grep Digital
    2. 02:00.0 Multimedia controller: Digital Devices GmbH Octopus LE DVB adapter


    Kann mir bitte jemand weiter helfen? Ich habe von Linux leider nicht so viel Ahnung...


    Danke,
    Micha

  • Naja die gebaute Treiberversion passt nicht zum Kernel


    Kann mir bitte jemand weiter helfen? Ich habe von Linux leider nicht so viel Ahnung...


    Warum machst du dir dann das Leben so schwer? Immerhin gibt es ein fertiges linux-media-dkms Paket im yaVDR main PPA, das die Karte unterstützt...
    Also wenn möglich alles von dem händischen Installationsversuch runterwerfen (müsste über make uninstall im Quellverzeichnis gehen) - oder nochmal mit einem frischen System anfangen und dann:

    Code
    1. sudo add-apt-repository ppa:yavdr/main
    2. sudo apt-get update
    3. sudo apt-get dist-upgrade
    4. sudo apt-get install linux-media-dkms


    Zukünftige Updates dann bitte nur mit "sudo apt-get update" und "sudo apt-get dist-upgrade" (nicht "apt-get upgrade") machen, dann sollten die Treiber immer passend zum Kernel gebaut werden.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich habe den saa716x_ff-Treiber mal direkt in linux-3.5.0 gebaut. Da gab es section mismatches und include-Probleme. Entsprechende patches anbei, die duerfen von mir aus gerne in das Treiber-Repository uebernommen werden.


    Ich haette auch noch andere Problemchen und Aenderungsvorschlaege fuer den Treiber, sind solche patches hier erwuenscht oder soll ich die lieber woanders hin (oder ueberhaupt nicht) schicken?


    Gruss,
    S:oren

  • Um nicht immer nur etwas zu schreiben wenns nicht funktioniert: Mit der aktuellen Version funktionierts (wieder) (Kernel 3.0.0-23-generic) :-)

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

  • Vom ersten Teil des Themen-Beitrages



    Ja, es gibt eine Registereinstellung dazu: Der Loop-Through war deaktiviert.


    Bitte Treiber aktualisieren. Sollte jetzt funktionieren.


    CU
    Oliver


    Hallo, habe eben auf einem Esprimo E5625 die aktuelle yavdr 0.4 installiert.
    Hinter einer CineCT hängt noch eine PVR-500: hier ist das Bild ähnlich schlecht wie oben beschrieben.
    Habe nach Installation apt-get update & apt-get dist-upgrade sowie install linux-media-dkms durchgeführt,
    soweit läuft alles...
    Wer kann mir weiterhelfen?


    Grüße, lolldroll

    ___________________________________________________________________________________________
    in Rente: mein erster VDR Intel SR440BX, Slot1 PIII 500Mhz, 128MB / DVB-C FF / ctvdr 6.1

  • Hallo, habe eben auf einem Esprimo E5625 die aktuelle yavdr 0.4 installiert.
    Hinter einer CineCT hängt noch eine PVR-500: hier ist das Bild ähnlich schlecht wie oben beschrieben.


    Hast du überhaupt schon DVB-C Kanäle in deiner channels.conf oder sind das noch die mitgelieferten IPTV-Kanäle?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Nach der Installation habe ich eine Kanalliste mittels wirbelscan erstellt.
    Zuerst für DVB-C, danach für analog TV. Für letztere musste ich aber das Antennenkabel direkt an die PVR500 anschliessen.
    Direkt angeschlossen liefert die PVR ein Bild, nur eben nicht per Loop-Through. Von daher ja meine Frage...


    Grüße, lolldroll

    ___________________________________________________________________________________________
    in Rente: mein erster VDR Intel SR440BX, Slot1 PIII 500Mhz, 128MB / DVB-C FF / ctvdr 6.1

  • Hallo,
    modinfo ddbridge
    spuckt u.a. als Parameter folgendes aus: ts_loop
    Kann mir jemand sagen wozu dieser dient ?


    Und wie ggfs der Eintrag einer /etc/modprobe.d/ddbringe.conf auszusehen hat?

    ___________________________________________________________________________________________
    in Rente: mein erster VDR Intel SR440BX, Slot1 PIII 500Mhz, 128MB / DVB-C FF / ctvdr 6.1

    The post was edited 1 time, last by lolldroll ().

  • Da ist nix einzustellen, der Loop-Through ist immer aktiv.
    Evtl. ist der Signalpegel an der Grenze und am Loop-Through dann zu niedrig...


    CU
    Oliver

  • Da Mauro gerade die gesamte v4ldvb-Directory-Struktur durcheinanderwürfelt und daher nichts mehr kompiliert, habe ich den Upstream-Treiber auf den Stand vom 13.8.2012 eingefroren. Ich werde dies erst rückgängig machen, wenn sich die neue Struktur stabilisiert hat und Upstream wieder kompiliert. Schätze Anfang September... ;(


    CU
    Oliver

  • Hi, leider klappt es bei mir immer noch nicht. Ich nutze Ubuntu 10.04 LTS server mit dem Kernel 2.6.32-42-server und DuoFlex-S2 Karte.


    Wenn ich die linux-media Datei vom 30.06 nutze, dann kommt genau wie bei der aktuellen der Fehler:

    Code
    1. Applying patches for kernel 2.6.32-42-server patch -s -f -N -p1 -i ../backports/api_version.patch
    2. 1 out of 1 hunk FAILED -- saving rejects to file drivers/media/video/v4l2-ioctl.c.rej


    VIELEN DANK für Eure Hilfe.


    *EDIT*
    Ich habe jetzt schon mehrere ältere versionen des git hub und auch mehrere Versionen des linux_media archives versucht. Leider immer ohne Erfolg.


    Ich hoffe ihr könnt mir helfen.

    VDR-Server:

    XEON mit Digital Device PCIe Karte und DuoFlex S2 auf Ubuntu 14.04 mit VDR 2.2 in Docker Container.


    Clients:

    Intel I3 3225 mit nvidia Grafikkarte und yavdr 0.61
    Zotac Ion mit N330 mit yavdr 0.61 und streamdev-client
    Diverse PCs im Netz per streamdev in vlc player

    The post was edited 1 time, last by big_blue ().


  • Verwendest Du media_build oder media_build_experimental?


    Hier geht es ausschließlich um media_build_experimental wie im ersten Post beschrieben.
    media_build_experimental kompiliert definitiv mit 2.6.32.43. Gerade noch einmal getestet. :wow


    CU
    Oliver

  • *EDIT*
    Mit dem experimental package klappt es ohne Probleme. VIELEN DANK. :D


    Hi. Vielen Dank für die Info. Habe ich dann wohl überlesen. Bisher habe ich nur die media_build genutzt. Aber wenn die experimental Klappe, dann nehme ich die. Wenn es nicht klappen sollt, dann melde ich mich noch mal.


    Vielen dank.
    big_blue

    VDR-Server:

    XEON mit Digital Device PCIe Karte und DuoFlex S2 auf Ubuntu 14.04 mit VDR 2.2 in Docker Container.


    Clients:

    Intel I3 3225 mit nvidia Grafikkarte und yavdr 0.61
    Zotac Ion mit N330 mit yavdr 0.61 und streamdev-client
    Diverse PCs im Netz per streamdev in vlc player

    The post was edited 1 time, last by big_blue ().

  • Moin zwei Fragen zu den ddbridge Treibern bei Octopus DVB C/T:


    - gibt es eine Möglichkeit beim Laden der Module schon zu sagen: Karte 1 nur DVB-C - Karte 2 nur DVB-T ?
    so werden mir zu jedem Device 2 Frontends geladen, was mir nicht weiterhilft.


    - gibt es eine Möglichkeit die Debugmelungen: "input_start 4" "input_start 5" etc zu unterbinden?



    System: Xen4 + Kernel 3.1.0-1-amd64 + Debian Squeeze + Treiber aus dem ersten Post

    -- wird überarbeitet -- VDR- Server: Gigabyte Brix 3150 - (2x Hauppauge DualHD DVB-C Sticks mit 4 Tunern) - Ubuntu 18.04 - Aufnahme und Streaming-Server
    Client Wohnzimmer: DQ77KB - i3 - Logitech z-5500 - Blaupunkt 39" TV - Openelec (Streaming)
    Client Büro: Asus AT3N7A-I , yaVDR0.6.1 (Streaming + Cutting) - 19" TFT
    Test Client1: Raspberry Pi + openelec

  • Nur so zu Info: :)


    Der "MXL111SF" lässt sich nicht bauem mit Kernel 3.5.2.


    Einfach die fehlende Konstante definieren...:

    Diff
    1. --- linux/drivers/media/dvb/dvb-core/dvbdev.h.save 2012-08-13 05:45:21.000000000 +0200
    2. +++ linux/drivers/media/dvb/dvb-core/dvbdev.h 2012-08-16 20:19:34.848602353 +0200
    3. @@ -89,6 +89,7 @@
    4. * calls, and should be removed soon.
    5. */
    6. #define DVB_FE_IOCTL_PRE 0
    7. +#define DVB_FE_IOCTL_POST 1
    8. int (*fe_ioctl_override)(struct dvb_frontend *fe,
    9. unsigned int cmd, void *parg,
    10. unsigned int stage);


    Gruß
    e9hack


  • Hm - Wackelkontakt/ungünstige Verlegung des Datenkabels käme auch noch in Frage.

    Hallo,



    auch ich habe diesee I2C-Fehler, danach ist die Karte bis zum nächsten Neustart unbrauchbar. Nachdem ich erst die Verbindung zum CAM in Verdacht hatte, weil es (hauptsächlich) grundverschlüsselte Privatsender (Unitymedia) betraf, habe ich mein Setup jetzt geändert:


    - Cine CT V6
    - kein CAM, daher auch keine Kabelverbindung


    Jetzt treten die Fehler hier - nachvollziehbar - hauptsächlich bei ZDF HD auf, da aber recht regelmäßig. Ich nehme Samstags und Sonntags morgens immer ZDF tivi auf, in ca. 60% der Fälle bricht die Aufnahme nach wenigen Minuten ab.


    Gibt denn "IRS 00000301" einen Hinweis, wo es kracht?


    Die weiteren Meldungen bzgl. drxk habe ich nicht im Log. Kernel ist 3.2.0-30-generic, Treiberversion aktuell aus dem linux-media-dkms-Paket (0~20120810.git285.323772~precise).


    Sebi

  • Hallo zusammen,


    das powarman Repo ist down?