Aktuelle Treiber für Octopus(ddbridge), CineS2(ngene/ddbridge), DuoFlex-S2, DuoFlex-CT, CineCT sowie TT S2-6400 (Teil 2)

  • Kann ich leider nicht ändern, das Upstream-Treiberarchiv paßt nicht mehr zu media_build.


    Abhilfe:
    Eine ältere, funktionierende Version des Treiberpacks herunterladen (z.B. http://linuxtv.org/downloads/d…-media-2012-06-30.tar.bz2) und unter dem Namen "linux-media.tar.bz2" in das Unterverzeichnis "linux" kopieren. Anschließend "make untar" ausführen, "make" usw.


    CU
    Oliver


    Heißt das nun, dass die Treiberentwicklung im media_build_experimental Repo nicht mehr fortgesetzt wird??

  • Sorry, wenn ich heute erst schreibe, aber mit dem Treiberpaket vom 30.6.2012 scheint es zu funktionieren - zumindestens hab ich keinen Abbruch mehr. Im Moment hab ich nur noch andere Probleme beim Kernelupdate.


    vy 73 ...
    NetWraith

    Meine Projekte:
    VDR1: Asrock B250-HDV, Core i3-6100T, Nvidia GTX 1050ti, DD CineS2 V6.5, DD Flex C2/T2, Crucial MX300 275GB, Seagate SSHD 1TB, LG CH12NS40B
    VDR2: Zotac IONITX-P-E, 2x2GB RAM, DD CineS2 V6.1, WinTV-Nova-TD, OCZSSD2-2VTXE60G, WD3200BEVT, Samsung SN-083C
    VDR-Server: Intel NUC D54250WYKH, 2x8GB RAM, 240GB Crucial M500, 525GB Crucial MX300, VMware ESXi V6.5 Hypervisor
    DVB-S(2)T(2)-Deviceserver: Seagate Dockstar, 2x Sundtek SkyTV Ultimate V & 1x Digital Home III, OpenWRT ... mehr Infos


    Nicht nur eine Frage der Höflichkeit: "Wie man Fragen richtig stellt ".

    The post was edited 1 time, last by NetWraith ().


  • Heißt das nun, dass die Treiberentwicklung im media_build_experimental Repo nicht mehr fortgesetzt wird??


    Nein, heißt es nicht. Davon habe ich kein Wort geschrieben.


  • Kann ich leider nicht ändern, das Upstream-Treiberarchiv paßt nicht mehr zu media_build.


    Abhilfe:
    Eine ältere, funktionierende Version des Treiberpacks herunterladen (z.B. http://linuxtv.org/downloads/d…-media-2012-06-30.tar.bz2) und unter dem Namen "linux-media.tar.bz2" in das Unterverzeichnis "linux" kopieren. Anschließend "make untar" ausführen, "make" usw.


    Sooo - nach 2 Wochen gibt es nun wieder ein kompilierbares Upstream-Treiberarchiv.


    media_build_experimental ist entsprechend angepasst, "make download" kann wieder genutzt werden.


    CU
    Oliver

  • [...]Sooo - nach 2 Wochen gibt es nun wieder ein kompilierbares Upstream-Treiberarchiv.


    media_build_experimental ist entsprechend angepasst, "make download" kann wieder genutzt werden.


    CU
    Oliver


    läuft bei mir leider nicht durch. :(


    2

  • läuft bei mir leider nicht durch. :(


    same here..

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

  • Die letzte compilierbare Version für Kernel 3.4.4 ist media_build_experimental r65 und linux-media-2012-07-06.tar.bz2 + Patch (fehlende Klammern):


    Gruß
    e9hack

  • Hi,



    same here..


    bei mir klappts ohne Probleme - um auch mal was Positives zu sagen - und danke für das Gesamtpaket!


    Ciao.
    Michael.

  • Hallo zusammen,


    ich habe folgendes Problem im Zusammenhang mit ngene und einer Terratec 2400i (und hoffe, dass ich mit dieser Karte hier überhaupt am richtigen Ort bin):


    Die genannte karte lief bis vor kurzem mit ngene einwandfrei unter Ubuntu Lucid(?) mit einem 2.6.32er Kernel. Den Treiber hatte ich manuell installiert, es handelt sich offenbar um eine recht alte Version desselben:



    In dmesg finde ich mit diesem alten Kernel und Treiber folgendes:


    So weit, so gut. Nun habe ich das System etwas voreilig auf Ubuntu Precise aktualisiert, und habe Probleme mit dem Treiber: die alte Version kompiliert nicht mehr gegen den aktuellen 3.2er.
    Also habe ich das linux-media-Pack probiert, und zwar sowohl als dkms-Paket (aus dem yavdr-repo), als auch von dieser Seite (allerdings noch nicht die gestern gepostete neueste Version).


    Ngene lädt auch, es werden aber keine Karten gefunden. Das Modul lädt nicht mal mehr automatisch wie noch unter 2.6.32.
    Dmesg sagt nach modprobe ngene nur noch:


    Code
    1. [ 951.964642] WARNING: You are using an experimental version of the media stack.
    2. [ 951.964650] As the driver is backported to an older kernel, it doesn't offer
    3. [ 951.964655] enough quality for its usage in production.
    4. [ 951.964658] Use it with care.
    5. [ 951.964661] Latest git patches (needed if you report a bug to linux-media@vger.kernel.org):
    6. [ 951.964666] 5472d3f17845c4398c6a510b46855820920c2181 [media] mt9m032: Implement V4L2_CID_PIXEL_RATE control
    7. [ 951.964670] 8d690c4a4e88297451edd027d37291676bc5b9c4 [media] mt9p031: Implement V4L2_CID_PIXEL_RATE control
    8. [ 951.964676] 0bc77f3f06fcf2ca7b7fad782d70926cd4d235f1 [media] mt9t001: Implement V4L2_CID_PIXEL_RATE control
    9. [ 951.969166] nGene PCIE bridge driver, Copyright (C) 2005-2007 Micronas


    Das ist alles.


    Infos zu den geladenen Modulen:



    Folgende Firmware liegt in /lib/firmware: drxk_a3.mc und ngene_18.fw.


    Den 2.6.32er einfach weiter zu nehmen schmeckt mir nicht ganz (zumal ich dann ein neues Problem mit der Grafikausgabe habe, aber das ist ein anderes Thema).


    Fragen:
    Ist der aktuelle ngene-Treiber überhaupt noch für die Terratec 2400i geeignet? Wenn ja, was mache ich falsch (bzw. welche Infos soll ich posten); wenn nein, gibt es eine Alternative, die sich für 3.2 bauen lässt?


    Herzlichen Dank vorab


    Gruß
    David

  • Der aktuelle Treiberstand kompiliert bei mir mit 2.6.35.13, 2.6.39.3 und 3.2.0.
    Neuere Kernel habe ich nicht getestet.


    CU
    Oliver


  • Afaik funktioniert die 2400i nur mit einer speziellen Treiberversion von Terratec bzw. irgendwelchen Patches.
    Sie wurde nie richtig integriert, läuft also weder mit media_build noch media_build_experimental.


    CU
    Oliver

  • läuft bei mir leider nicht durch. :(


    2


    Es sieht so aus, daß ältere gcc Versionen über 'nameless unions' stolpern. Mit folgendem Patch


    läßt sich der aktuelle Treiberstand mit Kernel 3.4.4 compilieren. gcc ist 4.4.1 der Suse-11.2-Installation.


    Gruß
    e9hack

  • Afaik funktioniert die 2400i nur mit einer speziellen Treiberversion von Terratec bzw. irgendwelchen Patches.
    Sie wurde nie richtig integriert, läuft also weder mit media_build noch media_build_experimental.

    Vielen Dank, dann weiß ich jetzt, in welche Richtung ich weiter experimentieren muss.

  • Der aktuelle Treiberstand kompiliert bei mir mit 2.6.35.13, 2.6.39.3 und 3.2.0.
    Neuere Kernel habe ich nicht getestet.


    CU
    Oliver


    3.4.4 klappt auch


    Ciao.
    Michael.

  • Hi,


    nachdem ich vor 2 Tagen rausgefunden habe, wie ich die aktuellen Treiber compilieren kann, habe ich neuerdings i2c-Fehler:

    Code
    1. Jul 18 21:10:44 vdr kernel: [ 8830.539040] I2C timeout
    2. Jul 18 21:10:44 vdr kernel: [ 8830.539066] IRS 00000301
    3. Jul 18 21:10:44 vdr kernel: [ 8830.539076] drxk: i2c write error at addr 0x29
    4. Jul 18 21:10:44 vdr kernel: [ 8830.539088] drxk: write_block: i2c write error at addr 0x831ffd
    5. Jul 19 21:29:45 vdr kernel: [10483.425028] I2C timeout
    6. Jul 19 21:29:45 vdr kernel: [10483.425045] IRS 00000301
    7. Jul 19 21:29:45 vdr kernel: [10483.425058] drxk: i2c write error at addr 0x2a
    8. Jul 19 21:29:45 vdr kernel: [10483.425064] drxk: write_block: i2c write error at addr 0x831ffd


    Das Bild friert ein. Kanal wechseln hilft nicht. VDR beenden und neu starten hilft. Die DVB-Module müssen dabei nicht entfernt und neu geladen werden.


    Gruß
    e9hack

  • Hi,


    nachdem ich vor 2 Tagen rausgefunden habe, wie ich die aktuellen Treiber compilieren kann, habe ich neuerdings i2c-Fehler:

    Code
    1. Jul 18 21:10:44 vdr kernel: [ 8830.539040] I2C timeout
    2. Jul 18 21:10:44 vdr kernel: [ 8830.539066] IRS 00000301
    3. Jul 18 21:10:44 vdr kernel: [ 8830.539076] drxk: i2c write error at addr 0x29
    4. Jul 18 21:10:44 vdr kernel: [ 8830.539088] drxk: write_block: i2c write error at addr 0x831ffd
    5. Jul 19 21:29:45 vdr kernel: [10483.425028] I2C timeout
    6. Jul 19 21:29:45 vdr kernel: [10483.425045] IRS 00000301
    7. Jul 19 21:29:45 vdr kernel: [10483.425058] drxk: i2c write error at addr 0x2a
    8. Jul 19 21:29:45 vdr kernel: [10483.425064] drxk: write_block: i2c write error at addr 0x831ffd


    Das Bild friert ein. Kanal wechseln hilft nicht. VDR beenden und neu starten hilft. Die DVB-Module müssen dabei nicht entfernt und neu geladen werden.


    DVB-C oder DVB-T?


    Sieht sonst im Log (Laden des Treibers/Firmware) alles normal aus?


    Quote

    Kanal wechseln hilft nicht. VDR beenden und neu starten hilft.


    Hast Du Kanalumschaltung auf eine andere Frequenz getestet?


    Kannst Du einen Treiberstand angeben, der diesen Fehler noch nicht zeigt?


    CU
    Oliver


  • DVB-C oder DVB-T?


    DVB-C


    Quote

    Sieht sonst im Log (Laden des Treibers/Firmware) alles normal aus?


    Ich habe nichts verdächtiges gesehen. Kannst aber selber nochmal schauen.


    Quote

    Hast Du Kanalumschaltung auf eine andere Frequenz getestet?


    Ja


    Quote

    Kannst Du einen Treiberstand angeben, der diesen Fehler noch nicht zeigt?


    linux-media-2012-07-06.tar.bz2 + Patch (fehlende Klammern)
    media_build_experimental r65
    ngene-octopus-test, vermulich tip, da sich seit 2 Wochen nichts geändert hat


    Gruß
    e9hack


  • DVB-C


    DVB-C kann ich hier leider nicht testen.


    Quote


    Ich habe nichts verdächtiges gesehen. Kannst aber selber nochmal schauen.


    Sieht normal aus.



    Hm - kann da, was die beteiligten Treiber angeht, keinen signifikanten Unterschied entdecken.


    Vergleiche bitte selbst einmal folgende Dateien der beiden Treiber-Trees:
    - linux/drivers/media/dvb/frontends/drxk*
    - linux/drivers/media/dvb/frontends/tda18271c2dd*
    - linux/drivers/media/dvb/ddbridge/*
    - linux/drivers/media/dvb/dvb-core/*


    Gruß,
    Oliver

  • Es sieht so aus, daß die Fehler eher zufällig aufgetreten sind. Nach viermal war wieder Ruhe.



    Vergleiche bitte selbst einmal folgende Dateien der beiden Treiber-Trees:
    - linux/drivers/media/dvb/frontends/drxk*
    - linux/drivers/media/dvb/frontends/tda18271c2dd*
    - linux/drivers/media/dvb/ddbridge/*
    - linux/drivers/media/dvb/dvb-core/*


    In dem Bereich gibt es keine Unterschiede. Irgendwo gab es aber eine Änderung, die mit I²C und Locking zu tun hatte. Daher hatte ich das Treiber-Update in Verdacht.


    Gruß
    e9hack