[gelöst] Problem ACPI-Wakeup mit ZOTAC ION-ITX F

  • Hallo zusammen,


    auch wenn an anderer Stelle im VDR-Portal (ein Bericht zur Installation mit yaVDR Setup) das Zotac ION-ITX F als sowohl für ACPI-Wakeup als auch für NVRAM-Wakeup geeignet beschrieben wird - ich kriege beides nicht zum laufen. Es ist zum davonlaufen ...


    Wie ist der Stand: Rechner mit Zotac ION-ITX F (mit aktuellem BIOS A123-PE02) und zwei USB-Sticks (Sundtek Media-TV); Installation von VDR auf Debian Squeeze (2.6.32-41squeeze2) nach Anleitung von e-tobi; VDR läuft prima, manuelles Hoch und Runterfahren klappt auch ohne Probleme, nur das automatische Aufwachen will nicht funktionieren ...


    Versuch 1: Händisches Einstellen einer Wake-Up Zeit im Bios (unter APM-Konfiguration: Resume by RTC-Alarm 13:04:00 Uhr) funktioniert. Der Rechner wacht automatisch auf. Beim nachfolgenden Auslesen der Uhrzeit mit cat /proc/driver/rtc wird folgendes angezeigt (bei Alarm-Date werden nur Sternchen angezeigt, aber das mag normal sein, denn der Rechner ist ja aufgewacht; im BIOS läßt sich ohnehin nur der Tag angeben).



    Versuch 2: Test des Wake-Up über ACPI mit Test Script (auf 13:12:52 Uhr) zu stellen (vdr wurde vorher beendet). Das Testskript behauptet die Zeit in das NVRAM geschrieben zu haben.


    Ein Auslesen des NVRAM zeigt aber, daß sich die Werte im NVRAM scheinbar gar nicht wirklich geändert haben ...



    und beim nächsten Einschalten steht auch in der RTC wieder der alte Wert, vom vorherigen manuellen Aufwachversuch (13:04:00 Uhr)




    Frage 1: Zunächst die Frage: Bei wem von Euch läuft dieses oder ein ähnliches Board, und welche Betriebsart (ACPI/NvramWakeup) nutzt ihr? Wie sieht Eure Konfiguration aus (gibts da einen Trick den man kennen muß)?


    Frage 2: Muß bei Nutzung von ACPI Wakeup die BIOS Einstellung "Resume by RTC-Alarm" abgeschaltet sein?


    Frage 3: Ich gehe davon aus, daß mein ACPI-Testprogramm (und mein VDR) auch ohne einen zweiten Netz-Aus Kernel laufen sollte. Oder? (War ja in dem anderen Fall nur wegen der SAT Karte nötig, mit der der Rechner nicht sauber herunter fuhr ...)


    Frage 4: Bei dem Script sollte doch auch kein Fehler drin sein, oder? (ob 1x oder 2x schreiben, gleiches Verhalten; die Ausgabe "echo $nextboot nach $DEV geschrieben" war ursprünglich auch nicht drin)



    An was kann das noch liegen? Mir gehen die Ideen aus ...


    m.f.G. Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i3) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.6-3 x86_64)

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von VdrMize ()

  • Habe ebenfalls das Zotac Ion ITX-F. Ich habe seinerzeit NVRAM + Poweroff-Kernel implementiert, da der VDR nicht richtig runterfuhr (DVB-CT von DigitalDevices war/ist schuld). Ich habe mir damals ein paar Notizen gemacht, die lasse ich dir hiermit zukommen. Ich hoffe, das hilft dir weiter...



    Versuche mal:


    Code
    1. nextboot=`date --date "now +12 min" "+%s"`
    2. sudo nvram-wakeup -C /etc/nvram-wakeup.conf --directisa -s $nextboot


    Ich musste zusätzlich --directisa mit angeben, da das Board sonst auch nicht aufwachen wollte. NVRAM mag übrigens keine Einschaltzeiten, die kürzer als 10 Minuten in der Zukunft liegen.


    BJ1

  • Hallo BJ1,


    danke für Deine schnelle Reaktion ...


    Willst Du mir damit sagen - ohne PowerOff Kernel hab ich keine Chance (denn mit den USB Sticks läuft ja mein PowerDown so weit ich das erkennen kann problemlos ...). Oder darf ich den Powerdown nicht nutzen, weil das sonst irgend welche Seiteneffekte hat ???


    Wenn bei Dir der vdr mit nvram-wakeup läuft, hast Du im BIOS die Einstellung "Resume by RTC-Alarm" aktiv, oder ist die abgeschaltet.


    Die nvram-wakeup.conf auf die Du in dem Link verweist, das ist doch die untenstehende oder? (Die hatte ich bisher schon verwendet, nur damit hat es auch nicht funktioniert. Und die läuft bei Dir?)



    Komisch, daß guess-helper auf meinem Board eine ganz andere nvram-wakeup.conf erzeugt hat, aber die lief auch nicht (da kommt die addr_stat doppelt vor, und der Hinweis "but differs somewhere else" macht wenig Vertrauen) ...



    Ich hab gerade noch mal mit ACPI und UTC=YES experimentiert (eigentlich möchte ich UTC weiter auf no stehen lassen, da ich auf dem Rechner parallel ein Windows nutze, das mit UTC im BIOS Probleme hat) ... Ich werde dann mal wieder das ACPI-Wakeup runterschmeißen, und wieder nvram-wakeup ausprobieren - wie Du empfielst ...


    m.f.G. Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i3) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.6-3 x86_64)

  • Willst Du mir damit sagen - ohne PowerOff Kernel hab ich keine Chance


    Doch, sofern per "sudo poweroff" die Kiste abschaltet, brauchst du keinen Poweroff-Kernel. Im BIOS ist übrigens alles disabled. Die nvram-wakeup.conf ist schon die richtige, die per guess-helper erzeugte .conf wollte mein BIOS nicht haben.
    ACPI-Wakeup überlebt einen Poweroff-Kernel übrigens nicht, daher eben NVRAM. UTC=yes ist zwingend erforderlich. Solange dann noch *** in der cat /proc/driver/rtc auftauchen, ist ohnehin noch was im argen.


    Da ich keinen VDR am laufen habe, kontrolliere mal den Eintrag (wahrscheinlich irgendwas mit poweroff.sh), wo die RTC gesetzt wird (hwclock....) und ergänze diesen mit --directisa


    BJ1

  • Hallo BJ1,


    ich hab Deinen Tip von oben ausprobiert ...


    Code
    1. nextboot=`date --date "now +12 min" "+%s"`
    2. sudo nvram-wakeup -C /etc/nvram-wakeup.conf --directisa -s $nextboot


    ... geht leider nicht.


    Es wird zwar angezeigt, daß die Zeiten nach /dev/nvram geschrieben werden, ein direkt folgendes
    cat /proc/driver/rtc zeigt aber ganz andere Zeiten, und ein nicht gesetztes Alarm Date.


    Wie mir scheint, werden die Daten zwar eingetragen (beim nächsten manuellen Start, kann man im
    BIOS die korrekten Zeiten und Datum als Startzeit eingetragen sehen, auch wenn das vorher disabled
    war), nur der Rechner hat eben das automatische Einschalten nicht geschafft ...



    Wer hat für mich noch einen Tip, woran das noch liegen kann (ich verzweifle noch daran), oder was kann
    sich verklemmen, wenn man mehrere male zwischen ACPI-Wakeup und NVRAM-Wakeup hin und her geschaltet
    hat? (hpet=disable als Linux Startkommando wird von grub2 mitgegeben; Die Uhr ist auf UTC eingestellt, ja.)


    m.f.G. Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i3) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.6-3 x86_64)

  • Wie mir scheint, werden die Daten zwar eingetragen (beim nächsten manuellen Start, kann man im
    BIOS die korrekten Zeiten und Datum als Startzeit eingetragen sehen, auch wenn das vorher disabled
    war), nur der Rechner hat eben das automatische Einschalten nicht geschafft ...


    Hast du danach nen reboot über den poweroff Kernel gemacht? Manche Boards brauchen das bei nvram wakeup.


    cu

  • Hallo Keine-Ahnung,


    danke für Deinen Tip, das mit dem poweroff Kernel probier ich in den nächsten Tagen aus.


    Ich versuch gerade mit einer zweiten Platte und einer neuen Installation, ob sich das System
    dort ähnlich verhält, weil ich früher mal eine ngene PCI-Bridge und das Doppeltunermodul im
    Rechner hatte, wo es scheinbar bekanntermaßen Probleme mit dem Reboot gab und gibt.


    Ich suche nach Treiberleichen, die - auch wenn die HW nicht mehr steckt - für die Probleme
    mit dem Reboot zuständig sein könnten. Wie krieg ich ggf. die Treiber weg, damit mir hier
    nicht eine Altlast in die Suppe spuckt? (Oder was kann beim Setup der ngene noch mit für das
    Problem sein - die Treiber werden ja nicht geladen wenn die PCI-Karte nicht mehr steckt ...)


    Ich würde ja gerne das bisherige System zu Booten überreden, da ich auf dem neuen System
    nur das nvram-wakeup ausprobieren möchte - bis da alles wieder drauf wäre, da fehlt noch
    einiges ...


    m.f.G. Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i3) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.6-3 x86_64)

  • Hallo zusammen,


    Wie es aussieht, läuft mein Board weder mit vdr-acpi-wakeup noch mit nvram-wakeup, ohne daß ich einen poweroff-kernel nutze.


    Ich glaube kaum, daß dies am leeren mini-PCI Steckplatz liegt (der ist leer, seit ich meine ngene PCI Karte gezogen habe, und durch zwei DVB USB-Sticks ersetzt habe), und ob ich noch Treiber-Leichen von der DVB-C Karte im System habe - die daran Schuld sind - weiß ich nicht (andere im Forum schreiben ja, das ZOTAC ION ITX F würde ja mit beiden Optionen zum Wakeup problemlos laufen ...)


    Mit nvram-wakeup und einem reboot klappt es aber prima (auch wenn der automatische Reboot noch nicht funktioniert). Das ist aber ein Problem von Debian Squeeze (welches die Dateisysteme unmountes, und schon im /rc0.d/K11halt einen poweroff durchführt, so daß die die Sxx Scripts die den Reboot steuern sollen nicht mehr richtig funktionieren (da kommen Fehler beim Zugriff auf /boot/grub/grubenv))


    Dazu hoffe ich im Debian Bereich weitere Info´s zu finden. Hier setze ich das Thema erst mal auf gelöst ...


    Allen die mir dabei geholfen haben, vielen Dank.


    m.f.G. Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i3) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.6-3 x86_64)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von VdrMize ()

  • Dein NVRAM Shutdownscript muss einfach das richtige Shutdown Kommando setzen. Bei mir mit Lilo (für Grub anpassen) klappt das unter Squeeze wunderbar.


    Code
    1. echo "SHUTDOWNCMD=\"sudo /sbin/lilo -R poweroff; sudo shutdown -r now\""


    cu

  • Hallo,


    hast Du wirklich das aktuelle Bios installiert?
    Bei mir ist das "Version 2K091012".


    Ich habe ebenfalls eine cine2 (Vers. 5.5) installiert.


    Ich starte bei zwei Rechner mit dieser Konfiguration mit ACPI.


    Kernel Version ist: 3.0.4.


    Viele Grüße
    kaminkehrer

    VDRMB2 (Wohnzimmer) :
    Gehäuse: Activy 330 FP mit TTL Wandler am Serial
    Intel DH61BE ; Geforce GT630 ; 2x2GB ; CineS2 5.6 ; 128GB SSD ; 1TB HDD
    Harmony 650 ; Samsung UE40C6200
    - Gen2VDR 6.0 -


    VDRMB1 (Schlafzimmer) :
    Gehäuse: Activy 330 FP mit TTL Wandler am Serial
    Zotac ionitx G-E ; 240GB SSD ; CineS2 5.4 ; 2x2 GB RAM
    Harmony 650 ; LG 32LG450
    - Gen2VDR 6.0 -


    VDRMB3 (Test) :
    Gehäuse: Activy 300 FP mit TTL Wandler am Serial
    POV 330-1 ; 240GB SSD ; Mystique SaTiX-S2-PCI ; 2x2 GB RAM
    Harmony 300
    - Gen2VDR 6.0 -


    und weitere ...

  • Hallo Kaminkehrer,


    ja ich hab das AMIBIOS Version 08.00.15, A123PE02, vom 10/12/09 ...

    • hast Du im Bios unter Advanced ACPI-Konfiguration die ACPI-Version-Features V-1.0 / V-2.0 / V-3.0 eingestellt? (bei mir ist´s die V-1.0)
    • und sind bei Dir - wenn Du mit ACPI rebootest - die "Resume by RTC Alarm" disabled
    • und damit ist bei Dir kein Reboot-Kernel nötig

    m.f.G. Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i3) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.6-3 x86_64)

  • Hallo,


    bei mir ist das Bios auf default Einstellung.
    -Das einzige was ich angepasst habe ist die Speichernutzung für die Grafikkarte (512MB).
    -Ich habe noch nie ins Bios geschaut, es funktioniert ....
    -Ich benötige kein reboot.


    Es gab in der Vergangenheit Probleme mit dem ngene Treiber.
    Hier gibt es einen fix für das shutdown Problem mit der SAT-Karte:


    Das ngene Kernel Modul muss mit folgendem Parameter geladen werden:



    Zitat

    options ngene one_adapter=0 shutdown_workaround=1

    Dann klappts auch mit dem shutdown. ACPI-wakeup lief dann out of the box.



    Grüße
    kaminkehrer

    VDRMB2 (Wohnzimmer) :
    Gehäuse: Activy 330 FP mit TTL Wandler am Serial
    Intel DH61BE ; Geforce GT630 ; 2x2GB ; CineS2 5.6 ; 128GB SSD ; 1TB HDD
    Harmony 650 ; Samsung UE40C6200
    - Gen2VDR 6.0 -


    VDRMB1 (Schlafzimmer) :
    Gehäuse: Activy 330 FP mit TTL Wandler am Serial
    Zotac ionitx G-E ; 240GB SSD ; CineS2 5.4 ; 2x2 GB RAM
    Harmony 650 ; LG 32LG450
    - Gen2VDR 6.0 -


    VDRMB3 (Test) :
    Gehäuse: Activy 300 FP mit TTL Wandler am Serial
    POV 330-1 ; 240GB SSD ; Mystique SaTiX-S2-PCI ; 2x2 GB RAM
    Harmony 300
    - Gen2VDR 6.0 -


    und weitere ...

  • würde das so aussehen?


    1. Im Webfrontend von yaVDR auf PowerOff Kernel stellen.
    2. In /etc/modprobe.d eine Datei mit dem Namen dvb.conf erzeugen
    und folgendes hineinkopieren: "options ngene one_adapter=0 shutdown_workaround=1"

    Einen schönen Gruß aus dem Bergischen Land
    Der Watz
    ----------------------------------------------------------------------------------------------------------------------------------------------------------
    – yaVDR 0.5, Gehäuse C581, 330N DualCore IONITX Zotac, twinlux dvb s2, X10 und Lenovo N5901 Bilder
    – yaVDR 0.5, Gehäuse C581, 330N DualCore IONITX Zotac, DVBSKy S952 Dual , Medion X10
    – MediaPortal QDI SF-FF DVB-S/ NOVA-T – g2v 1.4, 1 GHz P3; 256 MB RAM; 160 GB HD
    [/size]– 3 x Gbit Switch; DSL-16000 kbit mit AVM-7490

  • würde das so aussehen?


    1. Im Webfrontend von yaVDR auf PowerOff Kernel stellen.
    2. In /etc/modprobe.d eine Datei mit dem Namen dvb.conf erzeugen
    und folgendes hineinkopieren: "options ngene one_adapter=0 shutdown_workaround=1"


    Hi,


    klappt das also so wie hier beschrieben oder ist da mehr zu tun??
    Ich habe ebenfalls ein Zotac-MB und es will einfach nicht aufwachen... :§$%


    Danke und Gruß

    TV: Toshiba 42XV635D 42 Zoll
    AV-Receiver: Yamaha RX-V473
    VDR: YaVDR 0.6, Zotac H77-ITX-C-E (onboard Geforce GT620 512MB RAM), Intel Pentium G630T@1,6GHz, 2x 2GB RAM, 1TB Media-HDD 2,5", 30GB System-mSATA SSD, DD Cine S2 V6 (beide Tuner aktiv) -> alles verbaut im InterTech Mini ITX E-i7, PS3 Remote
    NAS: Synology DS415+, 4x 3TB Raid5
    Streaming-Clients: Google Nexus 7(2012) Tablet u. Google Nexus 5 Handy, jeweils mit Andro-VDR-App
    RPi2: MLD als Streaming-Client
    Lautsprecher: Magnat Quantum 670 Serie 5.1 Set

  • Hi Mitstreiter,


    ich bin grad dabei die dritte Generation aufzubauen (10 Jahre VDR!).
    Jetzt hab ich mir das ZOTAC D2550-ITX WiFi Supreme D2550ITXS-A-E wegen der Graphik nVidia GT610 ausgesucht. Anscheinend hab ich wiedermal das falsche gewählt, da ich keine nvram-wakeup finde.


    kann jemand helfen? Zotac hab ich angeschrieben... Erwarte mir aber keine Hilfe, da die Seite Windows lastig ist.


    Grüße Günter

    ZOTAC D2550-ITX WiFi Supreme + KINGSTON 30GB SSDNow mSATA 6Gbps | Toshiba 2TB 2,5" | Inter-Tech Mini ITX E-i7 | noDisplay | Digital Devices Cine S2 V6.5 |easyVDR2.0  | Philips 5004
    Point of View ION330 | Silverstone Petit PT09B | noDisplay | Samsung Spinpoint F1 HA751 LJ | Mystique SaTiX-S2 Dual | yaVDR 0.4| FB Philips SBC RU 760
    ausser Betrieb:
    EPIA M10000, iTV-Media Silver | 240x128 Blue | Samsung Spinpoint F1 HA751 LJ (LogiLink AD0006a - IDE-to-SATA) | TT1.5, easy-vdr | FB Philips SBC RU 760

  • Anscheinend hab ich wiedermal das falsche gewählt, da ich keine nvram-wakeup finde.


    Nicht nur auf dem falschen Pferd, sondern auch im falschen Thread:


    Zuerst mal ist der Thread auf gelöst gesetzt, wenn du hier keine Lösung findest, dann musst du zwangsläufig ein anderes Problem haben. Außerdem ging es hier um acpi-wakeup und nicht um nvram-wakeup, wiederum falscher Thread.
    Erschwerend kommt hinzu, dass es falsch ist überhaupt nach nvram-wakeup zu suchen, weil es ja acpi-wakeup gibt. Es ist doch schon abzusehen, dass es sehr bald überhaupt keine Hardware mehr geben wird die mit nvram-wakeup funktionieren wird, da alles was einigermaßen aktuell ist auf ein UEFI-Bios setzen wird.


    Mir ist seit Jahren schon keine Hardware mehr untergekommen die nicht mit acpi-wakeup funktionierte.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Manchmal kommt man nicht drum herum, nvram-wakeup zu nutzen. Es gibt Boards (Asus ION Boards sind solche Kandidaten), die nicht richtig runterfahren, wenn diverse Karten (DD bspw.) stecken oder USB-DVBs dranhängen. Dort ist man auf einen Poweroff-Kernel angewiesen, den aber die ACPI-Timer nicht überleben - deshalb NVRAM oder eben ein anderes in Hardware gegossenes Wakeup. Nichtsdestotrotz sollte ein Mod den Thread mal trennen, denn der Beitrag von GR24 ist hier echt fehl am Platz...


    BJ1