[patches] xine-lib-1.2+xine-plugin verbesserter vdr support

  • Da der ursprüngliche Thread [patches] xine-lib-1.2+xineliboutput+xine-plugin verbesserter vdr support 
    zu dem Thema ja schon sehr lang und unübersichtlich geworden ist startet ich hier mal einen neuen Thread für die drei noch verbliebenen Patches.


    Die Patches sind als Downloads zum Projekt xine-lib im Dateibereich auf vdr-developer.org verfügbar http://projects.vdr-developer.org/projects/xine-lib/files :


    1. xine-lib-vdpau-xlock.patch: Added configuration parameter for enabling/disabling XLockDisplay calls
    2. xine-lib-vdr-input-grab.patch: This patch added support for new continuous video frame grabbing feature for the vdr input plugin.
    3. xine-plugin-0.9.4-grab.patch: Erweitert das vdr-plugin-xine um die Funktionalität das Videobild über die die neue "continious grabbing" Funktion der xine-lib 1.2 zu grabben.
    Wird in Verbindung mit dem xine-lib-vdr-input-grab.patch angewendet.


    - durchflieger

    Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
    Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
    Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von durchflieger ()

  • Moin,
    im xine-lib-git auf projects.vdr-developer.org gibt's nur noch die master -Branch. Wurden die Änderungen alle in die offizielle Xine-Lib integriert?


    /Malte

    .. steht doch hier: [patches] xine-lib-1.2+xineliboutput+xine-plugin verbesserter vdr support


    gruß, ciax

  • Hallo,
    danke für das "ablösen" des Monster-Threads.
    Ich habe ein Problem mit dem aktualisieren des xineliboutput und der xine-lib - siehe hier:
    Problem mit Xineliboutput unter Squeeze


    Jetzt habe ich gerade hier was aufgeschnappt zum xine-lib - kann es aber ehrlich gesagt nicht ganz einordnen.
    Passt das hier noch:


    VDPAU: Xine-Lib aus GIT installieren
    cd /usr/local/src
    git clone git://projects.vdr-developer.org/xine-lib.git
    cd xine-lib/
    ./autogen.sh
    ./configure --prefix=/usr/local
    make
    make install
    ldconfig -v


    VDPAU: Xineliboutput-Plugin
    cd /usr/local/src/VDR/PLUGINS/src
    git clone git://projects.vdr-developer.org/xineliboutput.git
    cd xineliboutput
    make
    make install



    Oder hole/aktualisiere ich hier eine alte Xine-Lib??
    DAAAAANKE für voraus für jede Hilfe.


    Gruß
    Thorsten

  • Hallo,


    Nach meinem Gentoo-World-Update am vergangenen Donnerstag, 3.5.2012, habe ich auch die xine-lib aus dem GIT mit den beiden dazugehörigen Patches von Durchflieger installiert und anschließend auch xineliboutput aus dem GIT neu kompiliert. Leider habe ich seitdem, wie es schon RudiRabbit hier beschrieben hat kurze Tonaussetzer beim Kanalumschalten. Der Ton flattert für 2-3 Sekunden.


    Bei meinem letzten Update vor ca. 3 Wochen nutze ich noch den "df-extensions"-Branch von xine-lib ohne Probleme.


    Ein Quer-Check mit VDR-XINE (nutzt auch xine-lib) und dem SoftHDdevice (nutzt kein xine-lib) hat ergeben, daß dort die Probleme nicht auftauchen. Wie es scheint, verträgt sich xineliboutput, bei dem sich in den 3 Wochen laut Changelog nichts geändert hat, nicht mit dem "Master"-Branch von xine-lib.


    Hat jemand ähnliche Erfahrungen gemacht ? Weiß jemand Rat ?


    Soll ich einen Eintrag im Bugtracker zu xine-lib machen ?


    BTW:
    Weder im Syslog noch im Xine.log finde ich irgendwelche Hinweise warum die Aussetzer da sind :( .
    Verwendeter NVidia-Treiber: V295.49
    Am stärksten fällt das "Flattern" via Analogausgang auf. Bei HDMI merk ich die Aussetzer nur ein meinem Sharp TV. Der Toshiba reagiert hier etwas langsamer.


    Im Moment steh ich etwas auf dem Schlauch, vorallem, da ich xineliboutput werde weiter nutzen möchte, aber nicht auf den Stand von vor 3 Wochen von xine-lib zurückgehen kann :( .



    durchflieger :
    Gibt es eine Möglichkeit auf den Stand von xine-lib (df-extensions) von vor 3 Wochen zurückzugehen ?
    Ich würde das gerne testen.


    Mni tnx e 73...
    NetWraith

    Meine Projekte: 
    VDR1: Asrock B250-HDV, Core i3-6100T, Nvidia GTX 1050ti, DD CineS2 V6.5, DD Flex C2/T2, Crucial MX300 275GB, Seagate SSHD 1TB, LG CH12NS40B
    VDR2: Zotac IONITX-P-E, 2x2GB RAM, DD CineS2 V6.1, WinTV-Nova-TD, OCZSSD2-2VTXE60G, WD3200BEVT, Samsung SN-083C
    VDR-Server: Intel NUC D54250WYKH, 2x8GB RAM, 240GB Crucial M500, 525GB Crucial MX300, VMware ESXi V6.5 Hypervisor
    DVB-S(2)T(2)-Deviceserver: Seagate Dockstar, 2x Sundtek SkyTV Ultimate V & 1x Digital Home III, OpenWRT ... mehr Infos 


    Nicht nur eine Frage der Höflichkeit: "Wie man Fragen richtig stellt ".

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von NetWraith ()

  • durchflieger :
    Gibt es eine Möglichkeit auf den Stand von xine-lib (df-extensions) von vor 3 Wochen zurückzugehen ?
    Ich würde das gerne testen.

    Ins xine-lib Projektverzeichnis wechseln:


    git log | more


    Die commit id (HEX-Zeichencode) des gewünschten Zeitpunkt merken. Dann:


    git checkout <commit-id>

    Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
    Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
    Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV

  • Nach meinem Gentoo-World-Update am vergangenen Donnerstag, 3.5.2012, habe ich auch die xine-lib aus dem GIT mit den beiden dazugehörigen Patches von Durchflieger installiert und anschließend auch xineliboutput aus dem GIT neu kompiliert. Leider habe ich seitdem, wie es schon RudiRabbit hier beschrieben hat kurze Tonaussetzer beim Kanalumschalten. Der Ton flattert für 2-3 Sekunden.


    Bei meinem letzten Update vor ca. 3 Wochen nutze ich noch den "df-extensions"-Branch von xine-lib ohne Probleme.


    Für mich sieht das nach einem Problem vom xineliboutput Plugin aus. Ich habe am Wochenende beides aus den Reposetories aktuallisiert. Die alten Versionen waren von Mitte März. xineliboutput neu hat das Stotter-Problem mit beiden Versionen von xine-lib. xineliboutput alt funktioniert mit beiden Versionen von xine-lib. xine-lib alt ist der df-extensions Branch. xine-lib neu ist der Hauptpfad mit Durchliegers Patch verpatchet.


    Gruß
    e9hack

  • durchflieger  
    Danke ! Ich hab auch schon ne Möglichkeit gefunden das via Ebuild-Paket und Commit-Variable zu testen -> Das Egebnis war leider nicht erfolgreich..


    e9hack :
    Werde mich nochmals an xineliboutput versuchen. Wenigstens weiß ich jetzt, in welche Richtung ich gehen muß. Hättest Du noch ein Datum für mich ?


    Vielen Dank für Eure Hilfe!
    Sobald ich eine Lösnug gefunden hab, geb ich nochmals Bescheid.


    vy 73 ...
    NetWraith

    Meine Projekte: 
    VDR1: Asrock B250-HDV, Core i3-6100T, Nvidia GTX 1050ti, DD CineS2 V6.5, DD Flex C2/T2, Crucial MX300 275GB, Seagate SSHD 1TB, LG CH12NS40B
    VDR2: Zotac IONITX-P-E, 2x2GB RAM, DD CineS2 V6.1, WinTV-Nova-TD, OCZSSD2-2VTXE60G, WD3200BEVT, Samsung SN-083C
    VDR-Server: Intel NUC D54250WYKH, 2x8GB RAM, 240GB Crucial M500, 525GB Crucial MX300, VMware ESXi V6.5 Hypervisor
    DVB-S(2)T(2)-Deviceserver: Seagate Dockstar, 2x Sundtek SkyTV Ultimate V & 1x Digital Home III, OpenWRT ... mehr Infos 


    Nicht nur eine Frage der Höflichkeit: "Wie man Fragen richtig stellt ".

  • Hallo e9hack,


    danke! Ich hab's gestern noch mit dem Commit vom 17.3.2012 versucht uns siehe da, das Stottern ist weg.
    Leider konnte ich den Link auf meinen Tablet nicht mehr kopieren, ansonsten hätte ich es noch gleich gepostet.


    Mich wundert es nur, mein letztes World-Update inkl. xine-lib und xineliboutput war am 13.4.2012 und, wenn ich da ins Log vom GIT von xineliboutput schaue, sollte sich seitdem nichts verändert haben ?( . Egal, es funktioniert wieder.


    Ich werde mich jetzt mal iterativ ab diesem Zeitpunkt nach vorne arbeiten und schauen, ab wann das Phänomen des Stotterns auftritt.


    UPDATE (8.5.2012 - 19:15 MESZ):
    Das Stottern des Tons beim Zappen triff ab dem 22.3.2012 auf.
    Folgendes Commit läuft bei mir im Moment ohne Probleme.



    Vielen Dank für Eure Hilfe.


    vy 73 ...
    NetWraith

    Meine Projekte: 
    VDR1: Asrock B250-HDV, Core i3-6100T, Nvidia GTX 1050ti, DD CineS2 V6.5, DD Flex C2/T2, Crucial MX300 275GB, Seagate SSHD 1TB, LG CH12NS40B
    VDR2: Zotac IONITX-P-E, 2x2GB RAM, DD CineS2 V6.1, WinTV-Nova-TD, OCZSSD2-2VTXE60G, WD3200BEVT, Samsung SN-083C
    VDR-Server: Intel NUC D54250WYKH, 2x8GB RAM, 240GB Crucial M500, 525GB Crucial MX300, VMware ESXi V6.5 Hypervisor
    DVB-S(2)T(2)-Deviceserver: Seagate Dockstar, 2x Sundtek SkyTV Ultimate V & 1x Digital Home III, OpenWRT ... mehr Infos 


    Nicht nur eine Frage der Höflichkeit: "Wie man Fragen richtig stellt ".

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von NetWraith () aus folgendem Grund: Update

  • @C-3PO:
    Scheint so.


    @all:




    Phintuka hat das Audioproblem im GIT beseitigt (HIER).
    Man kann jetzt wieder ganz "normal" xineliboutput ziehen und installieren, ohne daß man auf ein bestimmtes Commit zurückgehen muß.


    BTW:
    Jetzt wird auch xineliboutput nicht mehr als Device 1 vor den DVB-Devices angelegt und als Primary Device 1 gesetzt.
    Denn ab hier wurde xineliboutput vor den DVB-Tunern als Device 1 gestartet/erkannt was wieder andere Effekte auf meinen VDR hatte (z.B. fehelerhafte Signalanzeige, ...).



    Danke Phintuka !



    vy 73 ...


    NetWraith

    Meine Projekte: 
    VDR1: Asrock B250-HDV, Core i3-6100T, Nvidia GTX 1050ti, DD CineS2 V6.5, DD Flex C2/T2, Crucial MX300 275GB, Seagate SSHD 1TB, LG CH12NS40B
    VDR2: Zotac IONITX-P-E, 2x2GB RAM, DD CineS2 V6.1, WinTV-Nova-TD, OCZSSD2-2VTXE60G, WD3200BEVT, Samsung SN-083C
    VDR-Server: Intel NUC D54250WYKH, 2x8GB RAM, 240GB Crucial M500, 525GB Crucial MX300, VMware ESXi V6.5 Hypervisor
    DVB-S(2)T(2)-Deviceserver: Seagate Dockstar, 2x Sundtek SkyTV Ultimate V & 1x Digital Home III, OpenWRT ... mehr Infos 


    Nicht nur eine Frage der Höflichkeit: "Wie man Fragen richtig stellt ".

  • Hi Durchflieger,


    seit ca 2 Tagen baut xine-lib nicht mehr durch unter Gentoo.
    Weisst Du, ob da was gefixt wird im Master?


    greedy2frame.c: In function 'DeinterlaceGreedy2Frame':
    greedy2frame_template_sse2.c:168:11: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
    greedy2frame_template_sse2.c:168:11: error: 'asm' operand has impossible constraints
    greedy2frame_template_sse2.c:200:11: error: 'asm' operand has impossible constraints
    make[4]: *** [libdeinterlaceplugins_la-greedy2frame.lo] Error 1
    make[4]: Leaving directory `/tmp/portage/media-libs/xine-lib-1.2.9999/work/xine-lib-1.2/src/post/deinterlace/plugins'
    make[3]: *** [all-recursive] Error 1
    make[3]: Leaving directory `/tmp/portage/media-libs/xine-lib-1.2.9999/work/xine-lib-1.2/src/post/deinterlace'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/tmp/portage/media-libs/xine-lib-1.2.9999/work/xine-lib-1.2/src/post'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/tmp/portage/media-libs/xine-lib-1.2.9999/work/xine-lib-1.2/src'
    make: *** [all-recursive] Error 1
    emake failed
    * ERROR: media-libs/xine-lib-1.2.9999 failed (compile phase):
    * emake failed.
    *
    * Call stack:
    * ebuild.sh, line 85: Called src_compile
    * environment, line 2992: Called die
    * The specific snippet of code:
    * emake || die "emake failed."
    *
    * If you need support, post the output of `emerge --info '=media-libs/xine-lib-1.2.9999'`,
    * the complete build log and the output of `emerge -pqv '=media-libs/xine-lib-1.2.9999'`.
    * This ebuild is from an overlay named 'local-repo': '/usr/local/portage/'
    * The complete build log is located at '/log/portage/media-libs:xine-lib-1.2.9999:20120528-125202.log'.
    * For convenience, a symlink to the build log is located at '/tmp/portage/media-libs/xine-lib-1.2.9999/temp/build.log'.
    * The ebuild environment file is located at '/tmp/portage/media-libs/xine-lib-1.2.9999/temp/environment'.
    * Working directory: '/tmp/portage/media-libs/xine-lib-1.2.9999/work/xine-lib-1.2'
    * S: '/tmp/portage/media-libs/xine-lib-1.2.9999/work/xine-lib-1.2'


    >>> Failed to emerge media-libs/xine-lib-1.2.9999, Log file:


    >>> '/log/portage/media-libs:xine-lib-1.2.9999:20120528-125202.log'


    * GNU info directory index is up-to-date.




    Gruss, Ralf

  • Ähnliches hier:



    CCLD libpost_planar_asm.la
    pp.c: In function 'pp_draw':
    pp.c:325:22: warning: passing argument 1 of 'pp_postprocess' from incompatible pointer type [enabled by default]
    In file included from pp.c:35:0:
    /home/henk/Dokumente/OpenELEC/OpenELEC.tv/build.OpenELEC_PVR-Generic.i386-devel/toolchain/i686-openelec-linux-gnu/sysroot/usr/include/libpostproc/postprocess.h:80:6: note: expected 'const uint8_t **' but argument is of type 'uint8_t **'
    CCLD xineplug_post_planar.la
    In file included from expand.c:138:0,
    from :144:
    noise.c: In function 'lineNoiseAvg_MMX':
    noise.c:232:5: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
    noise.c:232:5: error: 'asm' operand has impossible constraints

    Powered by Point of View ION330 und Mystique SaTiX-S2 Dual
    Geguckt wird auf einem 52PFL5605H/12 per HDMI mit Atmolight Quattro
    Audio optisch per Yamaha RX-V459 auf einem Teufel Concept P
    Non-TV content über XBMC und boblight
    Remote Harmony 525 durch Atric-IR
    Remote und Streaming mit Motorola XOOM und AndroVDR sowie Daroon Player
    Streaming auf ZBOX ID-81 und Desktop per streamdev
    All based on selfbuild OpenenELEC master


    Nebenbei noch ein par andere VDRs

  • Hey!
    Ich verwende xineliboutput immernoch auf meiner SMT.
    Könnte man nicht einstellbar machen, ob ein Resumefile
    verwendet werden soll, oder nicht? Da ich meist vom
    Archiv meines Fileservers streame, will ich nicht, dass
    dort zusätzliche Files angelegt werden. Eine Alternative
    wäre ein globales Resumeverzeichnis auf dem VDR selber.
    Momentan hab ich m_UseResumeFile im Code auf false
    gesetzt.

    VDR1:
    Gehäuse: Thermaltake Element Q
    Mainboard: Zotac IONITX-P-E
    Arbeitsspeicher: KVR1066D3N7K2/4G
    HDD: 1TB SATA
    SATA Front-Wechselrahmen
    Bluray: LG BH16NS40
    DVB: Digital Devices Cine S2 PCIe
    OS: Debian Stable
    VDR: Dev-Version mit MainMenuHooks P
    atch, div. Plugins
    Sonstiges: Kodi, XFCE


    VDR2:
    Samsung SMT-7020S mit Wakeup-Board
    HDD: 160GB 2,5" IDE
    OS: Debian Stable
    VDR:
    Dev-Version mit MainMenuHooks [size=8]Patch, div. Plugins