Umstieg auf yavdr 0.4 noch nicht abgeschlossen (immer noch Tonprobleme über HDMI)

  • Hallo,


    gestern habe ich mich daran gemacht, den Umstieg von yavdr 0.32 auf yavdr 0.4 zu wagen.
    Die Installation lief problemlos ab, nachdem ich die channels.conf aktualisiert hatte, stellte ich leider fest, dass nur die DVB-T, jedoch nicht die TEVII 464 out of the box funktionierte. Nachdem es nach dem update auf den aktuellen Stand immer noch nicht funzte, installierte ich die linux-media-dkms nach. Jetzt funktionierten auch die Tevii wie gewohnt und auch die FB wurde ootb unterstützt :) Leioder hatte ich von diesem Zeitpunkt an keinen Ton mehr und ich habe es in 2 Stunden nicht hinbekommen, dem HDMI einen Ton zu entlocken. Dabei half auch nicht das Abschalten der onboard Soundkarte, die verschiedenen Audioeinstellungen aus dem WFE und auch nicht die Xine configuration und die Alsa.conf vom alten System zu kopieren. Zum Glück habe ich auf einer neue FP installiert und bin nun wieder auf 0.32 zurück.
    Logs kann ich gerne nachliefern, sind ja noch auf der Platte. Leider hab ich keine Ahnung, wo ich ansetzen soll. aplay -l zeigte die NVIDIA als HDMI Device an.
    Hat jemand von euch ähnliche Erfahrungen gemacht?
    Welches Vorgehen schlagt ihr vor?
    Gibt es einen Weg, die TEvii FB auch unter yavdr 0.32 zum Funktionieren zu bewegen? (richtige Konfigurationsdateien sind ja in der 0.4 vorehanden ;)


    Gruß Micha


    Nachtrag:


    Heute ist wohl die yavdr 0.32 Systemplatte gestorben :( Jetzt hab ich die 0.4 Installation wieder connected und nach ca 3-4 Minuten kam dann auch Ton..... Leider bisher nur als PCM und noch kein DD, aber immerhin, so ist der Familienfriede erst einmal gesichert :)


    aplay -l



    aplay -L



    Gruß Micha


    P.P.S. leider ist das ganze nicht wirklich stabil, gestern Abend nach update und Neustart wieder kein TON, hab alle Audio-Dateien (alsa.conf, Xine.conf, xinelibout.conf) kontrolliert und für korrekt befunden, die onboard-Soundkarte ausgeschaltet und im Moment hab ich nur auf den DD-Audiokanälen PCM sound.


    Benötige hier wohl noch Eure Hilfe.....

    The post was edited 5 times, last by zaubi4u ().

  • Hat jemand von euch ähnliche Erfahrungen gemacht?


    Hattest du mal im alsamixer nachgesehen, ob der HDMI-Ausgang evtl. gemuted war?


    Was genau hat "sudo aplay -l" geliefert?


    Gibt es einen Weg, die TEvii FB auch unter yavdr 0.32 zum Funktionieren zu bewegen? (richtige Konfigurationsdateien sind ja in der 0.4 vorehanden


    AFAIK fehlt dem alten Kernel ein Großteil dessen was rc-core sinnvoll nutzbar macht. Was sagt denn "cat /proc/bus/input/devices" unter der 0.3.2?
    Falls da ein rc-core Gerät erkannt wird - das sollte so ähnlich aussehen:

    Code
    1. I: Bus=0001 Vendor=d464 Product=9022 Version=0001
    2. N: Name="cx88 IR (TeVii S464 DVB-S/S2)"
    3. P: Phys=pci-0000:05:09.2/ir0
    4. S: Sysfs=/devices/pci0000:00/0000:00:1e.0/0000:05:09.2/rc/rc0/input5
    5. U: Uniq=
    6. H: Handlers=kbd event5
    7. B: EV=100003
    8. B: KEY=6c0904 2470d1 0 0 0 8 10000 190 40000840 e1680 1 f8000000 ffc


    Müsstest du nur noch die FB-Konfiguration des yaVDR 0.3.2 umkrempeln, damit sie inputlirc oder eventlircd und das entsprechende Eventgerät nutzt (viel Spaß beim Basteln...)

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi seawhak,


    für das erste Thema muss ich nochmal die andere Platte reinhängen, ist aber problematisch, weil der WAF dann ins bodenlose sinkt ;)


    Die Fernbedienung wird erkannt, nur was müsste ich wo ändern?



    An der ersten Karte ist der IR Empfänger dran und damit lief es unter yavdr 0.4 :)


    Gruß Micha

  • Die Fernbedienung wird erkannt, nur was müsste ich wo ändern?


    Installier dir mal evtest und lausche damit auf /dev/input/event6:

    Code
    1. sudo evtest /dev/input/event6


    Wenn da für alle Tasten was kommt, kannst du z.B. inputlircd oder eventlircd dafür entsprechend einrichten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • ja, evtest liefert etwas, aber das sind keine Tastaurcodes, oder? (sahen irgendwie anders aus.....) und die trag ich in eine lircd.conf? Mir fehlt da noch der Zusammenhang, welche Variante mit welchen Konfigurationsdateien zusammen hängen....
    Bei lirc war das einfach ;)


    Wo werden die Tastaturcodes in der 0.4 gespeichert? (da könnte ich sie noch von der Platte auslesen und weiter benutzen...)


    Gruß Micha

  • Wo werden die Tastaturcodes in der 0.4 gespeichert? (da könnte ich sie noch von der Platte auslesen und weiter benutzen...)


    Nachdem es ein rc-core Empfänger ist liegen die ohne weitere Einstellungen direkt im Treiber...


    ja, evtest liefert etwas, aber das sind keine Tastaurcodes, oder? (sahen irgendwie anders aus.....)


    Zeig mal...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hier die Ausgabe von evtest



    Sind das jetzt dezimal codes? Weil so, wie es aussieht, fehlt nur die richtige codierung und das mapping zum vdr. Die Zahlentasten funktionieren sofort auch im vdr, die Pfeiltasten auch... Da lirc läuft und die lircd.conf auf lircd.conf.definput verlinkt ist, muss ich nur diese Datei editieren??


    Gruß Micha

  • Nicht ganz, aktuell steuerst du den VDR über das Frontend und nicht über lirc (da sich die Fernbedienung wie eine Tastatur verhält).
    Du kannst jetzt wählen: Entweder du passt einfach den Tastatur-Teil der FB-Konfiguration an (für xineliboutput/vdr-sxfe in der remote.conf, für xine AFAIK in dessen Tasten-Konfig unter /etc/xine/keymap) oder du konfigurierst inputlirc oder eventlircd für den Empfänger und passt dann die remote.conf im Lirc-Teil entsprechend an (oder du schaust, ob es ir-keytable auch für Lucid irgendwo gibt und passt die Tastennamen über eine Keytable so an, dass sie zur remote.conf passen).


    Für inputlircd gibt es eine gute Anleitung im UU-Wiki: wiki.ubuntuusers.de/Lirc (wenn der Server mal wieder verfügbar ist :P)

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke erst mal für Deine Tipps und Unterstützung. Die Anpassung der keymaps in xine hat nix gebracht... Die anderen Dinge werd ich mir anschauen, wenn der ubuntuusers Server wieder online ist :)


    Gute n8 und schönes WE :)


    Gruß Micha