[gelöst] yaVDR 0.4: xine vs. xinelibout

  • Hallo!


    Aufgrund diverser Problemchen habe ich meinen yaVDR gerade neu installiert.
    Da ich alle manuellen Nacharbeiten vorher akribisch gesammelt habe, funktioniert jetzt auch alles einwandfrei.


    Bis auf eine grundsätzliche Sache: xine vs. xinelibout


    Ich benutze einen LG HD-ready 32" Fernseher (Auflösung wurde automatisch auf 1360 x 768 gestellt; aber lt. Webinterface: "Auflösung: unbekannt" *seltsam*).
    Ich habe das Standard-Skin "NarrowHD" (gilt aber auch für "Pearl") ausgewählt.


    Wenn ich (so wie nach der Installation ausgewählt) xine verwende, habe ich ein super scharfes, knackiges OSD-Menü.
    Allerdings dauert das Umschalten (Kanalwechsel) recht lange und vor allem nervt das "No signal" Bild, das immer angezeigt wird.


    Wenn ich hingegen mit xineliboutput arbeite, dann klappt der Kanalwechsel viel schneller und es friert nur kurz das ursprüngliche Bild ein (kein "No signal").
    Dafür wirkt aber die Schrift im OSD sehr pixelig und überhaupt nicht mehr scharf und knackig.
    Wenn ich in den xineliboutput-Einstellungen im Unterpunkt "OSD" die Auflösung (von dzt. 1920 x 1080) auf einen niedrigeren Wert ändere,
    dann habe ich, zwar größere, aber auch sehr scharfe, knackige Buchstaben. Aber dann ist das OSD wieder nicht wirklich benutzbar (siehe hier ).



    Das Umschalt-Verhalten von Xine scheint sich ja nicht wirklich ändern zu lassen - das mit dem schwarzen Bild statt "no signal" will ich auch nicht unbedingt.
    Gibts eine Möglichkeit, wie ich das OSD bei xineliboutput so scharf und knackig bekomme wie bei xine (ohne mir einen neuen TV zu kaufen, selbstverständlich).


    Danke (mal wieder) für eure Hilfe!


    lg
    Davie

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 2 times, last by davie2000 ().

  • Hallo!


    Ist das Deine Frage oder kommt da noch was?


    Albert

  • Sorry, habe versehentlich nach Überschrift und Tags zwei mal Enter gedrückt.
    Hab den Beitrag oben mittlerweile editiert.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • @Davie,


    Erst mal das übliche. Bildschirm neu erkennen lassen, speichern. Beide deinterlacer auf temporal_spatial einstellnen. Nur 50 Hz benutzen.


    Albert

  • Hi Albert!


    Ich habe im webinterface auf xinelibout umgestellt und dann unter Anzeigeeinstellungen beide Deinterlacer auf temporal spatial umgestellt und den TV neu erkennen lassen (und gespeichert).
    "50 Hz" kann ich nirgends auswählen oder eingeben.


    Die Schrift hat sich minimalst verbessert (oder bilde ich mir das nur ein?) aber dafür hat das TV-Signal jetzt starke Aussetzer.
    => Habe die Deinterlacer also wieder auf default zurückgestellt. -> OSD-Schrift wird nicht schlechter.


    Verschiedene Schriftarten in den OSD-Einstellungen habe ich auch schon probiert.
    Die sehen leider alle gleich unscharft/ausgefranst aus.


    Update:
    Habe es mittlerweile im webinterface geschafft manuell 50 Hz einzustellen.
    Das ändert leider auch gar nichts.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 1 time, last by davie2000 ().

  • Ich weiß ja nicht wie das bei yaVDR ist, aber nen unscharfes OSD kann an den OSD Einstellungen in den xineliboutput Plugin Settings liegen. Da kann man irgendwo zwischen Hardware und Software umstellen.


    Claus

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

  • Ich weiß ja nicht wie das bei yaVDR ist, aber nen unscharfes OSD kann an den OSD Einstellungen in den xineliboutput Plugin Settings liegen. Da kann man irgendwo zwischen Hardware und Software umstellen.


    Korrekt. So ist es auch bei yaVDR. Einfach mal in xineliboutput Plugin an Einstellungen rumschrauben.


    Albert

  • Also da hab ich schon recht massiv herumgeschraubt.
    Die OSD-Einstellung habe ich auf Hardware stehen - mit Software wirds richtig gruselig.


    Und das OSD ist nicht wirklich unscharf.
    Man sieht ihm einfach deutlich an, dass es skaliert wurde.
    Wohingegen es beim xine so aussieht wie nativ, knackig und scharf eben.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Welche Auflösung nutz der TV denn nun wirklich?

    Ich benutze einen LG HD-ready 32" Fernseher (Auflösung wurde automatisch auf 1360 x 768 gestellt; aber lt. Webinterface: "Auflösung: unbekannt" *seltsam*)

    Wenn ich in den xineliboutput-Einstellungen im Unterpunkt "OSD" die Auflösung (von dzt. 1920 x 1080) auf einen niedrigeren Wert ändere,


    dann habe ich, zwar größere, aber auch sehr scharfe, knackige Buchstaben. Aber dann ist das OSD wieder nicht wirklich benutzbar (siehe hier ).


    • Die Auflösung vom OSD stellt man nie größer ein als die TV Auflösung. Das kann so schon mal nicht funktionieren und macht auch überhaupt keinen Sinn. Beides muß gleich sein.
    • Bei Hardware Scaling bekommt man ein scharfes Bild. bei Software nicht. das ist so und muß man so hinnehmen.
    • Wenn bei Hardwarescaling die Bedienung lahm wird, hast Du nicht genug CPU Leistung, bzw der Skin ist zu resourcenlastig. -> Kein Atom System verwenden! oder auf einfache OSD´s wechseln z.b. skinenigmang läuft am besten auf den Atoms
    • Xine schaltet langsamer um als xineliboutput? Das halte ich für ein Gerücht. Wenn überhaupt ist es kaum wahrnehmbar. No Signal kann man wegbekommen bei Xine, ist kein Hexenwerk (suche nach No signal xine), einfach 2 Dateien ersetzen... Hast Du an den xine.conf Settings Änderungen vorgenommen?

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Xine schaltet langsamer um als xineliboutput? Das halte ich für ein Gerücht. Wenn überhaupt ist es kaum wahrnehmbar.


    Torsten, das kann ich bestätigen. Heute hat Thomas Müller Update gemacht, seit dem schaltet Xine spürbar langsamer um als xineliboutput.


    Albert

  • Hmm, verstehe ich nicht. Abgesehen davon dass ich nicht weiss wer Thomas Müller ist, meine VDR´s sind auf aktuellem Stand und verhalten sich beim Zappen mit Xine nicht anders als sonst. 1-2s querbeet egal ob HD oder SD.
    Habe gerade testweise nochmal xineliboutput ohne HUD aktiviert, das läuft bei mir bescheiden. nicht wirklich viel langsamer, aber nach ein paar mal zappen bereits mehrere Frontend Crashes und Teilweise sogar grüner pixelsalat (nicht auf Servus TV sondern ARDHD) .
    Meines Wissens nach, ist imho xine immer noch das aktuellste und stabilste Frontend.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • No Signal kann man wegbekommen bei Xine, ist kein Hexenwerk (suche nach No signal xine), einfach 2 Dateien ersetzen... Hast Du an den xine.conf Settings Änderungen vorgenommen?
    [/list]


    Hier zum Beispiel, aber das ersetzt nur das No-Signal durch einen schwarzen Bildschirm. Hilft auch nicht viel.

    yaVDR 0.5a@AT3ION-T Deluxe, twinDVB-C, ATRIC+Harmony200
    *****************************************************
    Netzspeicher: Synology DS716+ II mit 8GB RAM sowie 9TB Plattenplatz


    (in Rente: Siemens M740AV, Debian Dockstar, Pogoplug)

  • Hallo!


    Also erstmal danke für eure zahlreichen Antworten.


    1. Die Bildaussetzer waren ein lokales, zeitliches Phänomen unserer DVB-T Sendeanlage - heute ist das Signal wieder stabil.


    2. Die Umschaltzeiten von xine und xineliboutput sind in etwa gleich, wobei xine eben einen Tick länger braucht.
    Kann aber auch sein, dass das eine Täuschung ist, weil das "no signal"-Bild dazwischen noch kommt.
    Bei xineliboutput wird der alte Kanal kurz eingefroren, die Info (unten) vom neuen Kanal wird angezeigt und eine 1/2 Sekunde später ist auch das Bild (natürlich inkl. Ton) des neuen Senders da.
    Bei xine friert der alte Kanal nur ganz kurz ein, dann kommt das "no signal"-Bild (gefühlt ca. 1 Sekunde), dann die Info vom neuen Kanal und dann das Bild (und der Ton). Wirkt gefühlt in Summe einfach etwas behäbiger.


    3. Dafür ist beim xine die Auflösung des OSDs gestochen scharf - bei xineliboutput sieht man, dass es skaliert wurde (unabhängig vom verwendeten Skin).


    4. Die OSD-Auflösung ist standarmässig mit 1920x1080 (konkret bei OSD-Einstellungen und Plugin-Einstellungen xine bzw. xineliboutput) eingestellt (nach der Installation).
    Ich benutze (jetzt wieder) die automatisch erkannte Auflösung von 1360 x 768 mit 60 Hz.
    Habe schon manuell auf 1280 x 720 mit 50 Hz umgestellt; bringt aber keinen Unterschied. Habe auch schon die unterschiedlichsten Deinterlacer-Einstellungen versucht und bin jetzt wieder bei den Default-Werten (bop und temporal) gelandet, weils auch keinen nennenswerten Unterschied macht.


    Wenn ich die OSD-Auflösung mit der des TV gleichziehe, dann bekomme ich den Effekt, den ich schon mal beschrieben habe:
    Der Inhalt des OSD-Menüs hat nicht mehr im OSD-Rahmen Platz.
    Hier ein Bild zur Verdeutlichung, wenn ich die OSD-Auflösung auf weniger als 1920 x 1080 einstelle:




    Hier noch die relevanten Auszüge aus meiner setup.conf - die ganze Datei kann hier (pastebin) eingesehen werden.



    Daher also meine Fragen:


    zu 2) Kann ich xine das Umschaltverhalten ("no signal" bzw. schwarzer Bildschirm) irgendwie abgewöhnen? Ich fürchte nicht.
    Bekomme ich bei xineliboutput das OSD irgendwie so gestochen scharf als wie mit xine?


    zu 3) Welche Auflösung sollte jetzt wo im VDR wie eingestellt sein? Also bei OSD-Einstellungen, Plugin-Einstellungen (xine bzw. xineliboutput), Webinterface-Anzeigeeinstellungen)?
    Fallen irgendjemand seltsame oder falsche Einstellungen in meiner setup.conf auf?


    Danke schon jetzt für eure Beiträge!


    lg
    davie

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Code
    1. OSDHeight = 1080
    2. OSDWidth = 1920
    3. xineliboutput.OSD.Height = 720
    4. xineliboutput.OSD.Width = 1280
    5. xineliboutput.OSD.Size = 1920x1080


    Ich denke das dürfte das unscharfe OSD erklären.


    Ich würde an Deiner Stelle erst einmal zusehen die OSD Größen übereinstimmend zu machen. Wenn Du die "OSD" Werte herunter setzte und die Werte bei Xine(liboutput) auf FullHD lässt, wundert es ja nicht, wenn das OSD abgeschnitten wird.


    Gruß


    EDIT: Ich meine das:

    Code
    1. OSDHeight = 1080
    2. OSDWidth = 1920
    3. xine.osdExtent.X = 1920
    4. xine.osdExtent.Y = 1080


    Du hast beim heruntersetzen der Auflösung vermutlich nur die OSDxxxxxx Werte herunter gesetzt. Aber nicht die des xine-Plugins.

    ASUS M4A78LT-M GL | AMD Athlon II X2 250 | 2GB RAM | Asus ENGT430 | Digital Devices OctopusNet mit 2 x Digital Devices DuoFlex S2 | PS3Remote | yaVDR 0.6.1

    The post was edited 2 times, last by BOP ().

  • Hallo BOP!


    Mal ne doofe Frage: Wo kann ich die OSD-Auflösung eigentlich einstellen?


    Ich habe über das webinterface die Auflösung (Anzeigeeinstellung) jetzt auf "gerade" 720p (also 1280 x 720) mit 50 Hz gestellt (statt 1360 x 768 @ 60 Hz).


    Wenn ich dann im OSD-Menü am TV suche finde ich nirgends einen Punkt, wo ich die Auflösung umstellen kann.
    Außer eben bei den Plugin-Einstellungen (xineliboutput):


    Menü - System - Einstellungen - Plugins - xlineliboutput - OSD
    => hier ist aktuell 1920 x 1080 eingestellt; wenn ich auf 1280 x 720 ändere, habe ich wieder das abgeschnittene OSD vom obigen Bild.


    Menü - System - Einstellungen - OSD
    - im Menü anzeigen: ja
    - Oberfläche: NarrowHD
    - ...
    => hier kann ich nirgendwo eine Auflösung angeben/auswählen



    Wo kann ich die Parameter OSDHeight und OSDWidth denn (per OSD) umstellen?
    Bzw. wie bleiben die Werte nach Reboot erhalten, wenn ich sie direkt in der setup.conf umstelle?


    Danke für deine Unterstützung!


    lg
    davie

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Stimmt, im OSD kann man dort überhaupt nichts einstellen. Ob die Einstellung überhaupt Auswirkungen hat?


    Vor manuellen Änderungen in der "/var/lib/vdr/setup.conf" musst du den VDR stoppen (stop vdr).

    ASUS M4A78LT-M GL | AMD Athlon II X2 250 | 2GB RAM | Asus ENGT430 | Digital Devices OctopusNet mit 2 x Digital Devices DuoFlex S2 | PS3Remote | yaVDR 0.6.1

  • Ich habe jetzt alle Stellen wo die Auflösung explizit in der setup.conf vorkommt auf 1280 bzw. 720 (bzw. 1280x720) geändert.
    Vorher den VDR gestoppt, dann neu gebootet.
    Ergebnis ist wieder das abgeschnittene OSD - dafür gestochen scharf.


    Aber wenn ich auf das Skin "anthra_1280_OS" wechsle, dann hab ich beides:
    ein gestochen scharfes Bild in der richtigen Auflösung und sichtbaren Größe.


    Es liegt also an den Skins.
    Da mir aber HDNarrow und PearlHD viel besser gefallen, würde ich doch gerne diese verwenden.
    Gibts die in 720p-Auflösung?
    Oder kann ich mit meinem HD-ready TV prinzipiell keine HD-Skins "gestochen scharf" verwenden?


    Wie kann ich die Einstellungen in der setup.conf vor update & upgrade schützen?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Aber wenn ich auf das Skin "anthra_1280_OS" wechsle, dann hab ich beides:
    ein gestochen scharfes Bild in der richtigen Auflösung und sichtbaren Größe.


    Schön.


    Gibts die in 720p-Auflösung?


    720p wird mit einer Auflösung von 1280×720 Pixeln ausgestrahlt. ;)


    Wie kann ich die Einstellungen in der setup.conf vor update & upgrade schützen?


    Template sie oder kopiere sie wo anders hin.


    Albert

  • albert :


    Hast recht, mit dem Anthra zu leben ist "schön". Zumindest schöner als mit dem zerschossenen Narrow oder Pearl.


    Quote

    720p wird mit einer Auflösung von 1280×720 Pixeln ausgestrahlt. [IMG:wcf/images/smilies/wink.png]

    Ich meinte, ob es die Skins NarrowHD und PearlHD auch in 1280 x 720 gibt, nicht nur in 1920x1080?


    Quote

    Template sie oder kopiere sie wo anders hin.

    Also einfach nur im Verzeichnis /etc/yavdr/templates_custom das Unterverzeichnis var/lib/vdr/setup.conf/ anlegen
    und dort eine Datei mit dem Namen 99_????????? anlegen und mit den paar Parametern (zB OSDWidth) befüllen, die ich dauerhaft geändert haben möchte?
    Wie muss die Datei korrekt heißen?


    Danke für deine Antworten!


    lg
    davie

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Zitat
    Also einfach nur im Verzeichnis /etc/yavdr/templates_custom das Unterverzeichnis var/lib/vdr/setup.conf/ anlegen
    und dort eine Datei mit dem Namen 99_????????? anlegen und mit den paar Parametern (zB OSDWidth) befüllen, die ich dauerhaft geändert haben möchte?
    Wie muss die Datei korrekt heißen?


    Wenn du das wissen willst, dann hast du es nicht verstanden und musst die Doku zum Templating noch mal lesen.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470