Reelvdr und Alphacooldispaly HILFE

  • Hallo,
    habe mir ein Alphacooldisplay zugelegt und bekomme es irgendwie nicht zum laufen.
    Habe alles installiert , bzw. libusb und graphlcd sind schon von haus aus installiert.
    Also, serdisplib installiert und mit testserdisp -n ALPHACOOL -p usb:060c/04eb probiert.

    Code
    1. testserdisp -n ALPHACOOL -p usb:060c/04eb


    Da der VDR nicht als Root läuft kommt:

    Code
    1. reel@ReelBox:/usr$ cd ..
    2. reel@ReelBox:/$ testserdisp -n ALPHACOOL -p usb:060c/04eb
    3. »testserdisp« ist unter »/usr/local/bin/testserdisp« verfügbar
    4. Der Befehl konnte nicht gefunden werden, weil »/usr/local/bin« nicht Teil der
    5. Umgebungsvariable PATH ist.
    6. testserdisp: Befehl nicht gefunden


    Mit Sudo su kommt dann auch das Testbild.


    Habe die graphlcd.conf angepasst

    Code
    1. [serdisp]
    2. Driver=serdisp
    3. Controller=ALPHACOOL
    4. Device=usb:060c/04eb
    5. Width=240 (oder 200, je nach Displaygröße - es gibt auch kleinere!)
    6. Height=128 (oder 64 " )
    7. UpsideDown=no
    8. Invert=no
    9. Backlight=yes


    und graphlcd gesagt das es serdisp als Treiber verwendet.


    Bei mir unter /etc/reel/p.graphlcd.conf, dort war vorher der eintrag für das Orginal Display.
    Eine udev Regel habe ich auch angelegt, weiss aber nicht ob das so korrekt ist.

    Code
    1. ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="060c", ATTRS{idProduct}=="04eb", GROUP="reel", MODE="0660"


    Das Syslog:

    Code
    1. Feb 5 11:17:44 ReelBox vdr: [2848] initializing plugin: graphlcd (0.1.3): Output to graphic LCD
    2. Feb 5 11:17:44 ReelBox vdr: [2848] graphlcd: ERROR: Failed creating display object serdisp
    3. Feb 5 11:17:44 ReelBox vdr: [2848] Error: initializing plugin graphlcd failed, continuing without...
    4. Feb 5 11:17:44 ReelBox vdr: [2848] setting primary device to 9
    5. Feb 5 11:17:44 ReelBox vdr: [2848] assuming manual start of VDR
    6. Feb 5 11:17:44 ReelBox vdr: [2848] SVDRP listening on port 2001


    Liegt es vielleicht daran das der VDR nicht als Root läuft ???


    Kann mir da jemand helfen ???

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Santos ()

  • Was sagt denn "lcdestpattern" (ds Displaytestprogramm von gaphlcd-base)?


    cu

  • Ich muss mal kurz den VDR neu aufsetzten.
    Glaube da habe ich jetzt zuviel verändert.
    Dauert ca . 1 Stunde.


    Danke

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • Ich bekomme diese Ausgabe:

    Code
    1. reel@ReelBox:~$ lcdtestpattern -d serdisp
    2. lcdtestpattern: Befehl nicht gefunden
    3. reel@ReelBox:~$ sudo su
    4. [sudo] password for reel:
    5. root@ReelBox:/media/hd/home/reel# lcdtestpattern -d serdisp
    6. lcdtestpattern: Befehl nicht gefunden

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • mach mal als root "find / -name lcdtestpattern".


    cu

  • Scheint er wohl nich zu finden.
    Er sucht ca.20 sec.


    Code
    1. root@ReelBox:~# find / -name lcdtestpattern
    2. root@ReelBox:~#

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • Tja, ich kenne reelvdr nicht. Worauf basiert das denn? Evtl. kannst du die graphlcd-tools (so heisst das Paket üblicherweise bei den Debian basierenden) über die Paketverwaltung des Systems nachinstallieren?


    Vermutlich fehlen (oder sind falsch) einfach nur Einstellungen in der graphlcd.conf. Aber das kann man mit lcdtestpattern am besten testen.


    cu

  • Es basiert auf

    Code
    1. Avantgarde detected ("(R)Ubuntu 10.04.2 LTS")
    2. Release=11.12.1
    3. VersionString=111201
    4. Build=R17840
    5. BuildDate=2012-02-03


    versuche mal das Paket Graphlcd-base zu installieren.
    Melde mich dann nocheinmal, und danke für deine Hilfe.

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • Hallo Santos,


    ich habe zwar einen VDR basierend auf yaVDR 0.4, aber bei mir sieht die udev-Regel für das Alphacool-LCD folgendermaßen aus:

    Code
    1. BUS == "usb",SYSFS{idVendor}=="060c", SYSFS{idProduct}=="04eb", GROUP="vdr", MODE="0660"


    Vielleicht hilft es Dir weiter.


    Ciao Stefan

  • So, habe graphlcd-base händisch nachinstalliert und bekomme diese Ausgabe.

    Code
    1. reel@ReelBox:~$ sudo su
    2. [sudo] password for reel:
    3. root@ReelBox:/media/hd/home/reel# lcdtestpattern -d serdisp
    4. lcdtestpattern: error while loading shared libraries: libglcdgraphics.so.2: can
    5. ot open shared object file: No such file or directory

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • Wie hast du base denn installiert? Vom Quellcode? Dann brauchts noch das "make install" damit die Libs ins richtige Verzeichnis kopiert werden und evtl. nen "ldconfig" damit das System die kennenlernt.


    Wobei bei einem debianartigen System eigentlich ein "apt-get install graphlcd-tools" reichen sollte. Wenn nicht dann hat da reel gepfusht.


    cu

  • Habe ich gemacht.

    Code
    1. make[2]: Verlasse Verzeichnis '/media/hd/home/reel/graphlcd-base/tools/convpic'
    2. make[2]: Betrete Verzeichnis '/media/hd/home/reel/graphlcd-base/tools/crtfont'
    3. install -d /usr/local/bin
    4. install -m 755 -o root -g root -s crtfont /usr/local/bin
    5. make[2]: Verlasse Verzeichnis '/media/hd/home/reel/graphlcd-base/tools/crtfont'
    6. make[2]: Betrete Verzeichnis '/media/hd/home/reel/graphlcd-base/tools/genfont'
    7. install -d /usr/local/bin


    ist nur ein teil des auszugs.



    Habe zu schnell gelesen, was ist ldconfig ???

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • Mit ldconfig hat es funktioniert !!!

    Code
    1. clear and test byte: 0xED
    2. clear and test byte: 0xEE
    3. clear and test byte: 0xEF
    4. clear and test byte: 0xF0
    5. clear and test byte: 0xF1
    6. clear and test byte: 0xF2
    7. clear and test byte: 0xF3
    8. clear and test byte: 0xF4
    9. clear and test byte: 0xF5
    10. clear and test byte: 0xF6


    Das hat auch funktioniert:

    Code
    1. root@ReelBox:/media/hd/home/reel/graphlcd-base# showpic -c /etc/graphlcd.conf -
    2. serdisp /etc/vdr/plugins/graphlcd/logos/ARTE_m.glcd


    Funktioniert aber nur als User Root (sudo su)

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Santos ()

  • Hier mal ein Auszug aus der udev.log


    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • Evtl. tuts schon diese Änderung

    Code
    1. ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="060c", ATTRS{idProduct}=="04eb", GROUP:="reel", MODE:="0660"


    Der Doppelpunkt sorgt dafür das die Sachen nicht durch sätere Regeln überschrieben werden.



    Was ist denn der Fehler wenn du showpic als User auführst? Im Syslog steht dann evtl. auch noch was.


    cu

  • Hier ein teil aus dem Syslog



    Ich glaube das graphlcd Plugin hat sich verabschiedet, finde kein Startversuch von graphlcd.
    Hatte vorhin mal versucht, dass graphlcd plugin händisch zu installieren, aber ohne erfolg.
    Die Ausgabe hatte ich vorher noch nicht, dass er die rules lädt.
    Versuche es morgen nocheinmal, muss jetzt schlafen(Arbeit).


    Testserdisp ohne Root

    Code
    1. reel@ReelBox:~$ testserdisp -n ALPHACOOL -p usb:060c/04eb
    2. »testserdisp« ist unter »/usr/local/bin/testserdisp« verfügbar
    3. Der Befehl konnte nicht gefunden werden, weil »/usr/local/bin« nicht Teil der
    4. Umgebungsvariable PATH ist.
    5. testserdisp: Befehl nicht gefunden

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • Wollte euch nur informieren, dass ich es aufgegeben habe.
    Die graphlcd-base ist mit Speziellen Treiben ausgerüstet , serdisp wurde entfernt.
    Hinzu kommt noch, dass alles miteinander verlikt ist mit dem System.


    Werde mit jetzt Yavdr installieren.

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)

  • Hallo ,
    habe da noch kurz ne frage zum Yavdr.
    Hat man eine grafische Oberfläche sprich KDE, wenn ich den Yavdr über die Install CD installiere ?


    Danke im vorraus.

    VDR1
    - Yavdr 0.5 - Zotac D2700 Atom 2X2.13GHZ - GT520 Onboard- 4GB Speicher - 32GB CF- Technotrend TT S2-4100 - Alphacool Display - YaUsbIr 2- Technotrend Fernbedienung - Gehäse Plexiglas (Stable)


    VDR2
    - Yavdr 0.5- AsRock 77 mit i3-3220T 2X2.8GHZ- 4GB Speicher- GT 440 Passiv - 64GB SSD 2,5"- DigitalDevices Cine S2- LG Bluray - 10" Monitor - YaUsbIr 2 - T Home Fernbedienung - uMouse Cardreader - Gehäse Bitfenix Prodigy M (Unstable)