[SOLVED / ACPI]NVRAm-Wakeup ASUS AT5IONT-I

  • Hallo,


    da ich eine "Mystique SaTiX-S2" SAT Karte verwende (PowerOff Kernel) kann ich ACPI-Wakeup nicht verwenden.
    Die Konfiguration von NVRAM-Wakeup gelingt mir nicht:


    Mainboard: ASUS AT5IONT-I


    Mit guess-helper habe ich eine nvram-wakeup.conf erstellt, beim test sieht alles gut aus:



    Durch den Poweroff Kernel wird der Rechner rebootet und das Bios meldet, dass es wiederhergestellt werden muss. Ich vermute das liegt an den Checksummen, die guess-helper nicht gefunden hat:



    hier das guess-error.log



    Das ist die erste nvram-wakeup config die ich erstellt habe, hier komme ich jetzt nicht weiter.


    Stippy

  • Hallo Stippy,


    warum nicht ACPI-Wakeup?


    Ist etwas betagt aber vielleicht hilft es:


    /boot/grub/menu.lst
    default 0 ist unbedingt in default saved zu ändern, da Grub sonst immer mit dem 1. Menüpunkt (Zählung beginnt bei 0) startet.
    Zwischen dem Key 'default' und dem zugehörigen Value '0' befindet sich ein nicht zu veränderndes Trennzeichen.
    Deshalb nur die '0' durch 'saved' ersetzten, weil ansonsten der neue Wert evtl. nicht beachtet wird.
    timeout auf 1
    Anschließend werden folgende Zeilen in die Datei eingefügt (am besten an das Dateiende):

    title PowerOff
    root (hd0,0)
    savedefault 0
    cat /boot/grub/default
    halt


    /etc/nvram-wakeup.conf anpassen


    /etc/vdr die vdr-nvram-wakeup.conf

    ENABLED="yes"
    COMMANDLINE="-C /etc/nvram-wakeup.conf --directisa"
    SPECIALSHUTDOWN="grub-set-default 2 ; reboot"


    Albert

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von DaKilla ()

  • Moin DaKilla!

    warum nicht ACPI-Wakeup?

    Aus der FAQ von yavdr:


    Code
    1. ACPI Wakeup...
    2. Diese Variante des Wakeup funktioniert grundsätzlich nicht, wenn man auf
    3. einen reboot-shutdown angewiesen ist (etwa wegen bestimmter SAT-Karten,
    4. mit denen der Rechner nicht normal herunterfährt): der ACPI Alarm
    5. überlebt den zwischengeschalteten Reboot nicht!


    Wenn diese Info falsch ist würde ich gerne ACPI-Wakeup verwenden.

    Ich benutze yavdr 0.4, hätte ich erwähnen sollen. Da wird grub2 verwendet. Mit dem Poweroff Kernel hab ich aber auch keine Probleme.
    Evtl. verstehe ich Deine Antwort nicht richtig...die anpassungen vdr mässig habe ich schon gemacht. Aber der test sollte ja erst mal funktionieren.


    Stippy

  • So, ich hab ACPI-Wakeup ans laufen bekommen, da es einen fix für das shutdown Problem mit der SAT Karte gibt:


    Das ngene Kernel Modul muss mit folgendem Parameter geladen werden:


    Code
    1. options ngene one_adapter=0 shutdown_workaround=1


    Dann klappts auch mit dem shutdown. ACPI-wakeup lief dann out of the box.


    Stippy

  • Ich benutze yavdr 0.4, hätte ich erwähnen sollen.


    Wäre ein Plan gewesen.


    Dann klappts auch mit dem shutdown. ACPI-wakeup lief dann out of the box.


    Das freut mich.


    Albert