[SOLVED]Streamzap pc remote and receiver

  • Hello,


    I have a problem setting this remote to work with vdr and xbmc. There are only a few buttons that works out of the box with vdr and xbmc. I followed the instructions here http://wiki.xbmc.org/index.php…amzap_PC_Remote_for_Linux that describes how to disable the remote from emulating a keyboard presses but it did not work for me in yavdr. I applied the same instructions in debian squeeze and they worked. Any idea please how to configure this remote to work in yavdr? Thank you.


    Regards,
    Sami

  • Some extra details:





    Thanks.

  • Code
    1. I: Bus=0003 Vendor=0e9c Product=0000 Version=0100
    2. N: Name="Streamzap PC Remote Infrared Receiver (0e9c:0000)"
    3. P: Phys=usb-0000:00:1d.2-1/input0
    4. S: Sysfs=/devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/rc/rc0/input3
    5. U: Uniq=
    6. H: Handlers=kbd event3
    7. B: PROP=0
    8. B: EV=100013
    9. B: KEY=3ff 0 fc000 100000000 0 18000 4180c0000801 9e168000000000 0
    10. B: MSC=10


    This is your remote reciever. It uses rc-core and can be configured by ir-keytable.


    Please post the output of my script:

    Code
    1. wget http://dl.dropbox.com/u/960809/list-rc-core.sh
    2. chmod +x list-rc-core.sh
    3. sudo ./list-rc-core.sh

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Thanks Alex for your help. Here is the output(I think I have already run your script two days ago while searching in the forum for a solution):


  • Hi, if you run my script with the argument "set" it will create most needes files for you:

    Code
    1. ./list-rc-core.sh set


    After that you can change the protocoll and keynames in /etc/rc_keymaps/rc-streamzap - AFAIK it should be edited to look like this (but this is just a guess):


    After a reboot or

    Code
    1. sudo ir-keytable -w /etc/rc_keymaps/rc-streamzap

    all keys should work.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Yup I already run your script with the argument set. Now I have changed the settings in the file /etc/rc_keymaps/rc-streamzap to looks like what you have suggested and then run the command:
    sudo ir-keytable -w /etc/rc_keymaps/rc-streamzap


    Now All buttons dont work! Do I need to reboot? or I should not have changed the file /etc/rc_keymaps/rc-streamzap ?


    Regards,
    Sami

  • Please post you actual rc-streamzap file.


    Maybe you need to specify another protocoll. Give RC-5-sz instead of RC-5 a try

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Here it is:



    root@ubuntu:/etc/rc_keymaps# sudo ir-keytable -w /etc/rc_keymaps/rc-streamzap
    Protocol RC-5-sz invalid
    Invalid parameter on line 1 of /etc/rc_keymaps/rc-streamzap
    Invalid parameter(s)
    ir-keytable: -w: (PROGRAM ERROR) Option should have been recognized!?
    Try `ir-keytable --help' or `ir-keytable --usage' for more information.
    root@ubuntu:/etc/rc_keymaps#

  • Mh - according to http://kerneldox.com/dc/d2c/rc-streamzap_8c-source.html the streamzap remote uses a special protocol - maybe this can be invoked by setting protocol to "other"

    Code
    1. # table rc-streamzap, type: other

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Then remove the first line of /etc/rc_keymaps/rc-streamzap and change the entry in /etc/rc_maps.cfg from

    Code
    1. streamzap rc-streamzap /etc/rc_keymaps/rc-streamzap


    to

    Code
    1. streamzap * /etc/rc_keymaps/rc-streamzap


    And do another reboot.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Great.


    As a final step you should edit the custom template for your entry in /etc/rc_maps.cfg accordingly so your configuration will survive future updates:
    /etc/yavdr/templates_custom/etc/rc_maps.cfg/90_rc-streamzap

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)