Microsoft Services for Unix

  • Hi,


    ich hab die SFU von Microsoft runtergeladen (233 MB) und installiert. Nach erstem groben tEst muss ich sagen, prima! Kein Wunder hat MS ja auch in den letzten JAhren alles zusammengekauft :D. Aber zur Sache. Bei der Installation kann man wie bei aktuellen MS Produkten üblich die Komponenten auswählen. Dabei sind u.a. ein NFS Client, NFS Server, NFS Gateway, Telnet Client und Server, Cron und Remote Shell Service, User Name Mapping (NIS), ksh Shell inkl. der üblichen GNU Tools und last but not least Perl. Ebenso ist X drauf, das konnte ich aber noch nicht zum laufen bringen, ich hab ja die schwache Hoffnung das das ein kompletter X Server ist.


    Somit hat man dann auch die GNU Tools und einen gcc drauf und auch in Firmen kann man jetzt ohne schlechtes Gewissen GNU Tools installieren lassen, weil ist ja von MS, wird ja supportet, ist also nicht mehr böse :D.


    Alles in allem das was ich mir in der VErgangenheit mühsam zusammensuchen musste ist jetzt in einem Stück erhältlich, läuft allerdings nicht unter NT erst ab 2000 aufwärts. Und der NFS Support ist seamless integriert, also ist Samba nicht mehr zwingend für jeden Linux Rechner erforderlich auf den man gelegentlich mal via Windows zugreifen will.


    Wie gesagt, ich habs nur mal oberflächlich getestet, aber was ich bisher gesehen hab sieht ganz brauchbar aus.


    WErs auch saugen will ...hier..gehts ohne Passport Registrierung.


    bye


    Sven


    Link: Richtig fragen

  • moin,
    habe es ebenfalls downgeladen und mal unter w2k installiert,
    nachdem ich aber festgestellt habe,
    das sich der Zugriff auf die Festplatte extrem verzoegerte,
    neues Verzeichniss anlegen hat ewig gedauert ,
    habe ich es wieder deinstalliert,
    seitdem gibts auch keine Verzoegerungen beim Zugriff auf die Festplatte
    mehr.
    Das ganze lief allerdings mit normalen Benutzerrechten,
    kein PowerUser (habe die engl. Version von w2k installiert).
    mfg

  • Hi,


    kann ich nicht bestätigen/nachvollziehen. Hab es ebenfalls unter w2k laufen (llerdings deutsche version) und hat sich nichts geändert bei den Plattenzugriffen. Evtl. übersprecheffekte von anderen Apps, Virenscanner oder so?


    bye


    Sven


    Link: Richtig fragen

  • Hallo,
    moeglicherweise lags an der Firewall (Kerio),
    hatte mehrere "unbekannte Zugriffe etc" laut der KPF,
    alles geblockt,das wirds wohl gewesen sein ;) ,
    Virenscanner lief auch noch.
    Will es demnaechst nochmal ausfuehrlicher testen,
    bzw mal schauen was fuer Dienste und Prozesse laufen.
    mfg

  • mhm, nun hab ich auch mal ne frage zu dem wsfu3.5...
    es geht um folgendes, vor na weile hab ich mir nen dlink nas zugelegt und vdr nimmt fleißig per nfs dorthin auf. nun hab ich noch nen xp lapi und hab per vdrzapper vorher immer per samba vom vdr server die aufnahmen geschaut.
    jetzt vom nas per samba ist irgendwie der datenstrom zu gering und es ruckelt nur noch bzw es geht überhaupt nicht. am vdr server die aufnahmen vom nas per nfs geht lupenrein.
    nun hab ich diesen nfs client von den wsfu installiert und die nas freigaben werden auch schön in der netzumgebung angezeigt. problem ich kann nicht drauf zugreifen, xp hängt sich weg. die passwd und group vom nas liegen auf dem lapi und ich hab schon die verschiedensten user mapping versuche unternommen, es will nicht. nun hoffe ich auf hilfe von euch bzw sven.
    vielen dank.

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


    dabei seit Version 0.72

  • hab nun mal einen nfs server auf dem vdr rechner aufgesetzt und das video verzeichnis exportiiert.


    Code
    1. /video 192.168.1.0/24 (no_all_sqaush,async,secure,rw,no_subtree_check)


    und siehe da ich kann mit dem ms nfs client der wsfu3.5 ohne ein usermapping eingerichtet zu haben, darauf zugreifen, als laufwerk einbinden und vdr aufnahmen per vdrzapper schauen, dabei bin ich indirekt auf dem nas da das exportierte /video quasi nicht auf dem vdr rechner liegt sondern auf dem nas.


    bleibt die frage warum das nicht direkt vom nas funktioniert, hab die gleichen exports einstellungen auch auf dem nas und kann die freigaben auch auf dem xp rechner sehn. ein zugriff darauf läßt den explorer abschmieren.


    elchi

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


    dabei seit Version 0.72

  • Hi,


    puh, erst mal den Thread entstaubt...der müffelt ja schon :). Ich hab das Gateway auf einem Windows 2003 Server laufen und mappe da NFS nach Samba. Aber ich habs chon häufiger gelesen und gehört, dass die Implementierungen auf den NAS nicht immer sehr performant sind. Warum auch immer. Aber du hast ja eine Lösung gefunden...


    bye
    Sven


    Link: Richtig fragen

  • halt sven, ich hab keine lösung gefunden...schliesslich soll der vdr ja nich immer laufen wenn mal eine aufnahme mit dem lapi angeschaut wird. performant iss der nfs server vom nas schon. gehört zu nem mod, das dns323 von dlink läßt sich prima erweitern. hoffe hast noch nen tipp, is das mapping von usern echt dringend lebensnotwendig? weil es geht ja auch ohne, nur beim nas bin ich mir eben nicht sicher...

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


    dabei seit Version 0.72

  • Hi,


    ja würde ich auch mal versuchen, ist wohl von Hummingbird...


    bye
    Sven


    Link: Richtig fragen

  • vielen Dank für die Antworten, ist dieser Client kostenfrei?
    hab inzwischen mal proNFS 3.0 als trial getestet (geht nur 1h) aber damit hab ich Zugriff auf das Nas.


    Elchi

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


    dabei seit Version 0.72

  • Hi,


    nicht wirklich, die c't Seite sagt:


    Einschränkung: Installierbar bis 31.12.2009 mit einer Laufzeit von max. 270 Tagen, die Vollversion kostet 161 Euro.


    bye
    Sven


    Link: Richtig fragen

  • Yohoo!


    Meine Meinung [habe das SFU vor ein paar Jahren mal ausprobiert]:


    Es ist bedeutend einfacher, ein Linux mittels Samba in ein Windows-Netzwerk einzubinden als ein Windows in ein NFS/NIS Netzwerk.


    Insofern:
    Vergesst SFU und nehmt Samba.


    Nur meine Meinung...

    Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
    Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

  • ja alles schön und gut, das mit samba klappt ja auch bei musik und fotos jedoch nicht mit nem mpeg2 stream vom nas...da gibt es echt performance probleme mit dessen sambaserver. keine ahnung wieso...deshalb nfs...

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


    dabei seit Version 0.72

  • Hi,


    ich weiss ja naicht was für ein Samba auf dem NAS läuft und ob sich da was konfigurieren lässt. Aber wirf mal einen Blick da rein. Evtl. ist der NAS Samba sehr konservativ eingestellt oder eher auf kleinere Dateien. Ich würde das mal eher auf die großen Files optimieren und nochmal probieren. Gerade read raw und TCP_NODELAY würde ich mir da ansehen. Vielleicht löst das ja Dein Problem.



    bye
    Sven


    Link: Richtig fragen

  • danke sven, kannst ja mal schaun bitte...


    [ global ]
    interfaces = egiga0
    unix charset = UTF8
    workgroup = workgroup
    netbios name = dlink1000gb
    server string = DNS-323
    hosts allow =
    hosts deny =
    security = SHARE
    encrypt passwords = yes
    max log size = 0
    socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
    max xmit = 65535
    create mask = 0777
    directory mask = 0777
    force create mode = 0777
    force directory mode = 0777
    load printers = Yes
    printcap name = /usr/local/LPRng/etc/printcap
    min print space = 2000
    max print jobs = 1000
    printing = lprng
    print command = /usr/local/LPRng/bin/lpr -P%p -r %s
    lpq command = /usr/local/LPRng/bin/lpq -P%p
    lprm command = /usr/local/LPRng/bin/lprm -P%p %j
    lppause command = /usr/local/LPRng/sbin/lpc hold %p %j
    lpresume command = /usr/local/LPRng/sbin/lpc release %p %j
    queuepause command = /usr/local/LPRng/sbin/lpc -P%p stop
    queueresume command = /usr/local/LPRng/sbin/lpc -P%p start
    use sendfile =yes

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


    dabei seit Version 0.72

    The post was edited 1 time, last by Elchi ().

  • nun muss ich das thema nochmal ausgraben, ziel ist es per samba freigabe von einem dlink nas die aufnahmen auf ein per wlanN angebundenes laptop zubekommen und das ohne ruckeln.
    das netz hier sieht so aus: an fritzbox7270 hängen 2 vdrserver wo auch damit fernsehn geschaut wird, dann 2 laptops, eines per 54mbit, das andere per 300mbit wlan angeschlossen und zu guter letzt das dlink NAS per 100mbit und noch ne alte xbox.
    nun was geht.


    samba bzw nfs freigaben bzw livstreaming von den vdr servern aufs 300mbit laptop -> alles ohne probleme, kein ruckeln, normale cpu auslastung.


    samba freigabe vom dlink NAS aufs 300 Mbit laptop -> nicht möglich ohne ruckeln bzw total zusammenbruch, egal wieviel cache für den mplayer


    samba freigabe vom dlink auf das xbox mediacenter -> keine probleme, kein ruckeln.


    nfs freigabe vom dlink Nas auf die vdrserver bzw live aufnehmen aufs dlink nas -> keine probleme


    wollte daher nen nfs client aufs 300 mbit laptop spielen, die unixservices für windows bekomme ich nicht zum laufen, alles andere kostet geld oder is demo und funktioniert irgenwie auch nicht. wer hat nen tip wie man mein problem beheben kann, wo ist der flaschenhals???

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


    dabei seit Version 0.72

  • ich habe hier über wlan keine Aussetzer selbst mit WPA2-PSK.
    IBMR52 Linksysrouter VDR
    Wird Dir nicht viel helfen außer das Du siehst das es geht...

    Software: gen2vdr V3 ( Beta8 ) / gen2vdr V2
    Hardware: Intel 5200EE - 5N7A-VM - Scythe Shuriken - BeQuiet(Netzteil) - X10-USB Remote
    SMT 7020S & P3@900 - Testsystem mit FF und X10-USB Remote
    Links für Neueinsteiger


    "Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

    The post was edited 1 time, last by Mr.N!ce ().

  • hast du richtig gelesen?

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


    dabei seit Version 0.72

  • Quote

    Original von Elchi
    nun hab ich diesen nfs client von den wsfu installiert und die nas freigaben werden auch schön in der netzumgebung angezeigt. problem ich kann nicht drauf zugreifen, xp hängt sich weg. die passwd und group vom nas liegen auf dem lapi und ich hab schon die verschiedensten user mapping versuche unternommen, es will nicht. nun hoffe ich auf hilfe von euch bzw sven.
    vielen dank.


    Die passwd und group hatte ich bei mir nur auf dem XP-Rechenr abgelegt, als ich mit der Dbox auf die NFS-Freigabe aufgenommen hatte.
    Aktuell habe ich noch so ein DualNas in Betrieb und da klappt das Mounten unter WinXP auch ohne passwd und group. Man hat ja das Verzeichnis auf dem Nas für eine bestimmte IP lesend oder schreibend freigeben.
    Der Speed unter Samba ist auf dem Teil (und anderen seiner Art) auch nicht berauschend. So wie ich auf meiner Suche nach mehr Performance in diversen Foren gelesen habe. liegt es wohl einerseits an der mickrigen Hardwareausstattung (wenig Ram und ein Prozessor, der alles abwickeln muss) dieser Speicherkistchen und auch am Samba Protokoll (mehr Overhead im Vergleich zu NFS). Mit einer Optimierung der smb.conf kann man den Speed etwas erhöhen, es ist aber nicht Die Lösung. Versuch doch mal alle unnötigen Prozesse zu killen und z.B. auch den Printserver zu deaktivieren. Beim Mounten auch den evtl. unterschiedlichen Pfad beachten, je nachdem wie die Festplatte(n) im Nas als Raid konfiguriert sind. Mit dem DualNas sieht es z.B. so aus:
    mount 192.168.0.205:/mnt/md1/video z:


    Ich persönlich werde bei meinem Eisfair Server (altes Siemens D1025 Board) bleiben. Die Performance passt und den kann ich zudem noch per WOL aufwecken und mit imond oder plink (je nachdem ob nun von Linux oder Win aus) wieder herunterfahren, wenn ich es will.