[ANNOUNCE] Neue Treiber für yaVDR 0.4

  • Ich wollte die deswegen auch schon anschreiben, das wiederum hab ich aber noch nicht geschafft.


    Ich habe den Entwickler mal angeschrieben. Mal sehen, was kommt.


    Gruß
    Thomas

    Asus S1-AT5NM10E, SSD, Mystique SaTiX-S2 Sky USB, Unicable/SCR, Terratec USB IR Receiver, video.00 per NFS auf QNAP 410
    VDR-User seit 2002

  • verlesen, daher gelöscht

    mfg traxanos
    ____________________
    Ist das neu?, Nein Linux!


    VDR1: Zotac NM10-ITX Wifi - 2GB Ram - S2-6400 HD mit IR - yavdr 0.4 (development) - LianLi PC-Q11


    Tags: VDR-HD - AT5IONT-I - 4GB Ram - 512MB ION - TT 3600 DVB-S2 - TT6400-FF - Sundtek DVB-S2 Sundtek DVB-C - Tevii S480 (dank an L4M für kostenlose Bereitstellung) - yaVDR 0.5 (development) - SKY - HD+ - Atric - X10 FB - Zotac ID41 PLUS - SilverStone LC19B-R - Yamaha RX-V671 - Samsung 8Series 55"

  • Quote


    Ich habe den Entwickler mal angeschrieben. Mal sehen, was kommt.


    Das ging ja einfacher und schneller als ich gedacht habe:


    Asus S1-AT5NM10E, SSD, Mystique SaTiX-S2 Sky USB, Unicable/SCR, Terratec USB IR Receiver, video.00 per NFS auf QNAP 410
    VDR-User seit 2002

  • Ah, fein. Dann kümmer ich mich nochmal und werd da nochmal versuchen was zu machen.


    Grüz!
    Hibbelharry

    - HTPC mit zerbasteltem Yavdr 0.6 , Origen ae X15e, MCE Remote, Asus P5N7A-VM, 1x Digibit R1, Kodi und vdr an Pana 46PZ85E
    - Diverse HTPCs im Umfeld bei Familie und Freundenm die sich vor mir fürchten, mit allen möglichen gruseligen Konfigurationen.
    Auch gern Debian, aber wehe jemand kommt mir mit Suse.

  • Zitat von »mysth«
    Nov 29 14:09:39 vdr2 kernel: [49362.060462] pctv452e: I2C error -121; AA 71 CC 00 01 -> 55 71 CC 00 00.
    Nov 29 14:09:39 vdr2 kernel: [49362.074707] pctv452e: I2C error -121; AA 88 CC 00 01 -> 55 88 CC 00 00.
    Nov 29 14:09:39 vdr2 kernel: [49362.160331] pctv452e: I2C error -121; AA A4 CC 00 01 -> 55 A4 CC 00 00.


    Gibt es hierzu etwas neues?


    Ich habe heute die aktuelle Version (24.12.11, 29.01.12 gibt es nicht für natty :-( ) ausprobiert. Die I2c Fehler sind weniger geworden (nur noch beim Umschalten). Die LED ist immer noch rot (Signal Lock).


    Gruß


    Murry

  • haste mein oneiric paket getestet?

    mfg traxanos
    ____________________
    Ist das neu?, Nein Linux!


    VDR1: Zotac NM10-ITX Wifi - 2GB Ram - S2-6400 HD mit IR - yavdr 0.4 (development) - LianLi PC-Q11


    Tags: VDR-HD - AT5IONT-I - 4GB Ram - 512MB ION - TT 3600 DVB-S2 - TT6400-FF - Sundtek DVB-S2 Sundtek DVB-C - Tevii S480 (dank an L4M für kostenlose Bereitstellung) - yaVDR 0.5 (development) - SKY - HD+ - Atric - X10 FB - Zotac ID41 PLUS - SilverStone LC19B-R - Yamaha RX-V671 - Samsung 8Series 55"

  • haste mein oneiric paket getestet?


    Geht leider nicht:





    Gruß


    Murry

  • Geht leider nicht:

    Code
    1. Consult the make.log in the build directory
    2. /var/lib/dkms/linux-media/0~20120129.git245.289074~oneiric/build/ for more information.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • das war nur eine frage ob du meins verwendet hattest auf einem oneiric system. war nicht eindeutig, da du hier im yavdr thread warst. das mein paket auf natty nicht geht war mir klar :D da wirste noch warten müssten :D

    mfg traxanos
    ____________________
    Ist das neu?, Nein Linux!


    VDR1: Zotac NM10-ITX Wifi - 2GB Ram - S2-6400 HD mit IR - yavdr 0.4 (development) - LianLi PC-Q11


    Tags: VDR-HD - AT5IONT-I - 4GB Ram - 512MB ION - TT 3600 DVB-S2 - TT6400-FF - Sundtek DVB-S2 Sundtek DVB-C - Tevii S480 (dank an L4M für kostenlose Bereitstellung) - yaVDR 0.5 (development) - SKY - HD+ - Atric - X10 FB - Zotac ID41 PLUS - SilverStone LC19B-R - Yamaha RX-V671 - Samsung 8Series 55"

  • Hallo zusammen,


    nachdem ich lange Jahre zwei "Uralt-VDRs" mit TT FF 1.5 bzw. 1.6 betrieben habe bin ich nun auf neue Hardware und yaVDR 0.4 umgestiegen. Zunächst mal mein Dank an die yaVDR-Macher und die übrigen Entwickler rund um den VDR. Gegenüber dem Stand den ich kannte hat sich ja sehr viel getan, auch wenn ich noch nicht überall durchblicke ;-)


    Folgende Pakete wurden daher aus unseren Repos entfernt:

    • linux-tbs-drivers-dkms
    • s2-liplianin-dkms
    • v4l-dvb-dkms


    Folgende Pakete sind neu und ersetzen die oberen:

    • linux-media-dkms (Ersatz für s2-liplianin-dkms und v4l-dvb-dkms)
    • linux-media-tbs-dkms (Ersatz für linux-tbs-drivers-dkms) - bleibt aber weiterhin eine inoffizielle Version, da Close-Source

    Ich habe jetzt ein System mit TT S2-6400. Im Großen und Ganzen läuft das System recht ordentlich, aber an der einen oder anderen Stelle hakt es noch ein wenig. Wenn ich es richtig verfolgt habe sind Treiber und Firmware für die Karte seit der Freigabe der Distribution mehrfach verbessert worden. Gehe ich recht in der Annahme dass es deshalb für mich sinnvoll wäre von s2-liplianin-dkms (hier liegen doch die alten Treiber der S2-6400?) auf linux-media-dkms umzustellen?


    Wie gehe ich vor?


    sudo aptitude update
    sudo aptitude install linux-media-dkms

    ?


    Sonst noch irgend etwas zu beachten? Außer der S2-6400 läuft keinerlei VDR-spezifische Hardware, ich nutze die beiliegende Fernbedienung.


    Sorry für die "dummen" Fragen, aber ich frage lieber bevor ich mir mein laufendes System "zerschieße" ;-)


    Grüße


    Ulrich

  • Hi,


    I am trying installin external FireDTV DVB-C card to my yaVDR. yaVDR is 0.4 almost latest updates.
    First I installed linux-media-dkms package.
    After that VDR is booting up normally and found my two Terratec DVB-C cards.


    Code
    1. [ 16.890011] DVB: registering new adapter (Mantis DVB adapter)
    2. [ 18.345026] DVB: registering adapter 0 frontend 0 (Philips TDA10023 DVB-C)...
    3. [ 18.401334] DVB: registering new adapter (Mantis DVB adapter)
    4. [ 19.322335] DVB: registering adapter 1 frontend 0 (Philips TDA10023 DVB-C)...


    But not FireDTV so i run command sudo modprobe firedtv and got error:

    Code
    1. FATAL: Error inserting firedtv (/lib/modules/2.6.38-13-generic/kernel/drivers/media/dvb/firewire/firedtv.ko): Invalid argument


    and restart vdr.


    And after that if i run dmesg i found these:


    So what i do wrong?


    Edit. Package linux-media-dkms is too much. After I removed that all got working fine.

  • Mal eine Anmerkung zu dem tt-s2-double-fix.
    Der ist schon lange im media tree, wurde aber im stv6110x.c angewandt:
    http://www.mail-archive.com/linux-media@vger.kernel.org/msg18431.html

  • In der Tat - werden wir dann wohl mal entfernen. Funktionieren tun 2 S2 1600 Karten zusammen trotzdem nicht richtig - aber das ist ja nicht relevant da der Patch da eh nix dran ändert

  • Laufen 2 S2-1600 auch mit ungepatchten dvb-Treibern nicht richtig?
    Ich habe deine Nachricht auf der Liste gesehen, ging das irgendwie weiter?
    http://www.spinics.net/lists/linux-media/msg37404.html
    Ich überlege nämlich mir auch zwei oder drei zu besorgen.
    Wie schlimm ist es, bzw. wie oft gibt es Probleme?

  • Nein es ging nicht weiter. Problem ist unsauberes Locking sobald eine der Karte beschäftigt ist. Ich vermute das die Aufnahme/getuned sein der einen Karte das Tunen/AFC der anderen Karte beeinflusst. Bei meheren parallelen Aufnahmen sorgt das dann regelmässig für zerstörte Aufnahmen. IMHO gab es das Problem mit den alten gepatchten Treibern auf der 0.3 nicht. Zumindest wurde mir letzteres noch nicht zugetragen (und ich habe ein paar Installationen mit 2x S2 1600)


    Fehlerbild sind Klötzchen im Bild als würde versucht Müll zu dekodieren (bei mir sobald eine Karte in Benutzung ist) Mehrfaches hin und herschalten, und man kann normal schauen.


    Interessant wäre jetzt den von dir verlinkten Patch rückwärts anzuwenden und unseren Patch drin zu lassen. Kann ich aber grad nicht liefern da mein VDR wegen Hardwareproblemen "in der Werkstatt" ist. Ausserdem habe ich grade auf eine L4m 5.4er umgerüstet, die sich gestern sehr problemlos angefühlt hat (wo er noch ging)


    Da mir jeglicher Ansatz zur Verfolgung gefehlt hat ist dein Link ein interessanter Ansatz.

  • Kannst du heraus bekommen, mit welchem Treiberstand es noch ging, und ab wann es nicht mehr geht?
    Dann könnte man vermutlich leicht heraus finden, woran es liegt. Die Änderungen in den betroffenen Modulen sind ziemlich überschaubar.

  • Quote

    Kann ich aber grad nicht liefern da mein VDR wegen Hardwareproblemen "in der Werkstatt" ist. Ausserdem habe ich grade auf eine L4m 5.4er umgerüstet


    Ausserdem ist mein Zeitrahmen grade stark eingeschränkt. Hätten wir die Diskussion früher geführt ...


    Das heisst das wird einige Tage(wochen?) dauern bis ich da was liefern kann. Auch der Beweis das es keine Probleme mit einem früheren Stand gibt müsste noch erbracht werden. Bisher ist es nur eine Vermutung.


    Wie du siehst nicht trivial für mich. Ich würde die 2 Karten aber verborgen (Shipping ginge auf mich) wenn sich da jemand drüm kümmern möchte. Interesse ?

  • Danke für das Angebot. Ich habe aber nicht soviel Kompetenz, dass ich der Richtige für dein Angebot wäre.
    Ich hätte zwar die Zeit, systematisch verschiedene Treiber Versionen zu testen, und zu gucken ob Unterschiede sich auf das Problem auswirken. Aber wenn ich damit nichts finden würde, wüsste ich auch nicht weiter.
    Ich denke, ich werde mir selbst eine zweite kaufen, und es damit ausprobieren.
    Falls du jemand kennst, der gerade günstig eine (oder zwei) verkaufen möchte ...