bitte um Hilfe bei udev rules

  • Hallo,
    Bei mir kommt eine Fehlermeldung, mit "Keine Berechtigung" auf das dvb Device und der Start des vdr bricht ab:


    Code
    1. 5 vdr vdr: [810]
    2. Nov 22 11:54:05 vdr kernel: [ 6.362051] stv6110x_attach: Attaching STV6110x
    3. Nov 22 11:54:05 vdr kernel: [ 6.395755] DVB: registering adapter 1 frontend 0 (STV090x Multistandard)...
    4. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'A - ATSC'
    5. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'C - DVB-C'
    6. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'S - DVB-S'
    7. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'T - DVB-T'
    8. Nov 22 11:54:05 vdr vdr: [810] ERROR: /dev/dvb/adapter0/frontend0: Keine Berechtigung
    9. Nov 22 11:54:05 vdr vdr: [810] no DVB device found
    10. Nov 22 11:54:05


    und etwas weiter unten kommt dann noch:




    wie im Forum vorgeschlagen, habe ich user vdr in Gruppe video rein genommen, usermod -aG video vdr

    Code
    1. root@vdr:/var/log# id vdr
    2. uid=666(vdr) gid=666(vdr) Gruppen=666(vdr),24(cdrom),44(video),46(plugdev)


    Auch die Rechte direkt am Device habe ich versucht anzupassen, die sind aber nicht sehr lange haltbar ... bringt also nix.
    Starte ich vdr per

    Code
    1. sudo service vdr start


    läuft er problemlos durch.


    Wie setzte ich die Rechte per udev Regel, so dass vdr problemlos dran darf?


    Die Module sind folgende:



    so am Rande: da ich ausschließlich per Satellit Programme empfange, macht es da Sinn,

    Code
    1. ov 22 11:54:05 vdr kernel: [ 6.395755] DVB: registering adapter 1 frontend 0 (STV090x Multistandard)...
    2. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'A - ATSC'
    3. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'C - DVB-C'
    4. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'T - DVB-T'


    Das auszuschalten?


    gerd

  • Moin!


    Eventuell hilft das (ist aber nur einfach aus dem Kopf hingeschrieben):

    Code
    1. ACTION=="add", SUBSYSTEM=="dvb", ENV{DVB_DEVICE_TYPE}!="", MODE="666"


    so am Rande: da ich ausschließlich per Satellit Programme empfange, macht es da Sinn,

    Code
    1. Nov 22 11:54:05 vdr kernel: [ 6.395755] DVB: registering adapter 1 frontend 0 (STV090x Multistandard)...
    2. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'A - ATSC'
    3. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'C - DVB-C'
    4. Nov 22 11:54:05 vdr vdr: [810] registered source parameters for 'T - DVB-T'


    Das auszuschalten?


    Nein, das kann man nicht ausschalten. Das sind die Parameter, die der vdr bereit ist zu empfangen. Er wird aber nur das nutzen, was er über die channels.conf bekommt.
    Wenn du z.B. noch pvrinput dazu lädst, würde noch ein Eintrag für "V - analog video" kommen.


    Lars.

  • Hi mini73,


    vielen Dank für den Tipp,
    ich habe folgende Regel neu erstellt:

    Code
    1. oot@vdr:/etc/udev/rules.d# cat 62-dvb.rules
    2. ACTION=="add", SUBSYSTEM=="dvb", ENV{DVB_DEVICE_TYPE}!="", GROUP="vdr", MODE="666"
    3. root@vdr:/etc/udev/rules.d#


    Den Namen der Datei (ist wohl egal) und die Zuordnung der Gruppe "video" oder eben gleich auf "vdr" habe ich von hier
    Ja, und damit scheint es auf den ersten Blick zu funktionieren, nach 'nem reboot ist jetzt alles guut ;-)



    Vielen Dank


    gerd

    yaVDR 0.4 virtualisiert unter Proxmox mit TT S-2 6400

    The post was edited 2 times, last by Gerd Peter: EDIT: Die Gruppenrechte von "video" auf "vdr" geändert => macht viel mehr Sinn! ().