yaVDR 0.4 - XBMC stürzt beim Abspielen von HD-Videos ab

  • Hallo,


    seit ein paar Tagen läuft bei mir im Wohnzimmer erfolgreich yaVDR 0.4 (das offizielle Release, keine beta o.ä.). Alles funktioniert soweit perfekt, nur eines läuft regelmäßig schief:


    Wenn ich XBMC aufrufe und ein Video abspielen will (Videos / Dateien / auf Video zugreifen (ist auf lokaler Platte) und mit OK abspielen), stürzt er regelmäßig ab. Mal hängt er komplett mit einem schwarzen Bildschirm, mal beendet XBMC und er ist wieder auf dem VDR-Frontend.


    Das XBMC Crashlog sagt mir:

    Code
    1. 07:30:39 T:140730365609952 ERROR: GLX: Same window as before, refreshing context
    2. 07:30:39 T:140730365609952 ERROR: VDPAU Device Preempted - attempting recovery
    3. 07:30:39 T:140730365609952 ERROR: (VDPAU) Error: The display was pre-empted, or a fatal error occurred.(2) at VDPAU.cpp:1384
    4. 07:30:40 T:140729657435904 NOTICE: Attempting recovery
    5. 07:30:40 T:140729657435904 NOTICE: (VDPAU) FiniVDPAUOutput
    6. 07:30:41 T:140729657435904 NOTICE: vdp_device = 0x00000001 vdp_st = 0x00000000


    (direkter Vergleich geglücktes Abspielen mit Crash, ab hier lief es schief)
    Dabei stürzt er mit Vorliebe immer beim Erststart ab, also wenn ich den VDR komplett starte (Poweron) und dann in XBMC hineingehe und ein Video starten will. Nachdem er einmal abgestürzt ist, läuft er zuverlässig.


    Hat jemand eine Idee, woran das liegen kann?


    Über Tipps bin ich dankbar!

    yaVDR 0.5a@AT3ION-T Deluxe, twinDVB-C, ATRIC+Harmony200
    *****************************************************
    Netzspeicher: Synology DS716+ II mit 8GB RAM sowie 9TB Plattenplatz


    (in Rente: Siemens M740AV, Debian Dockstar, Pogoplug)

  • Das ist ein Fehler in XBMC. So wie ich es verstehe tritt das nicht bei jedem auf. Ich habe das Problem exakt genauso - andere im Team haben dies noch nie gesehen.


    Die Lösung/workaround für den Moment ist das Abschalten des Umschaltens der Refreshrate in XBMC. Danach sollte es keine Probleme mehr machen

  • Also, bei mir hab ich die Refresh-Rate geändert und das Problem ist weg :-)


    genauer gesagt: System/Einstellungen/Video/Wiedergabe: Bildwiederholfrequenz anpassen ausschalten.

    yaVDR 0.5a@AT3ION-T Deluxe, twinDVB-C, ATRIC+Harmony200
    *****************************************************
    Netzspeicher: Synology DS716+ II mit 8GB RAM sowie 9TB Plattenplatz


    (in Rente: Siemens M740AV, Debian Dockstar, Pogoplug)

  • entsteht dadurch kein Ruckeln bei 24 und 60 fps Material?
    Ein besserer Workaround ist die Modelines in die conf einzutragen, dann klappts auch mit der dynamischen Anpassung der Bildwiederholungsfrequenz.

    oldVDR: 1.7.14-2yavdr1 | SkyStar HD2 | AMD XP 1700+ @1100Mhz & 1,1V | Geforce 4MX onboard NVIDIA CS Treiber (jemand Interesse an diesem stromsparenden SD VDR?)
    newVDR: yavdr 0.5a | TBS 6981 | Intel E5300 underclocked | Zotac 9300 | TBS RC + Harmoy 895 | Pearl LCD | 37W bei HD


    Panasonic TX-P50S20E & Onkyo NR-509 & Jamo S606 HCS 3