[gelöst][0.4] DFAtmo Plugin

  • Hallo Leute,


    hab heute mal die 0.4 auf mein Rechner installiert. Läuft soweit ganz gut. Nun sollen die Extras laufen...


    Durchflieger hat für mein geliebtes Atmolight ein neues Plugin erstellt das das bisherige libxine-atmo-plugin ablöst.
    https://github.com/durchflieger/DFAtmo#readme


    Das DFAtmo soll außerdem dann mit XBMC zusammenarbeiten.
    Leider hat es das Plugin nicht mehr in die 0.4 geschafft, daher hab ich versucht es vom GIT zu installieren.


    Nach kompilieren und installieren mit

    Zitat

    make dfatmo


    Code
    1. root@yavdr:/usr/local/src/atmo/DFAtmo# make dfatmo
    2. /bin/sh: pkg-config: Kommando nicht gefunden.
    3. /bin/sh: pkg-config: Kommando nicht gefunden.
    4. cc -I/usr/include/python2.7 -I/usr/include/python2.7 -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -O3 -pipe -Wall -fPIC -g -DOUTPUT_DRIVER_PATH='"/usr/local/lib/dfatmo/drivers"' -c -o atmodriver.o atmodriver.c
    5. cc -I/usr/include/python2.7 -I/usr/include/python2.7 -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -O3 -pipe -Wall -fPIC -g -shared -fvisibility=hidden -lpthread -ldl -lutil -lm -lpython2.7 -lm -ldl -o atmodriver.so atmodriver.o
    6. cc -O3 -pipe -Wall -fPIC -g -c -o dfatmo-file.o fileoutputdriver.c
    7. cc -O3 -pipe -Wall -fPIC -g -shared -fvisibility=hidden -o dfatmo-file.so dfatmo-file.o
    8. cc -O3 -pipe -Wall -fPIC -g -c -o dfatmo-serial.o serialoutputdriver.c
    9. cc -O3 -pipe -Wall -fPIC -g -shared -fvisibility=hidden -o dfatmo-serial.so dfatmo-serial.o
    10. root@yavdr:/usr/local/src/atmo/DFAtmo#

    und

    Zitat

    make dfatmoinstall


    Code
    1. root@yavdr:/usr/local/src/atmo/DFAtmo# make dfatmoinstall
    2. /bin/sh: pkg-config: Kommando nicht gefunden.
    3. /bin/sh: pkg-config: Kommando nicht gefunden.
    4. install -m 0755 -d /usr/local/lib/dfatmo
    5. install -m 0644 -t /usr/local/lib/dfatmo atmodriver.so
    6. install -m 0755 -d /usr/local/lib/dfatmo/drivers
    7. install -m 0644 -t /usr/local/lib/dfatmo/drivers dfatmo-file.so dfatmo-serial.so
    8. install -m 0644 -t /usr/local/include dfatmo.h
    9. root@yavdr:/usr/local/src/atmo/DFAtmo#

    und den Eintragungen in der vdr-frontend.conf kriege ich aber absolut kein Leuchten zustande.


    custom template:


    Code
    1. ## Adding Xine ATMO-Post Plugin
    2. XINEOPTS="$XINEOPTS --post=dfatmo:driver=serial,driver_param=/dev/ttyUSB0,top=1,bottom=1,left=1,right=1,brightness=150,enabled=1,filter_delay=2000 "


    Ich kann nichtmals sehen ob im postprocessing das plugin gestartet wird.


    Was kann ich tun um zu prüfen ob das plugin gestartet wird. Xine im debug höher setzen?


    Gruß,
    Jarv

    Client1 YaVDR0.5 Zotac ITX-F ATOM330 ION, 2*1GB DDR2, 8GB Boot SSD, MS-Tech MC1200, Alphacool 240x128, Quattro Atmolight


    Server1 YaVDR0.5 Athlon LE1600, DigitalDevices Cine S2,8GB Boot SSD, 1TB WD GreenCaviar


    Experimental: Banana Pi Client Sunxi-vdpau, Raspberry Client rpihddevice

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Jarvelin ()

  • Ich denk grad selber nochmal drüber nach...


    Das make dfatmoinstall legt die Dateien "/usr/local/lib"


    Ist das für den VDR so richtig? Hab ein wenig gestöbert, und andere xine post plugins liegen scheinbar woanders.


    "/usr/lib/xine/plugins/2.0/post/xineplug_post_tvtime.so" z.B.



    Wo muss also das plugin liegen?


    Mit xine-Parameter: --verbose= ? müsste ich ja mehr debugausgaben erhalten. Auf welches level soll ich das debug anheben? (Wenn ich wieder zu Hause bin)

    Client1 YaVDR0.5 Zotac ITX-F ATOM330 ION, 2*1GB DDR2, 8GB Boot SSD, MS-Tech MC1200, Alphacool 240x128, Quattro Atmolight


    Server1 YaVDR0.5 Athlon LE1600, DigitalDevices Cine S2,8GB Boot SSD, 1TB WD GreenCaviar


    Experimental: Banana Pi Client Sunxi-vdpau, Raspberry Client rpihddevice

  • Nabend Leute,


    nach ein wenig stöbern in den makefile ind mir 2 Sachen aufgefallen:
    1) mir fehlte wohl das libxine-dev Paket
    2) gibt es noch deutlich mehr Ziele für make außer dfatmo. (z.B. xineplugin)


    However: Ein beherztes

    Code
    1. make all
    2. cp xineplug_post_dfatmo.so /usr/lib/xine/2.0/post/


    Und läuft!


    Jetzt bin ich mal gespannt wie das unter XBMC geht.


    Gruß,
    Jarv

    Client1 YaVDR0.5 Zotac ITX-F ATOM330 ION, 2*1GB DDR2, 8GB Boot SSD, MS-Tech MC1200, Alphacool 240x128, Quattro Atmolight


    Server1 YaVDR0.5 Athlon LE1600, DigitalDevices Cine S2,8GB Boot SSD, 1TB WD GreenCaviar


    Experimental: Banana Pi Client Sunxi-vdpau, Raspberry Client rpihddevice

  • Viel eleganter wäre es gewesen das ganze folgendermaßen im Projektverzeichnis zu übersetzen (siehe auch README):


    dpkg-buildpackage -b -D -tc -sd -us -uc


    Das generiert dir installierbare debian packages und sagt dir auch welche Packete für den build process
    noch installiert werden müssen.



    Gruss
    durchflieger

    Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
    Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
    Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV

  • Hallo durchflieger,


    ich hab das mit den Paketen mal ausprobiert.
    Und du hast recht ;D


    Wahrscheinlich hab ich nicht gut genug gelesen. Prinzipiell hätte die Install Anweisung schlicht heißen können:


    1) dpkg-buildpackage -b -D -tc -sd -us -uc
    2) dpkg -i dfatmo_0.1-0_amd64.deb
    3) dpkg -i libxine-dfatmo-plugin_0.1-0_amd64.deb


    Einzige schwierigkeit wäre dann noch das Template für yaVDR zu erstellen.


    Unter XBMC einfach das Zip installieren und die Einstellungen im Menü vornehmen. Läuft!


    Damit bist Du eindeutig Entwickler des Monats für mich! (Bis heute war ich es selber, aber private Projekte toppen definitiv geschäftliche :D )


    Anyway, hast darüber nachgedacht mal ein VDR Paket zu erstellen? So das die Einstellungen genauso komfortabel wie unter XBMC vorgenommen werden können und auch das Template unter yavdr überflüssig wird?
    Das wäre echt :tup !



    Danke-sai!
    Lange Tage, angenehme Nächte!


    Jarv

    Client1 YaVDR0.5 Zotac ITX-F ATOM330 ION, 2*1GB DDR2, 8GB Boot SSD, MS-Tech MC1200, Alphacool 240x128, Quattro Atmolight


    Server1 YaVDR0.5 Athlon LE1600, DigitalDevices Cine S2,8GB Boot SSD, 1TB WD GreenCaviar


    Experimental: Banana Pi Client Sunxi-vdpau, Raspberry Client rpihddevice

  • Anyway, hast darüber nachgedacht mal ein VDR Paket zu erstellen? So das die Einstellungen genauso komfortabel wie unter XBMC vorgenommen werden können und auch das Template unter yavdr überflüssig wird?
    Das wäre echt :tup !

    Nachgedacht schon - aber bisher keine Zeit gefunden.
    Wobei das dann wohl kein vdr plugin werden wird sondern eher ein externes GUI Setupprogramm das dann einige nette Funktionen von dem Setupprogramm für den DF10CH Controller übernehmen wird.


    Gruss
    durchflieger

    Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
    Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
    Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV

  • Hey ihr 2,
    ich bin relativ laienhaft was linux und yavdr angeht. Ich habe aber ein karatelight (die 8 Kanal Variante des atmolight) und möchte das gerne in yavdr und xbmc nutzen.
    Könnt ihr mich unterstützen was ich alles installieren muss ?


    Damit wäre ich wieder einen großen schritt weiter bei meinem vdr testrechner :)


    vielen Danke und Grüße
    eXpression.

    MB: Asrock H77 Pro4-M ||CPU: Celeron G540 || GPU: Zotac GT520 Synergy || Tuner: DuoFlex S2, Octupus CI PCie Treiber: || HDD: Crucial M4 128GB || PSU: picoPSX 160XT, Leicke 12V-10A-120Watt 5,5x2,5mm || Case: MS-Tech LC-01Remote: Logitech Harmony 900 + IR Blaster ||extensions: 8 Kanal Karatelight

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Dr. n00b ()

  • Hi ich kleiner Linux Laie stecke gerade hier fest.


    Und zwar habe ich unter der Verzeichnis:


    /usr/local/src/dfatmo


    -> make dfatmo ausgeführt mit folgendem Resultat: Irgendwas geht :P :respekt
    -> und danach einen make install


    yacdr@yaVDR:/usr/local/src/dfatmo$ sudo make dfatmo
    cc -I/usr/include/libusb-1.0 -O3 -pipe -Wall -fPIC -g -c -o dfatmo-df10ch.o df10choutputdriver.c
    cc -I/usr/include/libusb-1.0 -O3 -pipe -Wall -fPIC -g -shared -fvisibility=hidden -lusb-1.0 -lm -o dfatmo-df10ch.so dfatmo-df10ch.o


    yavdr@yaVDR:/usr/local/src/dfatmo$ sudo make install
    install -m 0755 -d /usr/local/lib/dfatmo
    install -m 0644 -t /usr/local/lib/dfatmo atmodriver.so
    install -m 0755 -d /usr/local/lib/dfatmo/drivers
    install -m 0644 -t /usr/local/lib/dfatmo/drivers dfatmo-file.so dfatmo-serial.so dfatmo-df10ch.so
    install -m 0644 -t /usr/local/include dfatmo.h
    cc -O3 -pipe -Wall -fPIC -g -DOUTPUT_DRIVER_PATH='"/usr/local/lib/dfatmo/drivers"' -c -o xineplug_post_dfatmo.o xineplug_post_dfatmo.c
    cc -O3 -pipe -Wall -fPIC -g -shared -fvisibility=hidden -lxine -lm -ldl -o xineplug_post_dfatmo.so xineplug_post_dfatmo.o
    install -m 0644 -t /usr/lib/xine/plugins/2.0/post xineplug_post_dfatmo.so
    install -m 0755 -d /home/seven/.xbmc/addons/script.dfatmo
    install -m 0644 -t /home/seven/.xbmc/addons/script.dfatmo addon.xml dfatmo.py icon.png
    install -m 0644 HISTORY /home/seven/.xbmc/addons/script.dfatmo/changelog.txt
    install -m 0644 COPYING /home/seven/.xbmc/addons/script.dfatmo/LICENSE.txt
    install -m 0755 -d /home/seven/.xbmc/addons/script.dfatmo/resources
    install -m 0644 -t /home/seven/.xbmc/addons/script.dfatmo/resources settings.xml
    install -m 0755 -d /home/seven/.xbmc/addons/script.dfatmo/resources/lib/drivers
    install -m 0644 -t /home/seven/.xbmc/addons/script.dfatmo/resources/lib/drivers mydriver.py
    yavdr@yaVDR:/usr/local/src/dfatmo$



    Was muss ich denn als nächstes machen ? :applaus

    MB: Asrock H77 Pro4-M ||CPU: Celeron G540 || GPU: Zotac GT520 Synergy || Tuner: DuoFlex S2, Octupus CI PCie Treiber: || HDD: Crucial M4 128GB || PSU: picoPSX 160XT, Leicke 12V-10A-120Watt 5,5x2,5mm || Case: MS-Tech LC-01Remote: Logitech Harmony 900 + IR Blaster ||extensions: 8 Kanal Karatelight

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Dr. n00b ()

  • Das war ja auch nicht böse gemeint ich dachte nur die Antwort wäre dort besser Aufgehoben. Sorry :welle

    MB: Asrock H77 Pro4-M ||CPU: Celeron G540 || GPU: Zotac GT520 Synergy || Tuner: DuoFlex S2, Octupus CI PCie Treiber: || HDD: Crucial M4 128GB || PSU: picoPSX 160XT, Leicke 12V-10A-120Watt 5,5x2,5mm || Case: MS-Tech LC-01Remote: Logitech Harmony 900 + IR Blaster ||extensions: 8 Kanal Karatelight

  • Morgen,
    ich bin der Meinung , dass ich dfatmo wie in der Anleitung installiert habe.


    1) dpkg-buildpackage -b -D -tc -sd -us -uc
    2) dpkg -i dfatmo_0.1-0_amd64.deb
    3) dpkg -i libxine-dfatmo-plugin_0.1-0_amd64.deb


    Wie bekomme ich denn aber heraus ob mein atmocontroller/karatelight überhaupt am USB Port erkannt wurde.
    Denn ttyUSBx findet er nix.
    Muss ich irgendwie noch eine Treiber installieren?


    Danke und Grüße

    MB: Asrock H77 Pro4-M ||CPU: Celeron G540 || GPU: Zotac GT520 Synergy || Tuner: DuoFlex S2, Octupus CI PCie Treiber: || HDD: Crucial M4 128GB || PSU: picoPSX 160XT, Leicke 12V-10A-120Watt 5,5x2,5mm || Case: MS-Tech LC-01Remote: Logitech Harmony 900 + IR Blaster ||extensions: 8 Kanal Karatelight

  • Wie bekomme ich denn aber heraus ob mein atmocontroller/karatelight überhaupt am USB Port erkannt wurde.
    Denn ttyUSBx findet er nix.
    Muss ich irgendwie noch eine Treiber installieren?

    Normalerweise sollte das direkt alles klappen.
    Ein KarateLight erscheint als /dev/ttyACMx


    Falls keine devices erstellt werden mal mittels 'dmesg' nachschauen was der kernel nach dem einstecken des Geräts so meldet.