yavdr 0.4 auf altem 32bit Notebook

  • Hallo,
    gibt es eine Möglichkeit, den neuen yavdr 0.4 auf einem 32bit Notebook (Pentium M) zu installieren? In den PPAs sind ja alle yavdr-Pakete für i386 vorhanden - nur wie beginnt man die Installation ohne yavdr-32bit-Iso??
    Kann ich ein normales Ubuntu installieren und dann die yavdr-Pakete aus den PPA "nach-schieben"? Wird bei Installation des Pakets "yavdr-essential" wirklich alles benötigte installiert?


    Gruss,
    ChrisF

  • chrisF


    Naja, die 0.3 läge ja auch noch zum Download bereit ...


    Regards
    fnu

    HowTo: APT pinning

  • Stimmt, die 0.3 gibts auch noch, aber das war ja nicht die Frage.


    Würde mich persönlich auch interessieren, da in meinem VDR auch ein Pentium-M steckt.
    Natty in 32bit installieren und was muss dann alles noch aus den PPA nachinstalliert werden?


    Gruß
    Klaus

    MSI Speedster-FA4; Pentium-M 1,6GHz; 1GB DDR2; Samsung (HA250JC) 250GB; TechnoTrend TT-budget S2-3200; ZOTAC GT220 Synergy Edition 512MB
    yavdr 0.3; CoolerMaster CM 260 + IMON; 128x64 GLCD;

  • Hi,


    Sorry, my German is really basic, so I'll write in English...


    I would also like to know what is the best way to install yaVDR 0.4 to a 32-bit system.


    0.3 is not an option, as it has a nasty libX11 bug that freezes the xineliboutput and I'm building this system to a non-technical user.


    I have a mini-ITX board with CULV Celeron and a discrete Geforce GT 220.


    I hope someone would be kind enough to to help us 32-bit users... Thanks, und Vielen Dank! :-)

  • I would also like to know what is the best way to install yaVDR 0.4 to a 32-bit system.


    There is no way to do that.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • 0.3 is not an option, as it has a nasty libX11 bug that freezes the xineliboutput and I'm building this system to a non-technical user.


    Even with the latest updates we pushed to the repositories a couple of days ago?


    Regards
    fnu

    HowTo: APT pinning


  • Even with the latest updates we pushed to the repositories a couple of days ago?

    I didn't realize the 0.3 was still maintained, since I upgraded my own system to 0.4 a few weeks ago.


    This freezing bug was discussed in a Finnish VDR forum last April. Someone explained there that a bug in libX11 is the reason for these freezes and the bug is fixed in version 1.4.3. These threads were referenced on that post:


    http://cgit.freedesktop.org/xo…5fc17b2520f84316a11e8906f
    http://lists.freedesktop.org/a…cb/2011-March/006802.html


    Which yaVDR repository is the one that has the libX11 and what's the latest version there?


  • There is no way to do that.


    It's a shame. How would I install a system very similar to yaVDR 0.4 then?


    I would be happy if the box starts VDR automatically and works like a set-top-box, just like the yaVDR does. The Slide-In-Launcher menu
    would be nice to have, so I could launch Firefox or VLC.


    I mean, if I start with minimal ubuntu natty (i386) install, then add yavdr repositories and start installing the packages from there...


    Do I need other yaVDR repositories than these?
    - main
    - nvidia-legacy
    - stable-vdr
    - stable-yavdr


    Which packages do I need then?


    Openbox, lirc, yavdr-base, yavdr-essential, vdr, vdr-plugin-xx,...


    If there's a will, there's a way... ;-)

  • It's a shame. How would I install a system very similar to yaVDR 0.4 then?


    The shame are more words like yours, because the yaVDR team has made the decision to go this way. The advantages of 64-bit in yaVDRs main environment, HD@VDPAU, do overwhelm the few users operating ancient hardware, which is not able to run in 64-bit mode.


    Our packages are available in 32-bit & 64-bit flavour, like it is common in the Ubuntu universum, only the installation ISO is just available in x86_64.


    Since we know there still are users out there being immune to feedback, or do not need the newest of the newest, we did maintain the yaVDR 0.3 repositories heavily the last weeks, we number it yaVDR 0.3.1. Most plugins do have the same version compared to 0.4, but we have frozen VDR version to 1.7.20 from our 0.3 testing repositories. Right now, you can take advantage due installing from 0.3.0a ISO installation image and do an dist-upgrade from there, but an installation ISO yaVDR 0.3.1 might be possible.


    Regards
    fnu

    HowTo: APT pinning

    The post was edited 3 times, last by fnu ().

  • So geht's:


    1. Auf einem 64-Bit-System die Paketliste direkt nach der Installation laden.


    Code
    1. $ dpkg --get-selections > installed-software



    Ich hab meine mal angehängt.


    2. Wie oben erwähnt die Alternate-CD von Natty herunterladen (http://releases.ubuntu.com/nat…-11.04-alternate-i386.iso) und eine Minimal (F4 -> "Befehlszeilen-Installation" oder so ähnlich) durchführen.


    3. "/etc/apt/sources.list.d/yavdr.list" anlegen:


    Code
    1. deb http://ppa.launchpad.net/yavdr/main/ubuntu natty main
    2. deb http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu natty main
    3. deb http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu natty main
    4. deb http://ppa.launchpad.net/yavdr/stable-yavdr/ubuntu natty main
    5. deb-src http://ppa.launchpad.net/yavdr/main/ubuntu natty main
    6. deb-src http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu natty main
    7. deb-src http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu natty main
    8. deb-src http://ppa.launchpad.net/yavdr/stable-yavdr/ubuntu natty main


    4. Den GPG-Key des Repositories laden:


    Code
    1. $ sudo apt-key adv –keyserver keyserver.ubuntu.com –recv-keys 272A2CE18103B360


    5. Das System auf den neusten Stand bringen und die Paketliste von 64-Bit-System laden:


    Code
    1. $ sudo apt-get update
    2. $ sudo apt-get dist-upgrade
    3. $ sudo apt-get install dselect
    4. $ sudo dpkg – -set-selections < installed-software
    5. $ sudo dselect install


    6. In Schritt 5 geht die Konfiguration der Pakete tntnet, yavdr-essential und yavdr-webfrontend schief. Entfernen und neu installieren reicht jedoch:


    Code
    1. $ sudo apt-get install tntnet
    2. $ sudo apt-get install yavdr-essential yavdr-webfrontend
    3. $ sudo cp /etc/tntnet/tntnet.properties.dontremove /etc/tntnet/tntnet.properties


    7. yaVDR noch etwas konfiguration durchführen lassen:


    Code
    1. $ sudo yavdr-post-install


    Nach diesen Schritten (und dem löschen der nvidia-libs) hatte ich ein funktionierendes yaVDR-System. Nur die Paketliste im Webfrontend ist aus irgendeinem Grund leer.

  • Hallo Cybso,
    danke für die Anleitung, konnte ich bei mir umsetzen. Allerdings bekomme ich keinerlei Bild vom VDR. Weder ein "NO SIGNAL" noch ein Menü werden angezeigt. Alle nötigen Prozesse laufen scheinbar, die Seitenleiste, um Browser oder Terminal zu öffnen, erscheint auch, wenn ich mit der Maus an den linken Rand fahre. Auch der VLC läuft und holt IPTV. Ich habe beide Frontend "xine" und "vdr-sxfe" probiert.
    Irgenwelche Ideen, wie ich zum Bild komme?


    Gruss,
    ChrisF


    PS: ich habe es im VirtualBox versucht.

  • PS: ich habe es im VirtualBox versucht.


    Da klappt es mit den aktuellen Paketen der 0.4 nicht.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Da klappt es mit den aktuellen Paketen der 0.4 nicht.

    Bist Du dir da sicher? Wenn ich ein 64bit System im VirtualBox 4.1.6 vom yavdr-0.4.0.iso komplett installiere, bekomme ich das Menü angezeigt! Liegt das jetzt an den 64bit Paketen, oder müßte es mit 32bit doch irgendwie gehen?
    Gruss,


    Chris

  • Hast du das Bild noch, wenn du ein

    Code
    1. sudo apt-get update && sudo apt-get dist-upgrade


    gefahren hast?
    Bei der Installation der 32-Bit Pakete kommen gleich die aktuellsten Pakterversionen mit, mit denen es nicht mehr klappt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo Cybso,


    danke für die Anleitung, konnte ich bei mir umsetzen. Allerdings bekomme ich keinerlei Bild vom VDR. Weder ein "NO SIGNAL" noch ein Menü werden angezeigt. Alle nötigen Prozesse laufen scheinbar, die Seitenleiste, um Browser oder Terminal zu öffnen, erscheint auch, wenn ich mit der Maus an den linken Rand fahre. Auch der VLC läuft und holt IPTV. Ich habe beide Frontend "xine" und "vdr-sxfe" probiert.


    Irgenwelche Ideen, wie ich zum Bild komme?




    Sorry, keine Ahnung. Was steht denn nach dem Start in der /var/log/Xorg.1.log drin? Wenn die GUI selbst läuft muss das wohl gehen, dann sind die VDR-Meldungen im Syslog (/var/log/syslog) der nächste Kandidat.





    Ich hab bei mir inzwischen vollständig auf ein XBMC-Frontend umgestellt, und da der Server auf nem andere Rechner läuft (und ich für TV-Out wegen der KMS-Umstellung entweder nen alten 2.6.32er-Kernel oder nen topaktuellen 3.1er-Kernel brauche) läuft da nun ein selbst eingerichtetes Gentoo drauf. Aber wie gesagt, es lief ;-)

  • This method worked perfectly to get yavdr 0.4 running on my old pentium M based ATX mobo. I simply had to ditch my 64bit setup due to all the "irq: nobody cared" problems with random dropouts and disappearance with my nova-t 500 pci dvb-t cards on my Asus m35m1 pro board, which uses the ASM1083 PCIe-PCI bridge. This bridge is according to numerous postings on the LKML faulty with regard to PCI spec compliance, and causes problems with IRQ deassertions.


    I'm sad that yavdr chose to not do an official 32bit release as it appears that most 64bit processors these days are paired with motherboards that doesn't have native PCI support, but rather rely on PCIe-PCI bridges, like the ASM1083. Apparently all Asus motherboards uses this bridge, and thus all are unsuitable for use with any PCI DVB cards.

  • I'm sad that yavdr chose to not do an official 32bit release as it appears that most 64bit processors these days are paired with motherboards that doesn't have native PCI support, but rather rely on PCIe-PCI bridges, like the ASM1083. Apparently all Asus motherboards uses this bridge, and thus all are unsuitable for use with any PCI DVB cards.


    Well, this is just not true. There're a lot of users out there, running yaVDR64 with PCI DVB cards on Asus Mainboards. This is a unique problem with you're darn old mainboard and DVB card and far away from being a global issue.


    64-bit is the future and did solve a lot of performance issues especially w/ VDPAU. For those die-hards out there using ancient hardware which doesn't meet modern requirements, we do maintain a 32-bit ISO, yaVDR 0.3.1. You get the same VDR functionality and if you use "testing-vdr" you can get VDR in version 1.7.22.


    And bottomline, you got a 32-bit installation, just no ISO ...


    Regards
    fnu

    HowTo: APT pinning


  • Well, this is just not true. There're a lot of users out there, running yaVDR64 with PCI DVB cards on Asus Mainboards. This is a unique problem with you're darn old mainboard and DVB card and far away from being a global issue.


    Full ACK, this is complete nonsense, I can't believe that ASUS motherboards are the most sold motherboards. I use 3 PCI DVB-C cards with an AsRock motherboard (AsRock is an ASUS brand) in my VDR and I am using yaVDR 64 of course.
    It is not the fault of yaVDR that ASUS ist selling faulty products.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

    The post was edited 1 time, last by gda ().

  • The motherboard that is causing me problems is the Asus M35M1-M Pro (AMD Fusion processor), which is not an old motherboard by any stretch. When I reverted to my 32bit setup, I reverted to using my old AOpen i915Ga-HFS ATX motherboard.


    I'm not blaming yavdr for the problems caused by the ASM1083 PCIe-PCI bridge.