[gelöst] autostart plugin - vdr in startet in endlosschleife

  • Hallo,


    ich verwende yaVDR 0.4 stable. Ist eine frische Installation und nach dem aktivieren des autostart Plugin über das Web Frontend startet vdr in Endlosschleife


    Hier der syslog auszug:



    Und das wiederholt sich dann etliche Male bis ich das autostart plugin wieder deaktiviere!


    /var/lib/vdr/plugins/autostart/autostart.conf


    /var/log/vdr/stdoutxxxx

    Code
    1. INFO: validating live server ip '0.0.0.0'
    2. terminate called after throwing an instance of 'cDeviceKitException'


    Hat jemand eine Idee was hier falsch ist. Wenn mehr Informationen benötigt werden, einfach Bescheid sagen.


    Danke schonaml,


    Kokel

    The post was edited 1 time, last by kokel ().

  • Hi,


    entschuldigung wenn ich mal doof frage - wozu ist das autustart-plugin?
    Was wird damit automatisch gestartet?
    Ich konnte das Plugin weder bei e-tobi noch im Wiki finden oder ich habe Tomaten auf den Augen :-))


    Gruß


    badekap

    System 1) EPIA-ME6000 / 1GB-RAM / 2GB DOM / 1x FF Ver 1.3 / Debian Squeeze + e-Tobi Repo
    System 2) Intel Atom D525 / 2GB-RAM / 8GB SSD / 1x FF Hauppauge Ver 2.1 / Debian Squeeze + e-Tobi Repo
    System 3) Server Athlon 4000+ / 4GB-RAM / 2x SkyStar 2 /
    Debian Squeeze + e-Tobi Repo

  • Code
    1. Nov 2 18:41:58 jukelvdr vdr: Enumerate dev /org/freedesktop/UDisks/devices/sr0
    2. Nov 2 18:41:58 jukelvdr vdr: Enumerate dev /org/freedesktop/UDisks/devices/sda
    3. Nov 2 18:41:58 jukelvdr vdr: Argument is not String #000!
    4. Nov 2 18:41:58 jukelvdr init: vdr main process (3039) killed by ABRT signal
    5. Nov 2 18:41:58 jukelvdr init: vdr-frontend main process (3054) killed by TERM signal
    6. Nov 2 18:41:58 jukelvdr vdr-crash: vdr exit with signal ABRT . Restarting


    Der Part ist es wohl, habe mich jetzt aber noch nicht im detail auseiandergesetzt mit dem Plugin. Wird ein crashlog generiert wenn es entsprechend configuriert ist ? (Siehe Doku)


    badekap : das ist Threadhijacking ;) Das autostart Plugin ist ein automounter für zB USB Festplatten oder Sticks, wenn auf dem Stick Musik drauf ist wird ein entsprechendes Plugin gestartet (mp3 plugin oder so)

  • Danke für die Antworten,
    ich glaube ich habe ein wenig vorschnell den Thread eröffnet. Das Plugin ist bei mir noch mit der Standardconfig am laufen.
    Ich werde es meinen Bedürfnissen anpassen und hoffe, dass sich das Problem dann erübrigt...


    Grüße,


    Kokel

  • Das hört sich interessant an und das könnte ich vielleicht auch gebrauchen.
    Mit apt-cache search kann ich es leider nicht finden.


    steffen_b
    was verstehst du unter "Threadhijacking"?


    Gruß


    badekap

    System 1) EPIA-ME6000 / 1GB-RAM / 2GB DOM / 1x FF Ver 1.3 / Debian Squeeze + e-Tobi Repo
    System 2) Intel Atom D525 / 2GB-RAM / 8GB SSD / 1x FF Hauppauge Ver 2.1 / Debian Squeeze + e-Tobi Repo
    System 3) Server Athlon 4000+ / 4GB-RAM / 2x SkyStar 2 /
    Debian Squeeze + e-Tobi Repo

  • steffen_b
    was verstehst du unter "Threadhijacking"?


    Falls du es übersehen haben solltest, der Thread hat das Thema "autostart plugin - vdr in startet in endlosschleife".
    Du hast zu dem Thema überhaupt nichts beizutragen, weil du das Plugin ja noch nicht einmal gefunden hast, geschweige denn installiert, sondern übernimmst ihn für deine Zwecke.
    Das ist Thread-Hijacking


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Ich entschuldige mich hiermit unpassend gefragt zu haben und mich in anderer Leute Thread einzumischen - soll nicht wieder vorkommen.

    System 1) EPIA-ME6000 / 1GB-RAM / 2GB DOM / 1x FF Ver 1.3 / Debian Squeeze + e-Tobi Repo
    System 2) Intel Atom D525 / 2GB-RAM / 8GB SSD / 1x FF Hauppauge Ver 2.1 / Debian Squeeze + e-Tobi Repo
    System 3) Server Athlon 4000+ / 4GB-RAM / 2x SkyStar 2 /
    Debian Squeeze + e-Tobi Repo

  • Also das Plugin funktioniert nun, nachdem ich filterdev = Auto rausgenommen habe und meine Platte angegeben habe (sda).
    Nichtsdestotrotz sollte doch auch die Direktive AUTO funktionieren, egal was in /etc/fstab steht.


    Der yaVDR installiert ja standardmäßig LVM, vielleicht kommt das Plugin mit diesen Einträgen nicht klar?!
    Auch wenn das Plugin diverse Einträge nicht kenn, sollte es diese doch überspringen und nicht den vdr zum abstürzen bringen.

  • Der yaVDR installiert ja standardmäßig LVM


    Oh nein, das tut yaVDR nicht, das tust du weil du den default abnickst. Ich tue das zum Beispiel nie. Wenn ich Zeit hätte herauszufinden, wie ich dem Installer abgewöhnen könnte per default LVM anzubieten, dann hätte ich das schon längst getan. Wäre hier für Input dankbar.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • OK, sorry, natürlich der ubuntu installer, weil ja yaVDR auf ubuntu basiert, klar. Hatte mich nicht klar genug ausgedrückt. Gibs denn noch andere Nachteile wenn man LVM nutzt in Bezug zum VDR?