Wie bringe ich unter yavdr das imon vfd Display zum leuchten?

  • Hallo,


    nachdem ich es früher unter linvdr einmal geschaft habe, mein imon vfd Display zum leuchten zu bringen, kämpfe ich nun schon seit einigen Abenden erfolglos damit, dies nach einem Umstieg auf yavdr (0.4.0) auch unter diesem System zu installieren. Ich habe hier viel gelesen über lcdproc, LCDd, die entsprechenden .conf files etc. Leider versteh ich nur Bahnhof, sicher auch, weil ich in Linux selbst nur wenig versiert bin.


    Es wäre schön, wenn ich hier Hilfe erfahren könnte. Mein Problem ist, dass ich die Zusammenhänge nicht verstehe und daher bisher nur nach dem Prinzip "trial and error" vorgehen konnte.


    Falls es irgendwo eine zusammenfassende Anleitung/Hilfestellung geben sollte, wäre ich für einen entsprechenden Hinweis sehr dankbar. Ansonsten würde ich mich natürlich auch über einzelne Hinweise/Hilfestellungen freuen.


    Das vdr-plugin-lcdproc habe ich installiert und aktiviert.
    Das vdr-Plugin-imonlcd habe ich NICHT installiert, weil ich irgendwo gelesen habe, dass dies nur für LCD-Displays, nicht aber für VFD-Displayx aktiviert werden darf.


    Die LCDd Datei befindet sich unter /etc/init.d (und auch noch an einigen anderen Stellen). Veränderungen an dieser Datei habe ich nicht vorgenommen.


    Die Dateien lcdproc.conf und LCDd.conf befinden sich offenbar unter ./etc/. Dies habe ich mit "sudo find - name ..." herausgefunden. Mit dem mc kann ich aber diese Dateien nicht finden (versteckt?, was bedeutet der "." vor dem ersten Slash?). Einsehen konnte ich somit diese Dateien noch nicht und dementsprechend habe ich auch an ihnen noch keine Änderungen vorgenommen.


    Freue mich über jede Meldung!


    Vielen Dank und schöne Grüße


    Beginner ( immer noch 8))

    yavdr 0.4.0, Pentium Dual-Core E6300, Gigabyte GA-EG41MF-US2H, ASUS GT520 SILENT, TWIN DVBS2-Empfänger, 2 GB RAM, 320 GB Samsung 2,5" SATA-Festplatte, Standard DVD-Player, Gehäuse R3 Systems HT-1100, imon vfd-Display, imon-pad

  • Hallo Beginner!


    Was für ein vfd-Display ist es und wie es angeschlossen?


    Wie sieht denn deine LCDd.conf aus? Bitte mal anhängen!


    Fehler im Log?


    Grüße,
    wayne

    VDR-SW: easyVDR 3.5 mit VAAPI, ...
    VDR-HW: DD Cine V6.5, Mystique SaTiX-S2 V3 Dual, ASRock J3710M, 8GB, 60GB System, 2,5" 1TB Media, One For All URC 7960, GMC AVC-M1, ...
    AV-Geräte: Hisense H65MEC5550, Dali Zensor 5 AX

  • Was passiert denn wenn du imon installierst?
    Soviel ich weiß, ist LcdProc eigentlich nur unter XBMC aktiv.

    VDR_1:

    Asus J3455-M, GT 710, SSD 240GB, 8GB DDR3, 1x DvbSky S950 with yavdr-ansible (testing)

    VDR_2:

    AsRock J3455, GT 710, SSD 120GB + SATA 400GB, 8GB DDR3, 1x DvbSky S952 with yavdr-ansible (testing)

    VDR_3_Testing:

    AtomiPi with Intel Atom x5-Z8350, 2GB DDR3, 16GB eMMC, 1x Sundtekt DVB-S with yavdr-ansible (testing)


  • Quote

    Soviel ich weiß, ist LcdProc eigentlich nur unter XBMC aktiv.

    ...das ist natürlich Quark! Es heißt ja auch "vdr-plugin-lcdproc"! :lehrer1

    VDR-SW: easyVDR 3.5 mit VAAPI, ...
    VDR-HW: DD Cine V6.5, Mystique SaTiX-S2 V3 Dual, ASRock J3710M, 8GB, 60GB System, 2,5" 1TB Media, One For All URC 7960, GMC AVC-M1, ...
    AV-Geräte: Hisense H65MEC5550, Dali Zensor 5 AX

  • Hi,


    so hat es bei mir funktioniert:


    sudo apt-get install lcdproc vdr-plugin-lcdproc


    sudo mcedit /etc/LCDd.conf


    und folgendes anpassen / ändern, besonders die Auswahl des Drivers ist wichtig.



    Danach LCDd und VDR neustarten:


    sudo /etc/init.d/LCDd restart
    sudo service vdr restart


    Gruß,
    Chuck

    1- yavdr 0.5 - DVB-C
    1- VDR-1.7.14 - Xine Pugin - XBMC - DVB-C
    2- Activy 300 mit Gen2VDR V2

  • Aber du hast doch auch sicher zusätzlich zum vdr-plugin-lcdproc AUCH noch


    apt-get install lcdproc


    gemacht?

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe

  • holt sich vdr-plugin-lcdproc net aufgrund der Abhängigkeiten lcdproc ganz von allein ?


    Wollte ich auch erst schreiben, aber ich war zu faul nachzusehen. Theoretisch könnte ja das Plugin auch so konfiguriert werden, dass es mit einem LCDProc auf einem anderen Rechner Informationen austauscht und dann wäre ein lokales LCDProc überflüssig, aber vom Gefühl her würde ich dir zustimmen,


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Ich setzte das imon-Display schon lange ein und musste jedes Mal lcdproc separat installieren. Danach sollte es sofort laufen.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe

  • Ich musste Lcdproc nicht zusätzlich installieren, es reichte aus über des Webmenü das Plugin zu installieren.

    Gruß
    Frodo

  • Hallo,
    zuerst einmal vielen Dank für Eure Beiträge!


    Bei meinem Display handelt es sich um ein SoundGraph imon VFD Display (2 Zeilen je 16(?) Zeichen). Es ist über USB mit dem Mainboard verbunden.
    Meine LCDd Datei und die LCDd.conf habe als Anhang einmal beigefügt.


    chuck : Danke für diese ausführliche Anleitung. Leider hat das bei mir nicht funktioniert. Ich habe im Folgenden einmal die Bildschirmausgabe nach der Eingabe von "LCDd" gepostet:


    Code
    1. yavdr1@yavdr:/$ LCDd
    2. Could not open driver module imon.so: imon.so: cannot open shared object file: No such file or directory
    3. Driver [imon] binding failed
    4. Could not load driver imon
    5. There is no output driver
    6. Critical error while initializing, abort.
    7. yavdr1@yavdr:/$


    Vielleicht könnt Ihr ja damit etwas anfangen!?


    Vielen Dank und viele Grüße
    Beginner

    Files

    • LCDd.conf

      (13.53 kB, downloaded 200 times, last: )
    • LCDd.txt

      (1.34 kB, downloaded 166 times, last: )

    yavdr 0.4.0, Pentium Dual-Core E6300, Gigabyte GA-EG41MF-US2H, ASUS GT520 SILENT, TWIN DVBS2-Empfänger, 2 GB RAM, 320 GB Samsung 2,5" SATA-Festplatte, Standard DVD-Player, Gehäuse R3 Systems HT-1100, imon vfd-Display, imon-pad

    The post was edited 1 time, last by Beginner ().

  • Mach mal ein "sudo find / -name imon.so"


    Und dann nochmal ne Rätzlelaufgabe: Gehe deinen letzten Beitrag nochmal Zeilenweise durch und zeige und die drei Fehler die darin stecken.


    cu

  • chuck : Danke für diese ausführliche Anleitung. Leider hat das bei mir nicht funktioniert. Ich habe im Folgenden einmal die Bildschirmausgabe nach der Eingabe von "LCDd" gepostet:


    Code
    1. yavdr1@yavdr:/$ LCDd
    2. Could not open driver module imon.so: imon.so: cannot open shared object file: No such file or directory
    3. Driver [imon] binding failed
    4. Could not load driver imon
    5. There is no output driver
    6. Critical error while initializing, abort.
    7. yavdr1@yavdr:/$

    Also mit der einfachen Eingabe LCDd startest du das Programm (das im Suchpfad liegt) unter /usr/sbin/LCDd direkt. Wenn du das Programm so startest, musst du auch die passenden Parameter mitgeben.
    Teste es einfach mal mit der Eingabe von " LCDd --help"......
    Du solltest es eigentlich über das Init Script starten --> sudo /etc/init.d/LCDd start


    Mach mal ein: dmesg | grep imon
    Es sollte sowas erscheinen --> Treiber imon wurde beim Systemstart geladen:

    Code
    1. [ 6.300104] imon 4-4:1.0: Unknown 0xffdc device, defaulting to VFD and iMON IR (id 0x30)
    2. [ 6.360383] Registered IR keymap rc-imon-pad
    3. [ 6.880226] imon 4-4:1.0: iMON device (15c2:ffdc, intf0) on usb<4:3> initialized
    4. [ 6.880271] usbcore: registered new interface driver imon
    5. [ 8.113706] lirc_imon: module is from the staging directory, the quality is unknown, you have been warned.
    6. [ 8.115276] lirc_imon: Driver for SoundGraph iMON MultiMedia IR/Display, v0.8
    7. [ 8.115538] usbcore: registered new interface driver lirc_imon


    Und ggf. ein: lsmod | grep imon
    Diese Module sind derzeit geladen:

    Code
    1. lirc_imon 18155 0
    2. lirc_dev 19232 2 lirc_imon,ir_lirc_codec
    3. rc_imon_pad 12505 0
    4. imon 32345 1
    5. rc_core 26918 9 ir_lirc_codec,rc_imon_pad,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,ir_nec_decoder,imon


    Und nochmal ein: lsusb
    Diese USB Geräte werden erkannt:

    Code
    1. Bus 004 Device 003: ID 15c2:ffdc SoundGraph Inc. iMON PAD Remote Controller


    Gruß,
    Chuck

    1- yavdr 0.5 - DVB-C
    1- VDR-1.7.14 - Xine Pugin - XBMC - DVB-C
    2- Activy 300 mit Gen2VDR V2

  • Hallo,


    Hier das Ergebnis der Eingabe:


    Code
    1. yavdr1@yavdr:/$ sudo find / -name imon.so
    2. /usr/lib/lcdproc/imon.so


    Nun zum Rätsel: Rein nach der Fragestellung vermute ich, dass Du darauf anspielst, dass sich irgendeine Datei nicht an dem Ort befindet, an dem sie sich befinden sollte :]
    Ich werd' die Zeilen nochmal durchgehen. Leider ist der vdr meine einzige Berührung mit Linux, so dass mir dies schon sehr schwer fällt... aber ich bleib dran... :tup


    Danke und viele Grüße


    Beginner

    yavdr 0.4.0, Pentium Dual-Core E6300, Gigabyte GA-EG41MF-US2H, ASUS GT520 SILENT, TWIN DVBS2-Empfänger, 2 GB RAM, 320 GB Samsung 2,5" SATA-Festplatte, Standard DVD-Player, Gehäuse R3 Systems HT-1100, imon vfd-Display, imon-pad


  • Hier das Ergebnis der Eingabe:


    Code
    1. yavdr1@yavdr:/$ sudo find / -name imon.so
    2. /usr/lib/lcdproc/imon.so


    Mach mal ein
    --
    DriverPath=/usr/lib/lcdproc/
    --
    in die "LCD.conf", sollte eigentlich nicht notwendig sein, aber wer weiss...


    Und schau auch mal ins syslog (/var/log), der Treiber schreibt da bei Problemen viel rein, evtl. kommt die Fehlermeldung auch daher das der Treiber einfach nicht getartet werden kann.



    Nun zum Rätsel: Rein nach der Fragestellung vermute ich, dass Du darauf anspielst, dass sich irgendeine Datei nicht an dem Ort befindet, an dem sie sich befinden sollte :]


    Nein, ich dachte nur dann fällt dir evtl. auf das es keinen Spaß macht durch 5 Meter Posting zu scrollen ;)
    Poste sowas besser als Anhang oder bei pastebin.com, dann bleibt der Thread übersichtlicher.


    cu

  • Hallo!


    Mach mal ein
    --
    DriverPath=/usr/lib/lcdproc/
    --
    in die "LCD.conf"[sic], sollte eigentlich nicht notwendig sein, aber wer weiss...

    Genau das war's!!! :D


    Vielen Dank!


    Nur das was da jetzt ausgegeben wird macht mir noch etwas Sorge... Vielleicht komme ich darauf nochmal zurück...


    Beginner

    yavdr 0.4.0, Pentium Dual-Core E6300, Gigabyte GA-EG41MF-US2H, ASUS GT520 SILENT, TWIN DVBS2-Empfänger, 2 GB RAM, 320 GB Samsung 2,5" SATA-Festplatte, Standard DVD-Player, Gehäuse R3 Systems HT-1100, imon vfd-Display, imon-pad

  • ich steh grad mit dem display total aufm schlauch ( is mein erstes display )


    angezeitgt wird es im lsusb : Bus 002 Device 003: ID 15c2:0038 SoundGraph Inc. GD01 MX LCD Display/IR Receiver


    trieber is auch geladen :


    aber es kommt kein bild kein pixel gar nichts ?! muss ich sonst noch etwas einstellen außer wie oben genannt in der LCD.conf , denn stimmt auch alles Driver Imon Driver path stimmt auch alles :dösen


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Lenovo T430
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

  • ich habe das gleiche display, die o.g. schritte ebenfalls gemacht aber es kommt kein bild, kann ich das display iwie testen os vllt kaputt ist ? erkannt wird es lt lsusb treiber is lt. dmesg auch geladen - es ist mein erstes display und ich habe null ahnung wie ich weiter fahren soll.


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Lenovo T430
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

  • Moin,


    da du XBMC benutzt...hast du das VFD denn in der advancedsettings.xml aktiviert? (<haslcd>true</haslcd>)


    Ciao Louis

  • ne sagt mir allet nix, dachte das geht automatisch bzw das display kommuniziert direkt mit dem vdr. werd mich gleich mal anschauen.


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Lenovo T430
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |