vaapi vorkauer gesucht !

  • ich/wir suchen dringend jemanden mit zeit und durchhaltewillen UND erfahrung um die oneiric pakete zu testen.
    bzw. VAAPI mit oneiric.


    der patch ist in libxine drin. sonst hab ich selber noch nichts grosses getestet.
    wer nicht weiss was vaapi ist braucht jetzt sich nicht als tester melden.


    alle anderen ..... ich will es vorgekaut haben :D
    am besten wären templates für die konfig also wenn z.b. vdr-frontend.conf passend geliefert wird ....


    dann am besten hier:
    https://bugs.yavdr.com/issues/298


    den verlauf "melden" ...
    ich hab auch interesse, weil sandybridge laptop, aber keine zeit für alles ....


    also entweder ich bekomme da hilfe, oder es wird nix vor 2013..... :D

  • muss ich doch mal mein mainboard gegen das amd board wechseln :D evtl am WE.

    mfg traxanos
    ____________________
    Ist das neu?, Nein Linux!


    VDR1: Zotac NM10-ITX Wifi - 2GB Ram - S2-6400 HD mit IR - yavdr 0.4 (development) - LianLi PC-Q11


    Tags: VDR-HD - AT5IONT-I - 4GB Ram - 512MB ION - TT 3600 DVB-S2 - TT6400-FF - Sundtek DVB-S2 Sundtek DVB-C - Tevii S480 (dank an L4M für kostenlose Bereitstellung) - yaVDR 0.5 (development) - SKY - HD+ - Atric - X10 FB - Zotac ID41 PLUS - SilverStone LC19B-R - Yamaha RX-V671 - Samsung 8Series 55"

  • Ich hab mit der yavdr 0.4 bzw. nackigem Ubuntu Natty schon mal bisschen rumexperimentiert... MPlayer läuft mit VAAPI-Support, aber bei Xine hängt es an diversen Updates von FFMPEG, H264, libxine uva.
    Hab ein Asus E35M-I, also einen AMD Fusion E-350.


    Ich hab reichlich Linux-Erfahrung, daran sollte es nicht scheitern :-)
    Könnte höchstens ein Zeit-Problem werden...

    Client1: MLD 5.3, softhddevice, Bild+Ton über HDMI an Toshiba 46" [Hardware: Zotac IONITX-D, Impactics C3LH-B, 2GB RAM, 30 GB SSD, lautlos] mit streamdev-client, alternativ XBMC per VNSI/XVDR, Logitech Harmony 300i an atric-Einschalter
    Client2: MLD5.1, softhddevice VA-API, Bild+Ton über HDMI an Telefunken D32F280R3 32" [Hardware: ASRock Q1900B-ITX, intel Celeron J1900, SilverStone SST-ML05B, 4GB RAM, 60GB SSD, lautlos] mit streamdev-client, Logitech Harmony 200 an yaUSBir-Einschalter

    Server: Ubuntu 16.04 headless + Frodo 2.3.8 PPA, Aufnahmen auf NAS [Hardware: ASRock G31M-GS, E6300, 4GB RAM, Quad Tuner: Digital Devices Cine S2 V6.5 + DuoFlex S2 (PCIe)]

  • Code
    1. nackigem Ubuntu Natty schon mal bisschen rumexperimentiert


    daher wollte ich warten bis oneiric.
    bzw. hab den patch eh erst ab oneiric libxine drin.


    ich dachte in oneiric sollte das reichen ohne ffmpeg libva patchen.
    aber mein erster test ging nicht.


    da kam irgendwas mit "driver return -1"


    und dann hatte ich keine lust mehr. :D

  • Wie stellt ihr euch das Testen denn vor? Reicht es, das Ubuntu der yavdr 0.4 Installation auf Oneiric upzugraden? Oder gibts spezielle yavdr-Pakete für Oneiric?
    Ich werde erst mal das dist-upgrade auf Oneiric machen, kann ja nicht schaden...

    Client1: MLD 5.3, softhddevice, Bild+Ton über HDMI an Toshiba 46" [Hardware: Zotac IONITX-D, Impactics C3LH-B, 2GB RAM, 30 GB SSD, lautlos] mit streamdev-client, alternativ XBMC per VNSI/XVDR, Logitech Harmony 300i an atric-Einschalter
    Client2: MLD5.1, softhddevice VA-API, Bild+Ton über HDMI an Telefunken D32F280R3 32" [Hardware: ASRock Q1900B-ITX, intel Celeron J1900, SilverStone SST-ML05B, 4GB RAM, 60GB SSD, lautlos] mit streamdev-client, Logitech Harmony 200 an yaUSBir-Einschalter

    Server: Ubuntu 16.04 headless + Frodo 2.3.8 PPA, Aufnahmen auf NAS [Hardware: ASRock G31M-GS, E6300, 4GB RAM, Quad Tuner: Digital Devices Cine S2 V6.5 + DuoFlex S2 (PCIe)]

  • Also ein System zum testen bestehend aus ASRock H61M und einer TeVii 480 hab ich bei mir rumstehen.
    Bin gern bereit damit zu testen, sollte sowieso irgendwann für Vaapi genommen werden.


    Beim kompilieren, wenn das nötig wird bräuchte ich eventuell bischen Hilfestellung.


    Uwe

    Wissen ist Macht, nix wissen macht auch nix
    VDR1: yaVDR0.3.0a Gigabyte GAM85M-US2H VDPAU 1GB Ram Sempron140 500GB WD CaviarBlue 2xTT-S2-1600, ATRIC on Com1
    VDR2: yaVDR0.3.0a Zotac Ion-F 2GB Ram 1TB WD CaviarBlue Dual TBS 6981

  • Also ein System zum testen bestehend aus ASRock H61M und einer TeVii 480 hab ich bei mir rumstehen.
    Bin gern bereit damit zu testen, sollte sowieso irgendwann für Vaapi genommen werden.


    Beim kompilieren, wenn das nötig wird bräuchte ich eventuell bischen Hilfestellung.


    Gratulation! Thread-Absicht missverstanden. Es geht um Vorkauer, nicht um Nachkauer. :D


    Gruß
    hepi

  • Hab auch lang gezögert :D
    Nur zum vorkauen reicht mein Wissen noch ned ?(

    Wissen ist Macht, nix wissen macht auch nix
    VDR1: yaVDR0.3.0a Gigabyte GAM85M-US2H VDPAU 1GB Ram Sempron140 500GB WD CaviarBlue 2xTT-S2-1600, ATRIC on Com1
    VDR2: yaVDR0.3.0a Zotac Ion-F 2GB Ram 1TB WD CaviarBlue Dual TBS 6981

  • hi fergest vaapi bei ati karten und vdr
    mfg det

    Jeder sollte sein Leben so leben können wie er/sie es möchte, frei und
    unabhängig, in der Not anderen zur Seite stehend, nie vergessen was man
    ist, eben einfach nur Mensch sein mit allen Schwächen und Stärken
    Lieber stehend sterben als ewig gebückt leben

  • psst, det nimm den leuten nicht den mut, ich hab immer mehr ati geräte hier:)


    vaapi mit mplayer läuft wirklich top, wäre wirklich schön wenns mit xine auch tun würde, hab n ati netbook, das ich gern als kleinen tv nehmen würde, also viel Erfolg!:)

    | HP Microserver Gen 7 | Cine S2 + DVBSky S952 | vdr2.2 | Streamdev Server |
    | Streamdev Clients: paar Rpi2, yavdr.... |

  • Wieder mal ein Thread für die Tonne, schade hoplo.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • nein ist er nicht.
    sollte in zukunft mal wieder eine anfrage zu vaapi kommen, hab ich einen link zu diesem
    thread.


    aber ich will es ja auch, nur nicht mit amd sondern eher das mit den intel dingern.
    naja patch ist ja drin in libxine evtl. kommt ja wirklich was...


    @SkinHD jetzt versteh ich auch warum "skin hd" :D

  • EIn weiteres Problem wird sein, dass manche nicht ohne weiters zu Oneric wechseln können. Mir geht es z.B: so man bekommt sie s2-liplianin Treiber unter Oneric mit dem Kernel 3.0 bzw. 3.1 nicht zum laufen. Es reicht nicht mehr einfach die Treiber aus zu klammern, die Fehler verursachen. Ich denke mal so lange Debian noch hinterherhinkt mit dem Kernel werden die s2-liplianin Treiber auch nicht angepasst und ohne s2-liplianin Treiber Spinnen meine Karten.


    Gruß
    Orgel

  • Also, nachdem heute die neuen ATI Treiberversion 11.10 erschien, hab ich da mal bisschen getestet...
    Package für Oneiric gebaut und installiert, alles was mit NVidia zu tun hat, deinstalliert.


    VAAPI-Support mit xvba läuft ziemlich ootb, nur sind halt bei AMD/ATI die Umgebungsvariablen für alle User zu setzen:


    Code
    1. add to /etc/environment:
    2. LIBVA_DRIVER_NAME=xvba
    3. LIBVA_DRIVERS_PATH=/usr/lib/va/drivers


    VAAPI-supported VLC und MPlayer laufen ziemlich problemlos, aaaber: libxine-1.2 mit VAAPI-Patch scheint noch ziemlich buggy zu sein. Ständig Abstürze wg. Speicherallocation :wand

    Code
    1. xine: object_heap.c:100: object_heap_allocate: Zusicherung »heap->next_free >= 0« nicht erfüllt.


    Es gibt ein paar Möglichkeiten, am X11/Xine etc. zu schrauben, aber das Problem scheint momentan eher libxine2 zu sein. Verschiedene libva und xvba-Versionen brachten keine Verbesserung.

    Client1: MLD 5.3, softhddevice, Bild+Ton über HDMI an Toshiba 46" [Hardware: Zotac IONITX-D, Impactics C3LH-B, 2GB RAM, 30 GB SSD, lautlos] mit streamdev-client, alternativ XBMC per VNSI/XVDR, Logitech Harmony 300i an atric-Einschalter
    Client2: MLD5.1, softhddevice VA-API, Bild+Ton über HDMI an Telefunken D32F280R3 32" [Hardware: ASRock Q1900B-ITX, intel Celeron J1900, SilverStone SST-ML05B, 4GB RAM, 60GB SSD, lautlos] mit streamdev-client, Logitech Harmony 200 an yaUSBir-Einschalter

    Server: Ubuntu 16.04 headless + Frodo 2.3.8 PPA, Aufnahmen auf NAS [Hardware: ASRock G31M-GS, E6300, 4GB RAM, Quad Tuner: Digital Devices Cine S2 V6.5 + DuoFlex S2 (PCIe)]

  • Soweit mit bekannt hat ebsi die vaapi für xine lediglich für INTEL und nicht für ATI angepasst. Deshalb braucht man sich nicht wundern, wenn das mit ATI nicht funktioniert.


    Gruß
    iNOB

  • Das große Problem ist das VA-API (für Intel) im Moment nur mit den GIT Versionen funktioniert.


    media-libs/xine-lib
    x11-drivers/xf86-video-intel
    x11-libs/libdrm
    x11-libs/libva
    x11-libs/libxcb
    x11-libs/pixman
    x11-proto/xcb-proto
    + vaapi intel driver


    ffmpeg funktioniert ab 0.8.5.
    Kernel 3.1 gibts ja inzwischen.
    xf86-video-intel gibts ja schon eine RC von der Version die dann funktionieren sollte.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • johns : Hast du das mit yavdr bzw. Ubuntu getestet?


    HDTV (h.264) funktioniert bei mir (AMD E-350) per streamdev-server an VLC völlig problemlos:
    - aktuelles Oneiric - VAAPI-enabled VLC ist schon dabei...
    - FGLRX 11.10 - oneiric .debs selbst gebaut
    - libva von ppa:ubuntu-x-swat/x-updates
    - ffmpeg/libav von ppa:motumedia/libav-daily
    - mplayer-vaapi von ppa:sander-vangrieken/vaapi


    Nur die libxine (GIT vaapi-testing von https://github.com/huceke/xine-lib-vaapi) bekomme ich nicht stabil zum laufen.
    Entweder kommen Abbrüche direkt nach dem Start oder das Bild flackert extem - suche noch die Ursache...x<yNurx

    Client1: MLD 5.3, softhddevice, Bild+Ton über HDMI an Toshiba 46" [Hardware: Zotac IONITX-D, Impactics C3LH-B, 2GB RAM, 30 GB SSD, lautlos] mit streamdev-client, alternativ XBMC per VNSI/XVDR, Logitech Harmony 300i an atric-Einschalter
    Client2: MLD5.1, softhddevice VA-API, Bild+Ton über HDMI an Telefunken D32F280R3 32" [Hardware: ASRock Q1900B-ITX, intel Celeron J1900, SilverStone SST-ML05B, 4GB RAM, 60GB SSD, lautlos] mit streamdev-client, Logitech Harmony 200 an yaUSBir-Einschalter

    Server: Ubuntu 16.04 headless + Frodo 2.3.8 PPA, Aufnahmen auf NAS [Hardware: ASRock G31M-GS, E6300, 4GB RAM, Quad Tuner: Digital Devices Cine S2 V6.5 + DuoFlex S2 (PCIe)]

    The post was edited 1 time, last by hueb_s: PPA für libav korrigiert. ().

  • Ich verwende nur gentoo. Nachdem Debian dauernd total veraltet war, bin ich dazu gewechselt.


    Nachdem mplayer und vlc mit va-api funktionieren, scheint es doch an den Unterschieden zwischen ATI/Intel und der xine-lib zuliegen.
    Mal gucken ob ich noch eine alte ATI Karte reaktivieren kann.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch