ALSA-NVIDIA Sound-Konfusion

  • Hallo zusammen,


    bisher war die VDR-Welt für mich einfach: ich hab ein Motherboard msi GF615M, bei dem ich Onboard-Grafik und Sound (analog) genutzt habe.
    Jetzt habe ich die Grafik auf eine msi N8400GS (Nvidia G98, VDPAU fähig, VGA & DVI-Ausgang)) aufgerüstet, außerdem ein neuer TV mit HDMI-Eingang.


    Ich möchte den Ton natürlich über DVI-HDMI zum TV bringen. Allerdings konnte ich bisher nicht herausfinden, ob das hardwaretechnisch bei meiner Konfiguration überhaupt möglich ist, und wenn ja, ab welchen Treibern in welcher Version.
    Die Grafikkarte hat keinen SPDIF-Eingang. Allerdings zeigt ein $lspci ein Audio-Gerät darauf an (siehe unten). Ich habe an andere Stelle gelesen, dass der Ton evtl. über PCI zur Grafikkarte kommt und dann auf den DVI-Stecker durchgeschleift wird. Ist das möglich?


    Viele Grüße
    Summitman


    Code
    1. $ aplay -l
    2. **** Liste der Hardware-Geräte (PLAYBACK) ****
    3. Karte 0: NVidia [HDA NVidia], Gerät 0: ALC887 Analog [ALC887 Analog]
    4. Sub-Geräte: 1/1
    5. Sub-Gerät #0: subdevice #0
    6. Karte 0: NVidia [HDA NVidia], Gerät 1: ALC887 Digital [ALC887 Digital]
    7. Sub-Geräte: 1/1
    8. Sub-Gerät #0: subdevice #0



    Code
    1. $ dmesg |grep -i nvidia
    2. [ 9.984193] hda_intel: Disable MSI for Nvidia chipset
    3. [ 11.068139] hda_intel: Disable MSI for Nvidia chipset
    4. [ 18.705703] nvidia 0000:02:00.0: PCI INT A -> Link[LNED] -> GSI 18 (level, low) -> IRQ 18
    5. [ 18.705709] nvidia 0000:02:00.0: setting latency timer to 64
    6. [ 18.705962] NVRM: loading NVIDIA UNIX x86 Kernel Module 195.36.31 Tue Jun 1 22:08:27 PDT 2010
  • Also,


    ich habe es geschafft. Ton geht über DVI-HDMI-Kabel mit einer NVIDIA 8400GS ohne SPDIF-Connector. Der Trick ist das Deaktivieren der Onboard-NVIDIA-Soundgeräte und die ALSA-Treiber-Version 1.0.24.


    Gruß
    Summitman