Pearl Display Yavdr *TODO* install

  • Also als erstes würde ich mal NICHT unterscheiden zwischen DVD usw. sondern schlicht bei den Standards bleiben (Play, Pause, Fwd, Rew) sonst sind die Chancen das es mal fertig wird ja Richtung null! Desweiteren nehmt doch BITTE BITTE endlich die vorhandenen Copyright-freien Symbole schwarz auf weißem Grund und fertig. Die Implementierung der Symbole MIT wahlweiser Endung *.png, *.jpg und meinetwegen *.xpm und gut.
    Und wenn ich dann weiß welche Größe, Farbtiefe und Endung ein entsprechendes Symbol hat kann ich mir aussuchen ob ich persönlich ein Copyright verletzen will oder nicht und die Dinger tauschen (!)


    Aber es wäre schön wenn endlich Schluß wäre mit dieser elenden Sucherei nach den Traumvorschlägen mit 32bit, Animation,Sprachausgabe und 100jährigem Kalender für das Motto des Tages ;D


    [EDIT]
    Ich bin raus aus der Nummer
    [/EDIT]

    The post was edited 2 times, last by Taipan ().

  • Hallo zusammen,


    ich schließe mich mal der Meinung von Taipan an. Warum nicht einfach mit den vorgeschlagenen einfachen Symbolen arbeiten.

    wie wäre es mit diesen:
    http://findicons.com/pack/2212/carpelinx?q=play


    Die stehen unter GNU/GPL.

    Lebt das Projekt noch? Sollte das Packet nicht auch mal ins graphlcd-plugin integriert werden?
    Nachdem ich vorgestern meinen Rechner neu aufgesetzt habe, musste ich doch nochmal diesen Thread durchgehen, um das Pearl-dpf wieder auf das LCD zu bekommen.


    LG
    CyberHogo

  • Hi


    Habe das problem, das bei mir einige Senderlogos nicht angezeigt werden ?


    Diese gehen nicht !

    Code
    1. 1-1019-10301:Das Erste HD
    2. Das Erste HD;ARD:11493:HC23M5O35P0S1:S19.2E:22000:5101=27:5102=deu@3,5103=mis@3;5106=deu@106:5104;5105=deu:0:10301:1:1019:0
    3. 1-1053-21108:N24 HD
    4. N24 HD;BetaDigital:10773:HC34M5O20P0S1:S19.2E:22000:767=27:0;771=deu@106:34:1830,1843,9C4,98C,648,1860:21108:1:1053:0
    5. 1-1057-61205:RTL2 HD
    6. RTL2 HD;BetaDigital:10832:HC23M5O35P0S1:S19.2E:22000:1535=27:0;1539=deu@106:37:1830,1843,9C4,98C,1860:61205:1:1057:0


    Diese gehen !

    Code
    1. 1-1011-11110:ZDF HD
    2. ZDF HD;ZDFvision:11361:HC23M5O35P0S1:S19.2E:22000:6110=27:6120=deu@3,6121=mis@3,6123=mul@3;6122=deu@106:6130;6131=deu:0:11110:1:1011:0
    3. 1-1057-61200:RTL HD
    4. RTL HD;CBC:10832:HC23M5O35P0S1:S19.2E:22000:255=27:0;259=deu@106:32:1830,1843,9C4,98C,1860:61200:1:1057:0
    5. 1-1057-61201:VOX HD
    6. VOX HD;CBC:10832:HC23M5O35P0S1:S19.2E:22000:511=27:0;515=deu@106:33:1830,1843,9C4,98C,1860:61201:1:1057:0


    Das kommt im syslog

    Code
    1. Jan 16 14:56:30 vdrNEU vdr: glcdgraphics: Couldn't load '/usr/share/vdr/plugins/graphlcd/logos/channels/.PNG': Magick: Unable to open file (/usr/share/vdr/plugins/graphlcd/logos/channels/.PNG) reported by coders/png.c:2790 (ReadPNGImage) (cExtFormatFile::LoadScaled)


    Ich habe mal die channel.conf, einträge immer unter die passenden channel.alias geschrieben.
    Es sind natürlich die dem entsprechenden PNG´s im logos Verzeichnis vorhanden !


    hat einer eine Idee


    gruß durmel

    VDR 1.Dual-Core E5200;Samsung HD103UJ 1 TB;Asus P5N7A-VM;Tevii 460S

    The post was edited 1 time, last by durmel ().

  • Ich wollte auch mal wieder ein bisschen mit dem Pearl-Display und dem Skin spielen, weil bei mir die Logos auch nie (zuverlässig) angezeigt wurden.
    Das Git-Repo scheint aber down zu sein. Ist das bekannt?


    Code
    1. $ git clone http://dl.dropbox.com/s/f4gc4243t4pgv98/pearldpf-simple.git
    2. Cloning into 'pearldpf-simple'...
    3. fatal: repository 'http://dl.dropboxusercontent.com/s/f4gc4243t4pgv98/pearldpf-simple.git/' not found
  • Ich habe mal einen der größten Vorteile von GIT (jeder, der jemals das Repository ausgecheckt hat, hat ein komplettes Backup davon) ausgenutzt und das ganze wiederbelebt.


    Die nicht existenten, bzw. nichtssagenden Angaben im "Author"-Feld habe ich vor dem Pushen alle überschrieben durch "Keine_Ahnung@vdr-portal.invalid".


    Bei vdr4arch kann das Paket bereits wieder gebaut werden (habe ich im gleichen Zug mit gefixt). Alle anderen finden das Repositiry hier:


    https://github.com/M-Reimer/pearldpf-simple


    Hinweis am Rande: Ich nutze das Display selber nicht. Mir war nur wichtig, dass das Skin nicht verloren geht. Ist nämlich wirklich gute Arbeit. Wenn jemand mit den nötigen Kenntnissen und der passenden Hardware aktiv am Skin weiterarbeiten will, dann einfach forken.

  • Hallo,


    Ich habe den Skin erfolgreich aus dem Git am Display aktiviert.
    Beim Durchstöbern der älteren Beiträge ist mir allerdings keine Lösung untergekommen, wie ich die Logos aktivieren kann!


    1.) Brauchen die PNG´s eine spezielle Größe, oder kann ich nicht einfach die Nopacity Logos nehmen, welche ich ja sowieso am Rechner aktiviert habe?
    2.) Wie muss den das Configfile des Skins für die Pfadangabe der PNG´s lauten?
    3.) Das mit der Channel Alias ist mir leider auch nicht ganz klar. Benötigt jedes Logo einen Eintrag in der Alias? Wenn ja hat jemand eine gut gefühlte, bzw. kann man das Simpel aus der Channels.conf generieren?


    Sorry bin leider kein Linux Pro.


    Wäre fein wenn ihr mir hier ein Howto für Dummys anbieten könnt ;-)


    LG.
    Chris

    VDR 1: ASUS AT3N7a-I Ion-330-1 (Intel Atom 330@1,9 GHz). 4GB, 64GB SSD, TT S2-1600 , Gehäuse: Streacom F7C, flirc streamcom edition, yavVDR since 0.1.1, yaVDR 0.6. BOSE 3.2.1 first gen, TV: Philips 52 PFL 8605K/02

  • Ich klinke mich hier mal ein, nachdem graphlcd-base und das plugin endlich fehlerfrei zu kompilieren gingen. Ich kann jetzt mit z.B. settext problemlos auf das Display zugreifen und dort ergreifende Texte darstellen


    Code
    1. Jan 17 19:57:02 raspberrypi showtext: ax206dpf: AX206DPF initialized (320x240).


    Wenn ich den vdr mit der Option


    Code
    1. -P 'graphlcd -d ax206dpf -s touchcol'


    aufrufe, dann steht im sysllog dies:



    und auf der Konsole das:


    Code
    1. Error: No matching USB device found!


    und es wird nix angezeigt. Bin schon ax206dpf.c und ax206dpf.h durchgegangen, komme aber nicht drauf, warum er/sie/es das Display beim Aufruf durch settext findet und durch das vdr plugin nicht. Kann jemand helfen?

    vdr 1.7.x auf/von Debian Wheezy mit Kernel 3.14.6, Alix.1c Board mit AMD Geode 500 MHz, PCTV 461e, Steuerung über Live-Plugin
    vdr 2.2.0 auf Raspbian GNU/Linux 7.6 mit Kernel 3.18.5+, Raspi B+, PCTV 461e, Plugins: dynamite, epgsearch, live

  • Hab's in einer Nachtsitzung selbst gefunden: Ein Zugriffsrechte-Problem. Die Antwort steht - allerdings verklausuliert - hier im Forum.
    Nachdem der vdr auf der Himbeere als user pi läuft:


    Code
    1. usermod -aG uucp pi


    dann geht's. Falls jemand in die selbe Falle tappt.

    vdr 1.7.x auf/von Debian Wheezy mit Kernel 3.14.6, Alix.1c Board mit AMD Geode 500 MHz, PCTV 461e, Steuerung über Live-Plugin
    vdr 2.2.0 auf Raspbian GNU/Linux 7.6 mit Kernel 3.18.5+, Raspi B+, PCTV 461e, Plugins: dynamite, epgsearch, live