[ANNOUNCE] TVHeadend Timer- und Powermanagement für XBMC/Kodi

  • Yes, I have switched to LibreElec and TVH Manager runs perfectly !


    Thanks for your work,
    BJ


    P.S. And what about LibreElec 8.0 ("7.90.001 Alpha") :D ?


    Server......: Case: Streacom FC5 EVO, Mobo: ASRock B75 Pro3-M mit Core i3-2120T, HD: WD10JUCT 1 TB, Hauppauge Nova HD S2; SW : yavdr5 und Openelec
    Clients.....: XBMC auf iMac/OSX und Openelec auf Raspberry Pi

  • P.S. And what about LibreElec 8.0 ("7.90.001 Alpha") ?


    Same procedure as every year ;)

  • "To your health, General!"
    It runs smooth also on LibreElec 8 Alpha. I had to replace OpenElec with LibreElec twice, may be you can integrate and combine that in you next revision?


    Code
    1. [service.tvh.manager]: OS seems to be LibreELEC


    Thanks,
    /BJ


    Server......: Case: Streacom FC5 EVO, Mobo: ASRock B75 Pro3-M mit Core i3-2120T, HD: WD10JUCT 1 TB, Hauppauge Nova HD S2; SW : yavdr5 und Openelec
    Clients.....: XBMC auf iMac/OSX und Openelec auf Raspberry Pi

  • I had to replace OpenElec with LibreElec twice


    Where did you do this?

    may be you can integrate and combine that in you next revision?


    No problem.

  • it's in your default.py just when you querry the OS :

    Code
    1. PLATFORM_OE = True if ('LIBREELEC' in ', '.join(platform.uname()).upper()) else False


    you need to expand it into two queries for LIBREELEC and OPENELEC via nested if...else...
    The second change I did can be


    Code
    1. if PLATFORM_OE: writeLog('OS seems to be OpenElec or LibreELEC')


    Regards,
    BJ


    Server......: Case: Streacom FC5 EVO, Mobo: ASRock B75 Pro3-M mit Core i3-2120T, HD: WD10JUCT 1 TB, Hauppauge Nova HD S2; SW : yavdr5 und Openelec
    Clients.....: XBMC auf iMac/OSX und Openelec auf Raspberry Pi

  • Code
    1. PLATFORM_OE = True if ('LIBREELEC' in ', '.join(platform.uname()).upper()) else False

    you need to expand it into two queries for LIBREELEC and OPENELEC via nested if...else...

    Or you could use any():

    Code
    1. PLATFORM_OE = any(dist for dist in ('LIBREELEC', 'OPENELEC') if dist in ', '.join(platform.uname()).upper())

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Teste ich morgen....


    Server......: Case: Streacom FC5 EVO, Mobo: ASRock B75 Pro3-M mit Core i3-2120T, HD: WD10JUCT 1 TB, Hauppauge Nova HD S2; SW : yavdr5 und Openelec
    Clients.....: XBMC auf iMac/OSX und Openelec auf Raspberry Pi

    The post was edited 1 time, last by berniejonnie ().

  • Löpt...
    (meinst du wirklich, es gibt noch mehr Forks? ;D )


    Server......: Case: Streacom FC5 EVO, Mobo: ASRock B75 Pro3-M mit Core i3-2120T, HD: WD10JUCT 1 TB, Hauppauge Nova HD S2; SW : yavdr5 und Openelec
    Clients.....: XBMC auf iMac/OSX und Openelec auf Raspberry Pi

  • Die 0.3.9 ist raus. In dieser kann man per Option in den Settings setzen, ob sudo-Privilegien erforderlich sind oder nicht (Bei OpenELEC/LibreELEC sind keine Admin-Privilegien erforderlich).

  • Hallo,


    ich bin Korgan und komme aus NRW. Ich bin 59 Jahre alt.
    Ich habe seit ein paar Monaten Libreelec und Live TV an laufen. ich würde gerne
    dieses tolle Programm Power Managament benutzen, komme aber nicht damit klar.
    Ich bin absoluter Anfänger und tue mich echt schwer damit.



    Was habe ich gemacht,


    Ich habe TVheadend installieret und eingerichtet. Tvheadend läuft einwandfrei. Dann habe ich PowerManagament installiert und eingerichtet. Ich habe eine remote.xml erstellt. Den Punkt "Keine Adminrechte" in dem Addon ausgeschaltet. Mehr muss man doch nicht machen, oder?


    Wenn der Rechner im Energiemodus Standby steht, ich die F12 drücke, dann wird die nächste Aufnahme gesetzt und der Rechner geht dann in den Standby. Er geht
    zur Richtigen Zeit wieder an, macht die Aufnahme und geht wieder in den Standby. Wenn der Rechner im Energiemodus Ausschalten steht, dann setzt er die Zeit zum
    Aufwachen richtig und geht Aus. Der fährt aber nicht mehr hoch.


    Ich habe mich echt schwer getan Libreelec so zum Laufen zu bekommen. Ich kommeaber nun nicht weiter. Ich glaube ich habe alle Deutschen Beiträge dazu gelesen. Leider ist mein Englisch so schlecht, das ich nur mit Google Übersetzer arbeiten kann und das ist eine Katastrophe.


    Ich habe anhand der Kodi.old.log herausgefunden das es an Tvheadend liegt.



    Keine Verbindung zu TVheadend. Aber Warum? Es Läuft doch einwandfrei, bis ich PowerManager aktiviere. Ich bin wahrscheinlich blind und muss irgendwo einen Haken setzen oder so.


    Kann mir einer behilflich sein?

  • Die Meldung, dass keine Verbindung zu TVHeadend besteht, kommt vom PVR-HTS-Client. Zu dieser Zeit hat der PVR-Manager (also das Addon) seine Arbeit bereits gemacht und hat sich beendet. Offensichtlich wird keine korrekte Aufweckzeit ins BIOS geschrieben oder das BIOS des Systems ist nicht richtig konfiguriert. Du könntest im BIOS unter ACPI, Wakeup mal schauen, ob dort 'Wakeup by RTC' auf 'OS' steht. Wenn nicht, bitte mal einschalten. Wenn das nichts hilft, bitte "Abschaltung erfolgt durch: Betriebssystem" einstellen. Dann sollte es gehen. Bei halbwegs aktueller Hardware sollten die grundlegenden Einstellungen unter Libreelec wie im Anhang aussehen.

    Images

  • Hallo BJ1,


    Danke das du dich meiner annimmst. Ich habe im Addon die Einstellungen wie auf den Bildern.
    Im Bois sieht es so aus:


    Wo kann ich denn OS einstellen?


    Edit


    Ich habe im Addon auf Betriebssystem gestellt und eine Aufnahme programmiert. Es ist das gleiche Ergebnis. Kein Starten von kodi.

  • Welche Möglichkeiten hast Du im BIOS bei 'Einschalten durch RTC? Wenn es dort kein "Betriebssystem, "OS" oder dergleichen gibt, auf "deaktiviert" stellen.

  • Wenn es dort nur 'aktiviert' oder 'deaktiviert' gibt, stelle es auf 'deaktiviert'. Was ist das überhaupt für ein Mainboard?

  • Es läuft. :mua :D


    Ich kann es garnicht glauben. Ich bin schon seit Tagen jeden Abend damit zu Gange und war schon an verzweifeln. Du hast mich erst mal auf das BIOS gebracht. Ich habe so oft gelesen das Rtc und Pcie bei Asus eingeschaltet sein muss, das habe ich natürlich auch gemacht und in den ganzen Wochen habe ich nie Rtc Deaktiviert. Jetzt ist nur noch PCIE aktiviert. Kann ich das auch Deaktivieren?


    Das ist ein Asus VivoPC VM62, ich kann dir nicht sagen was das für ein Mainboard ist.


    Ich kann es echt nicht fassen. Es hat nur ein hacken gefehlt und ich komm nicht drauf.


    Danke BJ1
    :D

  • Schön das es funktioniert ;) . PCIe aktiv wird manchmal benötigt, wenn ein PC per USB-Dongle einer Fernbedienung aufgeweckt werden soll. Bei ASUS ist es bei einigen Boards so, dass nur bei aktivem PCIe (und nur dann) die USBs ebenfalls mit Spannung versorgt werden. Das betrifft z.B. alle J1900-Boards und das J3455 von Asus.


    Wenn es bei Dir so funktioniert, lass' es einfach wie es ist.

  • Hallo,


    ich bin es nochmal. ich habe diese Nacht eine Aufnahme Programmiert. der Rechner ist um 4 Uhr Hochgefahren und hat Aufgenommen. Alls ich heute Morgen um 6 Uhr aufgestanden bin lief der Rechner immer noch. Ich habe es heute Abend noch mal probiert und eine Aufnahme programmiert. Der Rechner nimmt auf, Fährt aber nicht runter. ich habe keine User Aktivität gehabt.



    Wo ist denn jetzt noch eine Fehlender Hacken? :angst

  • Hi,
    wo steht die Einstellung der Inaktivität denn?


    Hast du Noad/markad aktiv?


    Fährt er manuell runter?
    MfG,
    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Guten Abend Stefan,


    Ich kann dir nicht sagen wo die Inaktivität steht. Das ist es eben. Der Rechner ist zur Aufnahme hochgefahren und sollte nach der Aufnahme runter fahren. Das macht er nicht.


    Was ist noad/markat?


    Ja, der Rechner fährt Manuel runter.