[ANNOUNCE] xine-lib vaapi support

  • Die xine-lib VAAPI Entwicklung hat eine neues zu Hause auf github bekommen.


    Um an die Source zu kommen :


    git clone git://github.com/huceke/xine-lib-vaapi.git
    cd xine-lib-vaapi
    git checkout vaapi-testing


    ffmpeg muss in der aktuellen git Version verwendet werden oder folgender commit gegen Version 0.7/0.8 angewandt werden :


    http://git.videolan.org/?p=ffm…5aae9f0baa47671af15de181a



    Libxcb hat ein deadlock Problem welches im libxcb git behoben wurde oder folgenden Patch gegen libxcb 1.7 anwenden :


    https://archvdr.svn.sourceforg…/xcb_wait_for_reply.patch



    Es gibt auch ein rudimentäres README dazu :


    https://github.com/huceke/xine…aapi-testing/README.vaapi



    Oder einfach hier im Forum diesen Thread durchlesen :


    http://www.vdr-portal.de/board16-video-disk-recorder/board85-hdtv-dvb-s2/102819-hd-vdr-mit-intel-hd-graphics-testbericht-zu-vaapi/


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • hi, ich hab da mal eine kurze frage.
    gibt es gen_vaapi_patch.sh nun gar nicht mehr? habe damit immer den patch erzeugt um es in df-osd-handling+alter-vdpau-h264-decoder git einzubasteln, für mein debian paket.

  • hi, ich hab da mal eine kurze frage.
    gibt es gen_vaapi_patch.sh nun gar nicht mehr? habe damit immer den patch erzeugt um es in df-osd-handling+alter-vdpau-h264-decoder git einzubasteln, für mein debian paket.

    "git diff master vaapi-testing" macht den Trick.


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Hallole,
    ich habe da ein Problem mit dem Compile von xine-lib-vaapi. Der make scheitert an po Files


    Was läuft da falsch?

    [font='Verdana, sans-serif'][size=8]vdr hd: Core i3 2100T, 2GB, Intel DH67BL, Tevii S480, Sandisk G25 SSD, 2TB HDD, Intel CIR, Harmony 300, MSI G210, yavdr 0.5

  • Hallole,
    ich habe da ein Problem mit dem Compile von xine-lib-vaapi. Der make scheitert an po Files


    Was läuft da falsch?

    Mach male ein "git pull --rebase" und probier es nochmal.


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • HI ebsi


    git pull hat nichts gebracht.

    Code
    1. root@H67:~/tmp/xine-lib-vaapi# git pull --rebase
    2. Current branch vaapi is up to date.


    immer noch der gleiche Fehler.

    Code
    1. root@H67:~/tmp/xine-lib-vaapi# git show
    2. commit 9dfc02242c2cedb14c058db39733760efbedfba1
    3. Merge: b64758d e608145
    4. Author: root <root@i7.(none)>
    5. Date: Fri Jan 6 00:51:08 2012 +0100
    6. Merge branch 'vaapi-testing' of https://github.com/huceke/xine-lib-vaapi into vaapi


    Noch ne Idee?
    VG Kurt

    [font='Verdana, sans-serif'][size=8]vdr hd: Core i3 2100T, 2GB, Intel DH67BL, Tevii S480, Sandisk G25 SSD, 2TB HDD, Intel CIR, Harmony 300, MSI G210, yavdr 0.5

  • Auf welcher Distri compilierst Du ?

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Code
    1. : --update cs.po libxine2.pot
    2. rm -f cs.gmo && : -c --statistics -o cs.gmo cs.po
    3. mv: Aufruf von stat für „t-cs.gmo“ nicht möglich: Datei oder Verzeichnis nicht gefunden


    Es ist etwas schwierig von den Optionen auf das Kommando zu schließen, aber fehlt da nicht einfach das Paket gettext und dadurch wird das Makefile falsch gebaut?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • gda  
    danke, guter Hinweis. Das Paket hat gefehlt. Dann compiliert es eine zeit lang, um dann aber mit

    Code
    1. CC xineplug_vo_out_vaapi_la-video_out_vaapi.lo
    2. video_out_vaapi.c:69:23: fatal error: va/va_x11.h: Datei oder Verzeichnis nicht gefunden
    3. compilation terminated.
    4. make[3]: *** [xineplug_vo_out_vaapi_la-video_out_vaapi.lo] Fehler 1
    5. make[3]: Verlasse Verzeichnis '/root/tmp/xine-lib-vaapi/src/video_out'
    6. make[2]: *** [all-recursive] Fehler 1
    7. make[2]: Verlasse Verzeichnis '/root/tmp/xine-lib-vaapi/src/video_out'
    8. make[1]: *** [all-recursive] Fehler 1
    9. make[1]: Verlasse Verzeichnis '/root/tmp/xine-lib-vaapi/src'
    10. make: *** [all-recursive] Fehler 1


    zu enden. Mir fehlt wohl libva-dev oder so. Habe übrigens yavdr 4.0/ubuntu 11.04 (natty) installliert und habe hole das X11/intel/libva Zeug aus xorg-edgers/ppa. Ist das evtl zu unsicher?


    Update: kaum macht man's richtig so geht's :). Die Libs ham gefehlt. Werd mal schaun, wie/ob xine über vaapi läuft


    VG Kurt

    [font='Verdana, sans-serif'][size=8]vdr hd: Core i3 2100T, 2GB, Intel DH67BL, Tevii S480, Sandisk G25 SSD, 2TB HDD, Intel CIR, Harmony 300, MSI G210, yavdr 0.5

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von kh1309 ()

  • Ich hab mich gerade mal an die xine-lib vaapi rangetraut, kann sie aber leider nicht kompillieren.


    System ist Suse 12.1 mit Standardkernel.


    Platform information:
    --------------------
    system name : Linux
    release : 3.1.10-1.9-desktop
    version : #1 SMP PREEMPT Thu Apr 5 18:48:38 UTC 2012 (4a97ec8)
    machine : x86_64
    model name : Intel(R) Core(TM) i7-2700K CPU @ 3.50GHz



    ffmpeg, intel-Treiber und libva sind die aktuellsten GIT versionen



    beim Kompilieren der xine-lib-vaapi bricht es mit folgenden Fehler ab:



    Was mich auch noch wundert, wenn ich ein autogen vorher mache, sollte dann nicht auch zumindest vaapi als video driver plugin aufgelistet werden ???


  • VA-API GIT hat eine neue API:


    Code
    1. #ifndef VA_SURFACE_ATTRIB_SETTABLE
    2. /// make source compatible with old libva
    3. #define vaCreateSurfaces(d, f, w, h, s, ns, a, na) \
    4. vaCreateSurfaces(d, w, h, f, ns, s)
    5. #endif


    und alle vaCreateSurfaces ändern auf neue API.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Nicht ganz korrekt. Der master Tree weist diese API Änderung nicht nicht auf.

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Immer diese Erbsen Zählerei.


    Die Fehlermeldung war GIT (branch vaapi-ext oder staging) und wer nimmt schon GIT master?


    Die Änderung muß in ./src/video_out/video_out_vaapi.c.


    Die #define am Anfang möglichst nach den Includes, dann die vaCreateSurfaces ändern,
    oder den Macro umbauen, daß er aus der Alten Version die Neue macht.
    Ein paar Parameter sind vertauscht und zwei zusätzliche (Null, 0).


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Danke schon mal für die Klärung.
    Wie schaut es denn mit meiner anderen Frage aus ?
    Müsste nicht beim configure auch ein vaapi als video driver aufgelistet sein ??