Mac Mini und Sound über HDMI

  • Analog Sound und Sound über SPDIF funktionieren. Nur Sound über HDMI bekomme ich nicht hin:


    aplay ergibt:




    aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: NVidia [HDA NVidia], Gerät 0: Cirrus Analog [Cirrus Analog]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 0: NVidia [HDA NVidia], Gerät 1: Cirrus Digital [Cirrus Digital]
    Sub-Geräte: 0/1
    Sub-Gerät #0: subdevice #0
    Karte 0: NVidia [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 0: NVidia [HDA NVidia], Gerät 7: HDMI 0 [HDMI 0]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 0: NVidia [HDA NVidia], Gerät 8: HDMI 0 [HDMI 0]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0




    aplay -L
    null
    Discard all samples (playback) or generate zero samples (capture)
    front:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    Front speakers
    surround40:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    4.0 Surround output to Front and Rear speakers
    surround41:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Digital
    IEC958 (S/PDIF) Digital Audio Output
    hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
    hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 0
    HDMI Audio Output
    hdmi:CARD=NVidia,DEV=2
    HDA NVidia, HDMI 0
    HDMI Audio Output
    dmix:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    Direct sample mixing device
    dmix:CARD=NVidia,DEV=1
    HDA NVidia, Cirrus Digital
    Direct sample mixing device
    dmix:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample mixing device
    dmix:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct sample mixing device
    dmix:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct sample mixing device
    dsnoop:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    Direct sample snooping device
    dsnoop:CARD=NVidia,DEV=1
    HDA NVidia, Cirrus Digital
    Direct sample snooping device
    dsnoop:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample snooping device
    dsnoop:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct sample snooping device
    dsnoop:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct sample snooping device
    hw:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    Direct hardware device without any conversions
    hw:CARD=NVidia,DEV=1
    HDA NVidia, Cirrus Digital
    Direct hardware device without any conversions
    hw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
    hw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
    hw:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
    plughw:CARD=NVidia,DEV=0
    HDA NVidia, Cirrus Analog
    Hardware device with all software conversions
    plughw:CARD=NVidia,DEV=1
    HDA NVidia, Cirrus Digital
    Hardware device with all software conversions
    plughw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
    plughw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
    plughw:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Hardware device with all software conversions


    Hat jemand eine asound.conf, die funktioniert?


    Ich habe die Vermutung, dass auch an der Xine config was angepasst werden muss.


    Pete

  • Eine davon sollte gehen, eventuell noch die Mixer unmuten. Dann jeweils mit speaker-test probieren, ob sound kommt. Wenn Du die richtige Einstellung hast, musst Du noch die xine config entsprechend anpassen.



    Die xine config sollte in etwa so aussehen, je nach dem, was du in der asound.conf eingestellt hast.


    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hmm, alle 3 durchprobiert ohne Erfolg. :(


    Was meinst Du mit Mixer unmuten?


    Was muss ich bei speaker-test für Parameter eingeben?


    Braucht speaker-test eigentlich eine passende asound.conf oder kann ich damit testen, was überhaupt geht und danach entsprechend die asound.conf basteln?


    Pete

  • Was meinst Du mit Mixer unmuten?


    starte den Alsamixer und wenn in der Mitte in dem Kästchen MM drin steht, dann musst du mit der Taste M den Ton einschalten.

    Server: Lian Li PC-34F, i3 530, 4GB RAM, 1x 2,5" HDD,1x 6TB, 2x2TB HDD, TV Karte Max S8, openmediavault, vdr
    Client1: Origenae M10, Zotac ION ITX P, 4GB Ram, 40GB SSD, openelec
    Client2: Raspberry, openelec
    Client3: Raspberry, openelec

  • Einfach mal alsamixer aufrufen.


    Ansonsten:
    speaker-test -Dplughw:0,3
    speaker-test -Dplughw:0,7
    speaker-test -Dplughw:0,8

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Yep, der Tipp mit Alsamixer war gut. Jetzt habe ich auf Dev 8 Ton über HDMI. :)


    Seltsam allerdings, dass ich in alsamixer S/PDIF 3 unmuten musste. Die Zuordnung scheint dort nicht ganz zu stimmen.


    Pete