Wakeup-On-Lan: Gleicher Rechner: Bei EasyVDR geht es, bei LinVDR nicht. Was kann ich tun?

  • Hallo,


    ich hab seit ein par Jahren im Wohnzimmer einen VDR auf Linvdr-Basis (Mahlzeit 3.2).
    Alter HP-Firmenrechner, SkyStar2 Budget + DXR3.
    Läuft eigentlich ganz prima. Große Platte. Familie zufrieden.


    Ziemlich am Anfang hab ich versucht, Wakeup-On-Lan einzurichten.
    Ging einfach nicht, also hab ich mich damit abgefunden.


    Nun hab ich vor kurzem mal spaßeshalber mit einer alten, übrigen mini-Festplatte easyVDR installiert,
    nur um zu sehen, ob es überhaupt geht und was da besser ist.
    Da hat mich letztlich nicht zufrieden gestellt:
    Ausgabe mit DXR hat nicht vernünftig funktioniert,
    Rechner ist immer wieder mal eingefroren.
    Macht ja nichts, man hat ja ein laufendes System.


    Aber - Dort hat Wake-On-Lan sofort funktioniert. Und bei LinVDR eben gar nicht.


    Das hat mich natürlich schon motiviert, nochmal zu suchen.
    Aber sämtliche irgendwie passend aussehenden Menüpunkte oder Konfig-Dateien haben nichts gefruchtet.
    Und ergoogelt hab ich auch nichts Wirksames.


    Daher:


    Hat jemand genug Kenntnisse in beiden Welten um mir zu sagen, was man dann in LinVDR noch versuchen könnte.
    (Oder auch eine begründete Aussage dass es eben nicht geht.)


    Ich bin gern bereit auch noch verschiedene Tips auszuprobieren.


    Im Voraus vielen Dank für alle guten Ideen


    Mamaisen

  • Hallo,


    kann am Netzwerkmodul liegen. Eventuell benutzen EasyVDR und LinVDR verschiedene (Test mit lsmod)
    Habe das Problem auch, mit einer alten Debian Version ging WOL aber als ich dann auf den naechsten Release
    upgedatet habe, bei der eine anderes Treibermodul verwendet wurde ging es nicht mehr.


    Gruss
    Leo

    Hardware: Asus P5G41T-M LX, Gigabyte GeForce GT220, Digital Devices Cine S2 V6 & TechnoTrend Budget S2-1600, Hama MCE Remote Control
    Software: yaVDR 0.7 & neuste updates (
    ppa:yavdr/stable-vdr)
    Aktuell: yaVDR ansible

  • Hallo,
    hast du das mal versucht:
    http://www.vdr-wiki.de/wiki/index.php/WAKE_ON_LAN
    mit ethtool kann man da was machen.. vllt hilfts ja..


    [size=10]nOpacity: Icons
    [size=10]skindesigner: tryoutsglassy

  • kann am Netzwerkmodul liegen. Eventuell benutzen EasyVDR und LinVDR verschiedene (Test mit lsmod)
    Habe das Problem auch, mit einer alten Debian Version ging WOL aber als ich dann auf den naechsten Release
    upgedatet habe, bei der eine anderes Treibermodul verwendet wurde ging es nicht mehr.


    Selbst wenn es das gleiche Modul ist, dann ist es noch lange nicht das Selbe. Zwichen den Kernels von LinVDR und EasyVDR müssen doch Jahre liegen.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • die mahlzeit 3.2 hatte von Haus aus einen 2.6.18. Das aktuelle easyvdr 0.8 hat einen 2.6.28


    Es gibt aber von mir einen 2.6.29-Kernel für LinVDR, den ich aber nicht supporte. Zur Installation habe ich hier im Forum ein paar mal was geschrieben.


    Ich sehe nur das Problem, dass dann die dxr3 vielleicht auch nicht mehr besser läuft als mit easyvdr. Deren Treiber ist dann ja auch neuer und harmoniert möglicherweise weniger gut mit der alten vdr-Version und dem alten dxr3-Plugin.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Hab ich schon versucht. Danke.

    Ok, das hab ich noch nicht versucht. Dann muss ich die Platte nochmal anstöpseln.
    Ich melde mich wieder.

    Ok, ich hab nun doch zuerst die obigen Sachen probiert.
    ethtool zeigt an, dass WOL "g" möglich und auch WOL "g" eingeschaltet ist.


    Ein cat /proc/acpi/wakeup ergibt allerdings nur:


    Device Sleep state Status
    ICHB 4 disabled
    PS2K 4 disabled
    UAR1 4 disabled
    UAR2 4 disabled
    USB1 4 disabled
    USB2 4 disabled
    SLPB 4 * enabled


    Wer weiß was SLPB sein soll?
    Ich vermute mal, dass sich hinter ICHB das Motherboard versteckt. Und damit vielleicht die Onboard-Netzkarte?
    Aber ein cat ICHB > /proc/acpi/wakeup ändert zwar dessen Status auf enabled. Es geht aber dann trotzdem nicht.


    Also muss ich doch die andere Platte finden und vergleichen.

  • SLPB apparently stands for SLeeP Button


  • Ausgabe mit DXR hat nicht vernünftig funktioniert,
    Rechner ist immer wieder mal eingefroren.
    Macht ja nichts, man hat ja ein laufendes System.


    Bei mir ging das WOL mit Linvdr0.7 +ToxicTonic.....usw. hatte als Hardware eine 3Com die mit dem Mainborad (siehe VDR1) per WOL-Kabel verbunden war.


    Wenn es mit EasyVDR funtkioniert, aber die Ausgabe über die DXR nicht taucht, kauf für 30€ eine (neue) TechnoTrend Premium S-2300 "modded" inkl. Fernbedienung im DVB-Shop.
    Dann kannst du von dem alten Holzfloß* auf ein nues Boot umsteigen.


    * ich möchte LinVDR in keinster weisse hier abwerten, ich hatte es auch gerne und lange bei mir am laufen, aber es ist nun wirklich schon sehr lange und weit überholt
    Zumal selbst DukeNukemForever und die TT-DVBS2-FF mittlerweile erschienen sind, aber LinVDR0.8 wird es nicht mehr geben :(

  • Bei mir hat es geholfen in der /etc/init.d/rcShutdown ein :

    Code
    1. ethtool -s eth0 wol g


    einzufügen.

    Mein VDR: LinVDR 0.7 + MT, ASROCK K7VM4, Duron 1000@500, 128 MB RAM, Samsung SP1604+SP2014, Medion 4688, TT 1.3 + Skystar 2.6D