Kein EPG bei Cabelcom (Schweizer Kabel)

  • Ich habe das Problem, dass ich bei den meisten Sendern kein EPG bekomme. Ich habe schon die Epg.data gelöscht und die Channels.conf neu erzeugt, doch leider ohne Erfolg. Hat jemand einen Rat was ich noch tun kann? Ich bin auch schon lange auf dem Willkommens Kanal gewesen, leider auch ohne Erfolg.


    Ich benutze:
    - VDR 1.7.16
    - Ubuntu 10.10
    - Technotrend CT-3650CT
    - Sundtek MediaTV Pro

  • Evtl. senden die kein normales EPG? Manche Anbieter senden nur EPG in einem besonderen Format das nur ihre Receiver verstehen. Versuche das mal per Google zu klären.


    Es kann aber auch sein das sie die PIDs fehlerhaft senden, oder das die PIDs in deiner Kanalliste fehlerhaft sind (mal im Setup auf "PID automatisch aktualisieren" einstellen). Aber das ist nur geraten, ich bin mir nicht sicher in wie weit die PIDs Einfluss aufs EPG haben.



    Bekommst du am Ende wirklich kein EPG dann schau dir mal das xmltv2vdr Plugin an sofern du eine Möglichkeit findest EPG Daten im Web downzuladen (evtl. liefert ja das xmltv Projekt was für die Schweiz?).


    cu

  • Danke für die rasche Antwort.


    Jetzt hab ich Sender die kein Bild und keinen Ton haben aber dafür EPG haben. Kann es sein dass die Cabelcom eigene Sender für die EPG sendung benutzt?. Im Internet hab ich schon viel gesucht aber nur gefunden dass Cabelcom das EPG auf dem Willkommens Kanal sende. Leider half mir das auch nicht weiter.

  • Felice : im Gegensatz zum SAT Empfang wird der EPG nur auf einem bestimmten Transponder übertragen - welcher das ist hängt vom CC Netz ab. Der Sender RTS Sat müsste ein Treffer für alle Netze sein - findest du den, bleib eine Weile drauf und beobachte den EPG.

    MSI P6NGM-FD | ASROCK A785GXH | Grafik: GeForce 9400GT| DVB-S2 Karten: Twinhan VP 1041 & Skystar HD

  • Lou :
    Ich habe die Epg.data gelöscht und war dann lange auf dem Sender RTS Sat. Der Sender RTS Sat hat dann zwar Bild Ton und EPG aber die Anderen laufenden Sender leider trotzdem nicht.


    Keine_Ahnung :
    Wäre echt schade wenn ich ein externes EPG nehmen müsste. Ich hatte als ich noch in Deutschland wohnte Sat und war sehr zufrieden mit dem EPG. Andere Cabelcom Nutzer haben offenbar mit Cabelcom auch ein Standard EPG (http://www.topfield-europe.com/forum/showthread.php?t=37007 ), ich weiss nur nicht wiso es bei mir nicht Funtioniert.


    Vielen Dank für eure Hilfe

  • Naja, für genauere Ursachenforschung (da müsstet du dann aber einwenig Zeit investieren) müsstest du da vermutlich selbst ran (hier kann dir nicht wirklich jemand helfen weil wir das alle nicht nachvollziehen können). dvbsnoop http://dvbsnoop.sourceforge.net/ zeigt genau welches EPG Daten auf welchen Transpondern gesendet werden.


    Evtl. ist ja auch im VDR nen Bug der zufällig nur bei deisem Kabelnetzbetreiber für Probleme sorgt?



    Ne Googlesuche nach Cabelcom UND vdr hilft evtl. auch weiter?


    cu

  • Lou :
    Ich habe die Epg.data gelöscht und war dann lange auf dem Sender RTS Sat. Der Sender RTS Sat hat dann zwar Bild Ton und EPG aber die Anderen laufenden Sender leider trotzdem nicht.


    Dann probier andere Sender auf den Transponder aus (Welcome Channel etc.) - zapp hin und her. Bei den Dreamboxen klappt es danach. Wenn du die epg.data löscht darf ausserdem der vdr nicht laufen.

    MSI P6NGM-FD | ASROCK A785GXH | Grafik: GeForce 9400GT| DVB-S2 Karten: Twinhan VP 1041 & Skystar HD

  • Dann probier andere Sender auf den Transponder aus (Welcome Channel etc.) - zapp hin und her. Bei den Dreamboxen klappt es danach. Wenn du die epg.data löscht darf ausserdem der vdr nicht laufen.

    Ich war jetzt auf allen Kanälen die auf 458000 liegen für längere Zeit drauf, leider immer noch ohne Erfolg. Ich denke mein VDR oder Ubuntu ist etwas korrupt. Ich möchte demnächst auf Ubuntu 11.04 umsteigen und werde dann den VDR neu installieren. vielleicht habe ich ja Glück und es läuft dann plötzlich.


    Danke für die Tipps


    Kanäle die ich versucht habe:


    Welcome;Welcome:458000:M64:C:6900:60:61=ger:0:0:1:1:101:0
    RTS Sat;RTS Sat:458000:M64:C:6900:464+471:465:0:1801:661:1:101:0
    HRT TV 1;HRT TV 1:458000:M64:C:6900:592:593=hrv:595:1801:681:1:101:0
    Radio Beograd;Beograd:458000:M64:C:6900:0:913:0:0:1800:1:101:0
    Kral FM;Kral FM:458000:M64:C:6900:0:785=eng:0:0:1803:1:101:0
    HRT-HR1;HRT-HR1:458000:M64:C:6900:0:977=hrv:0:0:1807:1:101:0

  • Ich möchte demnächst auf Ubuntu 11.04 umsteigen und werde dann den VDR neu installieren. vielleicht habe ich ja Glück und es läuft dann plötzlich.


    Naja Ubuntu hat damit nix zu tun, wenn dann die VDR Version oder ein Patch dortdrin.


    Machs dir einfach und schau mal hier: http://wiki.xmltv.org/index.php/XMLTVProject
    Dann dazu einen xmltv Grabber für xmltv2vdr basteln (hat hier im Forum schonmal jemand getan) und gut ist.


    cu

  • Danke für die rasche Antwort.


    Jetzt hab ich Sender die kein Bild und keinen Ton haben aber dafür EPG haben. Kann es sein dass die Cabelcom eigene Sender für die EPG sendung benutzt?. Im Internet hab ich schon viel gesucht aber nur gefunden dass Cabelcom das EPG auf dem Willkommens Kanal sende. Leider half mir das auch nicht weiter.


    Lösch die Sender mit Bild&&Ton ohne EPG, aber lass die Sender _mit_ EPG am Ende der Kanalliste übrig. Die übrig gebliebenen Kanäle sollten dann upgedated werden.

  • Lösch die Sender mit Bild&&Ton ohne EPG, aber lass die Sender _mit_ EPG am Ende der Kanalliste übrig. Die übrig gebliebenen Kanäle sollten dann upgedated werden.

    Da ich nicht alle Sender doppelt habe habe ich mal probiert ob es mit der Einstellung neue Transponder hinzufügen neue Sender findet wenn ich nur noch einen in der Kanalliste übrig lasse. Dann hatten alle Sender EPG und die meisten Bild und Ton. Darum bin ich darauf gekommen dass W-Scan eine korrupte Kanalliste erzeugt. Habe danach WirbelScan benutzt, der findet die Sender mit EPG und Bild und Ton. Jetzt muss ich nur wieder alles ordnen und gut ist.


    Vielen Dank

  • Da ich nicht alle Sender doppelt habe habe ich mal probiert ob es mit der Einstellung neue Transponder hinzufügen neue Sender findet wenn ich nur noch einen in der Kanalliste übrig lasse. Dann hatten alle Sender EPG und die meisten Bild und Ton. Darum bin ich darauf gekommen dass W-Scan eine korrupte Kanalliste erzeugt. Habe danach WirbelScan benutzt, der findet die Sender mit EPG und Bild und Ton. Jetzt muss ich nur wieder alles ordnen und gut ist.


    Vielen Dank

    s


    Nö, nicht korrupt, sondern unvollständig. Was meist dann passiert, wenn deine Karte nicht gut empfängt.

  • Zitat


    Zitat wirbel:
    Nö, nicht korrupt, sondern unvollständig.

    Hi wirbel.
    Ist es möglich, dass man da eine Anpassung an wirbelscan macht damit man für diverse DVB-C Anbieter den Scan so ausführt, dass die Network ID korrekt ausgelesen wird ?
    Für MythTV ist z.B. dieses Script für einen korrekten Scan nötig. Siehe auch zugehöriger Thread.


    Und Erklärung aus MythTV Bug-Tracker.

    Zitat

    Same problem [ incorrect transport frequencies] in Switzerland with Cablecom Network.
    When I do a channelscan without the patch I get no valid transponder frequencies. Looking on the Cablecom Support Website I saw that they use what they call a Setup ID (which is nothing else than the Network ID) that has to be enter in the STB settings to identify the geographical location. I tried a Dreambox once, which did have no problems to scan for the right transponders. Also w_scan does get the right settings. So there might be two approaches to get around this, have the possibility to pass the Network ID to the scanner or rely on the physical data read from the card instead of the NIT.

    Als ich im VDR mit dem wirbelplugin scannte, bekam ich kein Ton/Bild bei 95% der Sender, dafür bei allen EPG. Als ich in der Konsole eine channels.conf generierte (w_scan -fc -cCH) bekam ich überall Bild/Ton aber nirgens EPG? VDR erstellt in letzterem Fall dann wie bereits oben erwähnt Sender-Duplikate (ohne Bild/Ton, dafür mit EPG).


    Helfe gerne mit mehr Info's.

    [SIZE=8] ASUS P7P55D, LGA 1156, i7 870@2.93GHz / 8GB DDR3 RAM / GeForce GT 520 (GF119) / WD RED 3 TB / KNC1 DVB-C mit SAA7146 (budget_av) / Terratec Cinergy DT XS (DVB-T)
    ansonsten Zweitinstallation: Archlinux, MythTV 0.27-fixes mit Kodi-pvr

  • Das Problem liegt genau darin, dass die Daten (vermutlich absichtlich) falsch gesendet werden. Soweit ich erkennen kann, wird die NIT actual (network information table) entweder falsch oder gar nicht gesendet, während alle Netzwerke in der NIT other (die Angabe anderer Netzwerke, aber nicht des aktuellen) Verweise auf alle (unter anderem des aktuellen) Netwerks enthalten. Ohne Angabe der ID oder der Information, welche Tuning Parameter aktuell korrekt sind, gibt es also keine verlässliche Information. Und die Tuning Parameter, die w_scan und wirbelscan wählen sind von der hardware abhängig.


    Ich möchte solche Art von Hacks nicht integrieren - ich mag nicht anschließend den Support dafür liefern.


    Zitat

    Als ich in der Konsole eine channels.conf generierte (w_scan -fc -cCH) bekam ich überall Bild/Ton aber nirgens EPG? VDR erstellt in letzterem Fall dann wie bereits oben erwähnt Sender-Duplikate (ohne Bild/Ton, dafür mit EPG).


    Das bedeutet, dass keine Daten von der NIT actual gefunden wurden.

    Zitat

    VDR erstellt in letzterem Fall dann wie bereits oben erwähnt Sender-Duplikate (ohne Bild/Ton, dafür mit EPG).


    Haben diese Kanäle mit EPG die gleiche Frequenz und FEC wie die mit Bild/Ton?

  • Hi wirbel

    Das Problem liegt genau darin, dass die Daten (vermutlich absichtlich) falsch gesendet werden. Soweit ich erkennen kann, wird die NIT actual (network information table) entweder falsch oder gar nicht gesendet, während alle Netzwerke in der NIT other (die Angabe anderer Netzwerke, aber nicht des aktuellen) Verweise auf alle (unter anderem des aktuellen) Netwerks enthalten. Ohne Angabe der ID oder der Information, welche Tuning Parameter aktuell korrekt sind, gibt es also keine verlässliche Information. Und die Tuning Parameter, die w_scan und wirbelscan wählen sind von der hardware abhängig.

    Entschuldige, aber ab "NIT other" kann ich dir nicht mehr folgen.

    Ich möchte solche Art von Hacks nicht integrieren - ich mag nicht anschließend den Support dafür liefern.

    Verständlich, leider leiden doch einige unter diesem nicht standardisierten Vorgehen ihrer DVB-C Anbieter. Es wäre halt schön eine Lösung zu haben. Ich würde auch selber daran sitzen, aber coden ist nicht drinn hier.

    Haben diese Kanäle mit EPG die gleiche Frequenz und FEC wie die mit Bild/Ton?

    1: w_scan in Konsole zu channels.conf, mit diesen: Bild/Ton ---> kein EPG 
    SF 1;upc:306000:M256:C:6900:60=2:61=deu@4,62=eng@4:63:1801,1850:2:1:74:0
    SF zwei;upc:306000:M256:C:6900:80=2:81=deu@4,82=eng@4:83:1801,1850:3:1:74:0

    2:
    Tuning auf obere Kanäle, erstellt folgende Dupliukate "auto-add new channels in VDR Einstellungen", Tuning auf diese: EPG --> kein Bild/Ton (logisch, keine V/A-PIDS)
    SF 1;upc:306000:M256:C:6900:0:0:0:0:2:1:69:0
    SF zwei;upc:306000:M256:C:6900:0:0:0:0:3:1:69:0


    3: Wirbelscan Plugin aus VDR
    SF 1;upc:306000:M256:C:6900:60:61=deu,62=eng:63:1801,1850:2:1:74:0
    SF zwei;upc:306000:M256:C:6900:80:81=deu,82=eng:83:1801,1850:3:1:74:0
    -----------
    Kombination aus 1&2 ergibt EPG & Bild/Ton
    --> SF 1;upc:306000:M256:C:6900:60=2:61=deu@4,62=eng@4:63:1801,1850:2:1:69:0
    --> SF zwei;upc:306000:M256:C:6900:80=2:81=deu@4,82=eng@4:83:1801,1850:3:1:69:0

    [SIZE=8] ASUS P7P55D, LGA 1156, i7 870@2.93GHz / 8GB DDR3 RAM / GeForce GT 520 (GF119) / WD RED 3 TB / KNC1 DVB-C mit SAA7146 (budget_av) / Terratec Cinergy DT XS (DVB-T)
    ansonsten Zweitinstallation: Archlinux, MythTV 0.27-fixes mit Kodi-pvr

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von schitthoch2 () aus folgendem Grund: Übersichtlichkeit, komme mit Zitatfunktion nicht zurecht :)

  • Dann ist die gesendete NIT actual _definitiv_ falsch und nicht standard konform.


    Damit hat nicht nur wirbelscan ein Problem, sondern auch VDR selbst kann diese Kanäle nicht updaten.
    Änderungen an Video-PID, Audio-PIDs, etc. wird VDR dann ebenso nicht können.

  • OK, macht denn das von mir oben verlinkte script (scan.sh) nicht genau die nötige Korrektur des NIT?


    In MythTV hatte dieses zusammen mit populate_channels.sh den Effekt das es meine Kanäle (zuerst Bild aber kein EPG aus MythTV Channelscan) so updatete, dass danach EPG erschien.


    Wenn ich verstehen kann, wie dies geschieht kann ich das script (scan.sh) evtl. so anpassen, dass der output eine channels.conf für vdr mit Korrektem NIT actual ist.


    Aber dafür müsste mir jemand die richtige Richtung weisen. :)


    Z.B. damit: Wie heisst der zweitletzte Eintrag einer VDR 1.7.20 channels.conf Zeile (SF zwei;upc:306000:M256:C:6900:80=2:81=deu@4,82=eng@4:83:1801,1850:3:1:74:0). Ist das die Network ID, die Service ID, der Multiplex oder sonst was? VDR-wiki erklärt dies nicht (mehr?).

    [SIZE=8] ASUS P7P55D, LGA 1156, i7 870@2.93GHz / 8GB DDR3 RAM / GeForce GT 520 (GF119) / WD RED 3 TB / KNC1 DVB-C mit SAA7146 (budget_av) / Terratec Cinergy DT XS (DVB-T)
    ansonsten Zweitinstallation: Archlinux, MythTV 0.27-fixes mit Kodi-pvr

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von schitthoch2 ()