[0.4Pre1] Imon Display wird nicht hell.

  • ich habe das imon display 15c2:0036 Display welches ich mit yavsr 0.3.0 mit dem vdr-plugin-lcdproc in betrieb habe. aber mit der 0.4Pre1 wird nicht einmal das display hell. was ist denn da anders?


    gruß


    dippes

  • hat jemand oben genanntes display zum laufen gebracht?

  • Sag mal, dippes, hast du die FB an der TV-Nova zum Laufen bekommen?


    nein,ich habe diese leider nicht in betrieb.

  • Hab kein yavdr 0.4, aber bei 0.3 hatte ich den Fall, dass mein Imon-VFD zwar erkannt wurde, aber das falsche Modul wurde geladen. Die Folge: FB ging, aber Display blieb dunkel, und es gab jede Menge Logeinträge in /var/log/messages. Um das zu umgehen, musste ich das richtige Modul explizit mit folgender Zeile in /etc/modules/lirc.conf angeben:

    Code
    1. options lirc_imon display_type=1


    Schau bei Dir mal in die Logfiles, ib es da irgendwelche Einträge mit Bezug zu imon gibt.


    Gruß, Nix

    • Server: Gigabyte H67-Board, i3-2120, 8GB Ram, 12 TB Video-Part., ca. 5000 Aufnahmen, 5x DVB-S (2x Cine S2, 1x USB), easyVDR 2.0 headless

    • WoZi-Client: Zotac ZBox ID86, Hama-MCE mit Harmony, keine Tuner, reiner Streaming-Client, easyVDR 2.0

    • zur Zeit wegen Pay-TV-Problematik leider nur E2-Infrastruktur

  • Ich würde mir wünschen:
    a) das gelesen wird ob das Problem schon bekannt ist
    b) Logs durchgeschaut werden um zusätzliche Infos anzuhängen
    c) wenn das Problem nicht bekannt ist und eine Ursache/Lsg gefunden wurde, ein Bug geöffnet wird


    Dem Log könnte man dann entnehmen ob das VFD erkannt wurde oder nicht (der Treiber heisst in der 0.4 übrigens imon).

  • Quote

    Logs durchgeschaut werden um zusätzliche Infos anzuhängen
    Dem Log könnte man dann entnehmen ob das VFD erkannt wurde oder nicht (der Treiber heisst in der 0.4 übrigens imon).


    Code
    1. Jul 19 17:13:16 FERNSEH-PC vdr: [1043] initJul 19 17:13:16 FERNSEH-PC vdr: [1043] initializing plugin: lcdproc (0.0.10-jw8): LCDproc Ausgabe
    2. Jul 19 17:13:22 FERNSEH-PC vdr: connection to LCDd at localhost:13666 established.
    3. Jul 19 17:13:22 FERNSEH-PC vdr: LCDproc-Plugin started at localhost:13666.
    4. Jul 19 17:13:22 FERNSEH-PC vdr: LCD output thread started (pid=1043), display size: 4x20


    Code
    1. 21.065081] input: iMON Remote (15c2:0036) as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/rc/rc0/input5
    2. [ 21.065182] rc0: iMON Remote (15c2:0036) as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/rc/rc0


    mehr habe ich leider nicht gefunden.


    das hatte ich bei der 04pre1 auch gemacht


    Code
    1. options lirc_imon display_type=1


    gruß


    dippes

  • Ich glaube die letzte Zeile von Steffen hast du ignoriert ;)
    Das Modul heist nicht mehr lirc_imon, sondern nur noch imon

    Code
    1. options imon display_type=1

    habe es geändert...aber das disply bleibt dunkel.nach was kann man noch schauen?

  • hier noch ein paar infos


    Code
    1. root@FERNSEH-PC:~# lsmod | grep imon
    2. rc_imon_pad 12505 0
    3. imon 32030 0
    4. ir_core 21212 13 rc_hauppauge_new,ir_lirc_codec,ir_sony_decoder,ir_jvc_decoder,cx88xx,rc_imon_pad,ir_rc6_decoder,imon,ir_rc5_decoder,ir_nec_decoder,ir_common


    Code
    1. root@FERNSEH-PC:~# ls -la /dev/lcd*
    2. crw------- 1 root root 180, 144 Jul 19 21:38 /dev/lcd0



    r


  • Augenscheinlich wird das Gerät ja gestartet. (Also lcd0 existiert)
    Sollte denn das Display sofort einen Mucks machen oder erst wenn LCDd korrekt drauf zugreift ?
    Ist hier niemand anders mit dem Gerät und kann grundsätzlich verifizieren das es nicht geht ?


    Ich habe und kenne das Gerät nicht ...

  • ist Dein imon-Display wirklich ein 4 x 20 ? evlt. ein Fehler in der LCDd.conf ?
    Gruss

  • Sollte denn das Display sofort einen Mucks machen oder erst wenn LCDd korrekt drauf zugreift ?

    also ohne das vdr-plugin-lcdproc zeigt das display "lcdproc server"


    ich denke jetzt mal das vielleicht das programm lcdproc nicht funktioniert.wie prüfe ich dies nach? in meinem funktionierenden yavdr 0.3.0 sehe ich in htop leider nicht das lcdproc läuft.


    dippes

  • ist Dein imon-Display wirklich ein 4 x 20 ? evlt. ein Fehler in der LCDd.conf ?
    Gruss


    ist schon richtig so mit der LCDd.conf funktioniert´s einwandfrei in yavdr 0.3.0

  • Braucht das Teil eine udev Rule wie das ...38?

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Braucht das Teil eine udev Rule wie das ...38?

    habe ich bei yavdr 0.3.0 nicht gebraucht.vielleicht bei yavdr 0.4pr1 da 64 bit?

    The post was edited 1 time, last by dippes ().

  • Nö, dann brauchst bei der 0.4 auch keine ;)

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Nabend,


    nur mal so nebenbei, wenn das Log sagt das ein 4x20er Display angesprochen wird, dann stimmt was mit der LCDd.conf nicht.


    Auch wenn du sagst diese conf funzt so, dann ist ist immer noch die Frage ob sie auch benutzt wird?


    Prüf doch mal welche .conf verwendet wird, oder sag uns wo du die .conf hinkopiert hast!


    Gruß
    Wolfgang

  • Prüf doch mal welche .conf verwendet wird, oder sag uns wo du die .conf hinkopiert hast!

    die LCDd.conf liegt in /etc da liegt aber auch eine LCDd.conf.dpgk-dist (das alles in yavdr 0.3.0 wos funktioniert) drinne.bei 0.4.0 kann ich erst schauen wenn famillie im bett.


    edit kann das sein das mein display nur 2 x 16 ist?


    zwei zeilen a 16 zeichen.


    so schaut meine LCDd.conf (yavdr 0.3.0) aus.

    The post was edited 1 time, last by dippes ().