Intel CIR Port - Erfahrungen?

  • Puh, also irgendwie ist das jetzt noch ein Showstopper. Linux bootet einfach nicht (oder nur sehr selten) sobald der Receiver dranhängt. Völlig unabhängig vom LCD-TV und ob ich den Receiver komplett abdecke oder nicht. Ansonsten funktioniert es. Wake-up, Tasten werden erkannt, XBMC lässt sich bedienen. Ich habe zwar einen TSOP1738, aber mit dem 1238, den ich vorher vom Atric benutzt habe, war es genauso. Das muss doch irgendeinen Grund haben.


    Auch ein halbes Jahr später mit einem anderen Board (Jetway NF9G statt NC9B) und einer neuen Installation mit neuem Kernel (Ubuntu 12.10 mit 3.5 statt 12.04 mit 3.2) habe ich noch keine Lösung für obiges Problem. Ich habe mir jetzt spontan auch noch mal einen zweiten Empfänger gelötet mit anderen Komponenten und nur in der Minimal-Variante mit 3 Bauteilen. Das Fehlerbild bleibt identisch: Linux hängt mit 50% Wahrscheinlichkeit beim Booten ohne Ausgabe oder sonstige Anzeichen. Dabei ist mir aufgefallen, dass dieses Problem auch auftritt, wenn überhaupt kein Empfänger am CIR-Header angeschlossen. Erst das Deaktivieren von CIR im BIOS hilft dauerhaft. Der Chip scheint bei beiden von mir getesteten Boards irgendein Fintek Super IO zu sein.


    Ich bin verzweifelt, wie kann ich die Ursache des Problem herausfinden? Welche Debug-Möglichkeiten habe ich? Linux steigt extrem früh beim Booten aus. so dass ich auch kein syslog oder ähnliches habe.

    Testsystem:
    Hardware: Lian Li C39, Core-i7-3632QM, Jetway NF9G-QM77, 4GB RAM, PicoPSU 160XT inkl 80W Morex, 3x 2,5" 1TB RAID5, 1xSamsung PM830 mSATA 128GB, 1x LG BDROM, 1x DD Cine CT (v6) + CI + Alphacrypt CAM
    Software: Ubuntu 13.04 mit 3.8 x64, VDR 2.0.1 + xbmc 12.2

  • Hat das was mit Intel CIR zu tun? Das ist doch ein Jetway CIR dann hier oder nicht?
    Der Intel CIR funktioniert auf meinem Board ohne Probleme mit beiden Ubuntu Versionen die du genannt hast.
    Du könntest evtl. mal OpenElec versuchen oder Windows, um das Problem einzugrenzen, aber ich glaube der Fehler ist
    in dem Thread falsch aufgehoben.

  • Fintek Super IO


    Tja, was geht heißt: Nuvoton CIR Transceiver. Bei Fintek SuperIO CIR wirst wohl Du Hand anlegen müssen. ;)


    Albert

  • Danke für eure Antworten. Auch wenn sie nicht direkt zielführend waren, haben sie mich in die richtige Richtung geführt.


    Natürlich lief bei mir das fintek-cir Modul. Das nuvoton tuts ja nur mit Intel. Den Thread habe ich verwendet, weil hier die CIR-Experten mitlesen und da sich die beiden Treiber nicht so sehr unterscheiden kann es ja durchaus sein, dass die geschilderten Symptome bekannt sind.


    Letztendlich scheint es aber ein Anfängerfehler gewesen zu sein. Ein simples depmod -a brachte die Lösung. Bei mir kommt fintek-cir aus media_build_experimental . Da ich die Module aber noch manuell kopiert hatte, waren die Abhängigkeiten kaputt, insbesondere die zu rc-core. Ich vermute, dass beim Booten mal rc-core und mal fintek-cir zuerst geladen wurde. In ersterem Fall gibt es keine Problem, in zweitem eine Kernel Panic, die ich aber nie gesehen habe. Das habe ich erst beim manuellen Laden der Module festgestellt.


    Edit: Das war's noch nicht. Modul war noch auf der blacklist

    Testsystem:
    Hardware: Lian Li C39, Core-i7-3632QM, Jetway NF9G-QM77, 4GB RAM, PicoPSU 160XT inkl 80W Morex, 3x 2,5" 1TB RAID5, 1xSamsung PM830 mSATA 128GB, 1x LG BDROM, 1x DD Cine CT (v6) + CI + Alphacrypt CAM
    Software: Ubuntu 13.04 mit 3.8 x64, VDR 2.0.1 + xbmc 12.2

    The post was edited 1 time, last by Flachzange: Ergänzung ().

  • Hi,


    ich kann hier mal bestätigen das mein Intel DH77EB erst aus dem S5 via CIR aufwacht nachdem einmal ein Windows nuvoton Driver irgendwas in die Register des Board bzw. Chips/Nvram geschrieben hat. :wand


    CU
    9000h

    Es ist eagl in wlehcer Reiehnfogle die Bchustebaen in Woeretrn vokrmomen. Huapstache der estre und leztte Bchustbae sitmmen.

  • Also nach Bios Update und Stromabschaltung bleibt die Funktion ja?!


    Stromabschaltung ist kein Problem. BIOS-Update, CMOS-Batterie entfernen oder vielleicht BIOS-Reset könnte eins werden. Würde mich schon interessieren, was hier die Eintragung in NVRAM kicken kann.


    Albert