HDMI mit XMBC kein Ton, aber Ton in yaVDR

  • Ich bin gerade dabei mir einen neuen VDR zusammenzubauen. Ich nutze dafür das Board Jetway NC98-525-LF (siehe http://www.jetway.com.tw/jw/ipcboard_view.asp?productid=750&proname=NC98-510-LF%20/%20NC98-525-LF) als Plattform. Die Tonausgabe soll über HDMI an einen Yamaha RX-V367 erfolgen. Das ganze klappt jetzt mit yaVDR soweit das ich den Ton (nach der Installation des ALSA Backports, vorher wurde die NVidia Soundkarte nicht erkannt) höre, die Wiedergabe läuft usw. Wenn ich jetzt allerdings zu XMBC mit "5-> 2 -> 1" wechsle höre ich noch die Systemsounds (Tastenklick), aber bei der Wiedergabe gibt es keinen Ton und auf keine Fehlermeldung von XMBC, dass der Ton nicht wiedergegeben werden kann. Ich habe alle möglichen Einstellungen auf der Seite von XMBC durch. Wenn ich den Ton bei yaVDR über die Onboard Intelkarte ausgeben lasse (dann höre ich natürlich nichts über HDMI) funktioniert die Tonwiedergabe bei XBMC einwandfrei. Ich glaube das yaVDR das Soundgerät beim Starten von XBMC nicht freigibt, aber irgendwie finde ich nichts weiter zu diesem Thema. Hat jemand noch eine Idee was ich testen könnte?

  • Hi,


    damit habe ich am Wochenende auch gekämpft.
    Ich kann dir mein Ergebnis heute Abend genau sagen. Jetzt nur aus dem Gedächtnis.


    Audio Output: HDMI
    AC3: Ja
    DTS: Ja
    Audio Output Device: Default
    Passthrough Device: hw:1,3 (Hab ich noch nicht getestet. Bis jetzt nur MP3s abgespielt)


    Gruß Lokutus

    Server: ZOTAC H55-ITX WiFi, Core i3, Ubuntu 10.4 Server mit yavdr Paketen und ein Paar mehr
    Client1: ZOTAC NM10-DTX WiFi, YaVDR 0.5

    Client2: ZOTAC Zbox ION2, openELEC

  • Schlag mich nicht, aber Dein Tipp mit "Audio Output Device: Default" war der richtige Weg. Ich bin mir 100% sicher das ich alle Einstellungen durchgetestet hatte... Naja egal, Hauptsache es geht jetzt erst einmal.



    Was mir noch aufgefallen ist beim Testen. Ein Audiogeräte (Karte 1, Gerät 3) funktioniert nicht wenn man es "als erstes" anspricht beim speaker-test. Nimmt man vorher aber Karte 1 Gerät 7 und dann erst Karte 1 Gerät 3 hört man einen Ton.

  • Hi cjhbabel,


    ich muss heute Abend nach auf ne Veranstaltung.
    Wenn ich es schaffe, gucke ich mal ob es bei mir geht.


    Ich werde mich melden.


    Gruß Lokutus

    Server: ZOTAC H55-ITX WiFi, Core i3, Ubuntu 10.4 Server mit yavdr Paketen und ein Paar mehr
    Client1: ZOTAC NM10-DTX WiFi, YaVDR 0.5

    Client2: ZOTAC Zbox ION2, openELEC

  • wenn du 2 Soundkarten hast (Onboard Intel, Audio per Nvidia) bei denen du parallel ausgeben willst, kommst du an der Konfiguration der asound.conf nicht drum herum. Dort leitest du "default" an beide Soundausgabegeräte gleichzeitig. In den einzelenn applikationen (yavdr, xbmc) brauchst du dann nur noch "default" angeben. Weiterhin musst du Module-Option angeben, welche Soundkarte als erstes geladen werden soll damit du diese dann exakt in der asound.conf darauf zugreifen kannst.
    Wenn du das nämlich nicht machst ist es immer ein glücksspiel ob du sound hast oder nicht, je nachdem welche Soundkarte als erstes geladen wurde.
    So habe ich es auch (Soundkarte onboard -> HDMI zum TV; Soundkarte USB -> Receiver Onkyo) und es klappt perfekt.

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Eventuell habe ich mich richtig ausgedrückt. Ich will den Ton nicht auf zwei Soundkarten gleichzeitig ausgeben. Ich will den Ton ausschliesslich über HDMI an den Receiver weitergeben. Irgendwie klappt es mal und dann wieder nicht. Und es ist auch ein Unterschied ob ich einen Kaltstart mache oder irgendwas vorher schonmal aktiv war.


    Aber ich werde mal den Tipp mit der asound.cfg versuchen. Eventuell kann ich ja da einfach zwei "virtuelle" Soundkarten konfigurieren die die gleiche Hardware nutzen.

  • So, gestern abend habe ich noch ziemlich lange gebastelt und ich glaube das Probleme jetzt gelöst zu haben. Allerdings will ich das ganze heute abend nochmal komplett durchtesten, nicht das irgendwas wieder nach dem Neustart nicht klappt. Ich poste dann die Lösung wenn es geklappt hat.

  • völlig egal ob du ton auf 2 oder nur auf einer soundkarte ausgeben möchtest. Entscheidend ist, wieviel Soundkarten du im System hast, und das sind nunmal zwei

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Hi cjhbabel,



    ich habe es hinbekommen.
    Du musst unter /etc/modprobe.d eine Datei alsa.conf mit folgendem Inhalt erstellen:

    Code
    1. options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2



    Dadurch gibt es nur noch ein Nvidia HDMI Gerät

    Code
    1. **** Liste der Hardware-Geräte (PLAYBACK)****Karte 0: Intel [HDA Intel], Gerät 0: ALC888 Analog [ALC888 Analog] Sub-Geräte: 1/1 Sub-Gerät #0: subdevice #0Karte 0: Intel [HDA Intel], Gerät 1: ALC888 Digital [ALC888 Digital] Sub-Geräte: 1/1 Sub-Gerät #0: subdevice #0Karte 1: NVidia [HDA NVidia], Gerät 3: NVIDIA HDMI [NVIDIA HDMI] Sub-Geräte: 0/1 Sub-Gerät #0: subdevice #0


    Jetzt kannst du im XBMC an beiden Ausgabeoptionen "Nvidia HDMI" auswählen und schon sollte Ton funktionieren.


    Gruß Lokutus



    PS: Sollte wie bei mir nach der Aktion xine nicht mehr hochkommen, musst du mit

    Code
    1. sudo dbset system.hardware.alsa.hdmi.device=3process-template /etc/xine/config


    das Ausgabedevice in xine ändern.

    Server: ZOTAC H55-ITX WiFi, Core i3, Ubuntu 10.4 Server mit yavdr Paketen und ein Paar mehr
    Client1: ZOTAC NM10-DTX WiFi, YaVDR 0.5

    Client2: ZOTAC Zbox ION2, openELEC