VLC mit AtmoLight unter unter OSX compilieren

  • Ich hab endlich mal zugriff auf einen neueren Mac gehabt. Auf meinem NewWorld 12"-G4-Powerbook lässt sich kein halbwegs aktueller VLC mehr übersetzen.
    Dabei ist mal ein VLC-Binary mit atmo-support rausgekommen. Testen konnte ich das leider nicht (ich war nur per ssh drauf).


    Download der Binarys (darwin, x64) ist hier:
    http://ca.rstenpresser.de/~cpresser/data/unsorted/vlc.tar.bz2
    http://ca.rstenpresser.de/~cpresser/data/unsorted/vlc.tar.bz2.md5


    Compilieren lässt sich das ganze doch relativ einfach nach der Anleitung aus dem VLC-Wiki (google: vlc, compile, osx). Ich habs anstatt mit dem GIT-head mit version 1.1.9 gemacht.


    Damit sich der Atmo-Filter auch bauen lässt sind zwei manuelle änderungen notwendig.
    0. Source-Datei entpacken
    1. in der Datei "configure.ac" die beiden zeilen 3961 und 3965 löschen (das sind tests auf OS und compiler)
    2. in der Datei "modules/video_filter/atmo/AtmoChannelAssignment.cpp" die Zeile 16 (malloc.h) löschen
    3. bootstrap und compile wie im Wiki angegeben.

  • Hi und danke für den Thread!


    ehrlich gesagt weiß ich gar nicht wo ich anfangen soll. Ich glaube es wäre einfacher es selbst zu machen als es mir zu erklären Schritt für Schritt :/

  • hey,
    verfolge die diskussion schon länger.
    brauche unbedingt was vergleichbares wie atmowin für den mac ;)
    hab versucht es zu compilen. allerdings finde ich in den von dir verlinkten sources kiene configure.ac oder gar den modules ordner.
    gruß
    max

  • hey,
    verfolge die diskussion schon länger.
    brauche unbedingt was vergleichbares wie atmowin für den mac ;)
    hab versucht es zu compilen. allerdings finde ich in den von dir verlinkten sources kiene configure.ac oder gar den modules ordner.
    gruß
    max

    Lad dir mal den VLC Sourcecode von der Homepage, dort findest du die besagten Ordner. Glaube ich zumindest, dass er das meint. Schön dass es noch einen gibt, wie mich :)

  • also die malloc.h ist in zeile 11, hab jetzt einfach mal 3955 und 3959 gelöscht.
    lässt sich zwar alles compilieren, aber immer noch kein atmo filter in den einstellungen.


    slime: hast du es schonmal geschafft den filter unter macos zu aktivieren ?


    ich würde nen macbook pro von 2008 zur verfügung stellen, um sowas wie AtmoMac zu programmieren ?
    Und meine Hilfe! ;)


    Lg
    Max


  • Soweit bin ich auch. Sry, kp :/

    Da es nur eine Zeile mit 'malloc.h' gibt solle diese eigentlich gut zu finden sein.


    Bei configure.ac

    Code
    1. AS_IF([test "${enable_atmo}" != no], [
    2. AS_IF([test "${SYS}" = "mingw32" -o "${SYS}" = "linux"], [
    3. AC_LANG_PUSH(C++)
    4. VLC_ADD_PLUGIN([atmo])
    5. AC_LANG_POP(C++)
    6. ])
    7. ])


    wird zu

    Code
    1. AS_IF([test "${enable_atmo}" != no], [
    2. AC_LANG_PUSH(C++)
    3. VLC_ADD_PLUGIN([atmo])
    4. AC_LANG_POP(C++)
    5. ])


    Ansonsten der Anleitung aus dem VLC-Wiki folgen.


    Eine komplett neues Programm (AtmoMac) kann ich nicht schreiben. Das ist jeneseits meiner Möglichkeiten.


    Am Wochenende auf dem VDR-Camp hab ich auch die möglichkeit genutzt mit einem neueren Mac ein wenig zu spielen. Das compilieren hat auch geklappt, der Filter hat sich aktivieren lassen. Allerdings hat die Atmo-Hardware prinzpiell nicht mir dem Mac reden wollen. Auch auf der Console habe ich da nichts hinbekommen.
    Das werde ich mit meinem alten Powerbook mal nachvollziehen und versuche zu debuggen.

  • hey,
    okay werds gleich nochmal ausprobieren.
    hast du denn kontakt zu den leuten die atmowin programmiert haben ? basiert ja auf c++ sollte nicht zu schwer sein es zu portieren.
    mit dem "screen" befehl im terminal bekomm ich auch keine verbindung zur hardware, benutze allerdings auch keine atmohardware.
    das programm "zterm" hilft auch nicht weiter der serielle controller will einfach nicht antworten.
    wär toll wenn du da weiterkommst.
    gruß
    max

  • so,
    gleiches problem. filter lässt sich aktivieren. einstellung können gemacht werden. keine reaktion vom gerät.
    allerdings stürtzt vlc abundzu ab und zeigt nicht immer bild.
    lg max

  • Kannste es mal uploaden? Ich hab die AtmoHardware und könnte es testen.


    Ich habe spaßeshalber mal ein virtuelles Windows über Parallels auf dem Mac laufen lassen... dort konnte ich auf die AtmoHardware problemlos zugreifen. Aber hat wohl wenig mit dem Thema hier zu tun.


    Gruß

  • Hallo,


    da melde ich mich auch mal zu Wort. Wenn Ihr den AtmoFilter für VLC ohne Probleme mit wenigen Änderungen an "configure.ac" zum Laufen bekommt. Würde ich ggf. die Änderungen die notwendig sind in den Source übernehmen und ins VLC Repository einpflegen nur müßte man dann noch den Maintainer der Mac VLC Variante herausfinden - dass dieser den AtmoFilter enabled - so dass auch die nachfolgenden Releases von VLC mit dem Filter geliefert werden. (das dürfte aber eher ein kleineres Problem sein.)


    Warum der Atmo Filter nicht mit der Hardware redet? - schonmal VLC mit Debug Ausgaben laufen lassen? (Meldungen Fenster --> Strg + M aufrufen und dort vor der Wiedergabe das Verbosity Level auf 2 setzen - dann erscheinen dort mit ein wenig Glück auch Meldungen vom Atmo Filter - vielleicht ist das ja ein entscheidender Hinweis dabei.


    Vielleicht gibt es ja auch ein Problem mit den API's für die Serielle Schnittstelle unter MacOS? - warum die Kommunikation streikt?



    Igor

  • hey,
    hänge mal das protokoll file an. habe gerade keine zeit mehr durchzugucken. mach ich später.
    problem
    ist wenn ich meiner meinung nach alles richtig eingestellt habe mit
    atmolight filter. zeigt vlc kein bild an und stürtzt ab. ton ist soweit
    da.




    kann das gerät auch nicht mit zterm ansprechen glaub ich.b bekommt zwar ne verbindung aber kann keine daten senden.

  • Jetzt bin ich aber verwundert, das ihr versucht atmo auf MacOS zu kompilieren, denn in den diversen Apple Foren haben sich schon alle "Insider" die Zähne daran ausgebissen, da die Verarbeitung inkompatibel ist.


    Dementsprechend gab es auch bereits in den diversen Foren (beispielsweise Apfeltalk) immer mal wieder Bestrebungen auf der Basis einer laufenden Anwendung (z.B. Boblight) etwas Eigenes zu entwickeln...


    Da bin ich mal gespannt, ob ihr das zum Laufen bekommt :]


    Hardware:______Antec Veris Fusion Remote / Zotac IONITX-P-E SU2300 CULV / 4 GB Kingston HX LL / 2,0 TB Seagate Barracuda XT / Digital Devices Cine S2 / Denon 4308 / Wharfedale Opus / Panasonic TX-P50VT20E
    Ambilight:______Sedu Board & Stripes von Nino (Led-Styles.de-Forum)
    Software:_______nach Krautmaster's Guide > Ubuntu 10.10 64bit minimal, XBMC Dharma 10.0, VDR 1.7.17, VNSI, etc. > zusätzlich OSCam, SC

  • Die VLC.app lässt sich bei mir gar nicht öffnen. Fehler (Ignorieren, Bericht anzeigen)


  • Warum der Atmo Filter nicht mit der Hardware redet? - schonmal VLC mit Debug Ausgaben laufen lassen? (Meldungen Fenster --> Strg + M aufrufen und dort vor der Wiedergabe das Verbosity Level auf 2 setzen - dann erscheinen dort mit ein wenig Glück auch Meldungen vom Atmo Filter - vielleicht ist das ja ein entscheidender Hinweis dabei.


    Vielleicht gibt es ja auch ein Problem mit den API's für die Serielle Schnittstelle unter MacOS? - warum die Kommunikation streikt?


    Ich konnte das mangels Zeit auch nicht genauer testen.
    Nachdem der Filter nicht direkt wollte habe ich es mal auf der shell mit 'echo blah > /dev/tty??' probiert.
    Aber auch nach diversen Versuchen mit einfachen C-Programmen (sowas habe ich zum Atmo-Testen) hab die die Hardware nicht dazubringen können mal eine LED zu aktivieren. Ich vermute da schon eher einen systematischen Fehler meinerseits.


    @DaChris: Mir mag jetzt nicht so direkt einleuchten, warum das nicht gehen sollte. Der Filter arbeitet ja im VLC, eigentlich (TM) hat das mit dem Betriebsystem ja nix zu tun.Evtl. gabs da bei PowerPC dank BigEndian probleme, aber da sind wir dank x86 ja vorbei :)

  • Quote

    @DaChris: Mir mag jetzt nicht so direkt einleuchten, warum das nicht gehen sollte. Der Filter arbeitet ja im VLC, eigentlich (TM) hat das mit dem Betriebsystem ja nix zu tun.Evtl. gabs da bei PowerPC dank BigEndian probleme, aber da sind wir dank x86 ja vorbei :)


    ...keine Ahnung an was es lag oder liegt, augenscheinlich scheint es jedoch noch niemand laufen zu haben, obwohl überall immer mal wieder Leute aufeinander treffen, die es gerne laufen hätten... ;-)


    Hardware:______Antec Veris Fusion Remote / Zotac IONITX-P-E SU2300 CULV / 4 GB Kingston HX LL / 2,0 TB Seagate Barracuda XT / Digital Devices Cine S2 / Denon 4308 / Wharfedale Opus / Panasonic TX-P50VT20E
    Ambilight:______Sedu Board & Stripes von Nino (Led-Styles.de-Forum)
    Software:_______nach Krautmaster's Guide > Ubuntu 10.10 64bit minimal, XBMC Dharma 10.0, VDR 1.7.17, VNSI, etc. > zusätzlich OSCam, SC