Lost files in VDR NFS share

  • Hi,
    This problem is driving me to corner. I haven't found any solution to this.
    First about my VDR system.
    There is mediaserver(NFS) and 3 clients. All these run Fedora 14 and VDR 1.6.0 installed from Fedora and rpmfusion repos.
    Server has 6 NFS shares in 6 different harddisks. Server runs also VDR and handles timer recordings. Server is shut down if any of clients are not answering to ping and no recording is ongoing. Server is powered up wake-on-lan or bios wake up event.
    Server FSTAB looks like this:
    "/dev/mapper/vg_vdrsrv-lv_root / ext4 defaults 1 1
    UUID=1a29d00a-bdb0-477e-bc45-0178a105a27e /boot ext4 defaults 1 2
    /dev/mapper/vg_vdrsrv-lv_home /home ext4 defaults 1 2
    /dev/mapper/vg_vdrsrv-lv_swap swap swap defaults 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0
    UUID=2b2c7990-6872-49f8-8ad4-3582c50ae2ff /srv/video0 ext4 defaults 0 0
    UUID=d4b8f5b6-ec4f-4295-8991-d7f3e09e44c4 /srv/video1 ext4 defaults 0 0
    UUID=517ba8f2-70c4-4812-8b30-c3091b1e242e /srv/video2 ext3 defaults 0 0
    UUID=02594aab-c6fc-41e1-be92-63043832cfd4 /srv/video3 ext3 defaults 0 0
    UUID=cf0c0c9e-9263-4371-a3c0-08c4c90c4ca7 /srv/video4 ext4 defaults 0 0
    UUID=f26e1ba0-0d6d-43a1-b07b-f46459820dd7 /srv/video5 ext4 defaults 0 0
    "
    And server EXPORTS like this:
    "/srv/video0 192.168.1.0/24(rw,insecure,sync,no_wdelay,nohide,no_root_squash)
    /srv/video1 192.168.1.0/24(rw,insecure,sync,no_wdelay,nohide,no_root_squash)
    /srv/video2 192.168.1.0/24(rw,insecure,sync,no_wdelay,nohide,no_root_squash)
    /srv/video3 192.168.1.0/24(rw,insecure,sync,no_wdelay,nohide,no_root_squash)
    /srv/video4 192.168.1.0/24(rw,insecure,sync,no_wdelay,nohide,no_root_squash)
    /srv/video5 192.168.1.0/24(rw,insecure,sync,no_wdelay,nohide,no_root_squash)
    "
    Client FSTAB looks like this:


    "
    #
    # /etc/fstab
    # Created by anaconda on Mon Dec 6 02:36:32 2010
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    /dev/mapper/vg_vdrnxt-lv_root / ext4 defaults 1 1
    UUID=3be614c9-0064-40d8-b46a-2d7358259b53 /boot ext4 defaults 1 2
    /dev/mapper/vg_vdrnxt-lv_home /home ext4 defaults 1 2
    /dev/mapper/vg_vdrnxt-lv_swap swap swap defaults 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0
    #/dev/vg_vdr1/lv_root /old ext4 defaults 0 0
    192.168.1.38:/srv/superv /srv/superv nfs rw,hard,intr 0 0
    192.168.1.38:/srv/video0 /srv/video0 nfs rw,hard,intr 0 0
    192.168.1.38:/srv/video1 /srv/video1 nfs rw,hard,intr 0 0
    192.168.1.38:/srv/video2 /srv/video2 nfs rw,hard,intr 0 0
    192.168.1.38:/srv/video3 /srv/video3 nfs rw,hard,intr 0 0
    192.168.1.38:/srv/video4 /srv/video4 nfs rw,hard,intr 0 0
    192.168.1.38:/srv/video5 /srv/video5 nfs rw,hard,intr 0 0
    "


    There is now a big problem. Suddenly some parts of recording are lost like you see in attachment.
    Can any one help me and tell what is happening. There is no errorlog in any of these server or client machines.
    This occurs few times in month. This started about month ago.


    PLEASE HELP!!