Auto Shutdown verhindern

  • Hallo, ich habe auf meinem Ubuntu Natty Fileserver VDR nachinstalliert jedoch stört dieser den 24/7 Betrieb.
    Ich würde den VDR gerne automatisch mit dem System starten aber auf das automatische herunterfahren völlig verzichten.
    In der /etc/default/vdr habe ich dafür bei shutdown eine 0 gesetzt was jedoch scheinbar nichts bewirkt.
    Automatisch gestartet wird der VDR zudem auch nicht obwohl auch hier der eintrag in der /etc/default/vdr stimmt...


    Vielen Dank schonmal für eure Hilfe

  • Tja, der VDR selber bringt kein init Script (also was was in /etc/init.d liegt und /ect/default/vdr auch auswertet) mit, wo hast du deines denn her?


    Edit: Ups, das Ding macht ja upstart und nicht SysV-Init. Fang mal an zu lesen: http://wiki.ubuntuusers.de/Upstart


    cu

  • Ich habe den VDR aus diesem ppa. nach der installation existiert eine datei /etc/int.d/vdr und ich dachte diese sollte automatisch gestartet werden. Wegen der Upstart problematik werde ich jedoch mal lesen...
    Aber nochmal zu dem Shutdown Problem. Über das OSD könnte man ja die Zeit bis zum shutdown beliebig verlängern aber wo kann ich diese Einstellung ohne OSD per Terminal vornehmen?

  • Du kannst bei gestopptem VDR diese Option auch in der /etc/vdr/setup.conf anpassen. Wenn du die Zeit für auf 0 setzt, werden die Shutdown-Timer deaktiviert.

    Code
    1. MinEventTimeout = 0
    2. MinUserInactivity = 0

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich habe den VDR aus diesem ppa. nach der installation existiert eine datei /etc/int.d/vdr und ich dachte diese sollte automatisch gestartet werden.


    Ja, eigentlich schon. Aber lese mal einwenig im geposteten Link zu upstart, evtl. muss da ja noch aktiviert werden oder so was. Kenne mich mit upstart nicht aus.


    cu

  • Habe jetzt einfach die vdr.conf aus dem yavdr svn kopiert und das scheint zu funktionieren. In der log gibt es zwar die ein oder andere Fehlermeldung, zb:

    Code
    1. May 21 14:21:09 Server vdr: [1292] ERROR: no OSD provider available - using dummy OSD!


    ...und er versucht unnötigerweise LIRC zu laden aber das soll mir egal sein denn es funktioniert trotzdem.
    Ob die Einstellung in der setup.conf erfolgreich war wird sich zeigen. Vielen Dank für die schnelle Hilfe