Cine S2 HD - Bild ist nicht gestochen scharf (wie beim Receiver)

  • Hallo,


    ich habe soeben nochmal meinen vdr am TV ausprobiert. Bei ARD HD ruckelt das Bild und der Ton hat ständig aussetzer. Aber auch die Qualität bei anderen Programmen ist deutlich schlechter als bei meinem Receiver.


    HW und SW bitte meiner Signatur entnehmen.


    Ich habe heute noch die "aktuellen" Treiber von

    Code
    1. hg clone http://linuxtv.org/^C/v4l-dvb/

    herunter geladen und mit make und make install installiert. Reboot und fertig.





    Im Logfile finde ich diese Meldung sehr häufig:

    Code
    1. May 19 17:19:08 marge vdr: [3249] [demux_vdr] ts2es: no payload, size 0
    2. May 19 17:19:08 marge vdr: [3249] [demux_vdr] ts2es: no payload, size 0
    3. May 19 17:19:08 marge vdr: [3249] [demux_vdr] ts2es: no payload, size 0
    4. May 19 17:19:16 marge vdr: [3249] [demux_vdr] ts2es: no payload, size 0
    5. May 19 17:19:17 marge vdr: [3249] [demux_vdr] ts2es: no payload, size 0


    Habt ihr ähnliche Probleme?

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • hi,


    also die cinse s2 dvb-karte empfängt nur die dvb-daten, die grafische darstellung (das was du bemängelst) ist sache des ausgabe device/plugin und da hast du nichts zu geschrieben
    das verwendete board impliziert etwas vdpau basiertes und du benutzt c't vdr
    ich würde dir empfehlen das in der distributionspezifischen gruppe zu diskutieren


    http://www.vdr-portal.de/board…bssystem/board69-c-t-vdr/


    bzw. bemüh doch mal die suchfunktion
    "ts2es: no payload, size 0" bringt treffer

  • Danke für die Antwort.


    Bin mir nicht sicher, ob es an dieser Fehlermeldung liegt.


    Ist aber schonmal beruhigend, dass es nicht an der Cine S2 liegt (war nicht wirklich billig), sondern an der Ausgabe über die grafische Schnittstelle des Servers (mit vdpau).
    Mal schauen, wie ich dies optimieren kann.....



    Wie sieht dies bei denen aus, die auch das MB POV 330 benutzen???

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • - wie ist deine cpu Last? (htop)
    - welches Frontend und wie wird das gestartet? (Parameter?)
    - welcher Deinterlacer und wo konfiguriert?

    Code
    1. watch -t fold -100 /dev/vcs10


    Lies doch mal die Wiki zu VDPAU, ansonsten WBREU hat auch eine gute Seite mit Infos dazu



    Das hört sich ganz danach an, als wenn Du nur per Softdecoder arbeitest, aber kein vdpau. Hat der ctvdr überhaupt mittlerweile vdpau Unterstützung? Von Hause aus kennt der nur FF Karten und irgendwie ist das Projekt doch so ziemlich eingeschlafen,d.h. für aktuellere Sachen also nicht mehr die beste Wahl. Da gibt es fertige Distris oder PPA´s die Dir das Leben einfacher machen.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
     Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Habe nur folgende devices unter /dev/

    Code
    1. ls -l /dev/vcs
    2. vcsvcs1 vcs2 vcs3 vcs4 vcs5 vcs6 vcs7 vcsa vcsa1 vcsa2 vcsa3 vcsa4 vcsa5 vcsa6 vcsa7


    Ich habe folgende vdr-Pakete auf meinem debian squeeze installiert:


    Ich habe folgende vdr-Prozesse nach einem Start des vdr's laufen (eigentlich inkl. --video=vdpau):

    Code
    1. root 2788 1 0 May19 ? 00:01:50 /bin/sh /usr/lib/vdrconvert/bin/vdrconvert.sh > /var/log/vdrconvert.log 2>&1
    2. 117 2819 1 0 May19 ? 00:07:42 vdradmind
    3. vdr 3091 2912 0 May19 ? 00:00:00 /usr/sbin/nodm
    4. vdr 3171 3091 0 May19 ? 00:00:00 /usr/bin/ck-launch-session /usr/bin/dbus-launch --exit-with-session x-window-manager
    5. vdr 3200 3171 0 May19 ? 00:00:00 /usr/bin/ssh-agent /usr/bin/ck-launch-session /usr/bin/dbus-launch --exit-with-session x-window-manager
    6. vdr 3227 3171 0 May19 ? 00:00:26 fluxbox
    7. vdr 3236 1 0 May19 ? 00:00:00 /usr/bin/dbus-launch --exit-with-session x-window-manager
    8. vdr 3245 1 0 May19 ? 00:00:00 /usr/bin/dbus-daemon --fork --print-pid 6 --print-address 8 --session
    9. root 28107 1 0 16:11 ? 00:00:00 /bin/sh /usr/sbin/runvdr -v /share/filme -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown-message -E /var/cache/vdr/epg.data -u vdr -g /tmp --port 6419 --lirc -P "burn --dvd=/dev/sr0" -P epgsearch -P "live --port=8008 --ip=0.0.0.0" -P externalplayer -P femon -P "dvdswitch " -P weatherng -P mp3 -P epgsearchonly -P "mplayer --mount /usr/share/vdr-plugin-mplayer/mount" -P "dvd -C /var/cache/vdr/dvd" -P lcdproc -P noepgmenu -P "xineliboutput --local=sxfe --video=vdpau --audio=alsa --display=:1.0 --fullscreen --primary --remote=127.0.0.1:37890" -P menuorg -P conflictcheckonly -P "tvonscreen --logos /usr/share/vdr-xpmlogos" -P quickepgsearch -P "xine -r" -P "skinenigmang --logodir=/usr/share/vdr-enigmang-icons --epgimages=/var/cache/vdr/epgimages" -P "skinsoppalusikka --logodir=/usr/share/vdr-xpmlogos" -P text2skin -P streamdev-server -P streamdev-client -P sysinfo --vfat -w 60 -D 0
    10. vdr 28121 28107 9 16:11 ? 00:00:12 /usr/bin/vdr -v /share/filme -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown-message -E /var/cache/vdr/epg.data -u vdr -g /tmp --port 6419 --lirc -P burn --dvd=/dev/sr0 -P epgsearch -P live --port=8008 --ip=0.0.0.0 -P externalplayer -P femon -P dvdswitch -P weatherng -P mp3 -P epgsearchonly -P mplayer --mount /usr/share/vdr-plugin-mplayer/mount -P dvd -C /var/cache/vdr/dvd -P lcdproc -P noepgmenu -P xineliboutput --local=sxfe --video=vdpau --audio=alsa --display=:1.0 --fullscreen --primary --remote=127.0.0.1:37890 -P menuorg -P conflictcheckonly -P tvonscreen --logos /usr/share/vdr-xpmlogos -P quickepgsearch -P xine -r -P skinenigmang --logodir=/usr/share/vdr-enigmang-icons --epgimages=/var/cache/vdr/epgimages -P skinsoppalusikka --logodir=/usr/share/vdr-xpmlogos -P text2skin -P streamdev-server -P streamdev-client -P sysinfo --vfat -w 60 -D 0


    Die CPU-Last ist OK, soweit ich dies über ssh und OHNE aktueller Ausgabe über HDMI am TV sehen kann. Müsste ich allerdings mit Ausgabe über TV noch nachreichen.




    Habe mir die Links angeschaut. Meine, dass diese "teilweise" veraltet sind, was die Pakete anbelangt. Allerdings weiß ich nicht, wie ich mein Problem lösen kann.



    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • Ok, die Frage war eine gute Vorlage ... ;-)

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • Ich kenne mich mit ctvdr nicht soweit aus. Aber hast Du denn nun herausgefunden ob Du vdpau überhaupt nutzt? Ansonsten logs helfen auch immer weiter, die längeren bitte als Link über pastebin hier posten.


    Alleine schon nvidia-settings sieht bei Dir anders "18.Mai 2010" aus und ziemlich alt:
    Mal ein Beispiel vom korrekt installiertem 270.16:


    ob vdpau genutzt wird erkennt man auch an anderen Infos, u.a. im syslog. Ohne nähere Details wirst Du kaum mehr Hilfe bekommen. Und nochmals, ob der CTVDR als Grundlage geeignet ist einen aktuellen HD-VDR zu erstellen halte ich für fraglich. Wenn Ubuntu kannst Du auch die Pakete vom yavdr ppa nehmen die gibt es für Lucid (yavdr 0.3 Basis) und auch für Natty (unstable 0.4) oder direkt die fertige Distris wie freevdr, Yavdr oder Easyvdr. Alle basieren auf Ubuntu und sind technisch dem betagten ctvdr weit überlegen.
    Also wenn es keinen trifftigen Grund gibt, installiere das System mit einer fertigen Distri neu und gut ist.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
     Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • hallo zusammen,


    habe die gleiche karte aber keine probleme damit und ich verwende die ngene_15.fw habe gesehen das du die version 18 benutzt...könnte daran liegen denn selbst digitaldevices sagt selbst lieber die 15 benutzen...also bei mir läuft alles auber und scharf, sowohl bei v4l als auch s2-liplianin


    gruß

  • Danke.


    Was für ein OS und welche vdr-Version benutzt du?
    Und vielleicht noch die Hardware...

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • Servus Duff1,


    ich verwende die gleiche Hardware (POV330er / CineS2) unter YaVDR 0.3. Mit dieser Konstellation habe ich ein scharfes Bild und 0,0 Probleme.


    Grüsse


    Reini P.

    Nr.1 YaVDR 0.5- M3N78-EM - TeVii S470 - Atric Rev.4
    Nr.2 YaVDR 0.4 - POV ION330 - Cine S2 DVB-S2 - Atric Rev.4