Soundgraph (0038) LCD ct vdr7.0

  • Moinsen,
    ich kriege bei mir einfach das Display und die FB nicht zum laufen.
    Habe sehr viel herumgesucht, aber krieg das irgendwie nicht hin.
    Habs als letztes hiermit probiert(also LIRC zu installieren):
    http://projects.vdr-developer.org/wiki/plg-imonlcd


    Nach ./autoconf.sh kommt:
    ./autogen.sh: line 4: autoreconf: command not found
    ./autogen.sh: line 7: automake: command not found
    cat: configure: Datei oder Verzeichnis nicht gefunden


    make gibt dann "keine Target" zurück.


    Hat jemand eine Idee wie man das hinkriegt?


    Habs nach einer Anleitung(die ich nicht mehr finde) es geschafft über dpkg installiert.
    Bei der Installation hat er mich dann nach Empfängern usw. gefragt, hab denn erstmal was ausgewählt, da ich unter dem Stichwörtern nichts gefunden haben.


    Was müsst ich da denn auswählen?
    Die Fernbedinung macht nichts.


    Das Imon Plugin hab ich auch installiert.
    Gemacht habe ich die über das Packet von eTobi.
    In der Log kommt allerdings:
    starting plugin: imonlcd
    Apr 11 19:56:15 ChristophVDR vdr: [2701] iMonLCD: using Device /dev/lcd0, with $
    Apr 11 19:56:15 ChristophVDR vdr: [2701] iMonLCD: ERROR opening /dev/lcd0 (Date$
    Apr 11 19:56:15 ChristophVDR vdr: [2701] iMonLCD: Did you load the iMON kernel $


    Das mit den Rechten per Udev habe ich gemacht.
    Das Verzeichnis ist wirklich nicht vorhanden.


    Mein System:
    ct vdr 7.0
    Soundgraph LCD 0038(im Antec Fusion Tower) und die dazugehörige FB.
    Kernel 2.6.28-etobi.3-686


    Hoffentlich kann mir einer helfen. Oder hat einer eine Anleitung wie das auch mit ct vdr 7.0 funktionert?
    Steh einfach auf dem Schlauch glaub ich. :wand


    Danke.


    Gruß
    lemp

  • Nach ./autoconf.sh kommt:

    Code
    1. ./autogen.sh: line 4: autoreconf: command not found
    2. ./autogen.sh: line 7: automake: command not found
    3. cat: configure: Datei oder Verzeichnis nicht gefunden


    make gibt dann "keine Target" zurück.


    Hat jemand eine Idee wie man das hinkriegt?


    Was verstehst du denn daran nicht? Es fehlen die Kommandos autoreconf und automake. Die musst du eben installieren.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • hi


    also ich habe es ganz normal laufen , dass plugin , ohne selber bauen.


    2 sachen sind wichtig


    a: in der plugin config das richtige device konfigurueren ( /dev/lcd1 oder /dev/lcd0 )
    b: die permission fuer das dev richtig setzen


    hierbei war ich etwas faul , ja ich gebs zu ;)


    habe es bei mir in der rc.local eingetragen


    Code
    1. if [ -c /dev/lcd0 ] || [ -c /dev/lcd1 ] ; then
    2. chmod 666 /dev/lcd[0-9]
    3. fi


    holger

    VDR1 : core2duo 3.2 Ghz , 1GB Ram , 2x TT 1501 DVB-C 1 GB HD , Asus EN 210 Silent , Debian Squeeze 64bit + e-tobi Pakete
    VDR2 : 1.2 Ghz P3 , Digitainer 768 MB Ram , yavdr 0.3a 32 bit

  • Moin,
    danke für eure Infos.
    Habs jetzt automake installiert.
    Das war wohl mein Schlauch :wand



    Krieg bei ./autogen.sh jetzt folgende Meldungen:
    configure.ac:24: error: possibly undefined macro: AC_PROG_LIBTOOL
    If this token and others are legitimate, please use m4_pattern_allow.
    See the Autoconf documentation.
    autoreconf: /usr/bin/autoconf failed with exit status: 1
    configure.ac:16: required file `./compile' not found
    configure.ac:16: `automake --add-missing' can install `compile'
    configure.ac:9: required file `./install-sh' not found
    configure.ac:9: `automake --add-missing' can install `install-sh'
    configure.ac:9: required file `./missing' not found
    configure.ac:9: `automake --add-missing' can install `missing'
    daemons/Makefile.am:12: library used but `RANLIB' is undefined
    daemons/Makefile.am:12: The usual way to define `RANLIB' is to add `AC_PROG_RANLIB'
    daemons/Makefile.am:12: to `configure.ac' and run `autoconf' again.
    daemons/Makefile.am: required file `./depcomp' not found
    daemons/Makefile.am: `automake --add-missing' can install `depcomp'
    tools/Makefile.am:51: Libtool library used but `LIBTOOL' is undefined
    tools/Makefile.am:51: The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
    tools/Makefile.am:51: to `configure.ac' and run `aclocal' and `autoconf' again.
    tools/Makefile.am:51: If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
    tools/Makefile.am:51: its definition is in aclocal's search path.
    configure.ac:10: required file `config.h.in' not found


    Nach ./setup.sh kommt:
    configure: error: cannot find install-sh or install.sh in "." "./.." "./../.."


    Make geht natürlich nicht.
    Denke mal das resultiert aus den Fehlern oben.


    Kann mir jemand weiterhelfen???


    Verzweifel langsam ein wenig.


    Gibts noch ne andere Möglichkeit das ganze zu installieren?
    (/dev/lcd0) ist bei mir übrigends auch nicht vorhanden.
    Wie hast du das hingekriegt mark05?


    Danke euch schon einmal.


    Gruß
    lemp

  • So bin jetzt ein wenig weiter gekommen.
    Mir fehlten noch libtools und python für die installation.
    Also alle die so auf dem Schlauch stehen wie ich:
    apt-get install automake libtools python


    Nach Anleitung installiert und das Display funktioniert.


    Meine FB will aber immernoch nicht.
    Habe es mit dem Startup script probiert:
    http://www.bergercity.de/wp-content/uploads/2009/07/lirc


    Jetzt erstellt er mir zwar "/dev/lircd". Er sucht aber nach auch nach "/dev/lirc0" welches nicht vorhanden ist.
    Ausgabe der log (lircd.log):
    Apr 17 11:33:02 ChristophVDR lircd: accepted new client on /dev/lircd
    Apr 17 11:33:02 ChristophVDR lircd: could not get file information for /dev/lirc0
    Apr 17 11:33:02 ChristophVDR lircd: default_init(): No such file or directory
    Apr 17 11:33:02 ChristophVDR lircd: WARNING: Failed to initialize hardware


    Kann mir da jemand weiterhelfen? Finde einfach nichts.


    Danke schon einmal.


    Gruß
    lemp