VDR belegt DVB Karten sehr seltsam ... ?

  • Hi,


    ich weiß leider nicht seit wann das "Problem" vorhanden ist, es fiel mir erst die letzten Wochen auf, möchte aber mal hören ob das noch jemand aufgefallen ist?


    An meinem Haupt-VDR mit 3x TT S2-1600 habe ich die letzten Tagen bis Wochen folgendes komisches Verhalten beobachtet, wenn ich mal per devstatus-Plugin nach geschaut habe:

    • Es stehen zwei Aufnahmen an, z.B. Donnerstags hintereinander CSI auf vox, d.h. die Aufnahmen überlappen sich durch Vor- und Nachlauf. Die erste Aufnahme läuft, natürlich auf einer Karte, die zweite Aufnahme läuft los, aber (!) auf einer zweiten DVB Karte, obwohl es ja eigentlich der selbe Transponder ist.
    • Alle drei DVB Karten empfangen lt. devstatus den selben Transponder obwohl aktuell keine Aufnahme ansteht oder ein streamdev-client dran hängt.

    Das selbe Verhalten habe ich auf meinem Test-VDR schon früher beobachtet, aber da hatte ich es auf LNB-Sharing geschoben, da ich 2 Tuner der CineS2 so verschaltet habe. Aber wenn dort überlappende Aufnahmen auf dem selben Transponder anstehen, belegt der VDR kurzerhand beide Tuner, also kein Wechsel auf einen anderen Transponder auf der ZF Ebene mehr möglich ... :(


    Ich kann mich täuschen, aber eigentlich sollte das anders laufen, oder?


    Regards
    fnu

    HowTo: APT pinning

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von fnu ()

  • Hi

    • Es stehen zwei Aufnahmen an, z.B. Donnerstags hintereinander CSI auf vox, d.h. die Aufnahmen überlappen sich durch Vor- und Nachlauf. Die erste Aufnahme läuft, natürlich auf einer Karte, die zweite Aufnahme läuft los, aber (!) auf einer zweiten DVB Karte, obwohl es ja eigentlich der selbe Transponder ist.

    Kann ich bestätigen. (VDR 1.6 mit 2 DVB-C Karten und angeschlossenem Streaming Client )


    LG gehlhajo

    VDR-1:  streamdev-server | Hummingboard Base | TT S23-600 USB DVB | Siemens S500 Gehäuse | VDR4Arch
    VDR-2: streamdev-client | rpihddevice | Raspberry B (1) | Remote: X10 | LG 42LV4500 |
    VDR4Arch


  • Meine Schwester (hat meinen VDR2) hat mir auch gesagt, dass mehrere Aufnahmen hintereinander nicht funktionieren.
    Die erste Aufnahme wird wie gewünscht durchgeführt, die zweite und dritte haben dann aber 0 Minuten Länge.
    Das könnte das selbe Problem sein, sie hat nur ein Empfangsgerät.


    Leider bin ich noch nicht dazu gekommen mir die Logdateien dazu anzuschauen.


    mfG,
    f.

    VDR1: HW: Asrock Q1900M, Celeron J1900, Zotac GT 630 Zone Edition, DigitalDevices Cine C2/T2, Sundtek MediaTV Pro USB-Stick, Sundtek MediaTV Digital Home, IR-Empfänger: Atric USB Eco, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr 0.6x
    VDR2: yavdr 0.6, Intel Pentium E5300, MS-Tech MC-1200, ASUS P5G41C-M LX, G41,MSI VN210-MD512H (NVIDIA GeForce 210), Atric, Sundtek MediaTV Digital Home, FB: Harmony 300, USB-Sound: Terratec Aureon Dual USB
    VDR3: Raspberry Pi2 als Streaming Client, MLD 5.1

  • nicht unbekannt das Phänomen


    hier letztens Diskutiert


    [testing-vdr]: Timer-Konflikte trotz freier Karte ?


    man vermutetet zuerst "testing" - tritt abergenerell auf, da ich drei Karten hab kommts eher selten - kann ich nicht sagen ab wann es so ist


    Christian

     CKone: yavdr 0.6.1/2.3.8 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 700, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr 0.6.1/2.3.8 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 700, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.3.8 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, Digital Devices MaxS8, Samsung 840 EVO 120GB, 3x WD Red WD30EFRX 3TB in SW Raid5

  • Nein, ich denke das hat nichts mit testing zu tun. Ich verwende die 0.3a stable mit akutellen Updates.
    Einmal ist es mir auch aufgefallen ... ähnliches Szenario wie bei fnu. Schauen Live-TV, 2 Karten sind mit Aufnahmen belegt (hier unterscheidliche Transponder), die dritte Aufnahme startet (auch hier Doppelfolge) und sollte sich eigentlich an eine der schon benutzten Karten klemmen. Aber was passiert, die letzte freie Karte wird genommen und ich bekomme plötzlich ein "Kanal nicht verfügbar" und VDR switcht auf Kanal 1.


    Gruss
    Markus

  • Nein, ich denke das hat nichts mit testing zu tun. Ich verwende die 0.3a stable mit akutellen Updates.

    Wie ich bereits oben schrieb: Das passiert auch mit 'nem 1.6er auf gentoo....

    VDR-1:  streamdev-server | Hummingboard Base | TT S23-600 USB DVB | Siemens S500 Gehäuse | VDR4Arch
    VDR-2: streamdev-client | rpihddevice | Raspberry B (1) | Remote: X10 | LG 42LV4500 |
    VDR4Arch


  • Wie ich bereits oben schrieb: Das passiert auch mit 'nem 1.6er auf gentoo....

    hm, also für mich ist dieses Verhalten neu. Konnte ich bisher auch nicht bei yavdr beobachten, eigentlich erst seit ich die DVB-S2-Karte im System habe. Meine reinen SD-Systeme mit 3 Karten (auch früher unterm 1.6er) und anfangs auch mit yavdr hatten dieses Verhalten nicht.

  • [testing-vdr]: Timer-Konflikte trotz freier Karte ?


    Interessanterweise kommt es zu keinerlei Konflikten bei den Timern, es werden keine ausgewiesen, noch ging bis jetzt einer "verloren". vmtl. hatte ich noch nicht ausreichend parallele Timer, damit dies geschehen konnte.


    Hmm, ausser die letztens fehlenden 15min bei einer der Raumschiff Enterprise Folgen auf dem zweiten VDR wäre aus der Ecke gekommen, aber das werde ich jetzt nicht mehr nachvollziehen können ...


    Einmal ist es mir auch aufgefallen ... ähnliches Szenario wie bei fnu. Schauen Live-TV, 2 Karten sind mit Aufnahmen belegt (hier unterscheidliche Transponder), die dritte Aufnahme startet (auch hier Doppelfolge) und sollte sich eigentlich an eine der schon benutzten Karten klemmen. Aber was passiert, die letzte freie Karte wird genommen und ich bekomme plötzlich ein "Kanal nicht verfügbar" und VDR switcht auf Kanal 1


    Ja, genau aus so einer Situation heraus fing ich an das Verhalten zu beobachten, eben das was ich oben in groben Zügen geschildert habe. Vorgestern schaute ich auf dem Main-VDR mit den 3 Karten mal nach, ich hatte ZDF Info Kanal am laufen und alle 3 Karten waren lt. devstatus auf dem selben Transponder gelockt ... ?(


    Meine reinen SD-Systeme mit 3 Karten (auch früher unterm 1.6er)


    Kann ich bestätigen, das Verhalten gab es bei meinem alten SD VDR, allerdings mit 1.4.7 aus dem eTobi Repo, aber mit auch 3 DVB Karten, definitiv nicht. Auch bin ich der Meinung das ich definitiv schon gesehen habe, wie über ein DVB-S2 Karte 2 Aufnahmen vom selben Transponder gemacht wurden.


    ===


    Inzwischen habe ich auch ein recht abstrakte Vermutung für ein Problem das bei mir ab und an auftritt, xine-ui als Frontend hängt sich ab. Mein VDR startet immer auf dem 1 Kanal, bei mir "Das Erste HD", nun kann es passieren, das beim Umschalten auf dann "ZDF HD" (2) oder "zdf_neo" (3) das Fernsehbild einfriert, aber man problemlos weiterschalten kann, man sieht das am kleinen lcd-Display. Wenn ich dann in den Situationen, nach dem schnellen Neustart des Frontends, den devstatus geprüft habe befanden sich eben 2 der DVB Karten genau auf den Transpondern, entweder dem HD Transponder mit "Das Erste HD", "ZDF HD" & "arteHD" oder eben auf dem Transponder mit "zdf_neo", "ZDF info" etc.


    Regards
    fnu


    ===


    PS.: Diese neue Zitieren-Funktion ist ja echt ein Hammer, genka, super !!!!

    HowTo: APT pinning

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von fnu ()

  • Ich kann das Problem auch seit längerem auf meinem VDR-Server und meinem Arbeitsplatz-Rechner beobachten ... gerade bei Aufnahmen von Doppelfolgen wie. z.B. K11 oder CSI und Dr. House. Scheint ein tiefgreifendes Problem zu sein.


    Bis dato bin ich aber sehr selten von dem Problem betroffen gewesen ... aber es ist da ... seit ca. einem halben Jahr scheint sich ab und an (1x in 2 Wochen) der Vompserver ohne irgendeine Fehlermeldung wegzuhängen. Immer wenn eine/zwei Aufnahme/n und Live-TV auf zwei Vomp-MVP-Clients gleichzeitig laufen ... und das bei 4 DVB-S-Karten. Da hilft meist nur Neustart.

    VDR-Server 2.0.6 yavdr-testing-repo - Kubuntu 12.04 LTS/64 - I-Dual-Core 2,2 GHz, 2 GB RAM, SATA 500GB, via NFS 2,9 TB HW-RAID5 an Sol10Sparc mit ZFS, 1x FF-TT 2.3 modded, 1x FF-TT 1.5, 2x TT-1600, via DLAN AVpro/Coax 4x 2x MVP Ver.D3A - VOMP 0.4.0 mit Media, MVP-Dongle 0.4.0
    Arbeitsplatz: 12.04 LTS/64 2.0.6
    yavdr-testing-repo - I-Dual-Core 2,4 GHz, 4 GB RAM, 2x 1TB, 2x TT-1600
    WAF-VDR-Client: openelec-3.2.4/XBMC-12.2-Frodo/ alternativ yavdr 0.5.0a: PulseEight-USB-CEC-Adapter, ZBOX-HD-ID41: 4GB RAM, 64GB SSD, 16GB Patriot-USB-Stick am Samsung UE37D5700 (gehackt) für TimeShift direkt am TV ohne VDR-Zugriff

  • Moin!


    Habt ihr mal versucht, das Problem mit einem vanilla-vdr nachzuvollziehen? Welche Patches setzt ihr ein, die einen Einfluss auf cDevice::GetDevice haben?


    Lars.

  • Jepp.... kann ich ebenfalls bestätigen. Mir ist das immer dann aufgefallen, wenn 2 Aufnahmen direkt hintereinander auf dem gleichen Kanal aufgenommen wurden. Außerdem verursacht der Start der 2ten Aufnahme ein kurzes Bildruckeln auf dem gerade aktuellen Livekanal unter xine. Eventuell hängt das aber mit der Verschlüsselung der TV-Kanäle zusammen... :schiel


    Gruß
    iNOB

  • Moin!


    Habt ihr mal versucht, das Problem mit einem vanilla-vdr nachzuvollziehen? Welche Patches setzt ihr ein, die einen Einfluss auf cDevice::GetDevice haben?


    Lars.


    siehe Signatur .... yavdr 0.3a immer mit den aktuellsten Updates.

  • siehe Signatur .... yavdr 0.3a immer mit den aktuellsten Updates.


    Hehe, genau das meinte Lars ja, das ist eben nicht Vanilla VDR, sondern der Patch-Level den Holger einpflegt ... ;)


    Habt ihr mal versucht, das Problem mit einem vanilla-vdr nachzuvollziehen? Welche Patches setzt ihr ein, die einen Einfluss auf cDevice::GetDevice haben?


    Grml, ich habe befürchtet, das dieser Tiefschlag kommt. Tatsächlich kennst Du den Patchlevel recht gut und weißt, das es zwei Verdächtige gibt, oder? dynamit && lnb-sharing ... :(


    Muß ich jetzt echt einen VDR ab Vanilla aufsetzen? Wenn ich das mache, bleib ich auch dabei, ..., mal sehen, ...


    Gruß
    Frank

    HowTo: APT pinning

  • Dito ... alles aktuell aus'm yavdr-repo. Beim Test-VDR aus Sig. kann's ich nicht nachvollziehen, weil a. z.Z. zweckentfremdet und b. nur ein USB-DVB-Device.

    VDR-Server 2.0.6 yavdr-testing-repo - Kubuntu 12.04 LTS/64 - I-Dual-Core 2,2 GHz, 2 GB RAM, SATA 500GB, via NFS 2,9 TB HW-RAID5 an Sol10Sparc mit ZFS, 1x FF-TT 2.3 modded, 1x FF-TT 1.5, 2x TT-1600, via DLAN AVpro/Coax 4x 2x MVP Ver.D3A - VOMP 0.4.0 mit Media, MVP-Dongle 0.4.0
    Arbeitsplatz: 12.04 LTS/64 2.0.6
    yavdr-testing-repo - I-Dual-Core 2,4 GHz, 4 GB RAM, 2x 1TB, 2x TT-1600
    WAF-VDR-Client: openelec-3.2.4/XBMC-12.2-Frodo/ alternativ yavdr 0.5.0a: PulseEight-USB-CEC-Adapter, ZBOX-HD-ID41: 4GB RAM, 64GB SSD, 16GB Patriot-USB-Stick am Samsung UE37D5700 (gehackt) für TimeShift direkt am TV ohne VDR-Zugriff

  • Also mit nem 1.6.0-2er mit einigen Patches aus dem ext-Patch funktioniert das. Ist also kein VDR Problem.


    Also, alle die das Problem haben sollten mal mit ner Pluginminimalaustattung starten und dann die Patches schrittweise abschalten. Anderst findet man wohl nicht raus woran das liegt.


    cu

  • Moin!


    dynamite fasst cDevice::GetDevice nicht an, LNB-Sharing schon. Ihr müsst ja auch nicht gleich einen kompletten vdr aufsetzen, einfach mal die Quellen auspacken, übersetzen und mit den passenden Verzeichnissen direkt von der Kommandozeile starten.


    Dieses Wochenende hab ich leider keine Zeit (hab jede Menge Besuch), aber nächste Woche könnte ich an der Stelle noch mal nachsehen. Wer zuarbeiten kann, ist herzlich willkommen.
    Und falls dynamite Schuld sein sollte, freue ich mich darauf, es zu korrigieren. Schließlich ist es erst gute 3 Monate alt, ich erwarte nicht, dass es problemlos läuft. Deshalb ist es ja auch in unstable...


    Lars.

  • dynamite fasst cDevice::GetDevice nicht an, LNB-Sharing schon.


    Jo, mag so sein, aber Du erinnerst Dich auch an die ersten Versionen des Patches, der sich mit LNB-Sharing gekappelt hatte, gell ... ;)


    Soll ja kein Vorwurf sein, aber eine der Stärken des VDRs wird IMHO im Prinzip ausgehebelt, was mir nicht wirklich zusagt und da gehört alles was nur in die Nähe kommt auf den "Prüfstand".


    Auf dem Test-VDR brauche ich aber blöderweise in nächster Zeit noch den LNB-Sharing Patch, bin noch nicht dazu gekommen das Thema Unicable aufzuarbeiten, wobei ich das vmtl. eh von der Pieke auf machen muß ...


    Mal überlegen ob ich den Main-VDR anfasse und die Patches (dynamit & LNB-Sharing) deaktiviere, wird eh einige Zeit laufen müssen um eine vernünftige Aussage zu bekommen.


    Gruß
    Frank

    HowTo: APT pinning

  • der dynamite Patch ist doch im 0.3a gar nicht drin? Bei mir ist der Sharing LNB drin und ich kann zumindest bestätigen, dass 2 Aufnahmen beim aktiven LNB Sharing, wenn sie auf dem selben Transponder liegen, nicht zwangsläufig auf dem selben Tuner aufgezeichnet werden.
    Ich vermute mal eher dass das lnbsharing da nicht die richtige Karte zuweist.Oder wer entscheidet welche Karte für die Aufnahme verwendet wird?


    By the way, unter Neutrino gab es eine sehr praktische Funktion der Senderliste, wenn eine Aufnahme lief, wurden in der Senderliste nur noch die Sender angezeigt die man empfangen konnte. Beim VDR gibt es so etwas ähnliches auch, aber leider nur wenn man die Channel +/- benutzt, die Senderliste selbst gibt keine Hinweise auf die verfügbaren Sender während der Aufnahme.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
     Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • der dynamite Patch ist doch im 0.3a gar nicht drin?


    In der Tat, der "subdevice.dpatch" ist nicht aktiviert, bleibt also nur "lnb-sharing". Ich war echt der Meinung der wäre mit einer der letzten Updates aktiv geworden ... mea culpa ...


    Gruß
    Frank

    HowTo: APT pinning

  • das yavdr Team weiß dazu bestimmt noch mehr als ich ;D , soweit ich das weiß, soll der dynamite erst in unstable/testing sein, bzw da ist er zur Zeit, da damit das ganze Handling der DVB-Devices sich ändert. Sollte das nicht sogar erst ein Feature der 0.4 sein?


    Aber am LNB-Sharing ist in den letzten Wochen mehrfach gearbeitet worden. Und der ist im Yavdr 0.3 ja enthalten als Patch.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
     Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue