SetSystemTime

  • Hi,


    ich habe gestern den NTP-Client abgeschaltet, da mein BLFS-System beim Systemstart sonst ewig hängt, wenn der Timerserver nicht erreichbar ist. Deshalb möchte ich via VDR die Systemzeit aktualisieren. Aber wie erreicht man das?


    VDR wird als User vdr gestartet (-u vdr). In der setup.conf steht "SetSystemTime = 1".


    Was genau sollte nun passieren? Im Log finde ich keine Meldung über irgendeinen erfolgreichen noch fehlgeschlagenen Versuch.


    Braucht man da Root-Rechte? Wie oft wird aktualisiert und von wo genau wird die Zeit bezogen?


    TIA!

  • Soweit ich mich erinnere gibt es eine Option in den EPG Einstellungen das man die Uhrzeit nach EPG stellen kann. Probier das doch mal.

  • Aha, darüberhinaus habe ich nun folgendes in setup.conf gesetzt:


    TimeSource = S19.2E
    TimeTransponder = 11953


    Der Transponder sollte der vom ZDF sein. Mal schauen, was bis morgen passiert. Aktuell geht der Rechner 13 Sekunden vor meiner Funkuhr.....

  • Äh, in die MANUAL hab ich reingeschaut, aber das ist ja eher etwas für die Bedienung mit OSD. Nur ist meine Kiste ein reiner Server mit 2 Budget-Karten. Von daher krieg ich da nicht wirklich was hin....


    Ich hab vdr nun mal ohne den Parameter "-u vdr" gestartet. Mal schauen, ob er nun die Zeit synchronisiert.
    Nun wird vdr als root bei mir ausgeführt. Wie kommt es bei dir, dass dies nicht der Fall ist?

  • Kleiner Nachtrag:
    Es lag an dem Eintrag von TimeTransponder. Komischerweise muss dort eine "1" am Anfang hinzugefügt werden, im Gegensatz zum entsprechenden Eintrag in der channels.conf. Warum? Keine Ahnung! Aber nun funktioniert es.


    Code
    1. ...
    2. SetSystemTime = 1
    3. TimeSource = S19.2E
    4. TimeTransponder = 111953
    5. ...


    Code
    1. system time changed from Fri Mar 11 14:12:34 2011 (1299849154) to Fri Mar 11 14:13:04 2011 (1299849184)


    Und alles, wenn vdr als User vdr (mit Parameter "-u vdr") ausgeführt wird.

  • Quote

    Originally posted by killajoe
    Es lag an dem Eintrag von TimeTransponder. Komischerweise muss dort eine "1" am Anfang hinzugefügt werden, im Gegensatz zum entsprechenden Eintrag in der channels.conf. Warum? Keine Ahnung!


    Weil in der setup.conf die ZF stehen muss und in der channels.conf steht die Transponderfrequenz. Das sind vollkommen verschiedene Dinge.


    Edit: Das scheints auch nicht zu sein, keine Ahnung was der VDR da will, aber macht nix, der VDR trägt da schon das richtige ein ;)


    Quote

    Originally posted by killajoe
    Aber nun funktioniert es.


    Naja, Glück gehabt ;) Zufällig passt das mit der 1 davor gerade so (ist noch innerhalb der Toleranz). "111954" wäre die richtige Frequenz.


    Ich verstehe gar nicht warum sich hier einige das Leben immer so unnötig schwer machen, das einfach in der GUI einstellen und solche Probleme tauchen erst gar nicht auf.
    Und wer aus irgendwelchen Gründen kein GUI am VDR hat, es gibt auch Plugins die die VDR GUI per Terminal anzeigen.



    BTW: Schau dir lieber mal deinen NTP Clienten an, der sollte da eigentlich nix verzögern wenns Netzprobleme gibt.


    cu

  • Quote

    Original von Keine_Ahnung
    Weil in der setup.conf die ZF stehen muss und in der channels.conf steht die Transponderfrequenz. Das sind vollkommen verschiedene Dinge.


    Edit: Das scheints auch nicht zu sein, keine Ahnung was der VDR da will, aber macht nix, der VDR trägt da schon das richtige ein ;)


    Was ist ZF?!

    Quote

    Original von Keine_Ahnung
    Naja, Glück gehabt ;) Zufällig passt das mit der 1 davor gerade so (ist noch innerhalb der Toleranz). "111954" wäre die richtige Frequenz.


    Ich verstehe gar nicht warum sich hier einige das Leben immer so unnötig schwer machen, das einfach in der GUI einstellen und solche Probleme tauchen erst gar nicht auf.
    Und wer aus irgendwelchen Gründen kein GUI am VDR hat, es gibt auch Plugins die die VDR GUI per Terminal anzeigen.


    Du wirst lachen, aber mit dem Remote-Plugin habe ich dann doch per OSD den Sender gewählt. Sonst hätte ich den Unterschied zw. channels.conf- und setup.conf-Transponder immer noch nicht raus.
    Habe das Ding einmal kompiliert gehabt, aber schon länger nicht mehr nutzen müssen :lol2