HD-VDR mit Intel HD Graphics - Testbericht zu vaapi

  • Ich habe die Sourcen von VLC gecheckt. Das dort das Deinterlacing geht ist kein wunder. In VLC passiert es in SOFTWARE. VLC verwendet VAAPI nur für die Decodierung, jedoch nicht für die Anzeige. Wenn Ihr vergleiche macht bitte mit mplayer-vaapi durchführen. mplayer-vaapi ist mehr oder weniger die Referenzimplementierung und besser vergleichbar zu Xine. Meldungen über andere Player werde ich einfach ignorieren und nicht komentieren.


    Ich habe mich mit dem Entwickler vom Intel VAAPI Treiber in verbindung gesetzt und ihm die Probleme geschildert. Bin gespannt ob dort was rauskommt.

    Hi Ebsi,


    da habe ich mich wohl falsch ausgedrückt. Es ging mir nicht um den Vergleich mit dem VLC. Dass der das in Software mach ist klar, zumal ich das mit dem VLC unter Windows ausprobiert habe. Ich wollte nur für mich sicherstellen, dass das Deinterlacing in Xine nicht richtig funktioniert, indem ich das gleiche Material mal mit dem VLC und aktiviertem Software-Deinterlacing abspiele und mir den Unterschied anschaue. Meine Frage hier in die Runde sollte dann Aufschluss darüber bringen, ob ich bei mir irgendetwas falsch konfiguriert haben oder es ein generelles Problem ist. Deiner Antwort entnehme ich nun, dass es evtl. doch eher ein generelles Problem ist.


    Grüße
    Christoph

    Testsystem:
    Hardware: Lian Li C39, Core-i7-3632QM, Jetway NF9G-QM77, 4GB RAM, PicoPSU 160XT inkl 80W Morex, 3x 2,5" 1TB RAID5, 1xSamsung PM830 mSATA 128GB, 1x LG BDROM, 1x DD Cine CT (v6) + CI + Alphacrypt CAM
    Software: Ubuntu 13.04 mit 3.8 x64, VDR 2.0.1 + xbmc 12.2

  • Für Mpeg2 gibt es nun auf decoder ebene ein einfaches deinterlacing. Das ganze kann über folgende config optionen gesteuert werden.


    # VAAPI Mpeg2 softdecoding
    # bool, default: 0

    # video.processing.vaapi_mpeg_sofdec:0



    # VAAPI Mpeg2 softdecoding deinterlace
    # bool, default: 0
    #video.processing.vaapi_mpeg_sofdec_deinterlace:0


    Leider funktioniert das Postprocessing von xine nicht. Es kommt da zu einem "deadlock" und ich habe keine Ahnung warum das passiert.
    Der ffmpeg deinterlacer ist zwar nicht der beste, denke mir halt, besser als nichts. Für mein persönliches empfinden ist er gut genug.


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Wenn ich die beiden Confs setze, bekomm ich auch den BlackScreenOfDeath. Außerdem fällt mir auf, dass bei Verwendung von VDR 1.7.16 bei 4:3 Sendungen auf einem 16:9 Screen, das OSD horizontal gestaucht wird. Liegt das an der VDR-Version?


    Gruß
    iNOB

  • Bei mir läuft die neue Version auch ohne die beiden Configs nicht. Sehr sporadisch erhalte ich nach dem Xine-Start ein Bild, spätestens nach dem Umschalten bleibt der Bildschirm aber schwarz und Xine hängt. Aufgefallen ist mir noch, dass im xine log etwa steht wie "video_out....no permission to raise nice level". da ich mittlerweile wieder zurück auf r190 kann ich den genauen Wortlaut nicht wiedergeben. Startet man als root bleiben die Ausgaben (sinnigerweise) aus, jedoch ist das oben beschriebene Problem nachwievor vorhanden.


    Vorsichtshalber habe ich noch mal den kompletten Treiber Stack und xine-ui aktualisiert, hilft aber auch nicht.

    Testsystem:
    Hardware: Lian Li C39, Core-i7-3632QM, Jetway NF9G-QM77, 4GB RAM, PicoPSU 160XT inkl 80W Morex, 3x 2,5" 1TB RAID5, 1xSamsung PM830 mSATA 128GB, 1x LG BDROM, 1x DD Cine CT (v6) + CI + Alphacrypt CAM
    Software: Ubuntu 13.04 mit 3.8 x64, VDR 2.0.1 + xbmc 12.2

  • Bei mir läuft die neue Version auch ohne die beiden Configs nicht. Sehr sporadisch erhalte ich nach dem Xine-Start ein Bild, spätestens nach dem Umschalten bleibt der Bildschirm aber schwarz und Xine hängt. Aufgefallen ist mir noch, dass im xine log etwa steht wie "video_out....no permission to raise nice level". da ich mittlerweile wieder zurück auf r190 kann ich den genauen Wortlaut nicht wiedergeben. Startet man als root bleiben die Ausgaben (sinnigerweise) aus, jedoch ist das oben beschriebene Problem nachwievor vorhanden.


    Vorsichtshalber habe ich noch mal den kompletten Treiber Stack und xine-ui aktualisiert, hilft aber auch nicht.

    Wie rufst Du xine auf und sind deinterlacer gesetzt ?


    Das ist mein xine aufruf :


    xine --no-gui --no-logo --no-splash -f -A alsa -V vaapi --post vdr --post vdr_audio --post vdr_video --post tvtime:method=use_vo_driver netvdr:/127.0.0.1 --config=/var/lib/vdr/.xine/config_ffmpeg


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

    The post was edited 1 time, last by ebsi ().

  • Wenn ich die beiden Confs setze, bekomm ich auch den BlackScreenOfDeath. Außerdem fällt mir auf, dass bei Verwendung von VDR 1.7.16 bei 4:3 Sendungen auf einem 16:9 Screen, das OSD horizontal gestaucht wird. Liegt das an der VDR-Version?


    Gruß
    iNOB

    Welche einstellungen für das OSD hast du im vdr-xine plugin gemacht ?


    Meine Settings :


    OSD display mode : X11 overlay
    OSD extent X : 1920
    OSD extent Y : 1080


    Auch hier die frage, sind xine postprocessing deinterlacer aktiviert ?


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Und stellt sicher das ihr auf revision r197 seid. Das Software deinterlacing wurde mit r195 gefixet.


    Testweise könnt ihr auch in src/videou_out/video_out_vaapi.c


    //pthread_mutex_lock(&this->drawable_lock);
    und
    //pthread_mutex_unlock(&this->drawable_lock);


    die "//" entfernen und neu bauen. Ich glaube zwar nicht das dies Auswirkungen hat, aber wer weis das schon ;)


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Es gibt mal wieder ein update. Hier die Commti message :


    Log Message:
    -----------
    YUV2/indeirect rendering/fixes


    Add YUV2 support to video out. Fixes xine-ui start crash. Xine-ui's start logo is rendered in YUV2.
    Rework display image logic. Add indirect rendering support. Allocate requested number of surfaces
    and do not use hardcoded values. Fixes here and there.



    lg



    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Hi ebsi,


    hatte jetzt noch mal Zeit zum Testen:


    Leider habe ich auch mit der aktuellen Version noch genau die gleichen Probleme: Egal ob ich das softdec aktiviert habe oder nicht, xinestart zeigt nur sporadisch und zufällig mal ein Bild nach dem Start. Es kann passieren, dass ich 5 mal hintereinander ein Bild nach dem Start bekomme und irgendwann geht es dann wieder nicht. Für mich nicht nachvollziehbar. Darüber hinaus raucht xine dann irgendwann auch ab, wenn es mal lief:


    Code
    1. xiTK received SIGSEGV signal, RIP.


    Ich kann es mir leider nicht erklären.


    Mein xine Aufruf:

    Code
    1. /usr/bin/xine -f --post vdr_video --post vdr_audio --post vdr --verbose=2 "vdr:/tmp/vdr-xine/stream#demux:mpeg_pes"


    Aber auch mit deinem Aufruf ist das Ergebnis identisch.



    Hier noch mal die Ausgabe, von der ich weiter oben mal geschrieben hatte, die auftritt, wenn man xine mit User-Rechten ausführt.


    Testsystem:
    Hardware: Lian Li C39, Core-i7-3632QM, Jetway NF9G-QM77, 4GB RAM, PicoPSU 160XT inkl 80W Morex, 3x 2,5" 1TB RAID5, 1xSamsung PM830 mSATA 128GB, 1x LG BDROM, 1x DD Cine CT (v6) + CI + Alphacrypt CAM
    Software: Ubuntu 13.04 mit 3.8 x64, VDR 2.0.1 + xbmc 12.2


  • Hier noch mal die Ausgabe, von der ich weiter oben mal geschrieben hatte, die auftritt, wenn man xine mit User-Rechten ausführt.


    Dieses Problem bitte an die Xine ml melden. Das kommt aus der xine-engine und nicht aus der VAAPI Ecke.


    Warum xine-ui beim starten abstürzt ist mir ein rätsel. Kannst du mal die Verwendeten Software Versionen posten ?
    ( X + Libs, xine-ui, libva, xf86 intel treibet....) Ich sehe in deiner Signatur das du Suqeeze verwendest. Welche Quellen
    hast Du dort eingebunden ? ( /etc/apt/sources.list ). Vielleicht werde ich am Wochenende eine Squeeze zum testen installieren.



    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Hallo zusammen,


    ebsi : Danke für deine Regelmäßigen Updates bezüglich der Verbesserungen und neuen Features :)


    Ich habe heute mit über einen guten Monat Verspätung meinen Core I3 geordert. Wenn alles gut geht werde ich am Sonntag mal ein paar neue Tests machen und hier Berichten. Die letzten Änderungen konnte ich nicht mehr Testen weil arch mir auf dem Testrechner abgeschiert ist ;)


    Gruß
    Atech

    HTPC:
    Softtware: Archlinux mit VDR aus Archvdr repo (1.7.31 mit softhddevice) und xbmc 12.2 Frodo stable
    Hardware: Coolermaster 260 mit Core I3 540, 4 GB Kingst. Ram, GA.H55M-D2H, PCIe 16X RiserCard, NVIDIA 430GT, TT3600USB, TT3650-CI USB, Samsung SSD 640, WD Blue 1TB (WD10TP), IR Einschalter, imon Display, mce FB und 12 Kanal Atmolight (4 Led Streifen) über DFatmo und Boblight

  • Warum xine-ui beim starten abstürzt ist mir ein rätsel.

    Also abstürzen tut xine nicht direkt, sondern es hängt beim Start.

    Kannst du mal die Verwendeten Software Versionen posten ?
    ( X + Libs, xine-ui, libva, xf86 intel treibet....) Ich sehe in deiner Signatur das du Suqeeze verwendest. Welche Quellen
    hast Du dort eingebunden ? ( /etc/apt/sources.list ). Vielleicht werde ich am Wochenende eine Squeeze zum testen installieren.

    Zu meiner Schade muss ich bekennen, dass die Signatur nicht aktuell war. Hatte in den letzten Wochen sehr viel gebastelt und geändert. Ich habe es mal aktualisiert


    Zu den Versionen:


    X: 1.9.2.901 (ist relativ alt, kann ich bei Zeiten mal aktualisieren; Die ganzen X packages und libs sind aus dem xorg edgers ppa)
    libva: GIT von dieser Woche
    xf86 intel treiber: GIT von dieser Woche
    mesa: GIT von dieser Woche
    xine-ui: SVN von dieser Woche
    xine-lib-vaapi: r199



    Da fällt mir gerade auf, dass ich parallel noch ein Ubuntu 10.10 minimal mit neuerem Kernel und X installiert habe. Das könnte ich noch mal testen.


    Grüße und Danke für dein Engagement!


    Christoph

    Testsystem:
    Hardware: Lian Li C39, Core-i7-3632QM, Jetway NF9G-QM77, 4GB RAM, PicoPSU 160XT inkl 80W Morex, 3x 2,5" 1TB RAID5, 1xSamsung PM830 mSATA 128GB, 1x LG BDROM, 1x DD Cine CT (v6) + CI + Alphacrypt CAM
    Software: Ubuntu 13.04 mit 3.8 x64, VDR 2.0.1 + xbmc 12.2

  • Nabend, hab mal auf die Schnelle eine Natty 64 bit installiert.
    Den vdr von den yavdr quellen genommen. xine-lib und xine-ui
    aus den sourcen gebaut. Auch die libva ( 1.0.12 ) aus den sourcen gebaut.
    Quintessenz der aktion, funktioniert einwandfrei.


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • xine-lib und xine-ui
    aus den sourcen gebaut.


    Wir bilden uns ein da relativ aktuell zu sein. Warum war das nötig, was sind die Unterschiede?


    Nicht dass da Missverständnisse entstehen. Wir sind nicht auf Nvidia-Grafik festgelegt. Aktuell ist aber nur Nvidia-Grafik gut genug.
    Sobald von euch das Signal kommt vaapi bringts, dann werden wir das in die Distri aufnehmen.
    Im Vorfeld stört es ja nicht wenn wir schon mal die gemeinsam genutzten Pakete auf einem Stand halten, der sie für beide benutzbar macht.
    Also minimal xine-lib und xine-ui. Wie siehst du das?

    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Also minimal xine-lib und xine-ui. Wie siehst du das?

    War ein missverstädniss. Xine-lib und xine-ui aus euren Paketsourcen gebaut, mit applizierten VAAPI patch. Libva nehm ich Prinzipiell die letzte upstream.
    Schön zu hören das intresse an eine Integration in yaVDR besteht.


    lg


    ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Auch die libva ( 1.0.12 ) aus den sourcen gebaut.

    "Beflügelt" von dieser Aussage, hab ich mir auch mal auf ner Testumgebung alles zusammengeschustert, krieg aber die libva 1.0.12 nicht gebaut.



    Lief das bei dir problemlos durch oder musstest du irgendwas abändern ?


    Danke & Gruss
    Hoschi



    Edit:
    Google war auch mein Freund. Das Problem wurde schon auf der entsprechenden Mailingliste diskutiert.


    http://lists.freedesktop.org/a…2011-February/000471.html


    Quote

    or patch the various Makefile.am under test/ with something that looks like:
    TEST_LIBS = $(top_builddir)/va/$(libvabackendlib) $(top_builddir)/va/libva.la


    and automake & libtool will do the rest.

  • HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

  • Hi,


    für alle die es unter Ubuntu Natty versuchen wollen, ich hab das ganze mal in ein PPA gepackt.


    https://launchpad.net/~arnoldpascal/+archive/vdr-vaapi



    Zusätzlich braucht ihr noch das unstable-vdr und das mail PPA vom yaVDR-Team (danke dafür)


    Damit xine von meinem PPA benutzt wird, müsst ihr noch ein Pinning auf mein Repository erstellen:


    Code
    1. pascal@htpc:/etc/apt/preferences.d$ cat vdr-vaapi
    2. Package: *
    3. Pin: release o=LP-PPA-arnoldpascal-vdr-vaapi
    4. Pin-Priority: 900


    Sollte jemand Probleme haben, kann er sich gerne bei mir melden. Ist mein erstes PPA :]


    Gruß Lokutus

    Server: ZOTAC H55-ITX WiFi, Core i3, Ubuntu 10.4 Server mit yavdr Paketen und ein Paar mehr
    Client1: ZOTAC NM10-DTX WiFi, YaVDR 0.5

    Client2: ZOTAC Zbox ION2, openELEC

  • Gibt mal wieder ein update im SVN. Wichtigstes neues Feature ist OpenGL rendering. Wurde zu großen teilen aus dem mplayer VAAPI Ausgabemodul portiert.



    Ich hatte die Möglichkeit ein ASRock E350M1 (http://geizhals.at/a610927.html) Motherboard zu testen. Es wär ja eine Perfekte VDR Basis. Wären da nicht die Schrottigen AMD Treiber und der Extrem schlechte xvba-vaapi Treiber. Leider ist der Entwickler vom xvba-vaapi Treiber nicht sehr gesprächig. Also eine Warnung an alle, lasst vorerst die Finger davon. Kann ja sein das sich das in der Zukunft ändert.


    lg


    Ebsi

    HW HD-VDR-1 : Foxconn H67S MiniITX, Intel G620T, 1x 80GB Intel Postvile X25 SSD, anysee E7 PS2 CI DVB-S2 intern, Gehäuse JCP MI 101, 2 GB DDR3 Ram.
    HW HD-VDR-2 : Zotac H61 MiniITX , Intel G440, 1x 320GB HDD, TeVII 470, Gehäuse Silverstone Sugo SG05, 4 GB DDR3 Ram.
    SW HD-VDR : archlinux 64bit mit archvdr Paketen ( http://archvdr.sf.net ) und VAAPI. Kernel 3.1.x, Rest bleeding edge :D
    xine-lib-1.2 VAAPI : https://github.com/huceke/xine-lib-vaapi/commits/vaapi + vdr-xine als Frontend

    The post was edited 1 time, last by ebsi ().

  • Hi,


    ich bekomme bei der neuen Revision leider einen Build Error:


    Gruß Lokutus

    Server: ZOTAC H55-ITX WiFi, Core i3, Ubuntu 10.4 Server mit yavdr Paketen und ein Paar mehr
    Client1: ZOTAC NM10-DTX WiFi, YaVDR 0.5

    Client2: ZOTAC Zbox ION2, openELEC