Idee: xmltv2vdr-plugin

  • Naja ich verwende xmltv2vdr 0.0.1 aus den yaVDR-PPA-Quellen.

    Es wird immer verrückter. Ich bekomme keine neuen EPG-Daten

    Bist Du immer noch bei der 0.0.1? Bei 0.0.2pre habe ich "tonnenweise" Änderungen gemacht und Bugs behoben, es gibt ein Log das man übers Menü erreicht und man kann selbst schauen wann das letzte Update gelaufen ist.


    Gruß


    Joe_D

  • Bei 0.0.2pre habe ich "tonnenweise" Änderungen gemacht und Bugs behoben,


    Das hätte ich jetzt nicht gedacht. Hmm, sollte ich das wohl doch mal versuchen...

    Asus AT3N7A-I (Dualcore Intel Atom 330), Nvidia GeForce 9400 (onBoard), Pinnacle PCTV 452e, Mystique Satix S2 Sky USB Rev.2, AverTV Green Volar HD, X-Tensions DVB-T-380U, 2GB RAM, Xubuntu 12.04 mit yaVDR stable-Paketen, gepatchter Kernel 3.6.7, yaVDR 0.4, linux-media-dkms bzw. media-match 3.3, USB-IR-Einschalter (igorplug-kompatibel)
    Gehäuse: Maxdata Favorit 5000i, Antennen: Strong SRT Ant 15 Eco, Selfsat HD30D4

  • Hi,


    mach ich was falsch? Ich habe im Zusammenspiel mit dem mitgeliefertem grabber epgdata2xmltv und epgdata.com (Test-)Abo auffällig z.B. bei Pro7 von mehreren Folgen immer nur die erste mit Subtitle.
    Also z.B. morgen, Di. 13.09.:


    18:10 "Simpsons ~ Der Videobeichtstuhl",
    18:38 "Die Simpsons ~ Die Simpsons",
    20:14 "Die Simpsons"
    20:44 "Die Simpsons"


    die Folge um 18:38 müsste "ein kleines Gebet" heissen, die nach 20:00 sind jeweils "Original EPG" (Astra 19,2), ohne externe Infos. Das passiert auch bei anderen Folgen auf Pro7.


    Ich verwende xmlt2vdr aus dem git, gezogen und gebaut am 03.09. (also im Moment die neueste Version) mit e-tobi VDR 1.7.20 unter Debian 6.


    Sollte man eher einen der Grabber von xmltv selbst verwenden (tv_grab_eu_epgdata)? Ich blick bei den vielen verschiedenen Plugins/Addons nicht mehr durch. Gibt es irgendwo eine Zusammenfassung, was im Moment überhaupt funktioniert?


    -=FuF=-

  • Das Plugin braucht die eigenen Grabber (also hast du da schon das richtige).


    Schau mal ins Log, das Plugin sagt genau was es versucht einzutragen, da sollte also drinstehen warum bestimmte Subtitle nicht angelegt werden.



    BTW: Wenn ich bei nickcomedy.de auf "mischen" gehe (Sender EPG ist per noEPG deaktiviert, mischen war nen Test wegen Comedy wird nicht eingetragen) erhalte ich einen Absturz.


    Ansonsten trägt es mit bei nickcomedy.de nur Nick ein und nix von Comedy.

    Code
    1. Sep 21 11:31:38 localhost vdr: [3320] xmltv2vdr 'tvm2xmltv' adding 'Johnny Test'@Sep 28 11:15-Sep 28 11:45
    2. Sep 21 11:31:38 localhost vdr: [3320] xmltv2vdr 'tvm2xmltv' ERROR cannot add 'South Park'@Sep 21 20:40-Sep 21 21:10
    3. Sep 21 11:31:38 localhost vdr: [3320] xmltv2vdr 'tvm2xmltv' ERROR found 'Sendeschluss'@Sep 21 20:15-Sep 22 05:45
    4. Sep 21 11:31:38 localhost vdr: [3320] xmltv2vdr 'tvm2xmltv' ERROR found 'Jimmy Neutron'@Sep 22 05:45-Sep 22 06:05
    5. Sep 21 11:31:38 localhost vdr: [3320] xmltv2vdr 'tvm2xmltv' ERROR cannot add 'Der Prinz von Bel-Air'@Sep 21 21:10-Sep 21 21:40
    6. Sep 21 11:31:38 localhost vdr: [3320] xmltv2vdr 'tvm2xmltv' ERROR found 'Sendeschluss'@Sep 21 20:15-Sep 22 05:45
    7. Sep 21 11:31:38 localhost vdr: [3320] xmltv2vdr 'tvm2xmltv' ERROR found 'Jimmy Neutron'@Sep 22 05:45-Sep 22 06:05
    8. Sep 21 11:31:38 localhost vdr: [3320] xmltv2vdr 'tvm2xmltv' ERROR cannot add 'Der Prinz von Bel-Air'@Sep 21 21:40-Sep 21 22:05


    cu

  • Schau mal ins Log, das Plugin sagt genau was es versucht einzutragen, da sollte also drinstehen warum bestimmte Subtitle nicht angelegt werden.


    Also wirkliche Auffälligkeiten sehe ich nicht. Nur das hier:


    Code
    1. Sep 24 17:03:22 metropolis vdr: [2870] xmltv2vdr 'epgdata2xmltv' ERROR cannot merge into empty epg (kabel eins) - try add option


    was im Prinzip erklären könnte, warum es bei kabel1 gar nicht zu funktionieren scheint.


    Zum Simpsons-Beispiel finde ich keine Einträge (über Fehler):


    Code
    1. ...
    2. Sep 24 17:03:22 metropolis vdr: [2870] xmltv2vdr 'epgdata2xmltv' processing 'prosieben.de'
    3. Sep 24 17:03:22 metropolis vdr: [2870] xmltv2vdr 'epgdata2xmltv' from Sat Sep 24 17:03:22 2011
    4. Sep 24 17:03:22 metropolis vdr: [2870] xmltv2vdr 'epgdata2xmltv' till Sun Sep 25 17:56:42 2011
    5. ...


    -=FuF=-

  • danke für den hinweis. läuft aber trotzdem oder ? :D

    Bisher kann ich nicht sagen, dass es läuft; aber es liegt wahrscheinlich nicht am xmltv2vdr: ich benutze nicht epgdata2xmltv, sondern versuche einige EPG Daten von französischen Sender damit in den VDR zu laden.

    Quote

    wie kommst du auf die debian/watch ? irgendwie interessiert mich das jetzt.
    :D

    Als ich xmltv2vdr vom yavdr repository installieren wollte, wollte Synaptic tvm2vdr rauswerfen. Da ich das nicht wollte, habe ich mir den Source mit 'apt-get source' vom yavdr repo geholt, um zu sehen, ob ich nichts am debian Verzeichnis ändern könnte, damit er nichts rauswirft; dabei habe ich mir auch debian\watch angesehen.


    Um auf eine Diskussion zurückzukommen, die hier geführt wurde: ich finde dass xmltv2vdr und die grabber auch getrennte source packete haben sollten, da die grabber zusätzliche Abhängigkeiten erfordern können, die dann auch auf den xmltv2vdr zurückfallen, wie es bei mir den Fall war wenn ich mein Problem richtig interpretiert habe.


    mfg

  • Hi,


    seit gestern kriege ich mit epgdata2xmltv einen XML Parsing Fehler:


    Code
    1. Nov 15 22:30:44 metropolis vdr: [16042] xmltv2vdr 'epgdata2xmltv' epgdata2xmltv 7 'X' das-vierte.de dmax.de kabel1.de kika.de prosieben.de rtl.de rtl2.de sat1.de sixx.de superrtl.de tele5.de vox.de
    2. Nov 15 22:30:44 metropolis vdr: [16042] xmltv2vdr 'epgdata2xmltv' executing epgsource
    3. Nov 15 22:30:44 metropolis vdr: [16042] xmltv2vdr 'epgdata2xmltv' ERROR epgsource returned 1
    4. Nov 15 22:30:44 metropolis vdr: [16042] xmltv2vdr 'epgdata2xmltv' ERROR failed parsing xml
    5. Nov 15 22:30:44 metropolis vdr: [16042] xmltv2vdr 'epgdata2xmltv' ERROR skipping after 2 retries
    6. Nov 15 22:30:44 metropolis vdr: [16042] xmltv2vdr importer thread ended (pid=2290, tid=16042)


    Ja, ich hab zwischenzeitlich was geändert: am 12. ist mir aufgefallen, dass mein Testkey ausgelaufen war. Diesmal habe ich mir das Jahresabo von epgdata.com gegönnt und im Zuge der Wochenendbinsowiesodrann-Session den e-tobi VDR aktualisiert, incl. xmltv2vdr plugin neu aus dem git gezogen (und dvbhddevice und aktuellste 6400er Treiber und Firmware, aber das hat mit dem Problem nichts zu tun).
    Den neuen key habe ich in /var/lib/vdr/plugins/xmltv2vdr/epgdata2xmltv eingetragen. Den grabber habe ich auch neu übersetzt und das alte Binary überschrieben.
    Diverse Neustarts gemacht, um Zickerein auszuschliessen und sehr viele funktionierende Einträge in den Logs. Z.B. hier:



    Wieso geht es "auf einmal" (bzw. erster Fehler gegen 17:00 am 14.11.) nicht mehr? Die ZIPs, die das Addon nach /tmp lädt scheinen in Ordnung, die XMLs darin auf den ersten Blick syntaktisch ok. Kann irgendwas anderes kaputt sein und obige Fehlermeldung hervorrufen? Oder spinnt schlicht epgdata.com und einige von euch haben die gleichen Probleme?


    -=FuF=-

  • Um auf eine Diskussion zurückzukommen, die hier geführt wurde: ich finde dass xmltv2vdr und die grabber auch getrennte source packete haben sollten, da die grabber zusätzliche Abhängigkeiten erfordern können, die dann auch auf den xmltv2vdr zurückfallen


    Nein, ein Source-Paket kann mehrere Binär-Pakete generieren und die Abhängigkeiten gelten für jedes Binär-Paket einzeln und nicht für das Source-Paket. Daran würden mehrere Source-Pakete nichts ändern.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Joe_D : Mach dir keinen Kopf. Die epgdata.com-Daten sind aktuell kaputt. Es wird dran gearbeitet. War schon Thema in einem anderen Thread.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Mach dir keinen Kopf. Die epgdata.com-Daten sind aktuell kaputt. Es wird dran gearbeitet. War schon Thema in einem anderen Thread.


    Oh Danke, trotzdem habe ich den Parser nochmals verschlimmbessert ;)


    Anbei ein Bild das zeigt, das sowohl TVMovie wie auch EPGDATA für heute Nacht auf Vox die falschen Daten liefern für die Sendung um 4 Uhr. Mittig ist ein Ausschnitt der VOX-Webseite (im Hintergrund das DVB EPG), rechts ein Ausschnitt der TVMovie-Webseite und unten ein Ausschnitt der EPGDATA-Webseite. Ich werde die Daten später nochmals prüfen, ob es dann ein Update gibt. Wenn nicht würde das bei Leuten die das komplette EPG von TVMovie bzw. EPGDATA beziehen bedeuten das manche Sendung nicht aufgenommen wird!


    Gerade bei zahlungspflichtigen Angeboten wie EPGDATA würde ich mehr erwarten (wenn ich denn ein Abo hätte) ;)


    Gruß


    Joe_D

  • Hallo,
    Ich bin gerade dabei vom tvm2vdr zum xmltv2vdr Plugin zu wechseln.
    Einen tvmovie Grabber habe ich Netz gefunden, das Plugin wollte aber erst keine EPG Daten importieren.


    Es musste der ' * ' in der tvm2xml bei den Sendern manuell eingefügt werden - Via VDR OSD war dies nicht möglich. (Plugin aktuell aus dem Git)
    Ich fände es auch von Vorteil wenn die Datei .conf heissen würde.
    Ansonsten läuft das Plugin Prima, muss aber nocht etliche Sender hinzufügen und weitertesten.


    mfg Rudi

    VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
    VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber

  • Hi,


    kann mir jemand sagen, ob es im Moment (also Stand Ende Januar 2012) mit xmltv2vdr und epgdata.com funktioniert oder sind deren Daten immer noch kaputt oder das plugin oder meine Installation?
    Ich krieg jetzt den ganzen Januar schon



    oder "wrong pin"


    *genervt*
    Christian