Mischbetrieb alte FF (ohne Empfang) + Cine S2 möglich?

  • Hi,


    kann man folgendes zusammen betreiben:


    - alte FF ohne Anschluss an die Schüssel
    - Cine S2 (beide Tuner angeschlossen)


    oder gibt es größere Probleme?


    Klar, die Cine S2 sollte tunlichst nur S Kanäle empfangen (erstmal keine HD Ausgabe). Ich möchte schrittweise auf HD aufrüsten. Im Moment nervt mich vor allem Ruckeln/zähes Verhalten des VDR beim Timeschift (ich denke mal, dass ich Probleme mit der Bandbreitenbeschränkung der alten FF habe).


    Ulrich

  • -D alleine hilft nur begrenzt, da man damit nur ein komplettes device abschalten kann. Man könnte so z.B. einen Empfänger der CineS2 und den der FF nutzen - was aber die Bandbreitenprobleme nicht wirklich löst.


    Die bessere Lösung ist, beide Empfänger der S2 zu nutzen, und dafür von der FF nur die Ausgabe zu verwenden. Das macht z.B. der localchannelprovide-Patch. Nach aktuellen Versionen des Patches musst du evtl. etwas suchen.


    Notfalls habe ich für VDR-1.7.x einen eigenen Patch aus den gleichen Gründen rumliegen, der gezielt nur das dvbsddevice-Plugin mit einer --OutputOnly Option ergänzt.



    Gruß,


    Udo

  • Ok, ich hänge den Patch mal an. Er leistet aber auch nichts anderes, als die localchannelprovide-Patches: Durch ein beherztes return false in ProvidesSource() behauptet jedes FF-Device, keine Kanäle empfangen zu können. Statt aber per Setup-Menü abschaltbar zu sein, habe ich mich für einen Kommandozeilenparameter entschieden:


    vdr -P"dvbsddevice --OutputOnly"


    Der Patch ist noch nicht allzu elegant, hat aber den Vorteil, dass er sich wirklich auf das dvbsddevice und damit auf FF-Karten beschränkt.


    Gruß,


    Udo

  • Hallo


    habe genau das gleiche Problem aber bring es leider nicht ganz hin.


    habe den Patch auf gen2vdr v3 unter Pfad /usr/local/src/vdr-1.7.14/PLUGINS/src/dvbsddevice eingespielt. Hoffe er passt auch auf V 1.7.14


    Seitdem bekomm ich die Meldung ERROR: no OSD provider available - using dummy OSD!


    Denke es liegt daran, dass ich den VDR nicht mit Paramter vdr -P"dvbsddevice --OutputOnly" starte



    Denke danach sollte das OSD Problem gelöst sein, wäre cool wenn jemand ein Post für mich übrig hätte.


    Danke
    Roland

    Gen2VDR V5.1


    Mainboard: AsRock G41M-S
    DVB: DVBS2 CineS2
    RAM: 2G
    HDD: 1TB Western Digital 3,5" SATA
    DVD-Brenner: Liteon
    LCD: imon
    IR: Mini USB Keyboard

  • Sorry spät und nicht ganz allein...



    ich denke ich hab alles hinbekommen, nur wie starte ich den vdr standardmäßig mit dem oben genannten parameter????


    denke erst dann bekommt mein osd wieder licht,...




    danke
    Roland

    Gen2VDR V5.1


    Mainboard: AsRock G41M-S
    DVB: DVBS2 CineS2
    RAM: 2G
    HDD: 1TB Western Digital 3,5" SATA
    DVD-Brenner: Liteon
    LCD: imon
    IR: Mini USB Keyboard

  • Wenn dein VDR bereits mit der FF als Ausgabe funktioniert, dann hast du bereits ein -P dvbsddevice in deiner VDR Kommandozeile drin. Andernfalls aktiviert VDR den Ausgang der FF nicht.


    Vermutlich wird es irgend einen Mechanismus geben, der bei deiner Distri darüber entscheidet, welche Plugins geladen werden sollen, und mit welchen Parametern. Und da muss das --OutputOnly dazu.


    Gruß,


    Udo

  • sorry wenn ich schon wieder lässtig ist, aber irgendwie bekomm ich das nicht gebacken...


    also ich hab im log rausgefunden, dass mein gen2vdr via folgenden befehl gestartet wird


    Code
    1. /usr/bin/vdr --localedir=/etc/vdr/locale --vfat -u root -w 60 --config=/etc/vdr --shutdown='/_config/bin/vdrshutdown' --epgfile=/video/epg.data --log=3 --video=/video --record='/tmp/vdr/vdr_record' --lib=/usr/lib/vdr/plugins --plugin='dvd -C/dev/dvd' --plugin='cdda ' --plugin='music ' --plugin='mplayer --mplayer=/etc/vdr/plugins/mplayer/mplayer.sh --mount=/etc/vdr/plugins/mp3/mount.sh' --plugin='osdteletext -d /tmp/osdteletext -n 20' --plugin='epgsearch ' --plugin='extrecmenu ' --plugin='skinenigmang --epgimages=/video/epgimages' --plugin='filebrowser ' --plugin='yacoto ' --plugin='admin ' --plugin='dvbsddevice'


    --plugin='dvbsddevice' hab ich auch gefunden aber einfach ein --OutputOnly mag er dann schon gar nicht, kann ich sein, dass ich noch ein spezielles Plugin mitangeben muss??


    sg
    Roland

    Gen2VDR V5.1


    Mainboard: AsRock G41M-S
    DVB: DVBS2 CineS2
    RAM: 2G
    HDD: 1TB Western Digital 3,5" SATA
    DVD-Brenner: Liteon
    LCD: imon
    IR: Mini USB Keyboard

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Dirk ()

  • Hallo


    spät aber doch, hab ich es hinbekommen und bin wieder ein Schritt weiter bei meinen Problemen...


    Für alle anderen die mal das gleiche Problem haben hier die Lösung:
    Um bei gen2vdr einen Parameter einem Plugin mit auf den Weg zu geben, einfach
    eine Datei /etc/vdr.d/plugins/<pluginname> öffnen und bei PLUGIN_PARAMETERS="<;Dein Parameter>" eintragen.
    Hoffe es wird mal jemanden weiterhelfensgRoland

    Gen2VDR V5.1


    Mainboard: AsRock G41M-S
    DVB: DVBS2 CineS2
    RAM: 2G
    HDD: 1TB Western Digital 3,5" SATA
    DVD-Brenner: Liteon
    LCD: imon
    IR: Mini USB Keyboard