CI-Unterstützung für CineS2, Mystique SaTiX-S2 Dual usw.

  • Der Patch tut, was er soll, gute Arbeit!

    Das harte und das weiche CAM gehen wieder.

    Vielen Dank nochmals!


    Mit vdr-2.4.0 geht es aber immer noch nicht.

    Dateien

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von jrie ()

  • Mit vdr-2.4.0 geht es aber immer noch nicht.

    Ich kann mir nicht vorstellen, dass das am ddci2 Plugin liegt.

    Vielleicht kann dir Klaus ja beim Debuggen helfen.

  • Ja, meine ursprüngliche Annahme, es müsse an ddci2 oder am ACL liegen ist offensichtlich falsch. Es liegt am vdr.


    Stört das hier? Dann könnte man die Beiträge in einen anderen Thread auslagern.

  • Mein Verständnis ist nur sehr oberflächlich.

    Ich habe ein paar printf‘s in vdr-2.4.0 eingebaut.

    Vielleicht blicke ich aber auch nur nicht richtig durch …


    Auf dem Transponder sind 4 Sender, die alle die 3 selben ECM Pids haben.

    Beim Hinschalten werden diese 12 CaPids hinzugefügt, beim Wegschalten werden diese 12 CaPids gelöscht. Auch wenn sie noch benötigt werden.


    Wie werden denn in vdr-2.4.0 shared CaPids geschützt?

    Dateien

    • ci.c.diff

      (1,16 kB, 12 Mal heruntergeladen, zuletzt: )
  • hallo,

    vdr-2.4.0 macht dass schon richtig - soweit ich den code verstanden habe.

    du könntest folgendes testen:
    zeile 2504 ci.c
    if (GetCaPids(source, transponder, p->programNumber, CaSystemIds, MAXRECEIVEPIDS + 1, CaPids) > 0) {

    if (Active)

    caPidReceiver->AddPids(CaPids);

    else {

    ++++ FixSharedCaPids(p->programNumber, CaSystemIds, CaPids);

    caPidReceiver->DelPids(CaPids);

    }

    }


    falls dies Besserung bringt - bitte unbedingt an klaus melden - der kümmert sich dann.
    gruß, onur

  • Bevor ich jetzt das Rad neu erfinde, frage ich lieber erst mal:

    Damit der VDR nach den DVB-S2-Karten startet habe ich in /etc/systemd/system/vdr.service.d eine wait-for-devices.conf:

    Das CI legt aber ein

    Code
    1. /dev/dvb/adapterx/ca0
    2. /dev/dvb/adapterx/sec0

    an, wobei adapterx mal adapter0 oder adapter1 oder ... ist.


    Wie bekomme ich die sauber getrennt, so dass sich das nicht beisst?

  • Hi!


    Das mit dem ca0 und sec0 in einem getrennten Adapter ist richtig, wenn du das ddci2 Plugin verwenden möchtest.

    Wenn du das CI im Kernel fest einen Tuner zuordnen willst (warum auch immer), dann musst du einen Kernel Parameter (adapter_alloc) definieren. Wie das geht, steht irgendwo in diesem Thread.


    LG,

    Jasmin

  • Es geht darum, dass für ddbridge jedes Mal dasselbe /dev/dvb/adapterN angelegt wird.

    Sonst funktioniert die wait-for-devices.conf nicht.


    Ich habe mir jetzt damit beholfen, dass ich in /etc/modprobe.d/50-blacklist.conf ddbridge und die Module für meine DVB-Karten geblacklistet habe, und dann in /etc/init.d/boot.local erst die Module für meine DVB-Karten starte und dann ddbridge.

    Dadurch ist das CI dann immer in /dev/dvb/adapter3, statt mal in /dev/dvb/adapter0, mal in /dev/dvb/adapter1, mal in /dev/dvb/adapter2 oder mal in /dev/dvb/adapter3.


    Noch einfacher:

    Code
    1. cat /etc/modprobe.d/99-local.conf
    2. options budget adapter_nr=0,1,2
    3. options ddbridge adapter_nr=3