[gelöst] TBS 6980/6981 Fernbedienung

  • Mit dem Treiber linux-s2api-tbs6980-1_20101024.rar funktioniert auch die Fernbedienung. Allerdings ist in dieser Version noch ein Fehler, der die Taste 'Mode' und 'Gelb' blockiert. Der Fehler kann vor der Kompilierung selbst behoben werden. Dazu ist das File rc-tbs-nec.c ( aus linux/drivers/media/IR/keymaps) anzupassen:


    falscher Wert:
    { 0x9d, KEY_MODE}


    richtiger Wert:
    { 0x9b, KEY_MODE}


    Danach den Treiber wie gewohnt mit make und make install installieren.


    weitere Konfigurationsdateien:
    /etc/udev/rules.d/10-dvb-remote.rules:
    KERNEL=="event*", ATTRS{name}=="cx23885 IR (TurboSight TBS 6981)", SYMLINK+="input/tbs-ir"


    ........snap .....................


    /etc/hardware.conf:
    #Chosen Remote Control
    REMOTE="cx23885 IR (TurboSight TBS 6981)"
    REMOTE_MODULES=""
    REMOTE_DRIVER="devinput"
    REMOTE_DEVICE="/dev/input/tbs-ir"
    REMOTE_LIRCD_CONF="/etc/lirc/lircd.conf"
    REMOTE_LIRCD_ARGS=""


    #Chosen IR Transmitter
    TRANSMITTER="None"
    TRANSMITTER_MODULES=""
    TRANSMITTER_DRIVER=""
    TRANSMITTER_DEVICE=""
    TRANSMITTER_LIRCD_CONF=""
    TRANSMITTER_LIRCD_ARGS=""


    #Enable lircd
    START_LIRCD="true"


    LIRCD_ARGS=""


    #Don't start lircmd even if there seems to be a good config file
    #START_LIRCMD=false


    #Try to load appropriate kernel modules
    LOAD_MODULES=true


    # Run "lircd --driver=help" for a list of supported drivers.
    DRIVER="dev/input"
    # If DEVICE is set to /dev/lirc and devfs is in use /dev/lirc/0 will be
    # automatically used instead
    DEVICE="/dev/input/tbs-ir"
    MODULES=""


    # Default configuration files for your hardware if any
    LIRCD_CONF="/etc/lirc/lircd.conf"
    LIRCMD_CONF=""
    ...................snap...............
    /etc/lirc/lircd.conf:
    #Rumpf erstellt mit irrecord
    #changes by blckcat
    #usage nearly as m740av remote control
    #date: 27.10.010


    begin remote


    name lircd.conf
    bits 16
    eps 30
    aeps 100


    one 0 0
    zero 0 0
    pre_data_bits 16
    pre_data 0x8001
    gap 35987
    toggle_bit_mask 0x0


    begin codes
    menu 0x0175
    onoff 0x0164
    mute 0x0071


    1 0x0002
    2 0x0003
    3 0x0004
    4 0x0005
    5 0x0006
    6 0x0007
    7 0x0008
    8 0x0009
    9 0x000A
    0 0x000B


    back 0x0192
    info 0x0073
    menu 0x0193
    epg 0x0072

    up 0x0067
    down 0x006C
    left 0x0069
    right 0x006A
    ok 0x0160

    red 0x008B
    yellow 0x0174
    green 0x016C
    blue 0x00AE


    fr 0x016d
    stop 0x0077
    play 0x0172
    ff 0x00d4


    back 0x019c
    pause 0x00A7


    end codes


    end remote
    .....snap...................
    /etcvdr/remote.conf:
    LIRC.Power onoff
    LIRC.0 0
    LIRC.1 1
    LIRC.2 2
    LIRC.3 3
    LIRC.4 4
    LIRC.5 5
    LIRC.6 6
    LIRC.7 7
    LIRC.8 8
    LIRC.9 9
    LIRC.Info info
    LIRC.Play play
    LIRC.Stop stop
    LIRC.Pause pause
    LIRC.Record rec
    LIRC.FastFwd ff
    LIRC.FastRew fr
    LIRC.Next next
    LIRC.Prev last
    LIRC.Volume+ vol+
    LIRC.Volume- vol-
    LIRC.Mute mute
    LIRC.Channel+ ch+
    LIRC.Channel- ch-
    LIRC.Up up
    LIRC.Down down
    LIRC.Menu menu
    LIRC.Ok ok
    LIRC.Back back
    LIRC.Left left
    LIRC.Right right
    LIRC.Red red
    LIRC.Green green
    LIRC.Yellow yellow
    LIRC.Blue blue


    KBD.Up 00000000001B5B41
    KBD.Down 00000000001B5B42
    KBD.Menu 000000000000006D
    KBD.Ok 000000000000000D
    KBD.Back 000000000000007F
    KBD.Left 00000000001B5B44
    KBD.Right 00000000001B5B43
    KBD.Red 000000001B5B5B41
    KBD.Green 000000001B5B5B42
    KBD.Yellow 000000001B5B5B43
    KBD.Blue 000000001B5B5B44
    KBD.0 0000000000000030
    KBD.1 0000000000000031
    KBD.2 0000000000000032
    KBD.3 0000000000000033
    KBD.4 0000000000000034
    KBD.5 0000000000000035
    KBD.6 0000000000000036
    KBD.7 0000000000000037
    KBD.8 0000000000000038
    KBD.9 0000000000000039
    KBD.Info 0000000000000069
    KBD.FastFwd 0000001B5B31377E
    KBD.FastRew 000000001B5B5B45
    KBD.Power 0000000000000070
    KBD.Volume+ 0000001B5B32347E
    KBD.Volume- 0000001B5B32337E
    KBD.Mute 0000001B5B32317E
    KBD.User7 0000001B5B31387E
    KBD.User8 0000001B5B31397E
    KBD.User9 0000001B5B32307E
    XKeySym.Up Up
    XKeySym.Down Down
    XKeySym.Menu m
    XKeySym.Ok Return
    XKeySym.Back BackSpace
    XKeySym.Left Left
    XKeySym.Right Right
    XKeySym.Red F1
    XKeySym.Green F2
    XKeySym.Yellow F3
    XKeySym.Blue F4
    XKeySym.0 0
    XKeySym.1 1
    XKeySym.2 2
    XKeySym.3 3
    XKeySym.4 4
    XKeySym.5 5
    XKeySym.6 6
    XKeySym.7 7
    XKeySym.8 8
    XKeySym.9 9
    XKeySym.Info i
    XKeySym.Pause space
    XKeySym.FastFwd F6
    XKeySym.FastRew F5
    XKeySym.Power p
    XKeySym.Volume+ F12
    XKeySym.Volume- F11
    XKeySym.Mute F10
    XKeySym.User7 F7
    XKeySym.User8 F8
    XKeySym.User9 F9



    graphtft-fe.Up 0000000000000062
    graphtft-fe.Down 0000000000000068
    graphtft-fe.Menu 0000000000000047
    graphtft-fe.Ok 0000000000000024
    graphtft-fe.Back 0000000000000016
    graphtft-fe.Left 0000000000000064
    graphtft-fe.Right 0000000000000066
    graphtft-fe.Red 0000000000000043
    graphtft-fe.Green 0000000000000044
    graphtft-fe.Yellow 0000000000000045
    graphtft-fe.Blue 0000000000000046
    graphtft-fe.0 0000000000000013
    graphtft-fe.1 000000000000000A
    graphtft-fe.2 000000000000000B
    graphtft-fe.3 000000000000000C
    graphtft-fe.4 000000000000000D
    graphtft-fe.5 000000000000000E
    graphtft-fe.6 000000000000000F
    graphtft-fe.7 0000000000000010
    graphtft-fe.8 0000000000000011
    graphtft-fe.9 0000000000000012
    graphtft-fe.Info 0000000000000048
    graphtft-fe.Volume+ 0000000000000063
    graphtft-fe.Volume- 0000000000000069
    graphtft-fe.Mute 0000000000000067
    ........... snap ...............
    /usr/share/xbmc/system/Lircmap.xml:
    ...
    <remote device="lircd.conf">
    <play>play</play>
    <pause>pause</pause>
    <stop>stop</stop>
    <forward>ff</forward>
    <reverse>fr</reverse>
    <left>left</left>
    <right>right</right>
    <up>up</up>
    <down>down</down>
    <select>ok</select>
    <pageplus>none</pageplus>
    <pageminus>none</pageminus>
    <back>back</back>
    <menu>menu</menu>
    <title>info</title>
    <info>info</info>
    <skipplus>Skip</skipplus>
    <skipminus>Replay</skipminus>
    <display>Aspect</display>
    <start>menu</start>
    <record>Record</record>
    <volumeplus>vol+</volumeplus>
    <volumeminus>vol-</volumeminus>
    <mute>mute</mute>
    <power>onoff</power>
    <myvideo>Videos</myvideo>
    <mymusic>Music</mymusic>
    <mypictures>Pictures</mypictures>
    <mytv>TV</mytv>
    <one>1</one>
    <two>2</two>
    <three>3</three>
    <four>4</four>
    <five>5</five>
    <six>6</six>
    <seven>7</seven>
    <eight>8</eight>
    <nine>9</nine>
    <zero>0</zero>
    <star>Star</star>
    <hash>Hash</hash>
    <clear>Clear</clear>
    <enter>ok</enter>
    <red>red</red>
    <green>green</green>
    <yellow>yellow</yellow>
    <blue>blue</blue>
    <teletext>Teletext</teletext>
    </remote>
    ...
    .............snap .........


    Als Anmerkung ist noch zu erwähnen, das ich die Tastaturbelegung an mein altes VDR-System auf einer m740av angepasst habe. Das ist sicherlich nicht für alle optimal, aber es funktioniert zunächst einmal:


    hier die Belegung:
    M740AV, 29 + 2 Codes --> 31
     
    Power

    1 2 3
    4 5 6
    7 8 9
    0
    xxxx xxxx


    UP


    LEFT OK RIGHT

    DOWN


    EXIT MUTE


    MENU EPG INFO


    << STOP PLAY >>


    RED GREEN YELLOW BLUE


    ----------------------------------------------------------------------


    TBS 6981


    MENU POWER MUTE


    1 2 3
    4 5 6
    7 8 9
    0
    BACK INFO
    MENU EPG


    UP


    LEFT OK RIGHT

    DOWN


    RED YELLOW GREEN BLUE


    << STOP PLAY >>


    BACK PAUSE



    .......snap.............


    Michael

    VDR1: AT3IONT-I mit TBS-6981, TBS-RC-Empfänger mit Harmony 650, Silverstone Gehäuse SST-PT09B, yavdr 0.3a
    VDR2: M740AV mit vdr 1.4.x mit ALLNET 6250

  • Mahlzeit,


    da ich die TBS 6981 auch seit einger Zeit zum Testen in einer meiner VDR's habe, kurz mal ein kleiner Nachtrag zu den neuen Treibern.


    - Die Karte bringt jetzt auch beim Start auf HD-Sendern jederzeit ein Bild.
    Vorher musste man immer 3 Sender furchzappen bis HD ging.


    - Das neue Treiberpaket bringt eine neue Firmware (v4l-cx23885-avcore-01.fw) mit, die muß unbedingt installiert werden (=> /lib/firmware)


    - Die Beschreibung der Installation hat sich geändert und ist nicht mehr angepasst an die eigentliche Installation. Es gibt jetzt ein .sh für die jeweilige Installation auf x32 oder x64 die das Frontend bestimmt.


    - Der Modulparamater des cx23885 card=30 ist jetz gültig (vorher card=29)


    - Ein zusätzliches Modul cx25840 wird beim manuellen Laden benötigt.


    - Die Zappzeit ist gefühlt schneller geworden


    Somit ist die Karte für den Preis von aktuell 124 Euro zzgl. Versand absolut zu empfehlen, auch wenn die Treiber an sich, nicht komplett open sind.
    Aber bei dem Support zum Treiber ist das zu verschmerzen.



    Gruß
    Wolfgang

  • Hi!


    Funktioniert die TBS 6980 denn mit diesem Treiber ebenso wie von wbreu beschrieben? (Start-auf-HD-Sender-Bug...)


    Hatte Sie schon in den Keller gelegt :-)


    Grüße,
    Tobias

    VDR 1: yavdr64 0.5.0a@VDR 2.0.3, DD Cine S2 V6.5+DuoFlex S2, Asus P5EVHDMIG35 + Intel® C2D E4500 Passiv, HD160XT PLUS HTPC Gehäuse, Zotac GeForce GT 630 (Kepler) Zone Edition 2GB
    VDR 2
    :
    yavdr64 0.5.0a@VDR 2.0.3, TeVii S471, Zotac MB (Intel D525, DDR2-800, Next Generation NVIDIA ION 512MB, PCIe-X16/4Lanes, WLAN, USB 3.0, HDMI, DVI-D, 90WATT PSU, PASSIVE, Mini ITX), 4GB Ram


    -DISEqC: Astra+Hotbird, -Router: Fritz!Box 7390, NAS: Qnap TS-459 Pro+ mit 9TB HDD@RAID5-ext4


  • Hast du sie schon aus dem Keller geholt und mal getestet?
    Habe auch die 6980 und bei mir besteht das Problem noch.

    HD-VDR:
    HW: ZOTAC D2550-ITX | Mystique SaTiX-S2 Sky Xpress DUAL
    SW: Debian Jessie | vdr-2.2.0 | softhddevice
    Streaming-VDR:
    HW: Cubietruck | CT2-4400
    SW: Debian Jessie | Kernel 4.3 | vdr-2.2.0

  • Hi oberlon,


    ich habe es noch nicht ausprobiert, aber bereits mit dem Gedanken gespielt die Karte zu verkaufen...



    Kann sonst wer etwas zu dem "Start-auf-HD-Sender-Bug" der TBS 6980 und den aktuellen Treibern berichten?


    Grüße, Tobias,

    VDR 1: yavdr64 0.5.0a@VDR 2.0.3, DD Cine S2 V6.5+DuoFlex S2, Asus P5EVHDMIG35 + Intel® C2D E4500 Passiv, HD160XT PLUS HTPC Gehäuse, Zotac GeForce GT 630 (Kepler) Zone Edition 2GB
    VDR 2
    :
    yavdr64 0.5.0a@VDR 2.0.3, TeVii S471, Zotac MB (Intel D525, DDR2-800, Next Generation NVIDIA ION 512MB, PCIe-X16/4Lanes, WLAN, USB 3.0, HDMI, DVI-D, 90WATT PSU, PASSIVE, Mini ITX), 4GB Ram


    -DISEqC: Astra+Hotbird, -Router: Fritz!Box 7390, NAS: Qnap TS-459 Pro+ mit 9TB HDD@RAID5-ext4

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von T o b i a s ()

  • #Start-HD-Problem


    Gerade nochmal etwas rumprobiert und bemerkt, dass wenn ich über femon von card#1 auf card#0 wechsel die Bildstörungen weg sind. Zurück auf #1 und sie sind wieder da.

    HD-VDR:
    HW: ZOTAC D2550-ITX | Mystique SaTiX-S2 Sky Xpress DUAL
    SW: Debian Jessie | vdr-2.2.0 | softhddevice
    Streaming-VDR:
    HW: Cubietruck | CT2-4400
    SW: Debian Jessie | Kernel 4.3 | vdr-2.2.0

  • oberlon ,
    mal noch eine Frage zu der TBS6980:
    Hast Du einigermaßen vernünftige Anzeigewerte für STR und SNR beim femon-Plugin auf beiden Tunern bei SD- und HD-Sendern?


    Paulaner

  • Ich verwende die TBS 6981 mit den aktuellen Treibern und bei mir besteht das Problem(HD-Sender beim start immer noch).
    Die Werte für sind


    STR 74%
    SNR 100%
    BER 0
    UNC 0


    Hab den VDR so eingestellt das er beim Start einen SD Sender anzeigt und habe beim umschalten auf einen HD Sender sofort ein Bild.
    Ich bin sehr zufrieden mit dieser Karte

    Hardware
    TBS-6981(rennt perfekt)
    ASUS AT3IONT-I Mini-ITX
    DDR3 4GB Kingston ValueRAM
    Samsung EcoGreen F2 1TB
    LG DH16NS schwarz Bulk
    Pollin X10


    Software
    yaVDR 0.4pre1 alle Updates

  • Hallo und happy new year,

    Zitat

    Original von Paulaner
    Hast Du einigermaßen vernünftige Anzeigewerte für STR und SNR beim femon-Plugin auf beiden Tunern bei SD- und HD-Sendern?


    Tuner 1:
    STR 74%
    SNR 91%


    Tuner 2:
    STR 74%
    SNR 88%


    Wie aussagekräftig diese Werte sind kann ich nicht sagen nur dass ich bei den letzten Schneefällen usw. keine Probleme hatte. Von der Empfangsstärke ist die Karte sehr gut. Einzig das HD-Start Problem nervt. Ich kann z.Z. damit leben;)

    HD-VDR:
    HW: ZOTAC D2550-ITX | Mystique SaTiX-S2 Sky Xpress DUAL
    SW: Debian Jessie | vdr-2.2.0 | softhddevice
    Streaming-VDR:
    HW: Cubietruck | CT2-4400
    SW: Debian Jessie | Kernel 4.3 | vdr-2.2.0

  • Hallo smash2k,


    probier mal mit

    Code
    1. evtest /dev/input/eventX


    alle durch und drücke ne Taste dabei.
    Tut sich da was?

    Wissen ist Macht, nix wissen macht auch nix
    VDR1: yaVDR0.3.0a Gigabyte GAM85M-US2H VDPAU 1GB Ram Sempron140 500GB WD CaviarBlue 2xTT-S2-1600, ATRIC on Com1
    VDR2: yaVDR0.3.0a Zotac Ion-F 2GB Ram 1TB WD CaviarBlue Dual TBS 6981

  • Wird zwar etwas ot, aber für das HD-Sender-Problem habe ich ins VDR -Startskript eingebaut, dass szap zweimal (für jeden Tuner extra) auf einem SD-Sender aufgerufen, zwei Sekunden gewartet und dann wieder gekillt wird. So kann VDR ohne Probleme auf einem HD-Sender starten.

    Dr. Brömme grübelt:
    Acht Wochen, nachdem man ihm beim Kölner Straßenkarneval einen Gratiskorn angeboten hatte,
    dämmert ihm langsam, dass er einem hinterlistigen Alaafisten aufgesessen ist.