Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 10. Juni 2010, 18:07

Bekomm "SKyStar S2" nicht zum laufen

Hallo,

bin absoluter VDR Neuling und hab gerade mein erstes System zusammengebaut. Leider bekomme ich kein Bild. Als DVB-S2 Karte benutze ich eine "Technisat SkyStar S2" (nicht die Skystar HD2 über die es schon viele beiträge gibt!) und bekomme sie nicht zum laufen. Wollte gerade z.B. mit w_scan eine Kanalliste laden, dann kommt die Fehlermeldung: " NO USEABLE DVB CARD FOUND".

Mein VDR besteht unter anderem aus:
- Asus Mainboard M3N78-VM
- AMD Athlon X2 235e
- auf dem VDR läuft yaVDR 0.2 mit Liplianin-Treibern

Hat schon irgendjemand Erfahrung mit dieser Karte? Braucht ihr noch irgendwelche Infos?

Gruß Tobi
yaVDR 0.2: Asus M3N78-VM, AMD Athlon II X2 235e, 2GB RAM
zwei TT budget S2-1600, Fernbedienung - USB X10

2

Donnerstag, 10. Juni 2010, 18:10

Ist bei

Quellcode

1
lspci
auf der Konsole die Karte mit gelistet?
Gruß utiltiy

meine VDR

vdr01: Scenic S PIII 1GHz, 512 MB, Board D1215, SDA IDE 400GB, Nexus-S Rev. 2.3, Full-TS Mod, JP2 Mod [etobi]
vdr02: Scenic xB PIII 933MHz, 512 MB, Board D1215, SDA IDE 160GB, Nexus-S Rev. 2.3, Full-TS Mod, JP2 Mod, AV-Board [etobi]
vdr03: Antec Remote Fusion, Intel DH67BL, Celeron G1620, GT610, 2x 2GB DDR3 - Hynix, SDA SATA 40GB, SDB SATA 1.5TB, DD Cine S2 [yaVDR/vdr4arch]
vdr04: Antec Remote Fusion Micro, Intel DH67BL, Celeron G550, GT630, 2x 2GB DDR3 - Kingston, SDA SATA 160GB WD, SDB SATA 3TB WD Red, L4M Cine S2 [yaVDR/vdr4arch]

VDR Projekte EPGD http EPG2VDR http

3

Donnerstag, 10. Juni 2010, 18:23

Der einzige Eintrag der was mit der Karte zu tun hat ist:

Quellcode

1
01:06.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)

Das ist doch nur der Netzwerkcontroller und nicht die DVB-S "Funktion", oder?
yaVDR 0.2: Asus M3N78-VM, AMD Athlon II X2 235e, 2GB RAM
zwei TT budget S2-1600, Fernbedienung - USB X10

4

Donnerstag, 10. Juni 2010, 18:27

Das ist in Ordnung, würde ich dazu sagen.
Gruß utiltiy

meine VDR

vdr01: Scenic S PIII 1GHz, 512 MB, Board D1215, SDA IDE 400GB, Nexus-S Rev. 2.3, Full-TS Mod, JP2 Mod [etobi]
vdr02: Scenic xB PIII 933MHz, 512 MB, Board D1215, SDA IDE 160GB, Nexus-S Rev. 2.3, Full-TS Mod, JP2 Mod, AV-Board [etobi]
vdr03: Antec Remote Fusion, Intel DH67BL, Celeron G1620, GT610, 2x 2GB DDR3 - Hynix, SDA SATA 40GB, SDB SATA 1.5TB, DD Cine S2 [yaVDR/vdr4arch]
vdr04: Antec Remote Fusion Micro, Intel DH67BL, Celeron G550, GT630, 2x 2GB DDR3 - Kingston, SDA SATA 160GB WD, SDB SATA 3TB WD Red, L4M Cine S2 [yaVDR/vdr4arch]

VDR Projekte EPGD http EPG2VDR http

5

Donnerstag, 10. Juni 2010, 21:19

Habe noch ein bisschen rumprobiert. Als ich eine alte DVB-S Karte reingesteckt habe, ging der Suchlauf mit "w_scan" ohne Probleme und ich hatte ein Bild. Mit der Skystar S2 geht aber nichts. Habe auf Linktv.org gesehen, dass meine Karte ganz unten unter "Currently Unsupported" steht. Wenn man sie anwählt ist auch ein Link angegeben unter dem man die Linuxtreiber findet. Soll ich die Karte zurückschicken und mir lieber eine "TechnoTrend TT S2-1600" kaufen oder hab ich als Linuxanfänger eine Chance meine Karte noch zum laufen zu bekommen?
yaVDR 0.2: Asus M3N78-VM, AMD Athlon II X2 235e, 2GB RAM
zwei TT budget S2-1600, Fernbedienung - USB X10

6

Dienstag, 26. Oktober 2010, 18:39

Hey ho @all
habe auch die Technisat Skystar S2 und si leuft auch net.
mit lspci bekomme ich auch
"01:06.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)"
Das ist aber ganz und garnicht ok
Das weist daruf hi das die Karte nicht richtig erkannt wird.
Es gibt von Techniesat ne Firmware und nen Patch für die v4l DVB Treiber.
Alternativ gibt es auf ner Russischenseite den Patch für die Liplianin-Treibern.
Habe aber leider noch keine zeit gefunden die Treiber zu pachen und neu zu bauen.
oder hatt jemand das schon gemacht?

have fun
AMD Athlon X2 6000+, Asus M2A-VM Mainbord, Croshair 2x1GB DDR2 800MHz, 250GB HDD, LG GCW-H20L, Nvidia Geforce 9600GT, SB audigy2 ZS, TechnoTrend TT-3200 CI, Opensuse 12.1, VDR 1.7.17, Xine-VDPAU

7

Mittwoch, 27. Oktober 2010, 09:32

Mal ins Blaue getippt ;)
Die Skystar benutzt doch den mantis-Treiber, oder?? Wenn ja, muss man den händisch in die /etc/modules eintragen.
VDR: Asus M3N78-EM mit Onboard Nvidia 8300, AMD 5050e, 2x2GB Ram, 8GB SATA Transcend SSD + 1 TB WD green, Atric-Einschalter, Hitachi-LCD 240x128 (HD61830) & AX206 (Pearl), Terratec S2 HD & TeVii S464 (unterstützt durch v4l-dvb per selfmade-patch), yaVDR 0.4

8

Samstag, 30. Oktober 2010, 16:09

@BlueVIP
mantis-Treiber?
wie gehts das denn?
@ all
Habe das jetzt mal veersucht mit der anleitung auf dieser russischen seite die Treiben zu patchen das geht auch alles wenn ich jetzt aber versuche die s2-liplinanin Treiber zu pbersetzen bekomme ich ne Fehlermeldung die wohl was mit IEEE 1394 zutuhen hat.
Schnell im net gesucht und das broblem läst sich dann auch beheben.
Jetzt stehe ich immer noch beim make und bekomme diesen fehler

Quellcode

1
ir-sysfs.c:137: error: implicit decleration of function "skip_spaces"

Dafür gibt es wohl auch nen patch leider schlägt der in 3 von 5 hungs fehl.
sonst wer ne idee?
AMD Athlon X2 6000+, Asus M2A-VM Mainbord, Croshair 2x1GB DDR2 800MHz, 250GB HDD, LG GCW-H20L, Nvidia Geforce 9600GT, SB audigy2 ZS, TechnoTrend TT-3200 CI, Opensuse 12.1, VDR 1.7.17, Xine-VDPAU

9

Samstag, 30. Oktober 2010, 16:28

Sorry das gilt natürlich nur für die HD2..
:versteck

EDIT: Das schon gesehen?? Sprich: 6. Frontend cx24123 deaktivieren
VDR: Asus M3N78-EM mit Onboard Nvidia 8300, AMD 5050e, 2x2GB Ram, 8GB SATA Transcend SSD + 1 TB WD green, Atric-Einschalter, Hitachi-LCD 240x128 (HD61830) & AX206 (Pearl), Terratec S2 HD & TeVii S464 (unterstützt durch v4l-dvb per selfmade-patch), yaVDR 0.4

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »BlueVIP« (30. Oktober 2010, 16:29)


10

Samstag, 30. Oktober 2010, 16:50

@ BlueVIP thx für die schnelle antwort

Zitat

"EDIT: Das schon gesehen?? Sprich: 6. Frontend cx24123 deaktivieren"

ok habs jetzt gefunden was du meinst aber der schritt kommt leider erst nachdem die treiber neu gebaut werden also hänge ich nen schritt davor fest.
Fackt ist das die SkyStarS2 karte nicht richtig erkannt wird bzw das kein B2C2flexcop treiben gefunden wird .
dmeg bringt das hier

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
[   55.335793] b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully 
[   55.338922] flexcop-pci: will use the HW PID filter.
[   55.338932] flexcop-pci: card revision 2 
[   55.338948] b2c2_flexcop_pci 0000:00:0c.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16 
[   55.343174] DVB: registering new adapter (FlexCop Digital TV device)
[   55.345127] b2c2-flexcop: MAC address = f65da030 
[   55.345835] CX24123: wrong demod revision: df 
[   55.619560] mt352_read_register: readreg error (reg=127, ret==-121) 
[   55.645604] nxt200x: nxt200x_readbytes: i2c read error (addr 0x0a, err == -121) 
[   55.645611] Unknown/Unsupported NXT chip: 00 00 00 00 00 
[   55.671929] lgdt330x: i2c_read_demod_bytes: addr 0x59 select 0x02 error (ret == -121) 
[   55.724846] stv0297_readreg: readreg error (reg == 0x80, ret == -121) 
[   55.751025] mt312_read: ret == -121 
[   55.751128] b2c2-flexcop: no frontend driver found for this B2C2/FlexCop adapter 
[   55.751666] b2c2_flexcop_pci 0000:00:0c.0: PCI INT A disabled

was mich dann wieder zum uhrsprung zurückführ das patchen des treibers und neu übersetzen.
AMD Athlon X2 6000+, Asus M2A-VM Mainbord, Croshair 2x1GB DDR2 800MHz, 250GB HDD, LG GCW-H20L, Nvidia Geforce 9600GT, SB audigy2 ZS, TechnoTrend TT-3200 CI, Opensuse 12.1, VDR 1.7.17, Xine-VDPAU

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Spawn0202« (30. Oktober 2010, 17:06)


11

Sonntag, 31. Oktober 2010, 22:27

Hey @ all

So jetzt habe ich aber überhaupt keinen plan mehr.
erstmal zu dem was ich gemacht habe
S2-lipliani triber runtergeladen den SkyStarS2 Patch runtergeladen und angewendet.
2 errors beseitigt bei übersetzen.
Versucht mit

Quellcode

1
make menuconfig
im verzeichnis /usr/src/s2-liplianin cx24123 zu deaktivieren.Bin sogar soweit gegangen das ich nur noch das relewante cx24120 dringelassen habe.
mit dem erfolg das egal wasich gemacht habe immer

Quellcode

1
[   55.345835] CX24123: wrong demod revision: df 
erscheint
mache ich was falsch ? oder habe ich was vergessen?



have fun
AMD Athlon X2 6000+, Asus M2A-VM Mainbord, Croshair 2x1GB DDR2 800MHz, 250GB HDD, LG GCW-H20L, Nvidia Geforce 9600GT, SB audigy2 ZS, TechnoTrend TT-3200 CI, Opensuse 12.1, VDR 1.7.17, Xine-VDPAU

12

Montag, 1. November 2010, 07:03

Ob es sinnvoll ist alle bis auf deine cx24120 zu deaktivieren, wage ich zu bezweifelt, da ja teilweise Abhängigkeiten unter den einzelnen Modulen herrschen.
Zumal du diese demod-Fehlermeldung auch schon vorher hattest, könnte ich mir vorstellen, dass du genau dieses Modul auch versehentlich deaktiviert hast.
Zeig mal ein:

Quellcode

1
lspci -vvn
VDR: Asus M3N78-EM mit Onboard Nvidia 8300, AMD 5050e, 2x2GB Ram, 8GB SATA Transcend SSD + 1 TB WD green, Atric-Einschalter, Hitachi-LCD 240x128 (HD61830) & AX206 (Pearl), Terratec S2 HD & TeVii S464 (unterstützt durch v4l-dvb per selfmade-patch), yaVDR 0.4

13

Montag, 1. November 2010, 12:08

Hey ho @ all

Glaubt es oder nicht mir ist doch der Durchbruch gelungen die karte leuft zumindestens wir sie von yavdr 0.3 gefunden und erkannt.
Scheint wohl noch ein paar probleme mit der Modulation zu geben aber das kommt erstmal später.
Für alle die die es mir nachmachen wollen ich habe folgendes gemacht:

1) Istallation von yavdr 0.3 mit V4l-DVB-dkms Treibern
2) Deinstallation der Treiber mit

Quellcode

1
aptitude remove v4l-dvb-dkms

alternativ wenn s2-liplianin treiber installiert worden sind

Quellcode

1
aptitude remove s2-liplianin-dkms

3) vorbereitende Massnahmen treffen

Quellcode

1
2
apt-get install build-essential linux-headers-generic 
apt-get install mercurial libncurses-dev

4) Aktuellen S2-liplianin treiber runterladen

Quellcode

1
hg clone http://mercurial.intuxication.org/hg/s2-liplianin/

5) patch besorgen THX to custler.ru

Quellcode

1
wget http://www.custler.ru/vdr/SVT-SkyStarS2-driver-install.run.tar.bz2

6) Entpacken und laufen lassen

Quellcode

1
tar xjf SVT-SkyStarS2-driver-install.run.tar.bz2

Quellcode

1
sh SVT-SkyStarS2-driver-install.run


Das installations skript kopiert die Firmware und patcht die Treiber.
Bei der auswahl dan I drücken für make und make install.

An dieser Stelle fing es dann an lustig zu werden da die Übersetzung immer mit dem fehler

Quellcode

1
ir-sysfs.c:137: error: implicit declaration of function 'skip_spaces'

stehen geblieben ist. Auch kein groses problem einfach http://linuxtv.org/hg/v4l-dvb/rev/6e0befab696a nachschauen oder in der Datei v4l/compat.h die mit plus gekenzeichneten Stelen einfügen

Quellcode

1
2
3
4
5
6
7
8
9
10
11
+#if LINUX_VERSION_CODE == KERNEL_VERSION(2,6,32)      
+#include <linux/ctype.h>      
+#undef _P     
+static inline char *skip_spaces(const char *str)     
+{     
+	while (isspace(*str))     
+		++str;     
+	return (char *)str;     
+}     
+#endif     
+

Solte von hand eigetragen werden über z.B. nano die plus zeichen am Anfang der Zeile weglassen aber wehm sage ich das sind ja alle Pros.
So dann kann es ja los gehen. Zurück in das Verzeichnis wo ihr die Treiber hin gepackt habt
1)

Quellcode

1
sudo make menuconfig

um das modul cx24123 zu dekativieren.

Quellcode

1
Pfad: -> Multimediasupport -> DVB/ATSC adapters -> Customize DVB Frontends "Conexant CX24123 abwählen" -> Exit & Save

An dieser Stelle THX to BlueVIP für den Hinweis.
2)

Quellcode

1
sudo make 

Quellcode

1
sudo make install

3)

Quellcode

1
sudo init 6

bei mir hatt es geklapt

have fun
AMD Athlon X2 6000+, Asus M2A-VM Mainbord, Croshair 2x1GB DDR2 800MHz, 250GB HDD, LG GCW-H20L, Nvidia Geforce 9600GT, SB audigy2 ZS, TechnoTrend TT-3200 CI, Opensuse 12.1, VDR 1.7.17, Xine-VDPAU

14

Samstag, 15. Januar 2011, 20:44

Und läuft die Karte so auch zuverlässig? Die Karte gibts für unter 40euro, deshalb wär die interesannt.

Gruß Andreas
| HP Microserver Gen 7 | Cine S2 + DVBSky S952 | vdr2.2 | Streamdev Server |
| Streamdev Clients: paar Rpi2, yavdr.... |

Immortal Romance Spielautomat